Having problems with your Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum ?

My bissell clearview 12 amp vacuum's motor races. Belt seems to be fine.


Answers :

Hi,

Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.

Bissell Proheat Upright Wet/Dry Vacuum Problems

heatman101 \012
\012rrugf
Repair Help & Product Troubleshooting for Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My bissell clearview 12 amp vacuum's motor races. Belt seems to be fine.


Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

My Hoover Wind Tunnel Bagless Pro Pet is making a very loud thudding noise when the belt rotates, belt seems to be intact and in place, what am I missing? Vacuum is less than 6 months old, belt is not worn and motor seems to be fine.


... Vacuums

We have a Bissell Revolution Lift-Off Turbo 3760-1 and the upright brush is not working/rolling. It only moves when pushing the vacuum. We checked the belt and it seems to be fine. The vacuum works fine as a hand-held. Any suggestions? Thanks!


These belts need to be changed every 6 months regardless of the way they look. ... Vacuums

My Bissell 3760-1 has stopped sucking in the roller portion. The grab n go part are working fine. Checked the belt and it looks fine. Did I burn up the motor or a microchip?


Hey Lisa! Sorry you're having difficulty with your Lift-Off vacuum. Here's a link to troubleshooting steps to assist you with the suction.\015\012http: ... Vacuums

The brushes will not rotate on my hoover vacuum. the belts are in good shape, the motor is turning the vacuum motor, but the belt on the brushes seems loose. I ordered a replacement belt but still nothing. Their is a small "idler" but their dosent seem to be enough tension on the belt. Any ideas?


Did you order the correct size of belt? These are the belts you should have:Hoover Windtunnel Belts ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My model 4870 Eureka type K Vacuum Cleaner won't turn back on after it started smoking. I turned it off, checked the belt and filters, and they seemed to be fine. The brush will turn so I don't think the motor is seized up. where do I go from here? Thanks for you help, David Andrews


... Eureka Smartvac 4870 Bagged Upright Vacuum

I have a problem with my model 6585-3 bissell upright powerforce bagless turbo with turbo brush vacuum The brush has quit spinning upon removal i noticed that one side of the brush was free to spin the other side that has the rectangular piece to help hold into place seems to be locked up and will not spin is it corroded or have i lost a piece that joins with it that allows it to spin freely belts are good and motor is turning brush will not budge


... Vacuums

My bissell powersteamer model 1695 does not spray enough water out. Hardly anything will come out of the handheld attachment either, just a few drips. With the floor unit, it appears the only water coming out is a result of gravity when the control is squeezed. Nothing appears to be plugged up with debrie or deposits. There does not appear to be any kind of drive belt for the pump as it seems to operate off the main vacuum motor. Any ideas?


Hi, my name is John I will do my best to assist you.\015\012\015\012Referring to this ... Bissell 1695 PowerSteamer Vacuum

Stopped working Was working fine then it smelled like burning rubber, not the belt I checked. It sounds like the motor wants to run then it just stopped but the light is on. What do you think, go by a new one?? This has been a great vacuum cleaner and I can not seem to find a Sharp anywere. Thanks for your time.


Well it could be the motor, if it is it would cost around $80 or so for a motor. May be better to buy new, thre are a number of good brands out there. ... Sharp Twin Energy EC-12TWT4 Bagged Upright Vacuum

I have a kenmore upright 12 amp (M.N. 116.30003402C) vacuum that is not drawing anything up the hoes. There is no obstrution in the hoes and motor, belts, components are working, but there seems to be perhaps something missing(a part) or lost in the macinism that aids in drawing the air required to **** dust/dirt through the hoes and into the bag. Perhaps a diagram of parts and their function would help. Thank you.


... Kenmore 31912 Progressive Direct Drive Bagged Upright Vacuum

My Dyson Animal has good suction and works fine for actually picking up dirt, but when I use the vacuum with the roller, I hear a grinding/rumbling noise. Its only when I use the vacuum with the brush rotating. It does not happen hen I shut the roller brush off. The belt is fine. I cannot figure out what is wrong as there are no clogs, debris, or foreign objects stuck in the brush or in the belt. The noise seems to be the only issue. The vacuum picks up fine. It just doesn't sound right a


Trace the path of the suction into the tank and see if there is anything loose or ingested.\015\012Also, remove the brush and clean as best you can. Perhaps there is something caught in it. Lubricate where it makes sense with some WD40. ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

The original belt on my upright Kenmore Progressive broke and I replaced it with the spare that was in the vacuum. The vacuum and spare belt are about 10 years old. Then the spare broke after one vacuuming session and there was a burning smell coming from the vacuum. I ordered new belts and replaced it with the new belt. It seems to be working fine with no smell. I checked the belt after I vacuumed the family room and although it was in tact, the belt was very hot. Is that normal? Should t


The belt heats up due to the friction, as well as being in contact with the shaft of a hot motor. It is normal. ... Kenmore Progressive 35922 Bagged Upright Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

I have a Eureka 4870GZ. It turns on, but the brush roller doesn't move. The belt looks fine. I do have an extra belt and would try replacing the old belt, but I can't get the old one off the motor shaft or the new one on. I called Eureka customer service. The lady said there's supposed to be a small space between the motor shaft and the outside edge of the vacuum where I can slip the old belt off and the new one on. I don't see it. It looks like the motor shaft goes into a recessed place in the


Remove the top cover so that you can access to belt, You'll find 2 rows of 4 decorative holes on the top cover, In two of the holes you'll find the screws, Please use a flash light to see in that., Once the screws are removed, you'll be able to ... Eureka Vacuums

Hi, I have a Dyson DC04, (silver/lime) making ear popping screams! Does not happen all the time, and more noticeable when it is pulled back.The suctions not a problem and no funny smells or strange noises from the motor. Ive taken the base plate off and the belt and brush bar seem fine, but when I turn the belt, it seems to be the motor spindle thats squeaking, almost as if it need oiling, any help please


... Vacuums

I have a Kirby Dual Sanitronic '50' Vacuum Cleaner I bought in 1966. The motor does not start when I attach the belt lifter of the rug nozzle. When I remove the rug nozzle and detach the belt from the motor fan shaft the motor starts when I depress the nozzle switch and the power switch . Seems like the brushes in the motor are worn out. I do not have a manual for this unit. Can you assist me as to what newer unit is this compatible to and the problem I'm having at present??


... Kirby Vacuums

My Bissell 9200 is not sucking the water into the dirty water resevoir. 1. The gasket on the clear-view seems fine. 2. The suction power just doesn't seem powerful enough (feeling with my hand). 3. The brushes turn fine and belt is fine (not sure if that even matters for this issue). Any help appreciated. Thanks, - Matt


Disassemble all lines and check to see if all O rings are installed. If cracked missing or stretched out of shape no suction will be provided ... Bissell 9200 Upright Vacuum

I have a Eureka Altima vacuum cleaner that doesn't pick up very well. The suction seems fine but the brush roller doesn't seem to pick up from the top of the carpet. When you lower the height of the vacuum the belt rubs and smells horribly. How can I get the vacuum to pick up better?


That means that you need to replace the belt. Here is the belt you need to replace and the manual which has instructions:Eureka Altima ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

My Vacuum DC-17 has just quit sucking. It has been making quite a racket since I had the belt changed at a repair shop several months ago. I was told that the belt was a new design and figured that was why it was making so much noise. it seemed to work fine, was picking up dirt and all, but today, when I started vacumming, I noticed it was not sucking air either with the belt engaged or not. My vacuum is approx. 5 years old.


... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

My Bissel Proheat smartmix bottle is emptying really fast and it doesn't seem like the carpet is even getting wet. I am just trying to do a rug in the kitchen and have filled the smartmix bottle 3x now and the rug is barely wet yet. I have cleaned out the flow indicator filter and it does not spin when I push the button like it used to. I have also checked the belt and it seems fine. It is actually a Bissel Proheat 7901/8910 (Pet) but they could not find my product. Any suggestions, I am


... Bissell Carpet Cleaner Powerbrush Deep Cleaner Vacuum

My kenmore vacuum model 116.36933502. It has no suction. I have cleaned out every spot,taken off the back and still nothing. The motor runs but doesnt seem to be at full power. The agitator brush works. When it broke i seemed to smell something and since it has no belt. Does this possibly have to motors?


... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

I have a Eureka 5902AVZ and the brushroll does not work. when i remove the belt, which is not torn nor worn out, the motor spins perfectly fine. Though when i put the brushroll back into place, it shows that the motor is trying to spin, but with resistance. it seems the brushroll will not spin if locked into place, because there is no attachment on the left side of the brushroll that will allow it to spin freely with the belt. am I missing some parts or is there something else wrong?


Hi and welcome to Fixya. I am Kelly. \015\012\015\012You have correctly identified the problem as the brush roll itself. \015\012\015\012There is a bearing under each end cap of the brush roll. You can gain access to the ... Eureka 5902AVZ Bagless Upright Vacuum

Motor quit working. i was vacuuming and all seemed fine. then the motor went really low. when I opened it I noticed that the bag was not attached and the cannister had filled up with stuff and the filter was full. the vacuum will not run now.


My friend, the dirt you sucked up went right into the motor and it burned up. I am very sorry to tell you this. It is probably not worth repairing unless you are able to replace it yourself.\015\012\015\012In addition to not being able ... Kenmore 31912 Progressive Direct Drive Bagged Upright Vacuum

My old bissell 3510 upright vacuum seems to have no suction into the bag...I replaced a broken belt several days ago, and now the vacuum picks up debris, but seems to just collect it behind a wheel..The bag does not "puff out" like it used to...How can I fix this??


... Bissell 3510 PowerPartner Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1204 seconds