Having problems with your Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum ?

The dirtlifter powerbrush do not trun.the belt are ok and i unplug it and trun it back . still not working

Answers :

I have a Bissell Dirtlifter Powerbrush that will not spray soap. I assume the soap lines are clogged, but how in the heck to you "unclog" them? I've searched high and low on the Internet looking for that answer.......
Have a Bissell Dirtlifter Powerbrush that will not spray soap. I assume\015\012the soap lines are clogged, but how in the heck to you "unclog" them?\015\012I've searched high and low on the Internet looking for that\015\012answer.......
Repair Help & Product Troubleshooting for Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

The dirtlifter powerbrush do not trun.the belt are ok and i unplug it and trun it back . still not working

I have a Bissell Dirtlifter Powerbrush that will not spray soap. I assume the soap lines are clogged, but how in the heck to you "unclog" them? I've searched high and low on the Internet looking for that answer....... ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

I have a windsor vsp 14, it is making a bad grinding noise, when I take the top blue piece off it stops, the brush works fine and when I put the top back on it grinds really loud and gets hot. it still vacuums and the belt and brush are working fine, can't figure it out. and when the lid is on I cant see what its grinding on. It only makes a grinding noise when you pull handle back and engade to vacuum flor and stops when you put it upright.

... Windsor VS14 Versamatic Bagged Upright Vacuum

My Eureka Altima vacuum the brush is not spinning. I took it apart and the belt is Not broke, but when I turn the vacuum on I can smell the motor overheating. I turned the machine off and unplugged it and then took it apart so I could see the underneath and plugged it back in and the belt still won't turn..can you help?

Hi, since you have detected the the smell of the overheating motor, then the motor is faulty which is why the belt is not turning. You should change th motor ASAP........... ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

I have a Bissell 1623-1 Steam Cleaner. It will work good for about 2 minutes and then after that it will not dispense cleaning solution on floor or through the hand held wand.I have replaced both drive belts with no improvement. I have cleaned it and found no obstructions in hoses and spray nozzles, put back together and it still will not dispense. Is it possible the pump or solenoid is no working? Aaron

... Bissell 1623 Steam Cleaner

I have a Kirby Heritage II which normally works amazingly well, but it's not playing at all nicely today - and of course we have apartment inspections tomorrow. *dies* The belt broke today (as did the replacement belt, which I'd bought at the same time, so apparently the rubber was old), so I went over to Stark's to get some new ones - but it still won't cooperate. I've taken the head apart and put it back together several times, to be sure that everything is properly seated, but it's just not

... Kirby Heritage II Vacuum

We have the GE sensor microwave WES1358DN1WW. It was made in 5/2009 & bought in July of 2010 brand new. it worked perfect til last week. i put something in it & it started to make a loud humming/vibrating noise. i assumed it was just something ontop of the microwaved & ignored it. 1 min later my food was still ice cold. we tried unplugging & plugging back in & made sure that it was clear of anything but it still makes noise & doesn't heat. GE charges $79 to look at it, & since the microwa

... Vacuums

Hello i own the bissle proheat steamer it turns on but no water or soap or suction from floor or the utensiles ive taken the take off the back to scope out anything that could be in the way but dont see anything the motor is making that clogged vacume noise witch makes me believe something could be stuck somewhere in it but it could also be no water is getting to the pump or despencer but the brissels still work belt for that is good where would i be best to check and where is the location of th

... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

Kirby g4 i cant get the belt back on try and still wont work ? can u help me

First things first...take the powerhead off of the front of the kirby. If you look at where the powerhead connects to the front of the kirby and you'll see a large hook...turn the hook using the crank on the front of the powerhead so that the belt is ... Vacuums

When I was using my Bissell ProHeat 7901, I smelled something hot (almost burnt) and turned off the vaccum. When I turned it back on, everything seemed to be working, but the vaccum part was not making the same sound. The bristles are still turning, but it isn't picking up as much and is leaving quite a bit of lint on the carpet. Could the belts be worn? How do I tell? Thanks!

Ya that is probably the issue. Here is a link to the belts you need and to the manual which has instructions:Bissell ProHeat Belts and M ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

We have a new hoover bagless that is a couple months old. The pet hair attachment stopped working. I disassembled it found lots of hair wound around the various rollers and removed - painstakingly thorough i might add. Problem is the brush still wont spin and now the belt seems loose - I think I put it all back together correctly but wondering if there is a trick to this?

Without the model number, I can't look it up, but this has a 1 years warranty on it, maybe take it to a warranty shop. Just take proof of purchase, model and serial numbers. ... Vacuums

Noise Hi... I was doing normal house work and had been using it on carpet... I put it on floor for my hardwood floors and picked up loose clean cat litter and went to put it back on carpet and it made a horrible noise like it was rubbing. cleaned the filter... cleaned the roller thingi ...checked the belt and it is still making that horrible noise. It does not make the noise when I have it on floor but as soon as I put it on carpet it screams at me. Help! Please and thanks Linda

Hi Linda,\015\012Sounds like clutch problems, try to move the lever for carpet/floor back and forth a few times maybe it will free up. If it still makes the grinding noise, the clutch assembly will have to be replaced. Let me know, i can even ... Dyson DC07 Bagless Upright Cyclonic Vacuum

My kenmore vacuum model 116.36933502. It has no suction. I have cleaned out every spot,taken off the back and still nothing. The motor runs but doesnt seem to be at full power. The agitator brush works. When it broke i seemed to smell something and since it has no belt. Does this possibly have to motors?

... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

I lent it out (NEVER AGAIN!) got it back and no water squirts out of it in front I looked at it with the cover off but it doesn't come all the way off anyhow nothing looks clogged the belt is all fine too. Clean all the grime is seen and still doesnt work. What's wrong?

It might be pet hair caught in its hose. You might have to disassemble everything just to be sure. ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

My Bissell Model 3760-4 is not working properly. The belt has been replaced (and checked 3 times), but the brush bar does not move when the brush motor button is on. The little metal turning piece that turns the belt is turnable with one's finger when the belt is off, but when we put it all back together and turn on the vacuum, the brush bar does not go around and the burning belt smell returns. The portable part of the machine works properly. It's the brush bar. It has been cleared of hair, etc

... Bissell Lift-Off(R) Revolution(R) Turbo Upright Vacuum

Brush Roll belt stops turning durring vacuuming on WindTunnel self-propelled, v belt is a little loose with handle down. Tensioning roll is engaged OK, but fully at the end of its travel. Replaced belts flat and v, but still stops turning even on high carpet setting when vacuuming. Carpet setting and height adjustment appears to be working OK, roll is clean and turns easily when out. Also turns easily until it engages the carpet. Self propel function works just fine.

... Hoover U6485900 Bagged Upright Vacuum

The hoover windmill brand new, new belts not working, replaced new belts with new belts still not working its a useless piece of ****.

... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

The vacuum won't start. I used it for about an hour and then turned it off and when I went to turn it back on ..there was no response. I cleaned every compartment on the machine and it's still not working. I also tried using a different outlet in the house. I've waited 24 hours thinking maybe it might have been just the vacuum over heating, but it's still not working.

I had the same problem and after removing the large round filter and cleaning it, (waiting 12 hrs to dry) it started.... ... Dyson DC07 Bagless Upright Cyclonic Vacuum

I have a Miele S1721 Powerhouse upright vacuum. When the belt broke I took it into the shop (because when i tried to replace the belt, the tension was so tight I couldn't get it back together!!). When I got it home I DISCOVERED THAT THE HEIGHT ADJUSTMENT DIDN'T WORK anymore. It seems like it's set really hight, because it no longer contacts and brushes the carpet. So it's now useless. I went back to the shop and the tech denied that there was anything wrong. (I didn't have the vac with me). No

Hi\015\012The Miele uprights (S170 and upwards) with the Powerhouse title are ALL Panasonic uprights which have been at one time sold in the UK. Therefore the upright may use TWO drive belts which need to be looked at: Take off the sole plate a ... Vacuums

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?

... Kenmore 34722 Grab-N-Go Upright Vacuum

Floor Attachment I took off my floor attachment, but now the belt seems to be off and I can't seem to get it back on right. I can't use the attachment and I don't know why it's so hard to figure this out. They say, just turn it to belt off, but when i turn it it lift's it up and can't line up with the belt off label. Then, when I turn it the other way, it's off. So I've been trying to pull it off so when it lines up with belt off, it's off. But the I turn it the other way and it's still off a

Try this,\015\012\015\012With the floor nozzle off the machine spin the belt lifter around until the red arrows match. If you look at the side that attaches to the vacuum you should be able to see the belt up on the hook. If is not on t ... Kirby Generation 3 Bagged Upright Vacuum

After using switch to go from floor to carpet, noticed the roller brush not working, and therefore the self-propelled feature also not working. Replaced what I thought was the problem, a loose belt, but still does not work. Motor runs and there is suction...???

... Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum

My Eureka Maxima isn't working right. The belt is spinning fine until I lower the handle to start to vacuum and then the belt stops spinning. As soon as I put the handle back in the upright position the belt spins again.

Sounds like belt is worn try changing belt. ... Eureka 4700A Maxima Bagless Upright Vacuum

Shark Euro-pro EP621 Bagless Upright Vacuum. Q regarding the brush not spinning / after troubleshooting and taking actions listed below, it now spinning for a few secs, but then stopping. Already removed hair, strings, etc. Checked that belt is aligned properly, checked that small wheel that turns belt is working (spins fine when belt removed. Oiled the turning parts a bit, that made it spin better, but still stops. It turns about 3-4 seconds then stops. If I switch it off and on again, I get ag

... Euro-Pro EP621 Bagless Upright Vacuum

Hoover U5344-950 My Hoover vacuum is a nightmare! I have had nothing but problems with it since day 1. The powerhead stops working if you try to lower the handle to vacuum. I took it in to be serviced and was told it sat on the shelf for too long in the store and it warped the belt...so it was replaced. Got it home, it worked the first time I tried it, then went right back to no powerhead working and as a bonus it is giving off a nasty smell like it is going to blow up! It now gets really hot to

... Hoover U5344-900 WidePath Vacuum

Brushes not turning but motor still working belt

Belt might be stretched out.. Take it to a local authorized shop and get it looked at. ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0822 seconds