Having problems with your Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum ?

The roller brushes do not rotate. The motor is running and the suction seems fine.


Answers :

Are the brushes free of threads, lint, pet hair? If not, this can stop them from rotating. Check the outer edges near the wheel case as well. You can use tweezers to remove all the "tangler" stuff! I hope this helps. If it does, please rate my suggestion. Thanks.
Repair Help & Product Troubleshooting for Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

The roller brushes do not rotate. The motor is running and the suction seems fine.


Are the brushes free of threads, lint, pet hair? If not, this can stop them from rotating. Check the outer edges near the wheel case as well. You can use tweezers to remove all the "tangler" stuff! I hope this helps. If it does, please rate my sugges ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

I bought a G5 (w/ all the attachments) at a lawn sale. It works as in the motor seems to run fine and the brush head rotates, but.....there's no suction. Is there another button or lever I need to push/pull?


This link is for the manual it may help you.http://kirby.110mb.com/docs/kirby_sentria_manual.pdf ... Kirby G5 Bagged Upright Vacuum

My Dyson Animal has good suction and works fine for actually picking up dirt, but when I use the vacuum with the roller, I hear a grinding/rumbling noise. Its only when I use the vacuum with the brush rotating. It does not happen hen I shut the roller brush off. The belt is fine. I cannot figure out what is wrong as there are no clogs, debris, or foreign objects stuck in the brush or in the belt. The noise seems to be the only issue. The vacuum picks up fine. It just doesn't sound right a


Trace the path of the suction into the tank and see if there is anything loose or ingested.\015\012Also, remove the brush and clean as best you can. Perhaps there is something caught in it. Lubricate where it makes sense with some WD40. ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Hoover upright bagless vacum.motor runs, brush turns, no suction through hole behind brush roller. however there is suction going out of dust cannister filter flap to motor. what could possible problems be?


Sorry to read about your problem, I hope this helps you out.you have a clog between the brush and bagI tried to help you. Please help me and Rate/Vote on my response, thanks and good luck ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Helping out someone that has a ECV 1590A model 117A Electrolux central Vacuum. There seems to be a problem with the brushes. I'm looking for a manual or what brushes to get or a new motor. It seems to run fine what it starts.


... Electrolux Vacuums

Hi, I have a Dyson DC04, (silver/lime) making ear popping screams! Does not happen all the time, and more noticeable when it is pulled back.The suctions not a problem and no funny smells or strange noises from the motor. Ive taken the base plate off and the belt and brush bar seem fine, but when I turn the belt, it seems to be the motor spindle thats squeaking, almost as if it need oiling, any help please


... Vacuums

My kenmore vacuum model 116.36933502. It has no suction. I have cleaned out every spot,taken off the back and still nothing. The motor runs but doesnt seem to be at full power. The agitator brush works. When it broke i seemed to smell something and since it has no belt. Does this possibly have to motors?


... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

I have a Eureka Altima vacuum cleaner that doesn't pick up very well. The suction seems fine but the brush roller doesn't seem to pick up from the top of the carpet. When you lower the height of the vacuum the belt rubs and smells horribly. How can I get the vacuum to pick up better?


That means that you need to replace the belt. Here is the belt you need to replace and the manual which has instructions:Eureka Altima ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

Runs but doesn't vacuum/****. Sidebrush works fine. Cleaned the roller brushes, and that seemed to confuse the robot and now it keeps going backward a few inches, turning, and then starts going backward again.


Sounds like a sensor problem. pull and clean the front black/white caster assembly and the revealed movement sensor and the 4 cliff sensors along the bottom of the front. Make sure the front caster wheel turns freely. You may have to remove the rolle ... iRobot Roomba 560 Robotic Vacuum

After using switch to go from floor to carpet, noticed the roller brush not working, and therefore the self-propelled feature also not working. Replaced what I thought was the problem, a loose belt, but still does not work. Motor runs and there is suction...???


... Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum

My Hoover U6430-900: the motor seems to be running fine, the brushes turn fairly well, no blockages but no air is moving through it at all? Is it likely the fan and is this something I can replace myself?


Keep looking it must plugged somewhere ... Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum

Motor is running, belt is on and brush is turing fast, however it does not seem to pick-up anything or have any suction ? bag is not full and does not inflate when it's on


... Dirt Devil M086365 Bagged Upright Vacuum

Noise My Dyson DC08 is making a loud, rough, vibration/noise that seems to be coming from the from the rotating brush housing. I replaced the old belt which was several years old and slipping. When I run the motor with the new belt removed the machine sounds normal. The bearings on the rotating brush seem to be running smoothly when turned by hand both when out of the brush holder and when installed in the machine. I can't find anything rubbing on the belt or rotating brush. I applied a bit o


Hi there, it's Jack at Dyson.\012I'm sorry to hear you're having difficulty with your Dyson vacuum. From your \012description, it sounds like the model number you've supplied may not be correct, \012as DC08 is a cylinder vacuum which doesn't use ... Dyson DC08 Cylinder Bagless Canister Cyclonic Vacuum

Brush Roller Wondering if I need a new brush as well as a belt. The Roller seems to have trouble spinning when it makes contact with the carpet no matter how the height is set. Everything else seems to work fine. Do I need a new roller to fix this problem?


The bearings can go bad in the brushroll. It may need replaced, even if the brushes aren't worn. Helpful link....\015\012\015\012 ... Kirby G6 Bagged Upright Vacuum

The motor is running, the roller brush spinning rubber smell


The belt may be stretched replace it ... Vacuums

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

My bissell model 18Z6 has developed a loud noise and vibration when the brush is running. I have removed the brush assy and cleaned all the hair, etc but still the noise. I ran the brush motor with the belt disconnected and all seemed ok, but of course there was no load on the motor. I suspect a problem with the brush assy bearings or axle or both but I hate to just throw parts at the problem. any suggestions would be greatly appreciated.


... Bissell Vacuums

I have a Kirby G series diamond edition. There seems to be no suction when I turn on the vaccum. The bag inflates, but the roller does not turn. It has a new belt and the roller brush is clean. Any suggestion on what I might do to increase the suction and get the roller bar moving?


THE IMPELLER LOOKS SHOT.. 25 QUID FOR NEW ONE,,LIFT THE LID AND TURN THE ROUND PIN AND CHECK FOR RIDGES ROUND THE WHITE IMPELLER,,IF NONE THERE THATS IT,, HAPPEND TO ME TEN MINS TO FIX GEORGE ... Kirby Ultimate G Bagged Upright Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

My Bissell 9200 is not sucking the water into the dirty water resevoir. 1. The gasket on the clear-view seems fine. 2. The suction power just doesn't seem powerful enough (feeling with my hand). 3. The brushes turn fine and belt is fine (not sure if that even matters for this issue). Any help appreciated. Thanks, - Matt


Disassemble all lines and check to see if all O rings are installed. If cracked missing or stretched out of shape no suction will be provided ... Bissell 9200 Upright Vacuum

No suction I have new belts. Everything is clean. No clogs. When I turn it on it smells like rubber , the brush doesnt spin. Everything seems to be free flowing.. Roller brush isnt stuck on the ends. Took off hose to make sure no clogs anywhere. There is not even suction thru the hose with the handle in upright position.


Generally, the problem is that the belt is not running the brushes.  This is caused by one of the following:\015\012\015\012\015\012beater brush is jammed.  This is either an object stuck in the brush or im ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

I have a Filter Queen Majestic 360 and am having problems with the powerhead. There is a loud rattling noise in the powerhead, especially when I vacuum thicker carpet. I have replaced the motor, roller brush, and belt, but the rattling remains. It sounds like it is coming from the roller brush area,and when I turn the powerhead over, it rolls free and sounds fine. Any thoughts?


Hi there, as per your information i guess its a problem of power transformer. He can't supply the proper power in the motor & thats why the noise will come from the transformer. Thanks & waiting for your feedback. ... Filter Queen Majestic Canister Vacuum

I have a panasonic mc-ul975 vacuum that works great when working properly. the airflow through the canister seems to stops once the aero blast technology is done running which causes the vacuum to not function as it should (does not have as much suction and the hose/tool accessories do not work at all). if air is continually running through the canister everything seems fine. please help!


Hi there. In Panasonic vacuums, there is a thermostat protection on the motor. It will auto ... Panasonic MC-UL975 Upright Vacuum

Have a Centralux Aerus about 5 years old. Don't see a model number. There is suction but beater brush quit working. Was using for a few minutes, shut it off for a few minutes, turned it back on and suction only. Tried the reset button also. Tried the sidekick attachment and it works fine. There was no smell like something was hot. Belt is fine. Are there any fuses or anything else to try? This vacuum cleaner has not really been used that much, it is hard to believe the motor would need replaced


There probably is a loose wire in the handle near the switch or a wire off near the swivel elbow near the vac power head. With the right fastener tool to remove some screws you can fix it yourself ... Electrolux Centralux Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1177 seconds