Having problems with your Bissell CleanView II Plus Upright Bagless VacuumVacuum ?

When I use the hose, I have noticed that there is NOT a cover and so dust and debris flies out of the hole when I'm using the hose with any of the attachments...is my vaccuum missing a piece or is this normal for this model?


Answers :

Repair Help & Product Troubleshooting for Bissell CleanView II Plus Upright Bagless VacuumVacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

When I use the hose, I have noticed that there is NOT a cover and so dust and debris flies out of the hole when I'm using the hose with any of the attachments...is my vaccuum missing a piece or is this normal for this model?


... Bissell CleanView II Plus Upright Bagless VacuumVacuum

I'm trying to use the reverse flow hole on my Miele s712 to blow up an air mattres. None of my fitting appear to fit so I can use the hose. Is there something I'm missing? Is there a trick of the trade? Or am i missing some gear. It's new, out of the box but I just can't get the hose onto the reverse flow. The Poduct is a Miele S712 vacuum dispite what this system has allowed me to enter. ; )


I GO THROU INSTRUCTION BOOKE OF SERIES 700 I DO NOT FOUND THIS REVERSE FLOW......THANKS ... Miele S548 Bagged Canister Vacuum

I have a Hoover windtunnel T series. Model #UH70105. The system check indicator was almost red so I cleaned the filter. There are no clogs and it vacuums fine without the hose, but when I go to use the hose there is very little suction and all the vacuum dust flys out of the end the hose piece fits into when not in use. Can you please tell me what is wrong?


... Hoover Vacuums

I have the Eureka The Boss Power PLus Model # 4703 Type A. When using the detached hose and wand it works OK; however, when using the Vacuum with the hose attached it doesn't work well at all.


... Vacuums

Model UH60010, Series X12.0, Mfg code K09A. While attempting to use the hose and the extensions to clean shelves, my wife reported no suction. I removed the brush roller and the plastic piece just below where the hose opening is located and saw a "flapper" door that was closed and had some debris sort of jamming it. I removed the debris, but the door requires extreme pressure to open to permit the dirt, etc to moved up thru the opening , through the hose, etc. I thught maybe that somehow tg


Hello,Check to make sure\015\012the dirt canister is empty. If dirt canister is full, then you will \015\012experience\015\012reduced suction. Empty dirt receptacle.\015\012 Could\015\012 be a clogged hose - ... Vacuums

I have an older model F6056-900 Hoover steamvac Spin Scrub Cleaner. My first problem was that I loaned it out to a friend. Anyway she ran over the hose (used for attachments) with her car. I tried using the cleaner for carpet cleaning this morning but when I tried to put the solution tank into place...its loose...won't snap back in like it used to. When I can get it somewhat in place the solution just complete drains out through the bottom fo the tank. The leak is where the small hole on the bot


... Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

I have an old Shop Vac model 3331.5. This is a 12 gallon 1.5 hight peak shop vac with a detachable blower. After many years I decided to use the blower feature, but have lost the lost the manual. Question; how do I attach the hoses to the blower? The motor has that cap on it the direct the flow of air in one direction and the wide hoses do not fit over it. I may be missing a part, but I would think the directional cap would have to come off anyway.


Remove the cap that directs the air and insert the hose in there. ... Vacuums

I have a Hoover Elite Rewind model #uh71009. We moved recently and it was jostled around and the red power switch popped out. I put it back in but it's stuck; it stays either left or right, it doesnt move back and forth. It appears there may be another piece missing from the power switch...all I have is the red switch and a tiny cylindrical metal tube with a spring on one end. This piece fits into the hole on the red switch. Inside the vacuum itself where this goes, there is quite a large cavity


... Vacuums

My bissell power force bagless model 6594-w vaccuum is not sucking up when vaccuuming but if i use the hose it works


Remove the bottom plate that covers the brush assembly and check the air passage that goes out where the vacuum is jointed between the vertical parts and the sweeper head. Look for any clog in that area. A bent hook on the end of a piece of coat hang ... Bissell 6594 PowerForce Bagless Upright Vacuum

Model number f 5912-900 hoover steam vav with clean surge.This is not the f5914 model........my new machine has 10 min. on it...in mid use it has stopped sucking and now is blowing more than anything, I took the front clear piece off as well as the black cowling/shroud and can find no obvious hoses to un-clog nor anything else to un-clog for that matter...I am looking for advise to fix this thing now, myself


Here is a list to go by for no suction problems that you can follow along with they are common proble\015\012Problem #1 Steamvac is not Sucking!If your Hoover Steamvac was working properly and suddenly it is not sucking any ... Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

My FIL purchased an Electrolux bagless canister vacuum model EL5 76501 last year. When I tried to use it today, the hose keeps pulling out of the power brush whenever I pull it towards me. it doesn't seem like anything has broken off. The only thing I noticed was that the rubber ring washer seems to be flattened. Could it be something that simple or do you think some part has fallen off and gone missing? Regards, Craig Somersett


I believe I've just had the same problem and after searching for a small gray horsehoe clip that needs to first be found and then inserted into the slot for it on the tube section that comes out of the beater bar. Insert this clip from the outside af ... Electrolux Vacuums

Power head attachment works great when plugged into the hose part of the vacuum. The problem is when I attach it to the tube for normal use there is no power. I have checked all the connections and switched the power switch on and off still no power from tube to power head. Is there anything else I can try? Model Callisto


Try having someone turn the machine on and off while you pull the cord in and out with the cord more angled towards the on/off switch. Sometimes these models have a break in the cord rewind and will not put the power through to the motor. ... Miele Vacuums

Need manual for Eureka Powerline Plus Model 9730 Type A - missing "door" that covers tool access port on body of upright motor...any ideas? This causes dirt to fly out unless tool hose is placed in "port"--don't always want to use tools, just main vacuum.


I found it at www.vacpartswarehouse.com for $4.79 + sh ... Eureka Powerline LiteSpeed 5845 Upright Vacuum

Scunci steamcanister model 52038 Steam does not get from canister through hose to nozzle. No apparent leaks - hose does not get warm. appears may be valve problem from canister to hose. Only used bottled water - barely used this machine.


... Scunci Vacuums

I have Optima, 12amp Eureka vacuum, Model 431, AXZ type and the extension hose for cleaning corners and edges --the plastic part that the attachments fit into has a piece broken off and tools don;t fit anymore. It looks like the hose attachment can be replaced--can it be and if so--where can I get a new hose attachment. It seems it is cheaply made of plastic and really shouldn't have broken a piece off.


... Eureka 431A Optima Bagless Upright Vacuum

Attachments when using the attachments for cormers and such, when you pull the hose out to use the attachments dust comes out the open hole where the hose originally goes?


Check also filter and replace if necessary. ... Eureka 2991AVZ Bagless Upright Cyclonic Vacuum

I'm using (or WAS using) a Eureka ''the boss'' model 8803. The belt broke, no biggie, so I replaced it with a Eureka model U belt, the problem is when I put the new belt on and turn on the vaccuum, the belt breaks again. I am also having trouble getting the brush roller to fit right when the belt is in place. I can't find any sharp edges that would cut the belt,nor can I find where any small bits may have broken. Anyone have a solution for me?


First, make sure you have the right belt, second, i am thinking that you are not lineing the roller up right, it will only fit one way. look at the ends of the roller and the grooves where it slides in, you should be able to see clearly how it goes. ... Vacuums

I have a Model 116.35922500 Kenmore upright vacuum cleaner. It makes a loud air noise when using the vacuum. I have disconnected and removed the hose to see if anything is lodged in the hose and it appears clear. It makes the noise when the hose is connected. When I remove it, the noise stops. When I place my hand over the hose, the nose re appears. I sounds as though the noise is coming from the fan or internal parts of the machine. So, when there is a load or pull on the machine, it mak


... Kenmore Progressive 35922 Bagged Upright Vacuum

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But


Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

I have a model 1561 electrolux central vac..can i use a hose and accessories from a model 15448 model electrolux central vac to compliment my central vac unit


If the hose fits into the inlets, then there should be no problem. ... Electrolux Centralux Vacuum

I have a dyson dc21. All the sudden the hose is hardly suctioning up anything. If I take the canaster off, the top air hole suctions extrememly well, but when I place that canister back on, the suction is not going thru the hose and picking anything up. I have squeezed the hose, I feel no air leaking and do not feel any blockages...what could be wrong. It worked fine the other day and today, it won't pick up a piece of lint!


... Dyson DC21 All Floors Stowaway HEPA Bagless Canister Vacuum - Iron/Titanium/Yellow

Hello, I have the same model. And though it is three years old, starting from the last month, it does not clean anything anymore. Cannot even pick up one single thing from the floor. Every dirt gets stuck in the hose. I cleaned the hose and cleaned the filters but it still does not pick anything up. Is three years its normal lifetime or do I have the change the filters, instead of cleaning them? Thanks.


I know bissell vacuums are very cheap but they should last more than 3 years. there should be two parts to the dirt cup. remove the dirt cup and above it there should be a round plastic part. unscrew it and check that filter. ... Bissell 6594 PowerForce Bagless Upright Vacuum

Have a Eureka Power Plus 12.0 Amps Model 4702 Type A 120 volts and 60 HZ that there is something wrong that it isn't picking up right and you can actually feel the air coming out of it near where the bagless canister attaches. My thoughts are that a seal is missing around where the hole lines up when the cannister is locked in. This Vac was my Mom's and she passed away and I think a part went missing maybe when it was taken apart to clean the filter and empty the canister. Need to figure out if


... Vacuums

When I disconnect the hose attachment from the vacuum to use it, the dust shoots up from the hole. Where is there something to make the hose have suction instead of the base of the vacuum?


Da house is stop up ... Vacuums

I have a Sunbeam Model Number 4065-000 and there is white particles comming out of the holes in the bottom. I think it is because we used tap water and there is a lot of deposits in the water. I read on the box that it was ok to use tap water and not distilled water. Is ther any way to clean the inside out to get the deposits cleaned out without affecting the possibility of doing something to the cloths that I will iron after cleaning the iron?


If the deposits are recent and still fairly soft, running a tank of vinegar through the machine should remove the deposits (obviously not using on any clothes, hold it over a sink). if the deposits are more stubborn, you can use a cleaning agent like ... Sunbeam Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.2746 seconds