Having problems with your Bissell LiftOff Revolution Pet Vac 37602 Vacuum ?

No suction, getting hot

\015 Motor runs. very little suction. unit gets hot\015

Answers :

Repair Help & Product Troubleshooting for Bissell LiftOff Revolution Pet Vac 37602 Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Shark navigator no suction and getting hot

Sounds to me there's a blockage somewhere .the link below is the manual it will show you where to look for blockages..http://www.totalvac.com/manua ... Euro-Pro NV22 Shark Navigator Bagless Upright Vacuum

Suction fine whe first switched on but soon (2 minutes) starts to die as a burning smell gets stronger. Filter cleaned. no parts feel hot to touch. What could be the problem. Machine used daily, approx. 6 years old.

Check belt for beater bar ,also check where motor pulls in cooling air ... Vacuums

Dyson Animal Dc28..no suction...getting hot - Vacuums

Hi there,Sorry to hear you're having difficulties with your DC28. If it doesn't seem to be picking up as well as usual, it's possible that there's a blockage in the system, and you may need to give the filters a wash.The easie ... Vacuums

Dyson DC 14 hose has no suction, with or without brush attachments. Hot air shoots out from the base of the canister when I try to use the hose. I cleaned the top filter, but can't figure out how to remove the hepa filter to clean it without destroying the case. It looks like it might take three hands to insert pennies and "flip" the case open as is suggested on a youtube video for a different model. Would this even help, assuming I could get the thing open?

... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

Hoover has no suction and base is getting very hot, have cleared all visible blockages

... VAX Appliances Vax X3 Bagless Upright Vacuum

Dyson has lost it's suction...i've cleaned all filters and checked all the hoses. The motor appears to be getting too hot

The filter housing can also be an issue. Check this:\015\012\015\012http://www.ehow.com/how_5870417_modify-dyson-prefilter-suct ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

It has been cleaned , yet there is no suction the hoover wont pick hardly anything up & it gets hot very quickly

Then there most be a clog either in the hose or the dirt inlet by the brush roll. If you pull the hose off like you are going to use an attachment, is there suction there. If not, then the problem is in the hose. If there is suction, then the prob ... Hoover Vacuums

Why is suction so poor and how do you install the filter . also vacuum gets hot fast

Dunno ur model, but if filter is full or not seated n sealed properly, itll **** at sucking. ... Sunbeam Vacuums SBH252 500W Deluxe Hand Vacuum with Attachments

It starting to put out a hot type smell. I have tried cleaning the filters real well and even tried to see if there was problem with the ozone filter. We have checked and could not find a jam. I know the hose has excellent suction. The vacumn works but the intelliclean sensors will not. It only takes about 15 seconds or so for the odor to start. Then it gets real strong and it makes my eyes water

Hi,The hot smell could be from the belt or the motor. Turn it on for a moment, turn it off, then flip it on its side and smell the belt that drives the brush. If that is where the smell is coming from, then your belt is burning up. ... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

Vacuum gets hot loses suction and turns off

You need to replace your silencing filter on the inside. I recommend calling Health Mor at 800-344-1840 and having their Tech. walk you through replacing that filter. It should have been replaced at about 2 year ... Filter Queen Majestic Canister Vacuum

Why is my hoover getting too hot and stopping

... Hoover U5753-900 WindTunnel Bagless Upright Vacuum

Belt and lifter getting hot right away on start up.

Hello,\015\012I would say that it is definitely running backwards. I have a guide to replacing the power switch that outlines the reassembly of the Kirby and tells you which carbon brush wire plugs into which hole on the power switch. Ea ... Kirby Ultimate G Bagged Upright Vacuum

Motor gets hot in moments and shuts off

True, the motor has safety measures to stop it from overheating... that's why it shut down. You smelled something, so some kind of damage was done. It's possible that the over temp switch itself got fried. Doesn't sound too good from here. ... Filter Queen Majestic Canister Vacuum

No suction for use of crevice tools, running hot, then shut off

Obviously no suction in hose would indicate a blockage, over heating is a breaker that shuts off the machine when it over heats. There is no way to clean hose the on this model because the hose does not detach at either end, therefore I had to emplo ... GE 106766 Bagged Canister Vacuum

The handle for my Eureka 5993 AVZ was getting very hot when used. Finally, the wires around the switch melted and now the vacuum will not work. What is wrong? Is the switch bad? The wires only melted in the immediate vicinity of the three-prong switch. Nothing else appears to be wrong; the vacuum worked fine when it was running - except for the handle getting hot. Thank you!

Try cleaning all...\015\012if have sam paoblem need replaced main motor.... ... Eureka 5893AVZ Bagless Upright Cyclonic Vacuum

After using my attachments I have a hard time getting suction when using upright again - how do I get the suction on my upright? It's a Hoover blue widepath Tempo~ thank you

It may be clogged underneath the vacuum where the roller is. Take the bottom plate off and look into the intake port. There may be some blocking the port. ... Hoover Tempo Widepath Upright Vacuum - Blue

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?

Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

I can't get the latch that connects to the brush head to engage. Thus the vacumn is extremely hard to push. It has suction, extreme suction. Rollers appear to be dragging. I've tried to remove and reinstall the head several times but cannot seem to get the latch to engage. Please advise.

It sounds like something has come out of it's socket. If the brushroll won't turn rapidly, your clutch is worn out ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Miele Cat & Dog vacuum gets VERY hot and is VERY loud. Hose has no restrictions and I have changed the dust compartment (motor) filter and the exhaust filter. It still gets hot when I run it with the top open and all filters removed, so I'm guessing the problem is with the motor. Should I be going into the motor compartment? If so, what am I looking for?

Hi\015\012\015\012The fact that it gets very hot could be due to a number of issues.,but the fact that it started making a very loud noise at the same time suggests that there might be more problems maybe brushes etc.\015\012\ ... Miele S514 Solaris Bagged Canister Vacuum

Help i can get suction from the hose but when i stick it in the back of the carpet head i get no suction and the beater bar will not turn. can you help

... Miele S184 Powerhouse Bagged Upright Vacuum

I have a hoover mach 5 multi-chamber cyclonic vacum cleaner and it keeps getting hot and quitting.it's got a strong smell like something is burned when it gets hot also.

If its giving off that strong smell then the motor is bad. probably caused by not keeping the filters clean. on any bagless machine one has to clean the entire vacuum after almost every use to keep the unit operating correctly ... Vacuums

No Suction I get great suction in the hose, but when I plug the hose back into the unit, there is no suction and the air flow indicator line goes completely red. I've changed the bag and filters. I took the small panel off the back and made sure there is no clog, and took the hose off to make sure there was no clog there. Still no suction. Please help.

I about to say that's always a clog of some sort that causes that ... Miele S7210 Bagged Upright Vacuum

No suction Just received my refurb. dyson animal bagless. Finally figured out how to get it all together, turned it on and there is no suction coming up thru the beater bar. The hair is just collecting around the bar and not going up into the canister. It appears all the suction is going thru the open red end of the attachment hose, which has a vented cover piece. Am I missing a piece or is there a switch to turn of the attachment suction?

So the red hose isn't connected to a part on the vaccum so like it is connected to the connester but not to an opening just above the beater bar, this is the only idea i can supply you with. good luck, maybe i got lucky and helped you out. ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

No suction I am getting no suction on my central vac at the vac. I do not believe that the piping is plugged up, the vacuum is not creating suction. What are the causes of no suction at the vacuum and how do I take the top half of the Nutone central vac off?

Use the guide at builtinvacuum.com/flowchrt.html to find the issue and solution. Most likely you need to test it without any filter and be sure the bottom of the unit is attached :) To get access to the motors you need to unbolt the very top sides. ... Broan-NuTone CV350 Performance Bagged Central System Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0600 seconds