Having problems with your Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum ?

My vaccuum makes a very high pitched sound when it runs. I cleaned it out and checked for itms stuck in it but there doesn't appear to be anything. What is causing this problem. Other than the awful sound it seems to be working fine.


Answers :

Could be a worn belt. Here is the belt you need:

Bissell Pet Hair Eraser Belt
Repair Help & Product Troubleshooting for Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My vaccuum makes a very high pitched sound when it runs. I cleaned it out and checked for itms stuck in it but there doesn't appear to be anything. What is causing this problem. Other than the awful sound it seems to be working fine.


Could be a worn belt. Here is the belt you need:Bissell Pet Hair Eraser Belt ... Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

I have had my RCA microwave model # RMW1108 for about 8 months now. It was working fine until yesturday evening. I went to warm up some food for 2 minutes, the microwave itself was on and everything appeared to be working except my food did not get warmed up. I plugged it out and checked all over it for any damage but i could not find anything wrong. What would cause it to just stop heating up the food? Is this type of problem covered in the 1 year manufacturer's warranty.


... Vacuums

All the suction has been lost at the bottom end, the hose still works and sucks fine. what can be the problem? there doesnt appear to be any blockages either


It sounds like you must have a blockage behind the beater brush on the bottom of the v ac ... Dyson DC07 Bagless Upright Cyclonic Vacuum

My filter queen majestic quit working. I opened up the unit to see what was wrong and I did not immediately notice anything wrong. Upon furter examination I noticed one of the traces on the printed circuit card was burnt. I used a soldering iron to "bridge the trace and it appeared to fix the problem for a while. Now it has stopped working again, and when I jumper the trace to run the motor it seems to work. Should I just replace the card? Or is there a more serious problem with too much current


I recommend replacing the card. Soldering involves the risk of further damaging the card, so it would be useless anyway. Why waste valuable time?\015\012There is a possibility of the motor overheating, generally due to a blockage in the airfl ... Filter Queen Majestic Canister Vacuum

My electrolux ambassador power wand quit working. I replaced the switch that shuts it off when the roller stops, but it wasn't the problem. The on/off switch is fine, the motor is fine. We have traced the problem to the wires inside the canister by opening the inside cover to the bag container. We see the power cords going into the canister but we're not able to get to anything. We can't find any screws to undo that would open it up in order to follow the wires deep into the canister. We've bypa


... Electrolux Vacuums

How many filters does the bagless dirt devil vision wide glide have cause the motor sounds fine but it doesnt **** hardly


Check and clean the hose. ... Vacuums

My Filter Queen vaccuum is working but it does not pick up the dirt. The power nozel is working and it sounds like it is working but it doesnt pick anything up?


... Filter Queen Vacuums

My e wave microwave appears to be in fine working order until the door is opened. It then trips the breaker and ceases working. Ater the house breaker is reset, the power is restored to the microwave until the door is opened again.. I havve tried plugging the microwave into another area that is on a different power breaker but again the breaker trips and the microwave ends all functions. Have you any solutions to my problem? Email Address [email protected]


You may have a short circuit on the INTERIOR LIGHT BULB circuit in your microwave.\015\012\015\012This might explain why the breaker trips every time you open the door.\015\012\015\012If so, you would have to unplug and disass ... Vacuums

My scooba seems to work fine but no longer makes the beeping noise. Several weeks ago the beep was sounding very strange almost like a battery was dying. Now it's not making any noise at all. Is this the beginning of more problems or can the machine function just fine without the beeps? If not then how can I fix it?


Your speaker went out. It could be totally isolated. You're not going to be able to determine what's wrong with your Scooba if something does happen, though, because without those beep codes, there's no way for the robot to communicate with you. ... iRobot 5900 Scooba Robotic Wet/Dry Vacuum

My Dyson animal seems to have an electrical issue that I am unable to pinpoint. Neither the wand nor the floor vac have any suction AT ALL. In fact the vac makes absolutely no sound and you wouldn't even know that it had power to it unless the rollers are turned on, the rollers work just fine. I had this problem start about a month ago and then it just started working again after messing with it for a while, now it has happened again and I am getting a little agitated! Please Help!!!!!!!!!!!


There is a filter inside the canister, and by your description it sounds like it needs to be cleaned. if you remove the filter and blow it out using a air compressor or using a slightly ridged brush and tapping the filter out this should solve your ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

I have an older Oreck XL vacuum that sounds like it is running twice as fast as it should. I disassembled the entire vacuum, including disconnecting the motor wires, to clean out the hair, string, and other things. When I put everything back and connected all the wires, everything appears to work, including the light. The only problem is, it sounds extremely loud like the motor is running too fast. The model number is: XL3610HH Ser. No. 3610HHXA039740-6 I do not have as electrical diagram to see


... Oreck XL Ultra Bagged Upright Vacuum

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?


... Kenmore 34722 Grab-N-Go Upright Vacuum

Rod problem... One of the electrical connection posts that are on the top of the rod appears to be broken which causes the power head to work only when it makes contact. Is this repairable? If not, is it replaceable? If not, are the rods available for purchase? The vacuum cleaner itself works well,


You would need a new wand. this might work for your unit. ... Fantom Vacums Lighting Canister Vacuum

My Bissell ProHeat 2x is pouring water out of the bottom anytime it's turned on. I had it in the shop for no water, took it back again for the same problem, took it back again because it had no suction, finally took it apart and found the problem with the suction and fixed it myself. Worked fine for a day and now it is constantly leaking water, if it's turned on, and is useless for anything except for making a mess.


Took the unit apart and discovered my heater had small pinholes in the metal and they had put in silicone, instead of a gasket, which didn't seal. So much for the place I took it to "saving" my heater for me. I repaired it myself by getting a few o ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

The vaccum cuts out replaced the wand but still having the same issue - the powermate head is fine and does not appear to be causing the problem. I have two Kenmore Progressive Canister Vacuum and this is happening on BOTH


... Kenmore 25512/ 25513 Progressive Canister Vacuum

My Kenmore canister model (116) 26212601 works in hard-surface mode (basic suction), but the brush won't spin for carpets, and when I try to turn it on, it makes a whiny sound and then turns off as it does when I need to press the overload button. I looked inside a bit, and the belt isn't broken--it seems fine. So not sure what the problem is. Thanks for any help.


... Kenmore 27815 Bagged Canister Vacuum

Lux legacy vacuum runs fine and was recently serviced - yesterday the tone of the motor on the vac started a higher sounding pitch - is this a potential problem and is there anything i can do with it - thank you


You don't mention whether it was the canister or upright model, but if it sounds differnet than what it usually does, then there is a potential problem. It could be anything from a full/clogged bag to a dirty filter to a clogged hose. You can check ... Electrolux Vacuums

Had my dyson root cyclone for about 4 years now, and in the last year it's had a few problems. About 4 months ago it started to make this awful grinding sound when the roller bar was engaged and I took it to a repair shop and they said it was the roller bar itself. The shop replaced the part and it worked fine for a couple of months and then it started to make the grinding noise again. I tried the clutch reset suggestion (turn it on its side and turn the carpet/bare floor switch slowly back and


Bdepends how much thay charged you for a roller brush because you can buy a good vac for about 100 pounds with a 12 month guarentee so its up to you ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Suction Problem I took my unit to my work and used it, when I returned home it wouldn't suck up anything. I took the recovery take out and it has inward suction. Shouldn't that be outward, so it goes into the tank? It also blows out of the bottom by the brushes. I check the filter in the bottom and that is fine. Is it possible that it is somehow reversed the direction of the air flow (rotor running backwards)? I am perplexed. What am I missing?


There is a stand pipe seal where the bucket sits on, and if it isn't there or out of place could cause a suction problem like you said yours is doing. In the picture it is #10. The motor seal may have gone bad and is leaking # 15.\015\012 ... Hoover F7220900 SteamVac V2 Upright Vacuum

My roller bar doesn't seem to be working, but I checked the belt and it appears to be fine, but a bit loose. Is this the problem? dial on front to determine heighth is also very loose and does not click anymore like it did a few months ago. Any help would be appreciated. thx.


If the brush roller stalls when it comes into contact withthe carpet, it might be that the tensioner spring has broken off. This is adesign flaw in the Eureka4870. The symptoms are: 1) brush spins until it contacts the carpet then itstalls, 2) the br ... Eureka Smartvac 4870 Bagged Upright Vacuum

Dead motor? My 8 year old Miele S251i has worked fine, until I was recently vacuuming and moved the plug from one outlet to another. When I restarted the vacuum, it made rrrrr.....rrrrrr....rrrrr noises and smelled like something was burning. I turned it off, and it's shown no signs of life since. Sound like a motor problem? I've taken the cover off and looked at the cord and seen the motor, nothing looks obviously wrong, but I'm also not mechanical.


... Miele S251 Flamenco II Bagged Canister Vacuum

No clogs, work fine, but makes a very loud wailing sound? what could it be?


My Dirt devil Reaction does the same thing. So I took apart the motor and it was crammed w/ dirt then I decided to clean it out. next time I vacuumed my house it was a lot quieter. The guy from Jones sew and vac said b ... Dirt Devil Reaction Twin Cyclone Upright Vacuum

Hoover floormate Hi, I'm not sure what the model number is on my Hoover Floormate, but I can't get the cleaning liquid to dispense. The vacuum(dry pickup works fine). The handle squeezes without a problem. It used to work without a problem and then I didn't use it for awhile. When I came back to it, it wasn't working. Thanks, Alissa


The tank sits on what is called the reservior asm. it is actuated by the control rod inside the handle. With the tank off, watch and see if you can see that rod hitting the reservior asm when you squeeze the trigger. If it is moving up and down on ... Hoover Floormate H3000 Upright Wet/Dry Vacuum

Hoover F7431-900 my carpet shampooer/steam vac was working fine until the brushes at the bottom of it just miraculously stopped working. they wont spin at all. Is this a motor problem? perhaps a water flow problem? please write back if you can be of any help. thanks


If the screen is not dirty, and the flapper valve to the turbine inlet is open, then the problem is mostly a stuck turbine impeller. The turbine impeller on my F7431-900 has seized TWICE!! The shaft for the turbine is not made of stainless steel, t ... Hoover F7431-900 SteamVac Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0809 seconds