Having problems with your Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum ?

The vacuum i've had for 6 months has very liittle suction power. checked that the belt is on. cleaned filter. checked to see if hoses were clogged. I used a super vac to suction any debris out of vacuum. still little suction power

Answers :

As this unit has 3 filters on it, a lot of people forget about the one filter that will cause all of your trouble here.
\012There is the exhaust hepa filter, no problem, your unit is pretty new, it shouldn't be a problem.
\012There is the circular filter in the chamber where all your dust and debris collects. It is in the top portion and will come out with a twist. This filter is washable. Warm water and no soap.
\012The third filter, and this is the one that is most commonly overlooked, is just below the dirt container you can take out and clean. It is in a grey "tray" that pulls out and the sponge filter is in the tray. As a word of warning, it is probably pretty dirty. Again just wash it, warm water no soap, and you should be good to go.
\012PLEASE make sure that the filters are DRY before putting them back into your machine.
\012Good luck.
Repair Help & Product Troubleshooting for Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

The vacuum i've had for 6 months has very liittle suction power. checked that the belt is on. cleaned filter. checked to see if hoses were clogged. I used a super vac to suction any debris out of vacuum. still little suction power

As this unit has 3 filters on it, a lot of people forget about the one filter that will cause all of your trouble here. \012\012There is the exhaust hepa filter, no problem, your unit is pretty new, it shouldn't be a problem. \012Th ... Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

I have excellent suction power through the vac, but when I try to use the hose there is no suction power there. I have cleaned everything and it is definitely clean and clear. I've also used the reset button.

When you use the upright Dyson, the handle has to be in the upright position for the hose to work. In this position, there should be a clear way through for the suction to the hose, and the suction for the normal sweeper should be off. This is all ... Sharper Image Dyson Slim DC18 All Floors Vacuum

I have a Kenmore central vacuum cleaner model number c107 34601. We have emptied the bucket and shaken the filter out to clean it. There is a filter that is filthy so we shook it out into a bag but the cleaner still seems to not have great suction. I notice there is a similar cap to the outlets I plug the central vac hose into on the unit itself that doesn't power the nozzle when used. 1 - what is this for? 2 - Should I somehow remove the entire filter and if so - can you tell me step by step ho

... Electrolux Vacuums

Poor suction I have a hoover hush s5627 vacuum purchased about 4 years ago from Costco. It's suction power isn't so good anymore. I've checked all the lines & hoses and they're clear and I've changed the bag. I even disconnected the pipe from the vacuum unit and held my hand over the intake. While the machine roars like a jet engine the suction power just ain't like it used to be. What could possibly be the problem?

This vaccuum has a Fan Blade inside connected to the motor that spins to create the suction you feel. After a few years of use (and misuse) the blades on this (plastic) fan will be broken off, thus damaging the unit. These Fans are replaceable if yo ... Vacuums

My Eureka/The Boss doesn't seem to have the suction power it had. However, when I place my hand under the hose, it has good suction, then when I try to pull in a small particle, it doesn't, unless I have the hose nozzle completely over the particle. The vac is 10 yrs. old. I cleaned everything. Someone said the belt. Would the belt matter if the hose doesn't **** well? It is just old and worn out? It did shut off recently do to overheating. Help. Thanks. Lorraine

Doesn't "The Boss" Vacuum have a filter? Perhaps your filter is clogged and not allowing it to work properly. ... Vacuums

I have a power drive baggless vacuum cleaner...it runs well, but suddenly it seems to have lost most of the suction coming through the hose and floor area. When I remove the dirt container, the suction below it seems strong. I have had it to repair twice--they have tuned it up and replaced all filters and belt. It still does not pick up well when I vacuum or use the hose. Can you help ?

There is something stopping it up,you will have to dissasemble the unit to find the blockage,this is the most likely problem. ... Hoover U6660-900 WindTunnel Bagless Upright Vacuum

My dyson vacuum cleaner doesn't seem to have the same suction power it used to. I have cleaned out the canister and have taken apart the vacuum head (for cleaning carpets) and it doesn't seem to be blocked but it seems to lose suction by the time it reaches the head. The suction is strong at the end of the hose (where you attach the telescopic attachment with vacuum head) Any ideas? Thanks, Irene

... Vacuums

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u

Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

My Hoover Steam Vac for my rugs works fine, but I don't have any suction when I try to use the hose and attachment for my upholstery. I went over the instructions dozens of times but still no suction.

Which type of hose do you have? One has a duct attached to it that fits into a slot in front of the recovery tak, make sure it is seated all of the way down. The other hooks direct to the machine, is it cracked where it hooks up? You can tell by l ... Vacuums

Recently purchase SC-N500 vacuum cleaner. Worked well only the first 2 times I used it to clean up plaster dust from floor after sanding. Since then it has not worked at all well wiht very poor suction. Fluff gets stuck in the hose and has to be manually removed. Suction power is very poor. I have washed the filter to remove the dust with no difference. Who do I contact in Brisbane to service or assess the problem further.

... Sanyo Vacuums

Have an electrolux 2100 canister vac, it has lost suction power thru the years. no clogs in newer hose or in sweeper. even with new bag, filter and belt only increases power minimally.

Have you ever over the years replaced your brushroll ? Have you tried dropping a coin thru the hose from one end to see if it comes out the other end ? Have you taken the wand loose from the elbow ( the swivel part of your carpet sweeper) to see if t ... Electrolux Vacuums

My Dyson DC14 has lost its suction power. And when using the hose it has no suction at all. Any suggestions?

... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

Smell/suction I have a Eureka Altima Model 2991 Type AVZ. I have suction when I use the power paw and attachments. I have all hoses clear. My brush is spinning and belt is not broken (I opened it up and checked), but I have no suction when I turn it on to vacuum my living room carpet. I also have a burning smell to go with it after about 30 seconds. I've never had a problem with this vacuum cleaner before.

Ours started smelling too, and it seems that the plastic end on the roller brush was melting. In process of finding rollerbrush for it now ... Eureka 2971AV EZ Kleen Bagless Upright Vacuum

The hose will blow out air but has no suction to use the vac

... Shop Vac 925-13 Canister Wet/Dry Vacuum

Suction power has left, shouldn't there be a second motor engaging when you use the tool hose?

... Dyson DC07 Bagless Upright Cyclonic Vacuum

I have a one year old Beam central vac. It has supervalves. The handle (connected to the hose stopped turning on the unit. The handle still powers the brush but no longer turns on the suction?

Http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=566201 ... Vacuums

After changing bag, vacuum motor does not work. Yes, it is closed. Yes, the correct bag was used. Yes, the power head bristles will turn, but there is no suction. This is a 3 month old vac. What to do?

If your carpet is quite new then sounds like its choked .Clear out all hoses check for blockages.. ... Electrolux EL6988A Bagged Canister Vacuum

When I use the hose, it makes a hissing sound that wasn't being made before. The suction power seems to be not as strong.

Either you have a hole in your hose or there is a knob on the top of the hand that is open. ... Eureka Whirlwind 4496 Bagless Upright Cyclonic Vacuum

When taking the handle/wand back to use it seems to lose the suction power regardless of what setting I use. Upon several times of standing it back up it seems to engage the suction power correctly is there a button or something that does not always engage to get power? can I fix it

When you say taking handle back I assume you mean the action to start rotation of brushes. Had simular problem and found by removing brush from tube and then cleaning "baked on rubbish" in plastic tube (so you can see clearly through tube) Clean with ... Dyson DC28 Animal Bagless Upright Vacuum

The hose that is used for upholstery has full suction..thereby making the suction on the floormachine less strong..have taken it to appliance repair store where hose was plugged up..i only use it for

... Hoover F5832-910 SteamVac Supreme Vacuum

My vac has lost suction. When I vacuum it picks up very little, but when I remove the wand hose it has good suction. We have cleaned both filters, checked for blockage in all hoses & cleaned the beater bar brush. All to no avail. Is it the motor? Or is there a blockage deep in the vac somewhere? We're debating repair versus buying a new one. Hope you can help. Thanks.

Hi there,Sorry to hear you're having a problem with your DC14. Since you say you've already washed the filters and checked for blockages, it's probably best if you get in touch with us so we can run through some simple troubleshooting ste ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

Hoover Jet and Wash 1500w S6254 001. Used once with great difficulty as assembly and use instructions are hard to follow.Now will not work as carpet shampooer at all, although assembly is correct as far as I can see and both motor and pump appear to be working and I am using the recommended cleaning fluid.Hoover website is no use at all in solving the problem.No cleaning fluid is being drawn up from the tank in to the cleaning fluid hose.There is suction from the suction hose so the problem appe

I am having the same prob my uncle got me one i cant find the manual anywhere to set it up the prob i have is where does the handle to make the water go out connect tooo ??? on the main pipe that sucks it back up i have tried every which way but not ... Vacuums

Beam solaire hose only works to suction The power head isn't working. Have another hose and the power head does work on that one so I know it is the hose

... Vacuums

Hi I need help because I have a problem with my Electrolux Centralux Central Vac system in my house. When I plug the vac hose in the central vac socket at first I heard the motor running very gently with NO suction then after a minute or so it went completely dead and they is NO motor sound, suction, or anything happening what so ever. Can anyone tell me what this problem is???

Have you checked for a clog in the lines or in the hose? If there is no clog in the system anywhere, then your motor could be dying. ... Electrolux Centralux Vacuum

I have a Hoover windtunnel T series. Model #UH70105. The system check indicator was almost red so I cleaned the filter. There are no clogs and it vacuums fine without the hose, but when I go to use the hose there is very little suction and all the vacuum dust flys out of the end the hose piece fits into when not in use. Can you please tell me what is wrong?

... Hoover Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0778 seconds