Having problems with your Bissell Vacuums ?

Can not attach top back to bottom

\015 Can not attach top to bottom after replacing belt for water pump\015

Answers :

Water pump on vacuum? steam cleaner / carpet cleaner? You have gotten something out of alignment. Check seal and make sure to have everything else in place before trying to screw back together
Repair Help & Product Troubleshooting for Bissell Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Can not attach top back to bottom


Water pump on vacuum? steam cleaner / carpet cleaner? You have gotten something out of alignment. Check seal and make sure to have everything else in place before trying to screw back together ... Bissell Vacuums

I have the Miele S7280...the one without the clog hatch on the back. I took the bag cover off, then continued the remove the screws and cover underneath it to detatch the top from the bottom. Found the clog and cleaned it out. Heres the problem...now the power nozzle light comes on and the vacuum "on" is lite up red, but it will not come on. Checked the filters and the bag. It certaintly seems like the top and bottom are meeting up to latch into each other, but I have no power. Help!!


... Miele S7210 Bagged Upright Vacuum

The rubber seal strip inside of the vacuum system on top and on the bottom has started coming off. I was wondering if I could reorder this rubber seal stripping to replace on my system. The model number on my system is #91740. MV 261414/1 is another number that was labeled on the back of machine as well. We ordered it off of QVC and the name of this vacuum system is called, Cook's Essentials's Vacuum Packaging System. Thank you for you time. Look forward to hearing back from you soon.


... Vacuums

Elna TX Electronic machine. Top thread gets tangled in rotary hook when straight stitching. Top thread is also found attached to bottom of fabric when removed from machine. Can you help please.


Try a different type of thread for this operation. ... Vacuums

I pulled out the hose assembly from the back of the sweeper to clean it out. When I did so, there was a red/black wire that was attached to a small metal plate on the top of the assembly. What is the purpose of this? Does it need to be soldered back on?


... Hoover U5753-900 WindTunnel Bagless Upright Vacuum

I have an older model F6056-900 Hoover steamvac Spin Scrub Cleaner. My first problem was that I loaned it out to a friend. Anyway she ran over the hose (used for attachments) with her car. I tried using the cleaner for carpet cleaning this morning but when I tried to put the solution tank into place...its loose...won't snap back in like it used to. When I can get it somewhat in place the solution just complete drains out through the bottom fo the tank. The leak is where the small hole on the bot


... Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

I have any easy-flo built-in vacuum. I recently had the bearings on the motor, top and bottom replaced. I put the vacuum back together and it mow has low suction power. There is plenty of suction on the side of the canister where the rigid tubing meets the canister body but little suction at the wall plates. Any ideas? Roger


There is either a blockage or a pipe is open somewhere. You should check the system at the wall valve without the hose to determine if the pipes are blocked or if perhaps the hose is plugged. If one of the wall valves is damaged or open, this will af ... Vacuums

I took the trap(or whatever it's called)off the bottom right corner to check for an obstruction as my hose was collapsing when using the attachments. Put it back on(perhaps wrong)and now when the vacuum is turned on, dust blows out the front and there is NO suction! HELP!


Now you have a dyson leaf blower! not funny huh? Ok, just slow down and recheck your connections. Sounds like the motor is running backwards or you are hook up to the discharge. ck for baffles that block off the vacuum to the roller part when at ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

Malfunction 8 franke flair. I have removed the brewing unit o rings to free up the drive. Drive motor keeps over running the top and bottom limits hence gears grinding. Could it be the sensor on the back of the motor? What is it measuring? Any help appreciated


... Vacuums

Loading my 52148 Scunci into the back seat of my truck the connector from the bottom of the handle to the top of the unit snapped off. It appeared to have a pivot ball that went into the sweeping unit to move,turn and pivot the sweeper. I could rig it to sort of function but if the lower handle part is available it would be nice to purchase one, if available. THANX, Don Colo Spgs Colorado


... Scunci 52004 Bagless Canister Vacuum

I have a Necchi LYdia 3 machine type 544 The motor was overheating and I removed the bottom cover and examined the motor .It looked fine and ran well. It worked OK for a time and then got hot.I was able to partially remove the motor for inspection.I found that the cooling impeller was not secured to the shaft,I tightened the set screws and reinstalled the motor. In process of getting the drive belt back on I turned the wheel that extends out of the case to index the screw that attaches the bobb


Good day!Please try to re align the motor position.You have to do is repeat the procedure that you take to remove the motor and double check the alignment because all motor in misalignment is very hard to turn.And ... Vacuums

Bissell ProHeat 2X - I removed the clean water tank bladder and now I can't figure out how to attach the insert from the bottom of the tank so I can put it back together. Any ideas? Make sense? :)


... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

I have the top of the line kenmore canister vacuum. According to the bottom plate the model nimbler is 116.28015700 I was doing the normal vacuuming and the bag full light came on and the vacuum action stropped. There is still power to the mortorized handle and agitator attachment. Is there some type of circuit breaker reset button for the vacuum function? This unit is probably less that two years old and has had very little use


... Kenmore Vacuums

Reattach spring Spring from bottom of base that attaches to the back wheel base came off


This is the only picture i can find it may help youhttp://abcvacuumwarehouse.com/stabilizer-assembly-for-dyson-dc25.html ... Dyson DC25 All Floors Bagless Upright Vacuum

I need to change the retractable cord in a Kenmore Model 116.228.13204 vaccum but can't figure out how to remove the housing. I have removed the bag and the two screws but the top appears to be attached under the foot pedal. How do you release it. Does the foot release pop off somehow to reveal another screw in the back of the housing?


Go to this web site, it gives you complete schematics of your model. This will make it easier to see where all screws are and what you have to remove to get to reel. http://www.searspartsdirect.com/partsdirect Just enter your model # and complete bre ... Kenmore Vacuums

I have borrowed a Euro Pro vapor steam cleaner. It is red with 4 wheels on bottom. It has a port on top to put in water,and it has various attachments. How much water do I put in it, and how do I


... Vacuums

Hover F7452-900 My brushes are not turning. I have taken the tanks off to check the switch that changes from carpet to hard terrain to Ceramic tile.I noticed that there is a spring that has came off. I tried to disassemble the top half (nose) of the cleaner but I have came to a stand still. I cannot figure out how to remove the cover so I can figure out where the spring should be attached. I have removed all the screws that are visible and it still won't budge. It is loose but on the back side o


Regarding the brushes not turning:\015\012\015\012Your filter may need to be cleaned. It is located behind your brushes. With your tanks removed and the cleaner unplugged; tilt your cleaner back. The filter screen located behind your b ... Hoover SteamVac Carpet/Upholstery Deep Cleaner Vacuum

I have a tear in the hose of my old model # F6030-900 unit which doesn.t allow water from the attachment to **** back into dirty water bucket. The model #F6039-900 is the same model # but different year I understand. The tear is at the bottom where set the recovery tank in the lay down position and can look in the unit at the bend of the hose.


You will have to replace the hose asm. You can order online at: \015\012http://vacuumsuperstore.com/F6019.html\015\012\015\012H-90001334 (43 ... Hoover SteamVac Carpet/Upholstery Deep Cleaner Vacuum

I sucked up a sock into the carpet attachment of my electrolux 3500 series and the carpet attachment cut off. After the sock was easily removed (it was only wrapped around the brush part) I reattached the carpet attachment, turned the vacuum on and flipped the switch to turn the carpet attachment back on, but it won't come back on. How can I fix it?


Did you press the reset button? There will be a reset button either on the back of the unit just below the bulkhead or on the top side of the base.\012\012Locate the reset button and press; this should allow the carpet attachment to resu ... Electrolux Epic 3500 Vacuum

How do i attach new outer bag to top of heritage handle


... Vacuums

I have a Kenmore upright progrssive intell clean. For some reason it isn't sucking when I use it to vacuum. When I use attachments they work fine, but when I plug the hose back in after using the attachments and turn it back on it makes a weird noise and I can feel air blowing out of the back. Can you help me resolve this problem?


You have the answer and just don't know it. You are there so keep looking. Somewhere between where the suction hose connects with the lower hose and the power-head. There is a blockage, you may need to turn the unit upside down and look there or try ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

I have a Kenmore upright progrssive intell clean. For some reason it isn't sucking when I use it to vacuum. When I use attachments they work fine, but when I plug the hose back in after using the attachments and turn it back on it makes a weird noise and I can feel air blowing out of the back. Can you help me resolve this problem?


Open this manual to page 18 and clean all the filters listed to restore air flow.http://www.managemylife.com/mmh/lis_pdf/OWNM/L0908343.pdf ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

I have a Kenmore quick clean model 116.36724500 and the belt popped off so we took the bottom off and put the belt back on, but now cannot get the bottom floor plate back on! Please help! :( I have no


... Vacuums

My Hoover Pet Cyclonic upright stopped working while I was using it. The bottom felt really hot so I emptied the canister & laid the vacuum down with the bottom in the air to cool off & went back in an hour or so, I even tried a different plug in but it still won't turn back on. I don't know what else to try.


This just happened to me. Any solutions or insights? I need to know asap. ... Dirt Devil Hoover Uh70085 Pet Cyclonic? Upright Vacuum

I can't find the 4 screws to get to the belt on a dirt devil 22.0 Fx. The bottom of the vaccuum says " remove four screws from bottom of nozzle then lift top nozzle cover off", where are these screws, I can only find two, and which is the top nozzle cover?


... Dirt Devil Vision Turbo W/Bonus Upright Vacuum Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1140 seconds