Having problems with your Broan-NuTone CV353 Central Vacuum ?

When i put hose in port it will not turn on...all the other ports work except one

Answers :

Open the door on the inlet port and look inside. You should see 2 small pins. These pins are spring loaded to make contact with the metal end of your hose when you plug it in. Two low voltage wires are screwed to the underside of these pins. The low voltage wires go all the way back to the low voltage switch/relay on your central vac power unit.
\015\012 Sometimes one or both of these pins will just break so that they don't make contact with the end of your hose. If you see no pins or just one then you will have to replace the inlet cover.
\015\012 If both pins are present; push down on them with your finger. If you feel resistance then your inlet is probably OK.
\015\012 Remove the two screws in the faceplate. Carefully slide the inlet cover out. Check the two screw on wiring connections. Make sure both wires are securely attached and that there are no breaks.
\015\012 If neither of the above fixed your problem, you may have a broken or disconnected wire somewhere between this inlet and the low voltage witch at your power unit.
Repair Help & Product Troubleshooting for Broan-NuTone CV353 Central Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

When i put hose in port it will not turn on...all the other ports work except one

Open the door on the inlet port and look inside. You should see 2 small pins. These pins are spring loaded to make contact with the metal end of your hose when you plug it in. Two low voltage wires are screwed to the underside of these pins. The low ... Broan-NuTone CV353 Central Vacuum

I was given a model 6591, plugged it in and it worked but didnt "****" and didnt sound right. I turned it off and removed the hose from the back found a badly plugged hose. Removed the hair plug cleaned filters and when I tried to turn it on again. Now the motor will not turn on or even make a noise. I hear there is a fuse that can be blown? How can I find the fuse if there is one? Thank You Ron

The User Guide for the bissell Clearview Power Trak\012\012http://canada.bissell.com/images/UserGuides/3590C.pdf\012 ... Bissell 6591 Power Trak Revolution Bagless Upright Vacuum

Kenmore 21875 One day it's working fine. Next day, it won't turn on. When I attach the hose to another vacuum cleaner, it runs. Is there a reset button on the canister? Could it be the receptacle is bad? My Kenmore Progressive won't turn on today either -but was fine last week. I cleaned the filters checked for blocked air, tried a different outlet and no luck. I'll check the pins on the connections and see if one of them is not matching up or appears worn.

Give the prongs a wiggle and see if there is any play in them.Might just be a plug end. ... Kenmore 25512/ 25513 Progressive Canister Vacuum

NOTHING WORKS Used the unit 3 1/2 weeks ago, now it will not do anything except turn on. The water and shampoo will not dispense and the brushes will not turn. Is there some type of reset button that can be utilized????????? Have had unit for several years with only one other problem, the soap dispenser had to be replaced because it leaked. Teresa

Check the foam filter on the underside of the recovery tank lid, make sure that it has at least a 1/4 in. gap from the top. There also is a filter, from the bottom, it has a red frame, pull out far enough to clean it.\015\012On the bottom of t ... Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

Hoover S3765 I have a Hoover S3765 (serial # 040600024465) and the unit stops working for no apparent reason. The light on top of the unit goes off when it shuts down, so I don't believe it's a problem between the hose, the tube and the floor unit. Sometimes I have to let it sit for over one hour before it will come back on. I've tried different electrical plugs too. Still won't turn on. Any ideas or suggestions? Thanks

If you light and nozzle motor both go off at the same time, you might have a bad power cord. Mine had this problem which I could verify by jiggling/twisting the cord near the strain relief on the nozzle. It would go on and off as I did this. ... Hoover S3765-040 WindTunnel Bagless Canister Vacuum

My bissell 6590 works fine with hose attachment. Motor shaft turns when belt and roller are off. When belt and roller are on it's noisy and smelly. Now one end of the roller actually melted in the holding slot. Do these rollers wear out like this or should I be looking for another problem.

Replace the roller,belt and before instalation clean motor shaft where belt rolls. you can turn on the vacumm and using a knife scrape the motor shaft from the black dirt. ... Bissell 6590 CleanView Bagless Upright Vacuum

Kenmore 21875 One day it's working fine. Next day, it won't turn on. When I attach the hose to another vacuum cleaner, it runs. Is there a reset button on the canister? Could it be the receptacle is bad?

My first recomendation would be to try pluging into a diffrent wall outlet as well as something that is on a diffrent circut . It is a known problem that the pins inside that make the connection could be worn out . There are several pins from the one ... Kenmore 21513 Vacuum

I have the smaller oreck portable hand vaccuum & it won't turn on. It was working fine in the one bathroom & I moved to the other & bathroom & it won't work or turn on at all?

Check the wall outlet has poser and make sure the plug is fully inserted. ... Oreck XL2200 Bagged Upright Vacuum

Beam solaire hose only works to suction The power head isn't working. Have another hose and the power head does work on that one so I know it is the hose

... Vacuums

Hoover Deluxe Elite Rewind vacuum has stopped working as it should. The airflow indicator snaps on almost immediately after I turn it on whether the hose is connected to the brush or not. There isn&

... Hoover Elite Rewind Bagless Upright VacuumVacuum

My BROAN CV-110 hose with the rug beater only works if I turn it on from the base unit. Shouldn't it turn on when I plug the hose into the wall recepticle? Do I need to replace the hardware at the end of this hose and if so, where would I purchase that? This central vac came in a house I just purchased. Thanks for any help. Sherry

... Broan-NuTone CV450 Central Bagged Central System Vacuum

I have a Hampton Bay ceiling fan St. Regis model #138 498. Somehow the remote got messed up and now the lower light flashes on/off when the power is on and nothing else works. This happened one other time and I simply turned off the switches and when they were turned back on everything worked fine. This fix does not work this time.

... Vacuums

My Bissell Model 3760-4 is not working properly. The belt has been replaced (and checked 3 times), but the brush bar does not move when the brush motor button is on. The little metal turning piece that turns the belt is turnable with one's finger when the belt is off, but when we put it all back together and turn on the vacuum, the brush bar does not go around and the burning belt smell returns. The portable part of the machine works properly. It's the brush bar. It has been cleared of hair, etc

... Bissell Lift-Off(R) Revolution(R) Turbo Upright Vacuum

Electrolux Central Vac- One hose works well, one does not

If its an older hose it might be crunching up when the vacuum is running that couses a loss is airflor due to high resistance. if this is the case the hose should be replaced. ... Electrolux Central Vacuum

My shopvac ultra pro 5.5 gal will work except will not pump water through a hose. it just shuts off when the tank is full. how do i get the hose working ?

... Shop Vac 962-12-00 Ultra Pro Wet/Dry Vacuum

I have a new (couple of months) Cuisinart Espresso Maker EM-100C. One has to turn on the power button on the front in order for the unit to heat the water. The button will only work if the two manual knobs are in a certain position. Very occasionally, it took a few tries to get the button to turn on. Now it usually does not work but will once in a while. Any ideas what we could do to repair this problem?

... Vacuums

No Suction My two year old Kenmore Progressive stopped working in January. The guy at the Sears service center convinced me that buying a new one would be cheaper than getting it fixed. So I bought the exact same model and now this one has given out in the exact same way! I'm so confused. When I press on, it lights up and makes the whirring noise. Everything seems to be working but there is no suction anywhere. Not in the main part or the hose and there's no "cyclone effect" in the chamber. All

Try looking within the vacuum to see where the suction is getting stuck at. You may have to do some disasselbmeing but this is a manufacturers problem. You should also try to speak to the manager at the support and make a big dispute until you get yo ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

My Hoover Whisper Cyclonic is collecting the dirt but not taking it into the cylinder. The brushes were at one point starting and stoping due to the belt periodically turning,now the brushes are turning and the dirt just collects and I'm starting to smell a an oder like rubber burning.I've taken it apart and tried to make sure the is no clog. The one hose that I can't check is in the back right base, above and left of the right back wheel.

... Hoover U5753-900 WindTunnel Bagless Upright Vacuum

I was vacuuming and part of a towel got sucked up, but not into the hose, and now it isn't working. I turned it off, unplugged it, and the hose still works with the attachments, it is just the base

Http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=833476\015\012Generic problem for all Vacuums\015\012I was vacuuming and part\015\012Posted by melly648 ... Vacuums

Bissell Spotbot Pet Model # 33N8A. "Hose" button is only one that works, and only intermittently.

... Bissell Vacuums

My Dyson DC25 animal is having issues. I believe everything is working correctly except I have realized that the mechanism which switches the hose/valve between the wand and the vacuum head isn't working properly. The two gear pieces that move the hose placement aren't close enough together, so they don't work together. It looks like there is a washer that I could potentially remove on the clear gear piece which would allow it to sit closer to the assembly. Would that work? Currently I am

... Vacuums

Dewalt DEWALT Cordless/Corded Wet/Dry Vac 2 Gallon Vacuum: It was purchased new, and used only one time,the second time the unit was turned on it never worked and have never worked since, the motor and switch were both tested and are working...any ideas?

This vacuum has a history of problems with the battery contacts. Check that yours are not bent out of shape or corroded. if they are... straighten them or remove the corrosion. ... Dewalt Cordless/Corded Wet/Dry Vac 2 Gallon Vacuum

Stopped working My filter queen just stopped working. The one off switch will not work. I tried several outlets and it will not turn on.

I had a simular probleme with my older model filter queen vac and it turned out to be worn brushes on the motor I simply ordered new ones installed them and then and all it costs was 15.00 usd to canada probably less in U.S. go to this site you'll fi ... Filter Queen Majestic Canister Vacuum

I have a Eureka Upright vacuum (4800 Series). When I try to start it by turning the switch on, it wont. For few days, I was able to get around this problem by repeatedly turning the switch on and off until it turned on but that does not work any more. Could it be something related to the switch it self or the power cable. My wife mentioned that one of my kids might have pulled the power cable too hard (at the back of the vacuum). Any help to solve this problem will be very much appreciated. Tha

... Eureka Smartvac 4870 Bagged Upright Vacuum

The motor on my Epic 6500 works, the hose is sucking, but the power head isn;t working... I tried the sidestep power head and that one works. Ive opened and replaced the belt and that is fine. The bulb was already burned out and wasn't replaced so I cant tell if theres power to the head. What else could it be?

Connect the power nozzle directly to the hose and try.\015\012Check the terminals where the wand connects to the PN. If any are discolored or cracked, that may be the problem.\015\012Open the PN and check for loose or broken wires and co ... Electrolux Epic 6500 Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0967 seconds