Having problems with your Broan-NuTone CV450 Central Bagged Central System Vacuum ?

Not full suction, noisy, sparks at the unit

\015 The unit is a CV350 and it lost some of its suction and also there are sparks visible at the top of the unit when is running. Also is noisier than normal.\015

Answers :

Yup you need a motor. try and find a nutone service center. they will have the parts and be able to repair it.
It sounds like the motor is burning out
Repair Help & Product Troubleshooting for Broan-NuTone CV450 Central Bagged Central System Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Not full suction, noisy, sparks at the unit


Yup you need a motor. try and find a nutone service center. they will have the parts and be able to repair it. ... Broan-NuTone CV450 Central Bagged Central System Vacuum

I have a Nutone CV-450. When the unit is turned on the motor makes a high pitched whining sound. The suction seems like it is reduced and there is a burning rubber smell coming from the unit. Suction at the unit itself is also reduced. Any ideas about the cause of the problem and the solution?


... Broan-NuTone CV450 Central Bagged Central System Vacuum

Very little suction from vacuum is occurring after I pulled a string from the roller. Hot air is blowing out of unit. Was working fine until I pulled out a string...Suction is occurring from wand.The brushes now make a loud sound too when activated...do I have to take the unit apart to readjust them or something?


Yes re adjust ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

My Dirt Devil M082476 Full Bag indicator light keeps coming on when I turn my vacum up to full intensity. I have tried changing the bag and checked that all hose is clear. If I leave the vacum on low intensity the suction is minimal and does not increas when I turn up the suction. Is there a solution to this? I look forward to your response


... Dirt Devil M084105 Jaguar Vacuum

Help hi there. i have a hoover savvy u8172-900 vaccum. the hose has great suction, but there is limited suction on the main unit and the brush does not spin when i try to use the product. we have cleared the brush of any debris and have also installed a new bag. a few days ago, we disconnected the hose to make sure there was not any foreign bodies stuck in the unit...nothing seems to help. any advise?


As the hose fits into the base (if i am correct) the power at the base should be fine, make sure the base is clean and free from blockage,\015\012you say the brush doesn't spin, has the belt broken, if so replace it, (very cheap) and only a couple of ... Hoover U8171-900 / U8172-900 / U8173-900 / U8174-900 Savvy Bagless Upright Vacuum

No Suction I get great suction in the hose, but when I plug the hose back into the unit, there is no suction and the air flow indicator line goes completely red. I've changed the bag and filters. I took the small panel off the back and made sure there is no clog, and took the hose off to make sure there was no clog there. Still no suction. Please help.


I about to say that's always a clog of some sort that causes that ... Miele S7210 Bagged Upright Vacuum

Poor suction I have weak suction at all ports and no suction at the canister. It is a Nutone model CV-350. This unit came with the purchase of our home, so we don't know much about it. thank you for your help.


Either you have clogged filters, or the motor is weak, you could check the carbon brushes, otherwise replace the motor. ... Vacuums

Decreased suction was using to vaccuum carpet and suction decreased..nothing plugging hose....suction remain at unit canister and exhaust is fine....suggestions??


You might have a clog, to try and unclog the lines, you need to unplug the unit, and remove the bag compartment. Then take a shop vac using the hose attachment hold it into the attachment door where there is low suction and try to draw the clog out t ... Broan-NuTone CV353 Central Vacuum

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But


Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

Low suction I have a Hoover central vacuum system. I've reset the fuse box, checked the fuses, all of the lines are clear and there are no holes for escaped air to travel out. The filter has been cleaned as well. The vac works well with high suction when hooked directly to the unit, however when using any of the indoor connections there is extremely low suction. The machine still turns on so I do not believe it is an electronic issue. I have troubleshooted the issue as best I could and would


... Hoover L2310 GUV Central System Vacuum

The unit comes on and the exhaust blows out however no suction at all. l placed a wet vac on the unit where the bag goes and all of the outlets pull some air. The unit is the cv350. Thanks.


There would be 2 things potentially wrong here... 1) the black rubber gasket is missing off the body where the pail goes onto the machine. If that is missing there will be no suction. 2) This is a little more complex but will ... Broan-NuTone CV350 Performance Bagged Central System Vacuum

Blue Moon S658 Miele vacuum problem where suction cuts off. The power light stays on. Sometimes I lose full suction, and other times I just lose partial suction. This shows on the handle by going from 1000 to 400, or nothing. Any thoughts on what this could be?


This is a problem with the circuit board in the SES-125 hose. If you replace the hose, this problem will stop. Unfortunately this is the only solution to this problem. \015\012\015\012-R ... Miele Blue Moon Bagged Canister Vacuum

Poor suction I have a hoover hush s5627 vacuum purchased about 4 years ago from Costco. It's suction power isn't so good anymore. I've checked all the lines & hoses and they're clear and I've changed the bag. I even disconnected the pipe from the vacuum unit and held my hand over the intake. While the machine roars like a jet engine the suction power just ain't like it used to be. What could possibly be the problem?


This vaccuum has a Fan Blade inside connected to the motor that spins to create the suction you feel. After a few years of use (and misuse) the blades on this (plastic) fan will be broken off, thus damaging the unit. These Fans are replaceable if yo ... Vacuums

Bag was full, changed it, the unit now turns off


Try dialing the control valve to the mid way position. If the unit still shuts down with the bag full light on you have a damaged control valve under the dial on the top of the vac. This valve failure is common in this model and can only be rep ... Electrolux UltraLux 2000 Bagged Canister Vacuum

I have a Riccar R-200 upright vac. My wife ran it for an hour without stopping and a full bag. The motor cut off and the unit won't turn back on. Is there a fuse to reset in the unit if it overhe


... Dyson Vacuums

Loss of suction and bag full


Sounds like you still have a clog, either in the hose, drop something down it to see if it comes out the other side. The other place is the dirt inlet by the brush roll. Take off either the top cover or the bottom plate and you can check it out. ... Vacuums

I have a dirt devil easy steamer deep cleaner that is a few years old but only used once or twice. I am currently trying to use it and when the unit is suctioning I hear a popping sound and then I lose suction. What could be wrong and how do I fix it?


I have always bought dirt devils and this last on that I got is bad it dose not clean by the base boards like the others it dose not pickup stuff from the floor like the others, when you add one of the attachments to it that takes away from the sucki ... Dirt Devil Vacuums

No suction The brushes spin as normal but there is little to no suction through the base of the unit.


Your Belt band probally broke. My is doing the same thing, I wonder if I could sew the belt back together? ... Bissell 6594 PowerForce Bagless Upright Vacuum

I have full suction with the hose and when the brush is off of the vacuum. However, in the vacuuming position, there isn't enough suction to pick anything up. I checked for clogs and cleaned all the filters.


So I have exactly the opposite problem, it sucks in floor mode but the hand held has zero suction. My daughter and i just spent the last hour disassembling and diagnosing and found this: The way the suction tube is configured, you have two places to ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

EF 1750 has lost suction power. There is a noticable decrease in suction power even at the power unit inlet.


Disconnect the actual pipe where it meets the vac. Then test the intake for suction. If you have poor suction still, check the intake itself from inside the vac body for blockage, then check the gasket on the pail for mis-alignement.If yo ... Easy Flo EF1750 Central System Vacuum

My cleaner does not have any suction and I clean the hose so there is nothing blocking it. The unit turns on, but no suction


Have you cleaned the filter in the top of the unit? ... Hoover U5780-900 Windtunnel Cyclonic Bagless UprightVacuum

Suction centralux vacuum two years old doesn't have the volume air movement it once had. Unit will still quickly reach an extremely high head of suction so no broken pipes. ran napkins thru no blockage, overode filter safety switch ran with out filter no difference. just don't move air like it used to


Hi!!! clean motor blower blades ,they collect alot of duct and the air in chopped,Good luck.Clean blower fan blades.. ... Electrolux Centralux Vacuum

Poor suction We bought a model home about 11 years ago and it had the Cental M&S Cyclonic Cleaning system. The suction has steadily been weakening. Now it is almost non-existant. I clean the filter bag in the main unit, but how clean does it need to be. Could there be a clog in the wall lines. If yes, how does one unclogg them. Thank you. I liked the system and would hate to just give up on it. Jean


This page has useful tips for unclogging a central vac. https://www.centralvacuumstores.com/cvs/trouble_help.php ... M&S Systems FX-3000 Bagged Central System Vacuum

Suction Problem I took my unit to my work and used it, when I returned home it wouldn't suck up anything. I took the recovery take out and it has inward suction. Shouldn't that be outward, so it goes into the tank? It also blows out of the bottom by the brushes. I check the filter in the bottom and that is fine. Is it possible that it is somehow reversed the direction of the air flow (rotor running backwards)? I am perplexed. What am I missing?


There is a stand pipe seal where the bucket sits on, and if it isn't there or out of place could cause a suction problem like you said yours is doing. In the picture it is #10. The motor seal may have gone bad and is leaking # 15.\015\012 ... Hoover F7220900 SteamVac V2 Upright Vacuum

No suction,but motor is working. suction at the unit works.


... Beam Industries 750 Classic Bagless Central System Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0423 seconds