Having problems with your Broan-NuTone CV653 Bagged Central System Vacuum ?

Motor is pulsing on and off, suction is good when motor running


Answers :

Repair Help & Product Troubleshooting for Broan-NuTone CV653 Bagged Central System Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Motor is pulsing on and off, suction is good when motor running


... Broan-NuTone CV653 Bagged Central System Vacuum

Does not pick up, no vaccum, motor runs, no blockage, should feel suction on hose outlet without hose hook up. Paper filter missing over cloth filter. float overload ball free, seal on section good no leakage. Maybe bad motor but runs.


Here\015\012 is a Link to one of my Tips:www.fixya.com/support/r6311178-vacuum_brush_bar_not_spinningThis\015\012 should solve the problem. ... Minuteman C82906-01 HEPA Vacuum Vacuum

7600 model - motor runs and good suction present Does not self propel and brush does not rotate although I can turn it easily


Your brush drive belt has broken. Generally you need to remove the bottom of the machine in order to get to it. On the belt you should see numbers even if you don't, just look on the bag that the new one comes in for the brand and model you have. Bel ... Hoover Self-Propelled WindTunnel Bagless Upright VacuumVacuum

Z330A Suction & Motor Good. Continuity of running is broken with any pull on the hose


... Electrolux Vacuums

No suction My Hoover Wind Tunnel vacuum runs but there is no suction. The last two or three times I used it, it shut itself off after having a burning smell. When I unplug it for the suggested 30 minutes, the motor will run again but no suction. What is wrong?? Should I just buy a nve one? This one is 8 years old.


Sounds like your motor bearings are going bad. This is generally indicated by the motor overheating, and the heat transferring out through the motor pulley, which is where the belt attaches. So, your machine is overheating, melting the belt, and then ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

No suction After taking the vacuum apart, I noticed there is no suction at all. The motor runs, belt runs, but no suction coming through.


You have a clog somewhere in the vacuum. Check the hose and the little trap door on the underneath side of sweeper.Does the brush turn? If not, then the belt that drives the brush is broken. Replace the beltJim ... Hoover Tempo Widepath Upright Vacuum - Blue

Bissell powerforce My lower pickup tube became clogged so I removed it and cleaned it out and reinstalled it.Now everything runs good but the vaccum want pick up any dirt .I replaced the bag andf when I turn it on it just exhaust air but does not have any suction,I tired tp pull the bag door of while it was running whick I could not do so it has plenty of suction inside just not getting any outside can you help?


... Bissell Vacuums

Hi I need help because I have a problem with my Electrolux Centralux Central Vac system in my house. When I plug the vac hose in the central vac socket at first I heard the motor running very gently with NO suction then after a minute or so it went completely dead and they is NO motor sound, suction, or anything happening what so ever. Can anyone tell me what this problem is???


Have you checked for a clog in the lines or in the hose? If there is no clog in the system anywhere, then your motor could be dying. ... Electrolux Centralux Vacuum

Power head motor is good,runs great from test cord switch seems to work. brush roll cleaned but power head motor will not run


If you have checked the power delivery down to the powerhead and you have current running to the powerhead, then you likely have a burned fuse. There is a fuse built into the powerhead motor and is usually located on the field winding. This is not ea ... Eureka 6831A Bagged Canister Vacuum

Motor is running and the brush is also running but i have no suction and the suction tube is clear


A clogged filter or if it has a bag hole in bag or bag isn't in correct. ... Hoover Vacuums

Brand new LG LUV200r used 10 minutes now after removing dust tank & reinstalling the vacuum motor does not run only the beater bar??? I have located wo circuit breakers both seam to be set. This suction motor should run when the switch is pressed & the beater bar should operate when the handle is moved down??? Not A happy customer will return unit to Best Buy only 100 mile round trip!!!! RDH


... LG Electronics Kompressor Pet Care Upright Vacuum Cleaner LUV200R

Motor doesn't run I believe it the brush on the motor. two motor brushes one is completly gone about 1/8 inch left could this be the problem.the other motor brush still has 1/2 inch left. and current to motor tested good.


Sounds like your belt slipped off. ... Dyson DC14 All floors Bagless Upright Cyclonic Vacuum

Electrolux 2 in 1 Ergorapido stick Vacuum. Motor runs then cuts out after 3 - 4 seconds. Sometimes it will run properly for 10 minutes so batteries are good. Why does it cut our usually?


If the hand held is working correctly (By itself) try pulling up a little bit on the 4 metal connection tabs on the wand. The connection tabs were not making a proper connection on my unit. ... Electrolux Pronto 2-In-1 Stick/Hand Vacuum - Cayenne

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

No suction on my Electrolux central vacuum in all outlets even though motor is running and there is no clog in the hose.


I would start with washing out the ilter really good and letting dry. then try the system. ... Electrolux Central Vacuum

Dyson dc04 motor runs but has no suction.


I would make sure it is the motor first by isolating the sounds to just the motor. Take off the dirt cup, both filters, and belt, then run it and see if the sound is still there. If it is, you need a new motor. If it isn't, you need to look for a clo ... Dyson DCO7 Animal Bagless Upright Cyclonic Vacuum

I have a riccar 8905 the motor runs but no suction


... Riccar 8955 Upright Vacuum

Hoover upright bagless vacum.motor runs, brush turns, no suction through hole behind brush roller. however there is suction going out of dust cannister filter flap to motor. what could possible problems be?


Sorry to read about your problem, I hope this helps you out.you have a clog between the brush and bagI tried to help you. Please help me and Rate/Vote on my response, thanks and good luck ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My dyson vacuum motor is sounding very high pitched... The tubes are all clear and there is suction with the tubes not not real good suction on the beater brush area....


If you have tried cleaning other parts and cannot find an obstruction, and still have no suction, you could try this:\015\012\015\012 ... Vacuums

I have a Kenmore Elegance model 116 that has lost suction. There is no blockage and both the filter and bags have been changed. The powerhead turns on but the vacuum itself is fairly quiet, not sure if that motor is running. How can I regain the suction?


... Kenmore Vacuums

No suction - motor runs, belt running. - Vacuums


Clogs, som,e times on the bottom there is a pan and a hose opening secured, if its clogged, it won't work, open the bottom where there should be a small latch, also I have used shop vacs to **** clogs out threw hoses? ... Vacuums

The roller brush on my Hoover Z700 vacuum no longer runs when you tilt the handle back. I have tested every part that I can: the motor is good; the "magnetic switch" at the pivot point is good; etc. I'm now stumped. Any help or suggestions would be greatly appreciated as I don't want to throw away a $400 vacuum.


Has this not got a rubber belt drive? ... Vacuums

Dyson Animal motor is running, beater bar is turning but very little if any suction. No suction from hose either. The inside canister is filling and moving, so there is some dirt being sucked in there. I have thoroughly cleaned all filters but not sure what is causing the problem. Any ideas?


Obstruction in the hose?\015\012Your vac has developed a hairball possibly.... when a piece of flexible media ie.... cardboard, plastic etc... gets lodged in the hose, and begins collecting hair & dust to the point it no longer has enough d ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Dyson My Dyson DC04 runs for a second or two then stops. I have checked the motor. The brushes are good but the commutator is a slightly pitted.Do I need a new motor?


Hi.\015\012\015\012Check mains lead where it enters machine very common for internal fracture.\015\012\015\012To prove this try waggling lead with machine switched on if it starts & stops this is the fault.\015\012 ... Dyson DC05 Cylinder Bagless Canister Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0685 seconds