Having problems with your Broan-NuTone Vacuums ?

Unit goes on when turn unit on but doesn't pull when hoses are put into wall


Answers :

The system could be blocked.
\012
\012the bag door could be open on the unit.
\012
\012The little black gasket between the dirt pail and the main body of the unit may be missing.
\012
\012Check those and you may solve the problem. I am almost sure it would be the black gasket is missing.
\012
\012good luck.
\012Mark
Repair Help & Product Troubleshooting for Broan-NuTone Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Unit goes on when turn unit on but doesn't pull when hoses are put into wall


The system could be blocked. \012\012the bag door could be open on the unit. \012\012The little black gasket between the dirt pail and the main body of the unit may be missing. \012\012Check those and you may solve ... Broan-NuTone Vacuums

The Vaccum is not turning on when i plug the hose into the wall. The hoover system will turn on when i turn the switch on at the base and wont go off till i turn the switch off. But it will not come on automatically when i put the hose in to the wall connections. Many Thanks Linda


You can test this out by taking a small metal spoon and with the bottom side of the spoon insert it into the vac outlet on the wall. you want to touch the two metal pins inside the vac outlet to test if the unit is the problem or the hose is the prob ... Beam Industries Vacuums

My BROAN CV-110 hose with the rug beater only works if I turn it on from the base unit. Shouldn't it turn on when I plug the hose into the wall recepticle? Do I need to replace the hardware at the end of this hose and if so, where would I purchase that? This central vac came in a house I just purchased. Thanks for any help. Sherry


... Broan-NuTone CV450 Central Bagged Central System Vacuum

I have Nutone VX550C. Motor runs intermittently (cycles on and off rapidly--the light on the handle is blinking furiously) when I use the on/off switch on the hose. This happens at all of the wall connectors, so suggests a hose contact problem. Motor runs continuously when I turn it on at the switch on the wall unit.


The unit does have a switchs the PVC outlets, and it sounds like the hose mech to operate the switches is broken, and intermittently making contact. A replacement hose would likely fix the problem. Looked them up on the net, and they're not che ... Broan-NuTone VX550 Bagged Central System Vacuum

Hoover S3765 I have a Hoover S3765 (serial # 040600024465) and the unit stops working for no apparent reason. The light on top of the unit goes off when it shuts down, so I don't believe it's a problem between the hose, the tube and the floor unit. Sometimes I have to let it sit for over one hour before it will come back on. I've tried different electrical plugs too. Still won't turn on. Any ideas or suggestions? Thanks


If you light and nozzle motor both go off at the same time, you might have a bad power cord. Mine had this problem which I could verify by jiggling/twisting the cord near the strain relief on the nozzle. It would go on and off as I did this. ... Hoover S3765-040 WindTunnel Bagless Canister Vacuum

No spray My Bissell Pro Heat 7901 will not put out any spray. I Took the pump out so I could get at it and disconnected the hoses. I put the one on the input side and the other in a bottle of water. Put the belt on the pump and turned on the machine .Nothing at all coming out of the pump. Where can I get a new pump? Also the lever that goes to the little flapper at the top under the clear plastic piece on the front that connects to the knob that changes from tools to floor broke off. Where can I


Pump part number is 2107181, the diverter valve # 2136988. You can Bissell and they can tell you who may have parts near you, or you maybe able to order thru Bissell.com. Before you took it apart, were you getting water to spray out of the hose. I ... Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum

No spray My Bissell Pro Heat 7901 will not put out any spray. I Took the pump out so I could get at it and disconnected the hoses. I put the one on the input side and the other in a bottle of water. Put the belt on the pump and turned on the machine .Nothing at all coming out of the pump. Where can I get a new pump? Also the lever that goes to the little flapper at the top under the clear plastic piece on the front that connects to the knob that changes from tools to floor broke off. Where can I


Search for bissell pro heat pump. bissell.com will not have it ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

Doesn't work Our home was built and finished in August 07.  The central vac doesn't work.  There is supposed to be a slot that opens in the kitchen where you sweep the dust and it sucks it up.  Also, the mounted unit on the garage wall has a hose that goes up into the house but there is a hole open at the bottom of the unit.  Where can I get someone to help us?  Or, is there an installation manual I can download to see if the builder did it properly.  He stole our solar heater for our pool and s


Has the slot in the kitchen (VacPan) been installed? Or is it just not working? There should be tubing coming into the unit in the garage, and possibly another piece to exhaust the unit to the outdoors, although this isn't always necessary. The intak ... Electrolux Centralux Vacuum

Stops Immediately. We have a Beam Serenity model 2100 installed in the home and when the hose is inserted into the wall it turns on for a few seconds and then shuts off on it's own. Turning the handle's power switch off/on restarts the unit only to have it once again stop after a few more seconds. The canaster is clean. What could be causing this stopping issue? Thanks.


The Relay Control Board in the 2100 is bad. Replace and it should work just fine. ... Beam Industries 2900 Serenity Plus Central System Vacuum

I have a central vacuum system. When I disconnect the hose from a wall outlet the central canister does not shut down dispite my turning off the vacuum at the handle of the hose. The only way I can get the system to shut down is to pull the plug at the canister. What gives? Rob


What I'm hearing is the canister(Not the Powerhead) portion of the unit is running all the time unless you unplug it. this problem could be caused by a short in one of your low voltage lines running through the house. To determine that just unplug on ... Vacuums

Every time we plug in the vaccum hose into the wall recepticle the vaacuum turns on for half a second and then blows the circuit breaker. This just started a few days ago. We tried replacing the 20 am


... Dirt Devil CV950 Central System Vacuum

My vac will turn on at the unit but will not come on when I insert the hose into any wall outlet


The problem is one of two things...either the hose part is bad or the wiring to the unit is bad....all that needs to happen to make the unit come on is to short between (connect) the two wires going to the unit. Therefore if the hose part is not conn ... M&S Systems Vacuums

Will not turn off when hose is pulled out of wall


Some units have an on/off switch on the power unit itself. Check to make sure that is not turned on. Unplug your power unit and remove the 2 low voltage wires (not the power cord itself) . The low voltage wires start at the unit and run throught your ... Broan-NuTone CV450 Central Bagged Central System Vacuum

No suction I have the central vac type. It has no suction at the can. I pulled the hose going to the walls and tested there...and nothing. I removed the dirt can and checked the motor ...it is spinning but does not feel like any suction. I checked the exhaust and it is pushing strong air out. I also cleaned the filter and still nothing. Is there a relay or something that would cause only exhaust air. I emptied the can of dirt and put it back together and have absolutely no air.....hear the motor


On some units there is a screen that protects the impeller of the motor. If this gets sealed off with debris then it is like putting a potato in the tail pipe of a car. Taking the top off the unit reveals the motor. DO UN-PLUG the unit first from th ... Electrolux Central Vacuum

The hose is disconnected, new bag in unit, new filter, unit runs when hose is detached but immediately turns off when hose is attached but hose has no obstruction, etc.. i was told i need some sort of valve. HELP! I have birds, a cat and 2 large dogs and no vacuum :)


There is a vacuum hose that attaches inside the unit to a round clear plactic piece. In most cases you can simply cut the small vacuum hose and it will fix the problem. ... Electrolux Epic 3500 Vacuum

I have a Eureka Boss Power Plus and the beater bar is rolling, the belt is turning, but after vacuuming up around the litter box (not a lot of litter), when I turn the vacuum off, the litter, or even household dirt, falls out. When I hold the vacuum back to turn it off so that it doesn't fall on the floor, it's sitting in the cubby where the wheels are. The bag is empty, the hose is not plugged, the hose is securely fitted on both ends of the unit. This vacuum was purchased in July and is being


Even though the brush is spinning, you probably need to replace the belt because it is s ... Eureka Vacuums

Bissell Pro Heat 7901 will spay through hose but not the floor and red flow indicator will not spin. So we took the housing off and after unclogging a hose running to the hearter, my husband unhooked the hose that goes to the flow indicator, blew in it and it started spinning. Put the deep cleaner back together, tried to use it and nothing. What else can we try? Can't afford to put it in the shop right now. Thanks in advance.


I borrowed my friends bissell to clean my carpet. It's the 7901. He brought it over and told me that it only sprayed out of the attachment hose. He said he couldn't figure out what was wrong. I'm no vacuum technician but, I am a mechnic. I decided to ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

I installed the Hoover Wind Tunnel Central Vac in my new home. After connecting the wall outlets and successfully turning on the system from the hose control, I discovered there is lots of air flow t


I would recommend checking your wall outlets where the hose plugs in for any type of clog in the tubing. If the vacuum itself ... Vacuums

I have the Aerus Lux7000-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)


Hi, you very likely have a defective control valve under the dial on top of\015\012the vac , or a kink or blockage in the tiny pressure hose that feeds\015\012the air from the throat of the vac or the back of the bag chamber\015\012against the two si ... Electrolux Guardian Bagged Canister Vacuum

I have the electrolux guardian-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)


Hi,\015\012Check your hose you have something stuck in the hose...stretch it out straight and run something through it to push out whatever is stuck in there...\015\012\015\012heatman101 ... Electrolux Guardian Bagged Canister Vacuum

Model # 5770 the brush motor runs and shuts down after a few seconds...Turn unit off and the brush again will run for a second or two...If I don't turn unit off brush will not start up..Could it be the printed board..the motor brushes..or the wiring that goes from the printed board to the main motor...Thank you


Seems like your unit goes into failsafe because it detects something wrong. Well you should check the brushes and replace them if they are worn out. Also check the wiring for shorts etc, becaue the unit maybe tripping due to an overload. The printed ... Bissell Vacuums

I have a 3 year old NuTone CV 353W central vac system and recently the switch on the hose handle does not turn the system on from any outlet in the house. I have to plug the hose into the outlet and then turn the unit on from the switch on the cannister. Any help would be greatly appreciated. Thanks


A great way to check if your switch in the hose is bad would be to turn the hose sideways in the inlet. If the unit turns on you most likely need a new switch. ... Broan-NuTone CV450 Central Bagged Central System Vacuum

Our dustbuster (dont' have model number with me-sorry) won't turn off when I pull back on the switch handle. I disassembled the unit and realize that the tab on the switch handle that pulls back on the internal switch handle to turn it off is not strong enough for its simple task. Does B&D have a proper replacement part?


If you can provide a model number, I can check availability of the switch and can either order it for you, or supply the B&D part number and you can order it from most local vacuum shops in your area or from Black & Decker direct online: ... Black & Decker 15.6 Volt DustBuster Vacuum

Dyson dc41 wont suck up on hose and hose pulls back when turned on


... Dyson Bagless Upright Vacuum DC41 Animal

Electrolux Centralux I have a Electrolux Centralux. When I plug the hose in at one of the wall outlets the motor will not start. If I go to the motor and slap the unit it will start.....then...it will not stop unless I unplug the power cord to the motor. If I plug the power cord back in, the unit will not restart until I slap the motor unit again. The unit has only been used 20 - 30 times. Any suggestions?? Thanks, Bruce


I dont know if you had your unit looked at yet but it sounds like the Power module is going. I repair the machines so I know some of the work. ... Electrolux Centralux Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0743 seconds