Having problems with your Broan-NuTone VX475 Bagged Central System Vacuum ?

Vx550 issues Like most here, ours shuts down after a few minutes use. Ichecked everything and found the thermal protection was shutting it down. I then decided to check online to see if this was a usual problem, it seems that it is. I guess a call to nu-tone is warranted. i wonder if they will ship a new unit to western Canada.

Answers :

Heven't fixed it yet, but I've pulled the motor to see what the specific issue is. As soon as I have the problem isolated and a solution, if possible, I'll post it here. I will have to contact Nutone Monday and see what they will do. If nothing, I'll sort it myself.
Repair Help & Product Troubleshooting for Broan-NuTone VX475 Bagged Central System Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Vx550 issues Like most here, ours shuts down after a few minutes use. Ichecked everything and found the thermal protection was shutting it down. I then decided to check online to see if this was a usual problem, it seems that it is. I guess a call to nu-tone is warranted. i wonder if they will ship a new unit to western Canada.

Heven't fixed it yet, but I've pulled the motor to see what the specific issue is. As soon as I have the problem isolated and a solution, if possible, I'll post it here. I will have to contact Nutone Monday and see what they will do. If nothing, I'll ... Broan-NuTone VX475 Bagged Central System Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.

Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

Hi my proheat bissell 7901 stopped pumping water to the floor, but it pumps water from the hand hose. I read the manual and followed how to check belt and the flat belt on right side of shampooer is fine and I turned on and it turns and so do the brushes at the bottom of the machine. I was reading online and I guess there's two belts on this machine? where can I find the other belt to see if it needs replacing. I guess it's a ribbed belt? that is the water pump belt?

Just taken ours apart with the same problem... found it was caused by the 2 halves of the main casing coming apart in the area where the upright pedal release is. I found this to be due to the upper casing having broken in 2 places - the bottom of th ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.

It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?

Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Bissell 7700 series, pro heat all rounder. Won't spray water. Have checked the line from the unit to the spray nozzel and all seems clear. Water doesn't seem to be flowing from the tank to the end of the unit where the hose connects into. What could be the problem? Any assistance would be greatly appreciated. Thank You. Steve

HelloGrasp the cleaning solution tank, and remove it from the machine. Reinsert the tank into the machine, making sure it fits snugly in the machine. If the tank is even slightly dislodged, water cannot get into the machine. Visually insp ... Vacuums

My filter queen majestic quit working. I opened up the unit to see what was wrong and I did not immediately notice anything wrong. Upon furter examination I noticed one of the traces on the printed circuit card was burnt. I used a soldering iron to "bridge the trace and it appeared to fix the problem for a while. Now it has stopped working again, and when I jumper the trace to run the motor it seems to work. Should I just replace the card? Or is there a more serious problem with too much current

I recommend replacing the card. Soldering involves the risk of further damaging the card, so it would be useless anyway. Why waste valuable time?\015\012There is a possibility of the motor overheating, generally due to a blockage in the airfl ... Filter Queen Majestic Canister Vacuum

Eureka TRUE HEPA Whirlwind Bagless same problem seems...roller just stopped...took everything apart and turned it on just in time to see belt melt...I was able to get the end caps off both sides at first and now can't seem to get the one side. Really love this vacuum! Don't want to have to part with it!

If you are able to remove one end cap, the brush roller shaft can be removed and the other bearing is exposed for examination and removal of the hair that probably is clogging it. After cleaning and reassembly the brush roller should rotate freely. C ... Eureka 2961AVZ Bagless Upright Vacuum

No power when turned on, I checked motor brushes and they are almost worn out, could this be the problem? and where do I find replacement brushes? I have checked on Dirtdevil's site but I don't see any motor brushes. I am in Montreal, Canada. Thank You.

Hi,\015\012Before that I wouild check the switch...the switches on those things go bad regularly...get a meter and check the power on either side of the main switch and I think your problem will be there...\015\012\015\012heatman101 ... Dirt Devil 12 Amp HEPA Filter Vacuum Vacuum

No suction I've only had my vacuum for a couple of months and it seem I have a similar problem but there is no clear blockage. It seems like I don't have adequate suction that reaches the accessory hoses nor the main one. I'm not sure where to start. I've taken the darn thing apart but I can't see any obvious malfunction. Any suggestions?

If you have low suction at the end of the hose, then you either have a clog in the hose or a clogged filter. Take the hose off and drop something in it to see if it comes out the other end. If you have suction at the end of the hose, then the dirt ... Hoover U5753-900 WindTunnel Bagless Upright Vacuum

The water tank on my bissell proheat 2x is not keeping the clean and dirty water separate. I;ve checked the container and there doesn't seem to have anything wrong with it. Also when I switch the machine on you can see the "washing" action, after a few minutes this seems to stop - there is water and forumula in the machine. Only had it a year!

... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

My Hoover T5703 has suddenly stopped working. I was using it, moved it to another room, presssed the start with my foot - and nothing! I have checked that the fuse and electricity socket are both OK.I did knock it over a while ago and am wondering if I have broken a bit of plastic in the foot starter. It doesn't seem to 'click' as firmly as it did, but I cannot see how to take it off to check?

... Hoover Vacuums

My G6 kirby stopped working. i have checked the wire for fraying and continuity and found no problems. I have noticed that the foot pedal that turns the machine on doesn't seem to click when pushed on or off either. i have the motor exposed now to check if it is bad, but i am not sure how to pursue doing just that.

... Kirby G6 Bagged Upright Vacuum

How to disassemble the brush to empty anything that might be stuck inside of the brush? The motor seems to be overheating, all belts have been checked, all airways are clear and the filter is clean. The vacuum is vibrating and releasing a burning smell, but still sucking up dirt. There is nothing stuck on the outside of the brush, but is there a way to check inside of it to see if that is where a clog is occuring?

If there's a burning smell and the belts are fine, the problem is going to be hot wires causing the insulation to melt, or the motor going bad. Discontinue use and have it checked at a repair shop. ... Bissell 6594 PowerForce Bagless Upright Vacuum

My vacuum seems to be having problems with sucking up and keeps cutting out. I have checked it and there does not seem to be a blockage anywhere

... LG Vacuums

Hoover Telios TC3202 200W Cord Rewind is jammed - cannot see how to open body of vacuum to look at the source of the problem. Found 4 screws but that did not help - guess you have to prise something open but cannot see where or how.

There are many models of the Hoover Telios. This solution applies to the T5603 at least, but perhaps not to all models... sorry, I don't know about the others. \015\012Anyway, this is it. The cover is held to the b ... Vacuums

Hoover Alyx Pets 2000w Hoover Model TC1208 001 Virtually no suction, have checked for blockages but cant seem to see any, however i can't remove the hose to check it. Any ideas?

Did you check the HEPA filter? I have the same problem with mine if I don't clean the filter after using it. It's a dirty job but helps for a while. ... Vacuums

Roomba Stops I've had a Roomba for about 2 months. Lately, it runs for about 45 secs, then stops, makes a two-tone (descending) sound, and flashes the CLEAN button while the STATUS button is red. I've emptied the dustbin on it. Can you help? I am seeing the same problem on my roomba today. I cleaned all that I could., the brushes, the pins on the sides and all that and it still gives the same problem..Any other fix?

Run your roomba through a self diagnostic test. I have posted the link below. Tell me your findings.\015\012\015\012\015\012http://mysite.verizon.net/gsplews/Diagnositic-Tests_Proc.v.0.5.htm ... iRobot Roomba 4210 Bagless Robotic Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

NO POWER My Dyson DCO4 Absolute (purple&lime) won't' switch on. I've checked the plug fuse, wall socket and also filters and hoses on machine all seem fine so think the problem is with the on/off button (maybe loose wire or something) but how do i get to it, is there a special way to remove the green on/off button in order to check the connection? Thankyou in advance for the help i am sure you will be able to provide.

The problem is almost certainly a fatigue break in the flex. These usually happen where the flex enters the handle through the rubber sleeve near the on off switch. You will need to cut about four inches off the wire and reconnect it to the switch. ... Vacuums

Saeco Odea Giro pumps the water but the internal spline or gear is not turning moving the ground coffee grinds to the point where the water can pump to the front exit lines so the water is pumped into the over flow resevoir. How do I replace the gear or check to make sure this is the problem. I want to replace this myself.. Also how do I get the unit apart it seems to be bullet proof. Is this a common problem.

It is a common problem if it is what I think it is. However your description is a little confusing. So the coffee does get ground up, but then has a hard time getting to the next stage of the process? Please clarify... And no water gets pumped th ... Vacuums

My bissell pro heat 2X has stopped dispensing water from the tank, the suction is working and it seems to be dispensing the detergent, so it is not rinsing or washing with water. I have cheaked to see if there is a blockage but that doesn't seem to be the problem...please help

I have a Proheat 2X and had the same problem. I tried the Water Rinse setting and found water came out and was suctioned properly, but on the Light Clean, Normal Clean, and Heavy Traffic settings, the unit failed to do anything. Problem may be with l ... Vacuums

Sunbeam water cooler YLR2-5-87 H3 I find a part inside is distorted I guess from the heater is sunbeam doing anything for this problem which seems to be a problem and can you get parts to fix it

... Sunbeam Vacuums

Replacing filter Got a Filter Queen Majestic vacuum from my inlaws when they moved overseas. I am in middle of vacuuming, got a weird noise, so opted to check and clean the filter for first time. UGH. The lower 'pot' that's the bottom part of the thing was full of gunk, but the filter pristine clean against the cone that's attached to the upper part of the unit. In other words, I am shocked to see that the dirt goes not INTO the filter, but outside of it into the bottom portion (that I call the

Its normal operation so don't worry ... Filter Queen Majestic Canister Vacuum

Brushes stopped The brushes stopped turning while using the cleaner. I removed the brushes to see if the spindle was broken, it wasn't. I then removed the top plastic cover and checked the switch that engages the brushes; it didn't seem to be moving correctly. There's one spring on the switch - should there be two? Or do you think something has broken on the inside? Thanks for any help

Most likely the turbine is bad, it may just be clogged up, you can take it apart and clean it out real good. That may work, but it may not. Sometimes it is best to replace the turbine. ... Hoover F7431-900 SteamVac Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0567 seconds