Having problems with your Broan-NuTone VX475 Bagged Central System Vacuum ?

I have a VX3000C Broan vacuum and the motor sometimes runs lower and comes back to normal time and time. Plus, now it lamost stops before coming back to normal speed. Can someone explain to me what that might be or if it did happen to someone else? It doesn't stop, but runs at very low speed and come back. It is like if a connection is not made properly. But it does the same at my 3 connections and I did check the one on the vaccuum itselfs.

Answers :

Repair Help & Product Troubleshooting for Broan-NuTone VX475 Bagged Central System Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a VX3000C Broan vacuum and the motor sometimes runs lower and comes back to normal time and time. Plus, now it lamost stops before coming back to normal speed. Can someone explain to me what that might be or if it did happen to someone else? It doesn't stop, but runs at very low speed and come back. It is like if a connection is not made properly. But it does the same at my 3 connections and I did check the one on the vaccuum itselfs.

... Broan-NuTone VX475 Bagged Central System Vacuum

I have an older Oreck XL vacuum that sounds like it is running twice as fast as it should. I disassembled the entire vacuum, including disconnecting the motor wires, to clean out the hair, string, and other things. When I put everything back and connected all the wires, everything appears to work, including the light. The only problem is, it sounds extremely loud like the motor is running too fast. The model number is: XL3610HH Ser. No. 3610HHXA039740-6 I do not have as electrical diagram to see

... Oreck XL Ultra Bagged Upright Vacuum

Over heating Light Comes on as soon as I try to turn the unit on. I have a Miele S558 Silver Moon vacuum that has only been used once and it shut off and will not come back on. The overheating light comes on as soon as I try to switch speeds on the handle or turn the unit on at the canister, and the vacuum will not run. Do you have any idea what the problem is?

... Miele s558 Silver Moon Vacuum

There is an "exhaust" pipe of sorts in the lower back part of the vaccuum. Most of the dust and specially pet hair just flies out of there and up in the air. It looks like more stuff comes out than stays in the vaccuum. I'm wondering if there should be something connected to that pipe? Vacuum assembled as per instructions out of the box (installing handle).

Something is wrong ... there should not be any dirt coming out as you describe ...\015\012\015\012I'm sorry, based on what you have told me ... I can't go further ... you know ... stuff link make and model.\015\012\015\012Than ... Vacuums

I have a Dyson DC07 animal ( purple). If you are standing behind the vacuum I am missing the lower righthand connection...therefore whatever is suctioned up comes out at that point just over the back wheel. I would like to purchase a replacement for this part. In the manual I believe this part is labeled as C. Can this part be purchased separately ?Please Help....

Hi there SmartAlec from NelsonVacuums.com.au i am not sure if you are based in australia but if you are you can ... Dyson DC07 Bagless Upright Cyclonic Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos

It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

Passat 2000 W Reg Had the rear brakes and disks changed then a month later had a front tyre replaced and as I drove off something went tinkle tinkle on the road (like someone had left a spanner). Week later the ABS light and the brake light come on with the usual STOP Brake Fail Service Manual message. Had brakes checked but they could find no fault. I've tried the ABS under controlled conditions and it works. What could the problem be?? I've been running the car under these conditions and no pr

The ABS module has a history of wearing out on VWs. Nothing wrong with the brakes themselves, but the ABS module would need to be replaced to stop the lights coming on... but the problem is a new ABS module can be very expensive for a new one (~$900 ... Vacuums

Hello, I got a used Kirby Sentria. When I run the vaccum and push and pull on the handle, I can hearing a friction type noise. I got up close to the vaccum and it is not the wheels or roller. It is coming from the base of the handle. It's like it is pushing on something on the vaccum body and is creating the noise. Maybe transmission? Is this normal, or is it something I should be concerned about? Thanks for your help!

Try new belt yours may be slipping ... Kirby G5 Bagged Upright Vacuum

Hi. I have a Kirby from back in the early 90s (model G3D). Never had major issues with it. Can't remember the last time I had maintenance/tune up done. It's just sounding different when I run it the last few times...almost like it's louder and kind of echo-ey. Still suctioning well, but something's not right and I don't want to run it until I know if anything's up. Any suggestions? I'd like to try and figure this one out on my own with your help. Thanks in advance for your help. Marci

Check the belt. this is a strong vaccume and even without the belt it will still have a decent amount of suction. If the belt is not tight or intact it can let the motor turn faster which will sound louder. other than that check all the hoses for hol ... Kirby Ultimate G Bagged Upright Vacuum

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after

... Vacuums

Changing fan I changed the broken fan in my eureka 1934A. Put the cover back on and reattached the belt and when I went to start it, it wouldn't work. I took the cover back off to see what was going on and it looked like the motor was running in reverse of what it had been. Is this possible?

My solution is one that only works if the vacuum is a spare... To get mad at it and throw it in the garbage... \015\012\015\012My thought though on what the problem actually was... Seeing as where the vacuum came from and what the problem ... Eureka 1934 Bagged Upright Vacuum

When connecting the wand into the brush component. sporatic power (sometimes runs sometime nothing) the power is on again off again. when hold pressure down on the wand the power stays on. do you think the coupling connection is bad on the wand? would the wand replacement likely be the culprit?

There is is switch or sensor in the connection. Likely that piece is worn or shorted out. You may be better off getting a new wand piece ... Kenmore 23913 Progressive PowerMate Bagged Canister Vacuum

I have a Rainbow E2 series, 23, for about 3 years. It has now a different and very aloud sound coming fron around the motor and also I feel it is not suctioning with the same power. If I close the hose like closing totally the suction entrance, the sound comes normally. I will appreciate if some one can tell me what to do, becouse there is not a Dealer in my Contry any more. Thank You. Pierre Chabaneix - Lima-Peru [email protected]

Hi there, Pierre!\015\012Sorry, but I think this is bad news. From your description, I suspect that a motor bearing has failed. The only way to fix it is to replace the motor, and without a dealer in your country, that could be a big problem.\015\012 ... Rainbow E series Canister Wet/Dry Vacuum

I have the Miele S7280...the one without the clog hatch on the back. I took the bag cover off, then continued the remove the screws and cover underneath it to detatch the top from the bottom. Found the clog and cleaned it out. Heres the problem...now the power nozzle light comes on and the vacuum "on" is lite up red, but it will not come on. Checked the filters and the bag. It certaintly seems like the top and bottom are meeting up to latch into each other, but I have no power. Help!!

... Miele S7210 Bagged Upright Vacuum


I dismantled the cover, withdrew the gear drive assembly and found the bits that had come loose. The mechanism that selects neutral or drive had come away from its shaft. I simply put it all back together and tightened everything back up. Works a dre ... Kirby Heritage II Vacuum

The vacuum turns on but wont run smells like burning rubber I took the bottom off and the belts dont appear to be broken but the one connected to beater bar seems like it may be loose

Http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=542493\015\012Generic problem for all Vacuums\015\012The vacuum turns on but\015\012Posted by mmetcalf on Apr 24 ... Vacuums

I have a bissel proheat carpet cleaner. THe trigger is stuck in the on position. However, no water or shampoo is coming out. I can pry it back out but it feels like a spring is missing or something like that.

You may need to replace the handle assembly, or at least take it apart and reconnect the spring inside the handle..here is the repair manual, which has good illustrations on page 9 and 22 of working on the handle..http://newz ... Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum

I have a Kirby G7 and it will run on the low speed setting. When i switch to the high speed it starts to spark and smoke near the back of the motor near the windings. Do i have a motor going bad or is there a simpler fix.

It's probably doing that on low speed too, you just aren't noticing. What you'll have to do is get to the motor. Look at the armature and see if it's scared, missing an pieces, scratched up.. if so, then your motor is shot, throw it away.. If not, if ... Vacuums

I installed a new battery in my Roomba 540. It charges and runs directly with power cord but will not charge on dock. When I push the dock button, it acts like it "sees" the dock and approaches it and even slides on, but then gets back off again and just keeps going back and forth until I turn it off.

... Roomba Robotic Floor Bagless Vacuum

Need the manual on how to run (put together and all) the hoover steam vac v2 (widepath) with auto rinse) we tried today and when we leaned it back (so we could run it on the carpet) water started pouring out all over the machine and got the carpet (like flooded) wet :( this one was me mom's and she passed on approx 2 1/2 years :( she always kept the manuals for everything but we caint find this one :( ... thnx

God Bless Your Mom.\015\012\015\012Hope this was helpfull to you. Sawdust46\015\012\015\012http://www.hoover.com/pdfs/manuals/F7411900.p ... Vacuums

When running the 2100 Electrolux vacuum, it is stopping and starting when pulling or pushing the floor attachment. Seems like the connection at the top of the handle is a little loose or the electric tabs are loose where the hose connects. Any ideas?

Other option is that on the hose end of the electrical connection, you can use an awl on the electrical connections to bend them in slightly so they make good contact when they are automatically plugged in when you connect the wands. HOWEVER, ONLY D ... Electrolux UltraLux 2000 Bagged Canister Vacuum

Makes a loud noise like a grinding noise then smokes comes out and it smells like burning rubber? When I take the (rod) brush off with the belt then run the vacuum there is no more noise? Please help me thank you

Your belt is worn and stretched and so it is slipping on the motor drive shaft. That is why it is noisy and smells like burning rubber. You simply need to replace the belt. You can get replacement belts here: ... Vacuums

Miele vacuum Sometimes when I hit the auto roll up cord button or even move the cord, the power vacuum goes off. I move the cord again and it comes back on. I took it apart and looked at the connection from the cord to the auto roller. These are the electrical slip on type connections and are still in good shape. There are no bends in the cord. I air dusted everthing inside, put it together (with no extra parts!). Good news..it powered up so I did not break it, but it still has the same problem.

... Vacuums

Infinity Vaccum by Shark, model number NV31COS, will not start. The vacuum was running just fine until it grabbed the edge of a curtain. Turned it off to release the suction. Turned it back on and was working fine. About a minute later the vacuum was making an odd noise. Every 2 seconds or so it would "heave" (lack of a better word) then go away, then come back and so on. Turned the vacuum off and checked for blockage, none that could be seen or felt, and now the vacuum won't turn. Any suggestio

Carpet brush won't turn when vac on ... Euro-Pro NV31 Infinity Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.

It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 1.0614 seconds