Having problems with your Broan-NuTone VX475 Bagged Central System Vacuum ?

Nu-tone 475 keeps running even without hose plugged in.

\015 Diconnected each outlet individually no help disconnected low voltage at vac still stays on!\015

Answers :

If the central vacuum tank will not turn OFF even with the switch in the “OFF” position, then the low-voltage wires should be disconnected from the tank. Once this is done, if the tank continues to run and cannot be turned off with the switch, then most likely the relay inside is defective and needs to be replaced (but it could be a defective and/or shorted ON/OFF switch). If with the low-voltage wires disconnected at the vacuum tank, it can be turned off with the internal switch, then either there is a short in the low-voltage wires, or else there is a hose still plugged into an inlet somewhere. ~ TTURAMBAR
Repair Help & Product Troubleshooting for Broan-NuTone VX475 Bagged Central System Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Nu-tone 475 keeps running even without hose plugged in.

If the central vacuum tank will not turn OFF even with the switch in the “OFF” position, then the low-voltage wires should be disconnected from the tank. Once this is done, if the tank continues to run and cannot be tu ... Broan-NuTone VX475 Bagged Central System Vacuum

We have an Epic6500. when we plug it in the machine works without the hose. We even purchased a new hose thinking there was a problem with the hose. However as soon as we put the hose on the machine the machine does not work. What do you think the problem may be?

Wow, this is a good one. I wonder if anyone has wrked on this machine before. Do you remember what happened when it stopped working / Obviously there is a foul up in the wiring. I need more info. When the machine is on does it shut off as soon as the ... Electrolux Epic 6500 Vacuum

Water leak I just bought this steamer a few days ago, and already I am having problems, when I fill the water tank that your suppost to fill the water runs out before I even turn the machine on. I have tried using plugs to keep it from doing this just so I can shampoo my carpet, this seems to work to a point, considering the fact that there are two holes underneath close to the brushes and one just a little ways back from that location. Do you know if this is something that should have plugs or

If you just pruchased this, then it is under warranty, take it along with proof of purchase to a warranty repair shop and have them fix it. If water just runs out, then there may be a seal missing or a water line off. ... Eureka Atlantis 2595A Upright Wet/Dry Vacuum

I was given a model 6591, plugged it in and it worked but didnt "****" and didnt sound right. I turned it off and removed the hose from the back found a badly plugged hose. Removed the hair plug cleaned filters and when I tried to turn it on again. Now the motor will not turn on or even make a noise. I hear there is a fuse that can be blown? How can I find the fuse if there is one? Thank You Ron

The User Guide for the bissell Clearview Power Trak\012\012http://canada.bissell.com/images/UserGuides/3590C.pdf\012 ... Bissell 6591 Power Trak Revolution Bagless Upright Vacuum

Dyson DC 14 hose has no suction, with or without brush attachments. Hot air shoots out from the base of the canister when I try to use the hose. I cleaned the top filter, but can't figure out how to remove the hepa filter to clean it without destroying the case. It looks like it might take three hands to insert pennies and "flip" the case open as is suggested on a youtube video for a different model. Would this even help, assuming I could get the thing open?

... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

Vacuum shuts off, bag light on, runs fine without hose connected

I'm not sure if I understand your problem completely, but if it is your full bag indicator that is coming on, even with a new bag, it's probably your control valve. These can be replaced by your dealer. When working correctly, the control valve shoul ... Electrolux Epic 6500 Vacuum

Does not pick up, no vaccum, motor runs, no blockage, should feel suction on hose outlet without hose hook up. Paper filter missing over cloth filter. float overload ball free, seal on section good no leakage. Maybe bad motor but runs.

Here\015\012 is a Link to one of my Tips:www.fixya.com/support/r6311178-vacuum_brush_bar_not_spinningThis\015\012 should solve the problem. ... Minuteman C82906-01 HEPA Vacuum Vacuum

My Bissell BS3920F upright (similar to the 10N6F) has been working wonderfully for the past 3 years but suddenly seems to not pick up dog hair as well as it used to. It has been pulled apart by my husband to ensure nothing is blocking the hoses etc and when running the suction seems to be there. It seems to grab the dog hair and leave it in a straight line directly under the unit without picking it up. I then disconnect the hose and use to hose to pick up the dog hair. This works well but obviou

Check to see if your brush is not worn down, they do wear with age - compare the length of the bristles with a new one. Replace the brush ir there is a significant difference in bristle lengths. Also check the flexible ben ... Bissell Vacuums

Power shuts off when hose is attached. runs without hose attached. bag is empty, hose is cleared.

... Electrolux Epic 6500 Vacuum

No suction on my Electrolux central vacuum in all outlets even though motor is running and there is no clog in the hose.

I would start with washing out the ilter really good and letting dry. then try the system. ... Electrolux Central Vacuum

I have a Eureka Boss Power Plus and the beater bar is rolling, the belt is turning, but after vacuuming up around the litter box (not a lot of litter), when I turn the vacuum off, the litter, or even household dirt, falls out. When I hold the vacuum back to turn it off so that it doesn't fall on the floor, it's sitting in the cubby where the wheels are. The bag is empty, the hose is not plugged, the hose is securely fitted on both ends of the unit. This vacuum was purchased in July and is being

Even though the brush is spinning, you probably need to replace the belt because it is s ... Eureka Vacuums

Electrolux Diplomat canister vacuum. The bag light comes on and it stops. It has to do with the hose because if I take the hose off, then the vacuum keeps running. I can't see anything blocking the connection. any suggestions on what else to look at?

... Electrolux Vacuums

My electrolux canister oygen vacuum cleaner will not turn on when plugged in. it quit working when I disconnected the hose while running? It does not have power when plugged in to the electrical outlet

This is often caused by a failure of a fuse on the Sumo board, or\015\012occasionally by a failure of the cord reel. Here are some instructions on how to check these things as a\015\012response to a different thread, but I will repost them here: ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

I have a roomba 551. Have cleaned and removed every bit of dirt and hair off it bu the brush cage won't close when the larger bush is put in. The cage will only click locked on one side, and the other side keeps hitting the brush and won't close. It's almost as if the bursh itself is not even, but this doesn't seem to be the case either. I've even tried removing the yellow rings, but makes no difference. Occasionally it runs fine, but most of the time the roomba just hobbles and clacks as i

Hi, had the same problem, it was like the main brush no longer fit into it's slot, so the brush cage would not latch. I discovered that the yellow bearing tip on the main brush twists off, and inside I found a lot of hair twisted around the pin. Th ... Vacuums

I was vacuuming with an attachment, the vacuum began to loose suction and the hose collapsed, then the vacuum stopped running. I have turned it off and continue to plug it in off and on, using different plugs. It will not turn back on.

Hi there VacuumGuru for www.vacuumspot.com.au here. You have got yourself a blockage in the hose is all. The reason it wont turn on is because that machine has a thermal cut o ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

I have a eureka cv2301b central vac system that turns on and works when the system is plugged in but when operating the hose and head inside the house you cannot shut off the system even if you unplug the hose from the wall... Whats going on

... Eureka CV2301 Bagged Central System Vacuum

Hello, I have a Kenmore Progressive Canister Vacuum 116.20912006. It won't turn on. On the hose assembly, the end where the hose swivel is, there are 4 metal pins that plug into the canister. One of the pins looks like it broke off. There are only three pins remaining. I assume there should be four pins as there are four holes. Is this the problem and is it fixable? The vacuum is from 2002 so I am not sure a replacement part is even available and at what price. Thank you. Susan susan.eng@

Hi Susan, if the pin has broken off you can do one of two things, first, would be to find a local vacuum repair shop and take it there for them to look at. they may be able to look at the hose and fix it for you pretty cheaply. what ... Kenmore Progressive 20912 Bagged Canister Vacuum

In my (almost new) Dyson DC31 Animal the rolling brush tends to stop like the bearing was kind of difficult to turn. I opened the side carter and removed the little belt. Without the belt the engine runs regularly. I cleaned the little knots of hairs trapped in the bearing but still the brush runs for a while then stops, tries for a bit then stops again. I even tryed putting a bit of synthetic lubricant with apparently no result. Could it be a defective bearing? Thanks for your help.

... Dyson DC31 Animal Bagless Handheld Cyclonic Vacuum

Why does the hoses on vacuum keep getting clogged even after cleaning them out?

... Hoover WindTunnel Pet Rewind Upright Vacuum

This vacuum keeps getting clogged in the hose and has terrible suction. The women who helps clean my house won't even use it as it performs terribly. Any suggestions

Check vac air filter(not the dirt collection bag) also something could be lodged in hose mechanism so there is always a partial restriction. make sure the beater bar is not set too low. check the dirt that accumulates in bag to see that there is no ... Hoover Fusion Plus Cyclonic Upright Vacuum Vacuum

Hi I need help because I have a problem with my Electrolux Centralux Central Vac system in my house. When I plug the vac hose in the central vac socket at first I heard the motor running very gently with NO suction then after a minute or so it went completely dead and they is NO motor sound, suction, or anything happening what so ever. Can anyone tell me what this problem is???

Have you checked for a clog in the lines or in the hose? If there is no clog in the system anywhere, then your motor could be dying. ... Electrolux Centralux Vacuum

My hoover keeps cutting off and on, now it doesn't even come on. I have checked the fuse its ok and i can't cheak the wireing,the plug is moulded into the socket.

Chances are your cord was damaged inside the insulation and over time it finally opened. That would cause the cac to not operate any more. If you have access to or one of your friends has a multimeter then you can check the wiring by using that meter ... Hoover Vacuums

My bissell 3522 powerforce is not sucking up the debris. I have to use the hose attachment and even then, it doesnt pick up like it should. I have to run along the same section several times.

Hi,\015\012Here is a tip that I wrote after having the same issues with my Bissell...\015\012\015\012http://www.fixya.com/support/r4 ... Bissell 3522 PowerForce Bagged Upright Vacuum

When we plug in the hose the motor in garage runs but no air or suction comes out of the outlets. we cleared all the lines too.

Check to see if you have suction at the unit. If you have suction at the unit, your pipes are stopped up. If you don't have suction, you have a pipe loose under the house. Also you could just have a stopped up hose ... Electrolux Centralux Vacuum

I bout this vacume in mid December 07 and about February-March it started not picking up the dust on the floor. So in early April I bout a new filter and it still wasn't picking up the way it had in the beginning. I've taken it a part several times and cleaned it out with it being plugged at the bottom hose with dust bunnies. Well I just took it back to Walmart where I purchased it and I failed to keep the reciet they could not do any thing about the sweeper. I went back to the sweepers and re

Pull the hose out of the holder, is there suction there. If not, then there is a clog in the hose. If there is suction, then check the dirt outlet by the brush roll. Also if the belt is slipping, it may appear to not have as much suction, belts wi ... Dirt Devil Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0600 seconds