Having problems with your Broan-NuTone VX550 Bagged Central System Vacuum ?

I have a CT600 power brush that would not power up. Thinking the motor was bad in it, I replaced it with a new CT700 power brush, I am still experiencing the same problem the power brush itself does not seem to be getting electic power, but the Vacuum unit does come on with suction.


Answers :

First try connecting the power nozzle directly to the hose. If it works, the problem is due to a broken wire or faulty connection in the wands. At least one wand will need to be replaced.
\015\012My guess is it's probably due to a broken or disconnected wire. This could be in the hose (most likely), the wands, or the tank wiring itself. You can test the hose wiring by using a multimeter or continuity tester. A tester may be easier for you to use, and will provide the info needed.
\015\012Disconnect both ends of the hose, sit down, and lay the ends on your lap. Touch one end of the probe to a terminal on one end of the hose. Place other probe on a connector at the other end. One connector will light, the other won't. Now repeat with the other terminal at the first end of the hose and repeat. The terminals will read opposite the reading in the first test. If the light fails to turn on with either test, it's a broken wire in the hose. This is most likely near/at the handle end, or at the wall end. In some cases it can be repaired, but not always.
\015\012It could also be due to a faulty switch.
\015\012For a definite diagnosis, take the unit, the hose, power nozzle etc. to a repair center.
Repair Help & Product Troubleshooting for Broan-NuTone VX550 Bagged Central System Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a CT600 power brush that would not power up. Thinking the motor was bad in it, I replaced it with a new CT700 power brush, I am still experiencing the same problem the power brush itself does not seem to be getting electic power, but the Vacuum unit does come on with suction.


First try connecting the power nozzle directly to the hose. If it works, the problem is due to a broken wire or faulty connection in the wands. At least one wand will need to be replaced.\015\012My guess is it's probably due to a broken or di ... Broan-NuTone VX550 Bagged Central System Vacuum

My model F5906-900 --- problem is the brushes have stoped working... I pulled the brush assembly out by holding the two tabs, and all seems clean and the brush assembly rotates easly... onced the brush assembly is removed. What I did notice is the female driver slot (found in the main assembly unit) that drives the brushes seems stuck..Is that normal when the machine is not hooked up to power? How can I get the brushed going??? it is a good machine, but the brush options is important too it's ab


(1) Assure the Brush Control on the hood is NOT set to the OFF position.\015\012(2) Remove the brush assembly by pulling/unlatching it from base on each side.\015\012(3) Does one of the brushes ... Hoover F5906-900 Upright Steam Vacuum

The brushes and the belt are not rotating. The power seems fine and there is suction. I have no other history on this problem since I was given this almost new unit over Thanksgiving. Where should I be looking for a problem/solution.


If you've got suction, but the brushes and belt are not rotating, then either the belt has come off the motor shaft, or the belt is broken and just looks OK.Remove the bottom cover off the floor head and check that the brush roller turns ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

I have an Easy-Flo central vac unit. The handle on the electric hose has a switch on the handle. With the switch on ''O'' in the center, it's off. On the left, is the ''I'' position. The vacuum runs but the power brush doesn't. On the right is the ''II'' position. The switch won't flip that way. It feels stuck. It feels as if there is something underneath of it that won't let it push that direction. I have the switch out of the handle, but I can't seem to get the actual black casing around the


Switches are not usually designed to be dissembled.I would strongly suggest that you dont take the switch apart. you are better off getting a new one. then if you feel like it you can take the old switch apart and if it dosnt work you still hav ... Vacuums

When taking the handle/wand back to use it seems to lose the suction power regardless of what setting I use. Upon several times of standing it back up it seems to engage the suction power correctly is there a button or something that does not always engage to get power? can I fix it


When you say taking handle back I assume you mean the action to start rotation of brushes. Had simular problem and found by removing brush from tube and then cleaning "baked on rubbish" in plastic tube (so you can see clearly through tube) Clean with ... Dyson DC28 Animal Bagless Upright Vacuum

Help hi there. i have a hoover savvy u8172-900 vaccum. the hose has great suction, but there is limited suction on the main unit and the brush does not spin when i try to use the product. we have cleared the brush of any debris and have also installed a new bag. a few days ago, we disconnected the hose to make sure there was not any foreign bodies stuck in the unit...nothing seems to help. any advise?


As the hose fits into the base (if i am correct) the power at the base should be fine, make sure the base is clean and free from blockage,\015\012you say the brush doesn't spin, has the belt broken, if so replace it, (very cheap) and only a couple of ... Hoover U8171-900 / U8172-900 / U8173-900 / U8174-900 Savvy Bagless Upright Vacuum

I have a bissell pro heat model 7901-B that has power but no water circulation. I was told that the previous owner used it without water and that she couldn't get it the power on. I bought it off of her and cleaned it out and now the power works, but there is no water circulation. The brushes run and heater works, just can't seem to get it to circulate water. Thankyou for your time, Don


... Bissell Carpet Cleaner Powerbrush Deep Cleaner Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.


Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

My Bissell 9200 is not sucking the water into the dirty water resevoir. 1. The gasket on the clear-view seems fine. 2. The suction power just doesn't seem powerful enough (feeling with my hand). 3. The brushes turn fine and belt is fine (not sure if that even matters for this issue). Any help appreciated. Thanks, - Matt


Disassemble all lines and check to see if all O rings are installed. If cracked missing or stretched out of shape no suction will be provided ... Bissell 9200 Upright Vacuum

I can't get the latch that connects to the brush head to engage. Thus the vacumn is extremely hard to push. It has suction, extreme suction. Rollers appear to be dragging. I've tried to remove and reinstall the head several times but cannot seem to get the latch to engage. Please advise.


It sounds like something has come out of it's socket. If the brushroll won't turn rapidly, your clutch is worn out ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Panasonic power brush with dual edge cleaning 12 amps rottating brush doen't move..motor runs but brush not...how to get inside unit to fix it ... Thanks Robert


... Panasonic MC-V9638 Bagged Canister Vacuum

No power to sensor SR 12. I also have cleaned rollers and filters and bags. I have reset the handle. When I hit the power the check brush and full bag lights flash once. That is the only power that is getting through.The unit was in storage for a bit and got wet but its been drying off for a couple months. Is there something I can check or replace. Its a great Vac.


... Windsor SR12 Sensor Bagged Upright Vacuum

No suction My vacuum does not seem to have much suction when in use. The agitator brush is rotating but I'm not able to get much off the carpet. The suction is fine when I use the attached wand.


If the belt is stretched, then it can't turn the brush rol under load, if you haven't chenged it in the last 6 months, then I would put a new one one. Also check the dirt inlet by the brush roll for a blockage. ... Riccar 8955 Upright Vacuum

Our unit is 7024A Electrolux Oxygen 3 - it seems to work great but suddenly, the head or 'power brush' or whatever it is called - has died. I checked by removing the hose and plugging it directly into the body, but it is still dead. Without that motorized head working, the vacuum is useless. Is it worth replacing? The unit is only about 1 year old and has seen light use only. Very frustrating, since it was the most expensive unit in the store:(


... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

Bad Motor? I have an upright Electrolux Prolux Heavy Duty "Appareil Industriel" and the motor does not seem to be working and turning the brush. Is there a trip switch somewhere to try and reset the motor? I have taken the plastic cover off on the base of the unit and cleaned it well, but can't seem to get the motor to start again.


... Electrolux Vacuums

I have a swivel sweeper, the original series, that is about one year old and is losing power. The battery has been replaced but it still seems weaker than it used to be. The brushes do not turn as quickly and the overall pick-up is not as strong as it was when it was new. Any suggestions on how to get the power back up to what it once was?


HiThank you for your queryI think what you will find is the base of the sweeper has 4 brushes, each of these brushes are run from a cog, if you can take the base apart you will find that it has been clogged up with hair and ot ... As Seen On TV Swivel Sweeper Vacuum

I have a Kirby G series diamond edition. There seems to be no suction when I turn on the vaccum. The bag inflates, but the roller does not turn. It has a new belt and the roller brush is clean. Any suggestion on what I might do to increase the suction and get the roller bar moving?


THE IMPELLER LOOKS SHOT.. 25 QUID FOR NEW ONE,,LIFT THE LID AND TURN THE ROUND PIN AND CHECK FOR RIDGES ROUND THE WHITE IMPELLER,,IF NONE THERE THATS IT,, HAPPEND TO ME TEN MINS TO FIX GEORGE ... Kirby Ultimate G Bagged Upright Vacuum

I have a Kirby Dual Sanitronic '50' Vacuum Cleaner I bought in 1966. The motor does not start when I attach the belt lifter of the rug nozzle. When I remove the rug nozzle and detach the belt from the motor fan shaft the motor starts when I depress the nozzle switch and the power switch . Seems like the brushes in the motor are worn out. I do not have a manual for this unit. Can you assist me as to what newer unit is this compatible to and the problem I'm having at present??


... Kirby Vacuums

My kenmore vacuum model 116.36933502. It has no suction. I have cleaned out every spot,taken off the back and still nothing. The motor runs but doesnt seem to be at full power. The agitator brush works. When it broke i seemed to smell something and since it has no belt. Does this possibly have to motors?


... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

CANISTER IS GETTING POWER BUT NO SUCTION FROM HOSE AND DOESNT SEEM LIKE THERE IS POWER GOING TO HOSE..I HAVE CLEANED OUT THE FILTER AND CHECKED ALL BREAKERS...


Hello,Carnister vacuum cleaners are all built with the same \015\012principle in mind. A motor \015\012generates power which powers a vacuum which, in turn, creates suction to\015\012 lift debris. The most common areas of suction loss are ... Hoover S5615 Hush Central System Vacuum

Hi -- I have a Kirby Sentria and it is great except that I am getting no suction at all through the big silver power head. Suction through all the other attachments works well. I haev tried it with the roller belt on and off, and that doesn't seem to make a difference. Am I missing something?? Thanks!


You can take off the power head and look in that whole where the belt is and see if there is a paper towel or something in there clogging it up. Also tug on the belt and make sure it is tight - because if it is loose it is broken and you ... Kirby Vacuums

I have a Hoover Platinum carpet cleaner, and it has stopped dispensing cleaning agent and water. This model has a separate tank for water and separate tank for shampoo dispensing. It also has a power hand unit that dispenses shampoo. All along the hand unit has continued to dispense shampoo. Symptom #1, the water tank seemed to be taking on shampoo, as it was getting sudsy. Symptom #2 - On wash mode, nothing would come out, on Rinse mode, sudsy water would come out. Later, symptom #3 - not


Somewhere on the outlet is a control tap thats driven by a rubber band and something is up with this control ,best advice here is put it in the boot of the car and take iot to a hoover dealer ,they will do it seconds for you ... Hoover SteamVac Carpet/Upholstery Deep Cleaner Vacuum

I have a Eureka Altima vacuum cleaner that doesn't pick up very well. The suction seems fine but the brush roller doesn't seem to pick up from the top of the carpet. When you lower the height of the vacuum the belt rubs and smells horribly. How can I get the vacuum to pick up better?


That means that you need to replace the belt. Here is the belt you need to replace and the manual which has instructions:Eureka Altima ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

We have a Kenmore canister vacuum cleaner and the power in the floor component (rotating brush, etc) is no longer functioning. The vacuum is producing suction, but does not seem to be providing power to the floor component.


The problem could be with the power head itself or the hose providing the power. If you can turn the unit on from the handle, then its not the hose and you need to get a new power head.. ... Panasonic Kenmore Canister Vacuum Vacuum

What do you do to get the most suction power from the DC04 dyson zorbster. It seems the only way to do it is to bang it which can't be the right way.The settings at the bottom do not seem to work and I have no instructions.


Clean or change the filters every 3 months and maybe have it serviced every year  ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1103 seconds