Having problems with your Dirt Devil BRUM M0414 Bagless Vacuum ?

I assembled my Brum, but it won't charge, and there seems to be no indicator light to be found. What am I doing wrong?


Answers :

If you just bought it, take it back and exchange it. Some batteries are bad from the beggining
Repair Help & Product Troubleshooting for Dirt Devil BRUM M0414 Bagless Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I assembled my Brum, but it won't charge, and there seems to be no indicator light to be found. What am I doing wrong?


If you just bought it, take it back and exchange it. Some batteries are bad from the beggining ... Dirt Devil BRUM M0414 Bagless Vacuum

When I turned on the sweeper it would not start. I put a different power cord on it and it worked fine. now it won't start but the light on the brush and the bag full will flash when i turn it on and off but it wont start. i have 2 of these doing the same thing. do you have any idea what could be wrong. I have checked for clogs but have found none. Bob


Its sounds to me like the computer board inside the machine has gone bad. Keep in mind that the filters in these machine do need to be replaced regularly to keep the vacuum working correctly. Any good vacuum shop should be able to fix your problem. R ... Windsor SR12 Sensor Bagged Upright Vacuum

Hoover SteamVac Model F6056-900 SteamVac/SpinScrub. Indicator light and high pitch suction noise indicates that dirty water tank is full. However, water level indicator (yellow bobbing plastic thing) is at the bottom of the tank and there is no water in the tank. Have check all the hoses for clogs, none found. Checked water port from motor area to receptacle tank for clogs, none found. Fixed broken hose to upholstery wand with duck tape, (wire not broken, just cracked plastic hose). The onl


There are 2 filters, make sure they are clean, one is on the tank lid, the other is from the bottom, it is red, pull it out and clean it. If yours has a foam filter on the tank lid covering the yellow ball, make sure there is at least a 1/4 in. gap ... Hoover Vacuums

Cant seem to get the green light going on vacuum head,hook seems to be wrong way when its should be hooking the band off its doing the opposite


1)First, you turn the square belt lifter on the front of the power nozzle until the red arrows line up (belt off)2)Remove the power head from the front of the machine. Now turn the belt lifter the other way and line the green arrows up ag ... Kirby Ultimate G Bagged Upright Vacuum

The unit is charged, the charge indicator light is green, and the three lights on the top are lighted and steady but nothing happens. What am I doing wrong?


Press each cycle button and see if it starts up. I don't know if this is new and you just got it, but if so, you may need to remove any straps and retainers blocking the brushes etc. ... iRobot 4150 Roomba Vacuum

My new H2O Mop Ultra (Danoz) seems to heat up ok then when the light switches to green and I start using it, the orange light comes back on as well as the green. Produces steam to start with but then it starts to spit water too and everything ends up wet. Any ideas on whats wrong or should I just send it back?


That is a major hardware fault, I have seen this numerous times with these H2O mop's... They seem to either work perfectly for a long while or have problems right off the bat. You definitely want to send this unit back and either get a refund or at ... Vacuums

Our roomba 560 wont charge have replaced the battery Tested the charing unit with another roomba that all seems ok put the uncharged battery into another Roomba but im guessing it now has a memory as this wont charge in the other hoover. Any ideas what may be wrong


Try cleaning the battery contacts with a little rubbing alcohol or contact cleaner on a foam swab, or a bit of paper towel. Take a litle time, it doesn't always dissolve instantly. (Don't use a pink pencil eraser, it would scrub off the plating that ... iRobot Roomba 560 Robotic Vacuum

Red light flashing on rainbow e2 ? just wondering if there may be something wrong ? it seems to be working alright. just cleaned the hepa filter and the seperator and light is still flashing.


The red flashing light is normal, as long as it does not give an error code, and is a steady flashing, when it is running.\012\012Thank you,\012Ralph ... Rainbow E series Canister Wet/Dry Vacuum

Our kenmore progressive model #11634922 was working fine today. And then - it's not. Plugged in - nothing is working on it. We let it cool down (though it didn't seem hot). Still nothing - no light, no motor. Tried it in some other plugs that we know are functioning well - and still nothing. Any idea what might be wrong with it? It's six years old but doesn't get heavy use. Thanks so much ~ Susan Golden


Hi, it could be a number of things, cord may be bad as well as a problem with the motor. There also is a fuse that could have blown. If you go to sears.com, click on parts, put in your model number, when the page loads, click on the first link ... Kenmore Vacuums

I have an older Wega 2 group espresso machine. Looks like a date of 1992 on the group head, but not sure. This has no model name that I can find. Anyway, when I turn it on I get all lights flashing after it heats up 5 minutes or so. I do get nice steam from the wands. I drained teh tank and found a little scale, but not much. I took apart the group heads and cleaned them thinking it may be a clog there, but that doesn't seem to have worked. Also fwiw the water level float is not visible and whe


For a new fridge, need more time to maintain the required temperature of the fridge abut mainly the goods in it? So everything seems normal. The time will be reduced day by day since the goods will stay for longer time in and door opening will bec ... Vacuums

Hello. My scooba 5800 had a check tank light on. I used a straw on the valve and that fixed the problem. Now the scooba runs like nothing is wrong, but there is no actual cleaning going on! It goes the full cycle, but no liquid comes out. The vac part seems to be working b/c there is fluff in the vac when it's done. Please help!


Hello, Take the battery out and hold the switch down for 30 seconds, to reset the curcuit board, then charge back up for 12 hours. this should take care of it. If I can help future please call @ 1561-848-3387 Thank you, Teresa. Clean Sweep Vacuums ... iRobot 5800 Scooba Vacuum

We have purchased a kerosene heater wick (dura heat dh-145)for a dyna-glo model rmc-95-c4. we put the wick on the heater and it seems that now that it is soaked with the kerosene it is to thick and wont move up or down with ease and only a small part of the wick will light.


... Vacuums

The belt burnt out and it seems as though the red arrown does not release the belt. Like it is backwards from the green arrow. It had a burning smell and the belt broke. Then the second belt started to burn out when the brush roller wasn't spinning. Not sure what might be wrong. Green light will not come on either.


It sounds as if there may be a piece of the broken belt in there. Look carefully with a flash light and remove any remnants you find, using a pair of pliers if you have to.\015\012\015\012Also, remove the entire brush roller assembly and ... Kirby Ultimate G Bagged Upright Vacuum

My Roomba Discovery (4210) that I purchased used seems to have charging trouble. I have tried setting it on the dock and directly plugging it in but the indicator light around the battery is blinking red then pulsating more slowly still red and repeating.


... iRobot Roomba 4210 Bagless Robotic Vacuum

Hi I've plugged it in and all indications, green light on, heated water.. it wont steam,


Hi,Here is a tip that I wrote about the Euro-Pro Shark Steam Mop and why it maynot be getting steam to the head...Euro-Pro Shark Steam Mop Problem ... Euro-Pro Shark Steam Mop - Gray/ Purple Vacuum

Last night as I was vacuuming, I noticed that the belt stop indicator light was on. I pulled out the hair that had gotten tangled around the brush in hopes of solving the problem. It didn't change things. I then unscrewed the entire bottom piece to take out the brush roller. I removed hair from the end piece of the brush roller and reattached the belt; however, I cannot figure out where the microchip is supposed to go so that I can reassemble the base piece by screwing it back together. It seems


Not sure what you mean when you refer to a "microchip" but maybe it is a sensor that works with the belt.\015\012Anyway, if you Google the make and model number of your vacuum you can probably get an exploded view or owners manual that might indicate ... Vacuums

The performance indicator light will not go out. I have cleaned the bag, filter and hose. there does not seem to be enough suction.


You are clogged somewhere ... \015\012\015\012no suction? \015\012performance indicator says no suction?\015\012\015\012find and remove the clog.\015\012\015\012id be looking in the hose about 4 inches from ... Vacuums

We have a new hoover bagless that is a couple months old. The pet hair attachment stopped working. I disassembled it found lots of hair wound around the various rollers and removed - painstakingly thorough i might add. Problem is the brush still wont spin and now the belt seems loose - I think I put it all back together correctly but wondering if there is a trick to this?


Without the model number, I can't look it up, but this has a 1 years warranty on it, maybe take it to a warranty shop. Just take proof of purchase, model and serial numbers. ... Vacuums

The belts are burning , I just replaced the belt as the last one seemed to be streched out. The little green light indicating the self propellsion in only on sometimes. Can anyone help me?


If the roller/beater is jammed with hair and stuff and not spinning freely that will cause the belt the burn. ... Kirby Ultimate G Bagged Upright Vacuum

My sebo 1.1 has a red light flashing, indicating bag needs emptied or clog. There is plenty suction with the hose attachments, and I cannot see any blockages in hoses etc. Some of the dirt seems to be collecting in the small flap in the base of the hoover. Any tips as to what could be the problem would be gratefully received


... Sebo Automatic X1 Bagged Upright Vacuum

I have the Miele S7280...the one without the clog hatch on the back. I took the bag cover off, then continued the remove the screws and cover underneath it to detatch the top from the bottom. Found the clog and cleaned it out. Heres the problem...now the power nozzle light comes on and the vacuum "on" is lite up red, but it will not come on. Checked the filters and the bag. It certaintly seems like the top and bottom are meeting up to latch into each other, but I have no power. Help!!


... Miele S7210 Bagged Upright Vacuum

I have a multifunction robotic auto vacuum cleaner model number XR210. It doesn't seem to be charging when at the docking station. The light is flashing on the docking station as if it was charging, but then I am getting intermittent noises like the vacuum is about to start up, then it beeps and goes silent again. I have emptied the machine. The display does not read 88 as if there is a malfunction, so I'm really not sure what's wrong with it. If I put the vacuum to the docking station the displ


... Vacuums

I just purchased an Electrolux Epic 6500 SR, Model #C102G. I found that inside the cover over the bag. But where is the Serial number? I can't seem to locate that anywhere. Also, in case it breaks, I will need a light gray color on/off switch button located near the front of the canister.rnThanks.


The serial number is on the bottom of the machine. I believe near the front wheels, but can't remember for sure.\015\012Parts can be purchased at any authorized Aerus Electrolux store. You can locate the one nearest you using the below link. ... Electrolux Vacuums

My Electrolux Epic 6500 will not turn on. I have no indicator lights other than power cord is connected. Prior to the vacuum not working the motor seemed to be going slower and slower till it stopped completely.What could my problem be and how would I then test to confirm?


... Electrolux Epic 6500 Vacuum

My kenwood steam mop makes for very wet mopping is this supposed to be? My floors are a lot wetter than when I use a traditional mop. When I fill the tank and turn it on the water seems to just leak from the bottom so I have only been half filling it and then the water light comes on within 2 mins of when steam starts to appear. What am I doing wrong??


... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0475 seconds