Having problems with your Dirt Devil M110000 Bagless Upright Cyclonic Vacuum ?

Dirt Devil bagless upright. sucks up dirt in the front and spits it out in the back. I have taken it apart to check for visible clogs in hoses and checked belt and rollers all of which are fine. what next?

Answers :

There seems to be no vacuum drawing the debris away from the brush head. Remove the debris canister to check for air blowing into it. Check particularly, the area where the brush head pivots off of the upright portion. Hope this helps!
Repair Help & Product Troubleshooting for Dirt Devil M110000 Bagless Upright Cyclonic Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Dirt Devil bagless upright. sucks up dirt in the front and spits it out in the back. I have taken it apart to check for visible clogs in hoses and checked belt and rollers all of which are fine. what next?

There seems to be no vacuum drawing the debris away from the brush head. Remove the debris canister to check for air blowing into it. Check particularly, the area where the brush head pivots off of the upright portion. Hope this helps! ... Dirt Devil M110000 Bagless Upright Cyclonic Vacuum

My Dyson Animal has good suction and works fine for actually picking up dirt, but when I use the vacuum with the roller, I hear a grinding/rumbling noise. Its only when I use the vacuum with the brush rotating. It does not happen hen I shut the roller brush off. The belt is fine. I cannot figure out what is wrong as there are no clogs, debris, or foreign objects stuck in the brush or in the belt. The noise seems to be the only issue. The vacuum picks up fine. It just doesn't sound right a

Trace the path of the suction into the tank and see if there is anything loose or ingested.\015\012Also, remove the brush and clean as best you can. Perhaps there is something caught in it. Lubricate where it makes sense with some WD40. ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Suction stopped. Roller and belt working-in fine order. Checked hoses have not found any blockage. Blowing out air or sucking so little can't feel it with hand on hose end. Help!

Either a blockage or the main air filter is blocked , some it can be washed and others it must be replaced I would check the owner manual and look at the filter, foam ones can and usually have instructions where they install to wash them. ... Hoover Tempo Widepath Upright Vacuum - Blue

Belts breaking/melting The original belt broke at almost 1 year so I replaced it. I changed the carpet setting to shag even though my carpet is very low pile to make it easier on the vacuum. I didn't get to use it but just a couple minutes and could already start smelling the new belt getting hot. I checked the roller and it is easy to spin. Not clogged with hair or dirt. Now the inside of the new belt has small pieces of rolled rubber instead of being smooth. The metal shaft that goes into the

... Dirt Devil M088905 Vision Bagless Upright Vacuum

My Hoover Whisper Cyclonic is collecting the dirt but not taking it into the cylinder. The brushes were at one point starting and stoping due to the belt periodically turning,now the brushes are turning and the dirt just collects and I'm starting to smell a an oder like rubber burning.I've taken it apart and tried to make sure the is no clog. The one hose that I can't check is in the back right base, above and left of the right back wheel.

... Hoover U5753-900 WindTunnel Bagless Upright Vacuum

Have ultra vision and have changed filter and foam filter, checked all hoses but still will not pick up. Belt is fine and brush is clean and spinning properly. dirt stays at top of filter instead of falling into canister.

My kids get mine stuck all the time :(Take the vacuum outside then:Remove the hose at the bottom and see if there is any obstructions. Also shake the hose to make sure there is nothing in there as well or take it out side and make s ... Dirt Devil Vacuums

I have a Dyson all-floor model (not the ball). I recently replaced my carpet to a Frieze. Since replacing the carpet, the Dyson is extremely hard to push. It almost forms a "seal" with the carpet. Seems to work fine on Berber carpet and laminate floor. My husband has checked to make sure the brushes are working, hoses are not clogged and belts are OK. I've had it for about a year. It is virutally impossible to push on the new carpet. Any ideas?

Have you adjusted the brush control system. If you look at the link below page 6 will tell you how to adjust. If this is not you vacuum please give the model # of the one you have so I can help you more.\015\012\015\012 ... Dyson DC14 All floors Bagless Upright Cyclonic Vacuum

Suction vacuum one day fine next not having great suction picking up big things but not feeling that deep down suction rolling too too easy changed bag, belt and cleaned roller it is like it is gliding over but not really getting deep visible cannot even tell I went over carpet

Don't panic! Easy fix!\015\012\015\012I was having the same problem, but I removed the base plate from the bottom of the vaccum (5 screws on mine), revealing the roller and the engine. Just behind the roller is an intake tube. Mine had ... Oreck XL Ultra Bagged Upright Vacuum

Hi, There is a high pitched whirring sound coming from lower part of the vacuum. When I tilt it toward me (while standing in the normal vacuuming stance) the sound sometimes lessens for a minute or so. I have tried the following things: -cleaned the two sponge filters -emptied the dirt receptacle -removed the roller and cleaned it -cleaned the brushes -the belt is not ragged and does not seem floppy -checked all of the airways for clogs (including removing the wheel base) Can you help?

Your looking for some dirt stuck in some thing you didn't check yet. with the roller out and the belt out of the way run it to see if it still makes the noise. if it does then you looking at the impeller or the motor bearing themselfs those bearin ... Bissell 3750 Lift Off Bagless Upright Vacuum

Motor runs fine and hose not clogged will not pickup dirt

This may sound silly, but have you checked the belt? A lot of Eureka vacuums use the vac motor to run the brush, and if the brush is not running the vacuum won't pick up. Another thing to check is the condition of the fan blades.. if they get worn th ... Eureka Vacuums

My bissell 6590 works fine with hose attachment. Motor shaft turns when belt and roller are off. When belt and roller are on it's noisy and smelly. Now one end of the roller actually melted in the holding slot. Do these rollers wear out like this or should I be looking for another problem.

Replace the roller,belt and before instalation clean motor shaft where belt rolls. you can turn on the vacumm and using a knife scrape the motor shaft from the black dirt. ... Bissell 6590 CleanView Bagless Upright Vacuum

Hoover tempo upright is clogged. I can only vac for a few minutes, then I have to unplug it and turn it over and clean out the under part under the roller. It is totally stuffed with dirt and dust and carpet fibers. I have a new bag in. It is like it is clogged up inbetween the bag and the roller. Also gets clogged when using the hose. It is maybe a year old. How can I take it apart and unclog it?

Disconnect the hose and head and wands. Drop a quarter thru the hose, the handle sometimes clogs. peer thru the wands and inspect the elbow on the head for blockage as well ... Vacuums

No suction I have new belts. Everything is clean. No clogs. When I turn it on it smells like rubber , the brush doesnt spin. Everything seems to be free flowing.. Roller brush isnt stuck on the ends. Took off hose to make sure no clogs anywhere. There is not even suction thru the hose with the handle in upright position.

Generally, the problem is that the belt is not running the brushes.  This is caused by one of the following:\015\012\015\012\015\012beater brush is jammed.  This is either an object stuck in the brush or im ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Kenmore 21875 One day it's working fine. Next day, it won't turn on. When I attach the hose to another vacuum cleaner, it runs. Is there a reset button on the canister? Could it be the receptacle is bad? My Kenmore Progressive won't turn on today either -but was fine last week. I cleaned the filters checked for blocked air, tried a different outlet and no luck. I'll check the pins on the connections and see if one of them is not matching up or appears worn.

Give the prongs a wiggle and see if there is any play in them.Might just be a plug end. ... Kenmore 25512/ 25513 Progressive Canister Vacuum

Motor runs fine and hosed not clogged will not pickup dirt

Check your fan for damaged or worn blades, then following the flow towards the bag check for blockage. Does your bag inflate when the vacuum is on? If so, it is less likely that you have blockage, than it is that there is an issue with the fan. ... Eureka Vacuums

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?

Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My Bissell 3760-1 has stopped sucking in the roller portion. The grab n go part are working fine. Checked the belt and it looks fine. Did I burn up the motor or a microchip?

Hey Lisa! Sorry you're having difficulty with your Lift-Off vacuum. Here's a link to troubleshooting steps to assist you with the suction.\015\012http: ... Vacuums

Hi my proheat bissell 7901 stopped pumping water to the floor, but it pumps water from the hand hose. I read the manual and followed how to check belt and the flat belt on right side of shampooer is fine and I turned on and it turns and so do the brushes at the bottom of the machine. I was reading online and I guess there's two belts on this machine? where can I find the other belt to see if it needs replacing. I guess it's a ribbed belt? that is the water pump belt?

Just taken ours apart with the same problem... found it was caused by the 2 halves of the main casing coming apart in the area where the upright pedal release is. I found this to be due to the upper casing having broken in 2 places - the bottom of th ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

I have a Hoover windtunnel T series. Model #UH70105. The system check indicator was almost red so I cleaned the filter. There are no clogs and it vacuums fine without the hose, but when I go to use the hose there is very little suction and all the vacuum dust flys out of the end the hose piece fits into when not in use. Can you please tell me what is wrong?

... Hoover Vacuums

I have Hoover whisper Cyclonic. I just opend beacuse it was showing Clogged. I removed all dirt etc from the belt and now roller are not moving round and the smell of burning is coming due to rubber not moving on the roller. I looked at the manual which tells me in cased on roller being Jamed if need to use the stich to reset. I looked all over could not find the switch. Can you guys help me please.

... Hoover Sh40080 Zen Whisper Bagless Multi-Cyclonic Canister Vacuum

I have a eureka airspeed AS1000A I bought it 3 months ago. It worked fine but today it will not power on. I have checked for clogs , checked hoses and tried different outlets any suggestions?

... Vacuums

The roller turns strong and the belt is new,but the dirt accu-mulates and doesnt get sucked up! there no observable clogs and the filter side vent blows strong.......ive removed beater,belt and am assuming there may be a problem inside the motor housing as all else appears normal..i was an aviation mech in the military and the above is my assessment........

Are you sure you have the belt on correctly?\015\012If it is not, the beater brush will push the dirt, etc, in front of itself and not back to the suction port. ... Hoover Tempo Widepath Upright Vacuum - Blue

I have a Dirt Devil MVP and it has no suction, I have checked all the hoses and they are NOT clogged, There is no suction at the 1st hose attachment at the base of the vacuum

... Dirt Devil SwivelGlide Bagged Upright Vacuum

The vacuum i've had for 6 months has very liittle suction power. checked that the belt is on. cleaned filter. checked to see if hoses were clogged. I used a super vac to suction any debris out of vacuum. still little suction power

As this unit has 3 filters on it, a lot of people forget about the one filter that will cause all of your trouble here. \012\012There is the exhaust hepa filter, no problem, your unit is pretty new, it shouldn't be a problem. \012Th ... Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

Vacume cleaner The vacume has no suction. the belt is fine i checked it. It turns fine no air is comming from the hose.

Check the hose and see if it has a clog, also the hose at the bottom. The filters may be clogged, make sure they are clean and that air flows thru them, if not then replace them. ... Eureka 5892AVZ Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 2.3161 seconds