Having problems with your Dirt Devil Vacuums ?

My dirt devil is not sucking,i cleaned out hoses and bottom seems to be turning fine?


Answers :

The fan motor is probably not working. Does it sound normal? Higher or lower pitch sound?
Repair Help & Product Troubleshooting for Dirt Devil Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My dirt devil is not sucking,i cleaned out hoses and bottom seems to be turning fine?


The fan motor is probably not working. Does it sound normal? Higher or lower pitch sound? ... Dirt Devil Vacuums

I have Bissell ProHeat 2X 9300-M that I tried to use again today. Is does not dispense solution when turned to Floor Cleaning, when switched to Hose it seems to be working fine. Brushes and suction are working as well. Soap and water containers are full. I took off and replaced tanks, waited to prime the pump multiple times without success. Not sure what is going on.


Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell ProHeat Turbo Deep Cleaner Upright Steam Vacuum

I have a DC07 and the brush wasn't rotating and I had no suction at the brush but perfect suction through the hose. I noticed a large build up of dog hair around the brush so I took off the cover plate and removed all the hair, cleaned inside the floor/brush housing and cleaned out the hose. I also cleaned the filter and removed the other air access cover and made sure that they were clear. I put everything back and the brush still doesn't turn and there is still no suction through the bottom


Hi and welcome to FixYa. I am Kelly. \015\012\015\012Here is a link that can assist you in your quest for the missing suction: \015\012\015\012 ... Dyson DC07 Bagless Upright Cyclonic Vacuum

Kenmore 21875 One day it's working fine. Next day, it won't turn on. When I attach the hose to another vacuum cleaner, it runs. Is there a reset button on the canister? Could it be the receptacle is bad? My Kenmore Progressive won't turn on today either -but was fine last week. I cleaned the filters checked for blocked air, tried a different outlet and no luck. I'll check the pins on the connections and see if one of them is not matching up or appears worn.


Give the prongs a wiggle and see if there is any play in them.Might just be a plug end. ... Kenmore 25512/ 25513 Progressive Canister Vacuum

Not sucking from bottom into bag, but blows out the side filter,..yet it DOES **** FROM HOSE ATTACHMENT. How can this be?...the.belt is fine recently replace, the rollers clean..I can feel anything i


Here is a diagram ,it's probably the hose behind the brush bar thats blocked.http://www.vacsite.com/en/bissell-parts-1/bissell-parts/3522-powerf ... Bissell 3522 PowerForce Bagged Upright Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

Brushes won't turn on the bissell proheat 2X steam cleaner-I don't have the manual to see if there is a button I am not pushing to turn on the brushes. Also, do you put the clean water in the "bladder" in the tank? Sorry I am so dumb-this cleaner was given to me with no manual and I can't figure it out. There is a small tank on the bottom at the back of the machine, that says "formula here" and I don't know if that is where the cleaner goes or what that is for. The machine turns on just fine


... Bissell 8910 ProHeat Clear View Upright Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Bad smell after using my windtunnel for a couple of minutes i noticed an odd smell. i turned it over and checked, the belts are fine but i cleaned out the hair anyway. after doing that the self propel seems to struggle and it is hard to push. when i look through the window on the top i can see the brush spinning freely but then when i push it, it slows down dramatically and then picks up again. the suction is fine. what do you recommend?


It may be the roller bearings? ... Hoover U5450-900 Windtunnel Supreme Bagged Upright Vacuum

I was vacuuming the vent in the bottom of the fridge. I must have picked something because the motor got wildly noisey. I cleaned out hoses, etc. There is no suction. I can see the blades of the motor and they are not turning around. Model U4269-930 Series B.72. Can I get at the motor to see if something is keeping the blades from turning? What would be your suggestion. Many thanks. Pat Sauerman


Hi Pat, my name is John I will do my best to assist you.\015\012\015\012You certainly can get at the motor, with simple hand tools. \015\012\015\012Referring to this ... Hoover Vacuums

Hi my proheat bissell 7901 stopped pumping water to the floor, but it pumps water from the hand hose. I read the manual and followed how to check belt and the flat belt on right side of shampooer is fine and I turned on and it turns and so do the brushes at the bottom of the machine. I was reading online and I guess there's two belts on this machine? where can I find the other belt to see if it needs replacing. I guess it's a ribbed belt? that is the water pump belt?


Just taken ours apart with the same problem... found it was caused by the 2 halves of the main casing coming apart in the area where the upright pedal release is. I found this to be due to the upper casing having broken in 2 places - the bottom of th ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

No suction I have new belts. Everything is clean. No clogs. When I turn it on it smells like rubber , the brush doesnt spin. Everything seems to be free flowing.. Roller brush isnt stuck on the ends. Took off hose to make sure no clogs anywhere. There is not even suction thru the hose with the handle in upright position.


Generally, the problem is that the belt is not running the brushes.  This is caused by one of the following:\015\012\015\012\015\012beater brush is jammed.  This is either an object stuck in the brush or im ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My vax rapide xl v027 leaks water from the clean tank through the rubber seal at the bottom of the tank. Seal seems ok but seems to rely on gravity. Leak is there weather or not its turned on


... Vacuums

My bissell proheat 2x carpet cleaner is not spraying from the bottom or sucking up when turned on. The hand tool works just fine. I have made sure it was on floor cleaning when I used it to try and clean my carpet. the busshes are working but nothing else is happening this cleaner is about 21/2 years old and has only been used maybe 5 times so it has not had alot of use.


Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

I have Hoover Widepath Bagless 12 Amp Windtunnel vacuum. Yesterday I was vacuuming and smelled smoke and it shut itself off. Today I cleaned out the filters (they weren't bad) made sure nothing was obstructing the hoses or the spinning brush part. It turned on for 1 second, smells like smoke somewhere from the bottom and now won't turn back on so I don't know if anything is spinning or not. What can I do to fix this myself?


Hi There,\015\012\015\012When a vacuum cleaner smokes, it is usually only one of two possible problems.\015\012\015\012It could either be that your motor burned up, or that your belts burned. The belts on this particular mod ... Hoover Self-Propelled WindTunnel Bagless Upright VacuumVacuum

Now that I just fixed my Lux Legacy canister vacuum, I need help on my other Electrolux Regency Series upright! The vacuum works fine but the rotating brush does not work and the brush motor does not turn on. Tried cleaning the brush and hitting hte reset button to no avail. This upright has a triple setting switch and I checked the each of the wires seem to be attached. Tried rotating the brush by hand and it would not budge. Was going to "encourage" the brush to turn with a set of articula


There are a couple rectangular holes on the bottom of the power nozzle, beside the wheels. These have tabs in them that need released with a standard screwdriver. \015\012 ... Vacuums

I have a Kenmore upright progrssive intell clean. For some reason it isn't sucking when I use it to vacuum. When I use attachments they work fine, but when I plug the hose back in after using the attachments and turn it back on it makes a weird noise and I can feel air blowing out of the back. Can you help me resolve this problem?


Open this manual to page 18 and clean all the filters listed to restore air flow.http://www.managemylife.com/mmh/lis_pdf/OWNM/L0908343.pdf ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

Hi.My model 116 36933502 only works as suction hose. When I use the bottom, a loud "flapping" noise and no suction. Everything is clean. Seems like a broken diphragm or filter? Sears Kenmore Progressive Bagless Intelliclean 5 years. Thanks Kate


... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

Ive changed the filter and checked the hoses but vacuum doesnt pick up ...when its on the dust is being blown out the bottom of the vacuum....i took the canister off to test the suction its fine...also cleaned the filter ...help!


Have you check the roller brush and drive belt? It may be your belt has broke or is slipping and therefore not turning the brush.\015\012Turn on machine and power head see if brush is turning if it is put a small amount of pressure on the rol ... Kenmore Vacuums

I have a Kenmore upright progrssive intell clean. For some reason it isn't sucking when I use it to vacuum. When I use attachments they work fine, but when I plug the hose back in after using the attachments and turn it back on it makes a weird noise and I can feel air blowing out of the back. Can you help me resolve this problem?


You have the answer and just don't know it. You are there so keep looking. Somewhere between where the suction hose connects with the lower hose and the power-head. There is a blockage, you may need to turn the unit upside down and look there or try ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

Runs but doesn't vacuum/****. Sidebrush works fine. Cleaned the roller brushes, and that seemed to confuse the robot and now it keeps going backward a few inches, turning, and then starts going backward again.


Sounds like a sensor problem. pull and clean the front black/white caster assembly and the revealed movement sensor and the 4 cliff sensors along the bottom of the front. Make sure the front caster wheel turns freely. You may have to remove the rolle ... iRobot Roomba 560 Robotic Vacuum

I have a Bissell 7920 ProHeat and only used it 4 times and the brush on the bottom has stopped spinning and when attempting to spray solution the flow indicator doesn't spin and nothing comes out. I have looked at all of the belts and they seem fine. I have also removed and cleaned the heating unit. Still nothing. Any other ideas?


Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum

I have the Hoover Deluxe Elite Rewind with the 24 ft cord reel. I can't seem to find the instructions or a model # exactly for it. The vacuum is just over a month old but when I turn it on now it's not sucking at the bottom and the hose and everything else appears to be attached so I don't know why it's not working.


Http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=572145\015\012Generic problem for all Vacuums\015\012I have the Hoover Deluxe\015\012Posted by y2kas32 on May 05 ... Vacuums

Eureka 4D. Brush turns but not alot of suction. dust bunnies build up inside the hose at the bottom and at the dust brush connection. Seems to be very hot. ?????


Try cleaning the filters ... Eureka WhirlWind Litespeed 5844 Upright Vacuum

Lost suction I've only used this vacuum a few times, it's practically brand new. Now, one I turn it on, it sounds fine, and the hose feels as if it's getting some suction, but it's not strong enough to actually **** things up from the carpet into the canister. I have completely emptied the canister and bought a new filter. Nothing seems to help.


TOSS IT and forget it! I have never used a hand vac that worked that was worth the effort of turning it on .... I suggest they are all junk ... I found very few vacuum cleaners ... actually **** especially anything made by dirt devil ... I do have a ... Dirt Devil Vibe AllPurpose Hand Vacuum Bagless Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1052 seconds