Having problems with your Dirt Devil Vision Turbo W/Bonus Upright Vacuum Vacuum ?

Low suction When I start the vacuum, nothing picks up. I tried checking every aspect, but I don't seem understand the cause for this problem.


Answers :

Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you have low suction on the accessory hose, the problem is with a motor filter, HEPA filter, or a clog where the hose goes into the unit. If you have good suction on the accessory hose but none on the floor, it's usually in the brush head (clog or broken belt) Good luck
Repair Help & Product Troubleshooting for Dirt Devil Vision Turbo W/Bonus Upright Vacuum Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Low suction When I start the vacuum, nothing picks up. I tried checking every aspect, but I don't seem understand the cause for this problem.


Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you h ... Dirt Devil Vision Turbo W/Bonus Upright Vacuum Vacuum

I have a Hoover, Steam spin scrub, Model F5897-900. Only used it a couple times and the motor gave out. First started being noisy then a bad smell. It did seem noisier that what I would expect from the start but I didn't realize it was a problem with the shaft of the motor. I took it apart and found the motor shaft wasn't true and causing sparks. The motor looks like it can not be taken apart and repaired. This seems like a default from the beginning but it is past warranty. Also noti


You will have to replace the motor and the hose asm. thehooverstore.com may be able to help, or you should be able to find a repair shop that can order them for you. ... Vacuums

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?


Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

No water I have had a bissell proheat for 3 months. Now, the water won't come out in either the floor cleaner, or the tools. I have checked all the stoppers, they all seem to be in working order. It started to work for about 5 min, then stopped again. Is this a fixable, quick problem, or should I return it as being defective?


Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell ProHeat Turbo Deep Cleaner Upright Steam Vacuum

Hi all, I have a Janome 234D overlocker and when I try to sew with it, it misses stitches. What could be causing this problem and how do I fix it? I tried rethreading,checked the tension and stitch length dials on the side and I dont have a manual for any instructions, help is desperately needed, regards Wendy


... Vacuums

I HAD MY DC17 VAC FOR 3 YRS NOW NO PROBLEMS AT ALL, I REGULARLY CLEAN THE FILTER LIKE IT SAYS BUT LATELY I'VE NOTICE THAT THERE SEEMS TO BE A LOT MORE COLLECTION ON THE TOP OF THE FILTER WHEN I'M DONE VACUUMING. IT HAS ALSO STARTED THIS WEEK TO MAKE A VERY LOUD HUMMING TYPE NOISE WHILE RUNNING, I HAVE CHECKED FOR ALL POINTS FOR ANY BLOCK AND NOTHING AND NOW TODAY IT RUN A FEW MINUTES AND STOPS AUTOMATICALLY,IT WILL RESTART AFTER I LET IT SIT UNPLUGGED.WHATS UP WITH THIS THING, IT HAS BEEN GR


The vac is over heating. First, you should try a new filter. Also, keep in mind that after cleaning the filter, make sure that it fully dries. Using a wet or damp filter clogs it quickly. Second, turn the vac upside down and make sure that the roller ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

We replaced the belt after about 5 uses, and now every once in a while it smells like burning rubber, I checked to belt to make sure it was ok, and then last week it started smoking. Is there reported problems with this model?


If the belt is hot or burning during use, it could be due to a beater brush, which the belt drives, being bound up in some manner.\015\012The beater brush is removed during belt changes and should be cleaned of all debris as best you can.\015\012At e ... Dirt Devil Reaction Twin Cyclone Upright Vacuum

The brush roller stops turning and I can smell the belt burning, then it will catch and start working normal. I looked under the plate to check the belts and they looked okay and no hang ups of string or anything. The only thing that seemed weird was that the smaller belt that actually attaches and turns the roller is a bit loose. The larger belt is tight but looks like its the one that is burning and causing the smell.


Better to replace both belts the smaller one is stretched out thats whyits slipping ,be sure to clean the old rubber off the motor shaft before replacing the belts.it will cause the new belts to run unevevly and go bad before their time ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My versatility electrolux vacuum is 2 years old and it has lost its suction, i have replaced the filters and checked every hosing area i have access to, it seems to all be clear. I dont know what else to do, it has a higher pitched whinnig sound when it is on


It sounds like the fan blades have worn away until there's basically no air resistance, thus no air flow/suction. The whine is created by the motor turning at a higher speed due to lack of resistance. \015\012The fan wasn't covered by the wa ... Electrolux Vacuums

My vaccuum makes a very high pitched sound when it runs. I cleaned it out and checked for itms stuck in it but there doesn't appear to be anything. What is causing this problem. Other than the awful sound it seems to be working fine.


Could be a worn belt. Here is the belt you need:Bissell Pet Hair Eraser Belt ... Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

Shark/cordless /sweeper - over four years old. Started - but seemed like it was caught and shut off almost immediately. Not used year around - tried to start after absence. I have removed some hair and perhaps dental floss. Checked belt - it seems O.K. Do I need a new battery or is it just worn out.


Check the brush,is there any dirt got stuck in between brush rolls.If there is then it needs to be cleaned.Your cordless sweeper will automatically shut off if an obstruction is caught in the brush roll. the other thing to checks is dust contai ... Vacuums

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

The last time the vacuum cleaner was used the outlet sparked causing it to smoke when turning on vacuum cleaner. I replaced the outlet and plugged it in and things seemed o.k. Today I turned on the vacuum, it stayed on for a mili second and went off. I checked the switch on the vacuum and it showed voltage coming and going, but would not turn on again. I checked all the wires in the area of the switch all seemed o.k. I thought maybe there might be a short in the cord. When I went to plug


... Sharp Twin Energy EC-12TWT4 Bagged Upright Vacuum

Won't start. My son was using the vacuum & Didn't change the bag. The vacuum was making the full bag smell, but the light was't on & it didn't stop. I stopped him, changed the bag, checked the filter, closed the compartments & turned on the vacuum. Nothing happened. I checked to be sure that it was plugged in, that wasn't the problem. I've let the vacuum "rest" for several days, It still won't start. Any suggestions?


There is a reset button at the back of the powerhead. The user manual can be downloaded from the electrolux website, although I didn't find it very useful. There was some info on how to change the powerhead drive belt. ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

I just used my Bissell Proheat, when I heard the vacuum sound get lower and lower then suddenly something "gave" and it got very loud and started emitting a burnt rubber smell. It still worked to put liquid into the carpet; seemed to have trouble getting it out. I checked the tank, filters, belt, and roller and all seemed OK - but when I started up again and looked down I saw sparks in the motor/belt area and shut it down immediately. Any thoughts?


The bearing that is located at the top of the vacuum motor has failed . Because of that the shaft of the motor's rotor is out of position and the pulley attached to it has started rubbing on the other pulleys, giving you that smell. the spark appear ... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.


Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

Dyson animal won't start. Never had any problem with this vacuum. No apparent problem. No electrical problem with house or outlet. If there are some common things I could check/fix, things that might go wrong, I would like to check them out and get this machine going again.


Hi there, if the machine was running and cut out in use, this could be due to the motor overheating. The cause of this would be a blockage or a dirty filter. These checks can be found in the Support section on our website at www.dyson.com. ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Hoover Wind Tunnel 7500 Brush not Turning. I have replaced the Brush and the belt. The problem does not seem to be either to me. I believe might be a missing part. The place were the belt hooks on is a metal pole which never seems to grip the belt well. In fact it seems loose most of the time and slips on the brush, causing the belt to eventually burn up. Could there be a missing plastic or rubber piece meant to hold the belt taught  on the metal pole?


Check the Idler Pulley part Number 43241004 (Item 13 in the IPB)http://64.49.205.183/v/u6451900.pdf ... Vacuums

My Kirby 2HD has started making an odd roaring noise but still works fine. I have taken the front assembly off and cleaned and adjusted the roller and checked the belt. The noise seems to come from the motor housing. I have tried to wiggle the main shaft at the front (bearings?) and it seems tight. Can't seem to get the other housings apart. Any ideas? Thanks, John


It is quite possible, it just needs lubed. The motor comes in direct contact with dirt so, you have to make sure the front bearing has a drop of oil on it from time to time. If it starts to scream at you within one month, after oiling, the bearing ... Kirby Heritage II Vacuum

Roomba My Scheduler started making a "grinding" noise every now and then until one day it just started grinding and then stopped (I could restart the unit, however it repeated the grinding and stopping). I have checked the wheels and all of the gears appear to be in good order. I have a hunch the brush motor may be stripped. Any opinions? Thanks: RAnderson


Hi!\015\012\015\012Further investigation (running diagnostics mode) revealed the impeller (in the dust bin) was out of whack. I got another dust bin from EBAY and replaced the impeller and motor. Unit works fine. ... iRobot Roomba 4210 Bagless Robotic Vacuum

My G6 kirby stopped working. i have checked the wire for fraying and continuity and found no problems. I have noticed that the foot pedal that turns the machine on doesn't seem to click when pushed on or off either. i have the motor exposed now to check if it is bad, but i am not sure how to pursue doing just that.


... Kirby G6 Bagged Upright Vacuum

My Miele capricorn has started making an odd noise. It seems like something is blocking the engine. I've turned if off and on, and reset it and it still have the odd, almost loud barking noise. The power nozzle also does not seem to be working. I've checked the connections. Right before this happened I was using the vacuum. I didn't notice anything out of the ordinary until this.


Greetings,\015\012\015\012This is a major problem. The Miele vacuums motor should never make a loud noise, period. The way the motor is designed, it's quiet and should be quiet for the life of the motor. There are two motors on your ... Vacuums

NO POWER My Dyson DCO4 Absolute (purple&lime) won't' switch on. I've checked the plug fuse, wall socket and also filters and hoses on machine all seem fine so think the problem is with the on/off button (maybe loose wire or something) but how do i get to it, is there a special way to remove the green on/off button in order to check the connection? Thankyou in advance for the help i am sure you will be able to provide.


The problem is almost certainly a fatigue break in the flex. These usually happen where the flex enters the handle through the rubber sleeve near the on off switch. You will need to cut about four inches off the wire and reconnect it to the switch. ... Vacuums

No suction I've only had my vacuum for a couple of months and it seem I have a similar problem but there is no clear blockage. It seems like I don't have adequate suction that reaches the accessory hoses nor the main one. I'm not sure where to start. I've taken the darn thing apart but I can't see any obvious malfunction. Any suggestions?


If you have low suction at the end of the hose, then you either have a clog in the hose or a clogged filter. Take the hose off and drop something in it to see if it comes out the other end. If you have suction at the end of the hose, then the dirt ... Hoover U5753-900 WindTunnel Bagless Upright Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0657 seconds