Having problems with your Dyson DC07 Animal Bagless Upright Cyclonic Vacuum ?

When I use my Dyson in the upright position it does not **** up the dirt on the carpet. But if I attach a tool and use the hose it does. I have checked to see if there is a blockage any where and there does not seem to be

Answers :

Hi its Darran at Dyson.

I would recommend checking the brush bar to see if its spinning when you switch the machine on and release the head into the vacuuming position. If its not, check the brush control dial on the head of the cleaner to ensure that when the machine is stood upright, the dial is in the centre position and not switched to the hard/smooth floor setting. When in the centre position, on releasing the head this dial should move forward to the on position and the brush bar should start turning.

If the brush bar is fine, its possible there is a blockage in the base. The Support section on our website has full diagnostics that you may find useful, please visit www.dyson.com.

I hope this information has been useful. If so, please feel free to leave us a testimonial!

Kind regards
Dyson Customer Service
Repair Help & Product Troubleshooting for Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

When I use my Dyson in the upright position it does not **** up the dirt on the carpet. But if I attach a tool and use the hose it does. I have checked to see if there is a blockage any where and there does not seem to be

Hi its Darran at Dyson.I would recommend checking the brush bar to see if its spinning when you switch the machine on and release the head into the vacuuming position. If its not, check the brush control dial on the head of the cleaner to ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.

Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!

... Miele Vacuums

I cleaned out the hose and removed brush to clean and checked belt. Everything seems to work but will not pick up or suction on carpet. The hose is totally clear from clogs. I can see the floor from one end to the other. What am I missing that might be causing lack of suction?

Hi troupdavid,I see that your Vacuum is having issues with it suction, you mentioned that you took it a part to clean it, see steps below.\015\012\015\012Check if everything is inserted prope ... Hoover Tempo Widepath Upright Vacuum - Blue

Hoover Alyx Pets 2000w Hoover Model TC1208 001 Virtually no suction, have checked for blockages but cant seem to see any, however i can't remove the hose to check it. Any ideas?

Did you check the HEPA filter? I have the same problem with mine if I don't clean the filter after using it. It's a dirty job but helps for a while. ... Vacuums

My model # is 31075, I don't see it listed on this website, 31079 is the closest. The suction is almost non existant when I use just the hose around the edges of my room, I've checked the bag and filters, and for something plugging the hose, all is well in these areas, what else could it be?

... Kenmore 31079 Upright Vacuum

My Hoover T5703 has suddenly stopped working. I was using it, moved it to another room, presssed the start with my foot - and nothing! I have checked that the fuse and electricity socket are both OK.I did knock it over a while ago and am wondering if I have broken a bit of plastic in the foot starter. It doesn't seem to 'click' as firmly as it did, but I cannot see how to take it off to check?

... Hoover Vacuums

Hose extension tube will not fully go down after use (the hard tube seems to be stopped). Have lost manual - is there a way of taking hose base out to check for blockage. It is a DysonDC15 bought October 06

Keep ur tube, wand very straight. then there should be two side buttons, press them and the tube SHOULD gently slide down.\015\012\015\012Ive expierienced the same problem! ... Dyson Vacuums

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

The vacuum i've had for 6 months has very liittle suction power. checked that the belt is on. cleaned filter. checked to see if hoses were clogged. I used a super vac to suction any debris out of vacuum. still little suction power

As this unit has 3 filters on it, a lot of people forget about the one filter that will cause all of your trouble here. \012\012There is the exhaust hepa filter, no problem, your unit is pretty new, it shouldn't be a problem. \012Th ... Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u

Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

We have two of these vacuums and both of them have experienced the same problems. First the floor heighth adjustment doesn't work and now neither one will pick up on either carpet or floor when in the brush/floor mode. They both seem to work with the suction hose function. We have removed the back panel to see if there was an obstruction but it was clear. We have changed the bag and the small filter (not the HEPA filter) all to no avail. What else can we do? We are desperate to use our vacu

Did you check the powerhead for obstructions? With a bend in the tube just below where the hose connects, this is a common spot for clogs. To check, detach hose and drop a coin in the hole. If it doesn't drop through, a blockage is present. Use t ... Electrolux Oxygen 3 Upright Vacuum Cleaner - EL5035 Vacuum

Brushes stopped The brushes stopped turning while using the cleaner. I removed the brushes to see if the spindle was broken, it wasn't. I then removed the top plastic cover and checked the switch that engages the brushes; it didn't seem to be moving correctly. There's one spring on the switch - should there be two? Or do you think something has broken on the inside? Thanks for any help

Most likely the turbine is bad, it may just be clogged up, you can take it apart and clean it out real good. That may work, but it may not. Sometimes it is best to replace the turbine. ... Hoover F7431-900 SteamVac Vacuum

Bad smell after using my windtunnel for a couple of minutes i noticed an odd smell. i turned it over and checked, the belts are fine but i cleaned out the hair anyway. after doing that the self propel seems to struggle and it is hard to push. when i look through the window on the top i can see the brush spinning freely but then when i push it, it slows down dramatically and then picks up again. the suction is fine. what do you recommend?

It may be the roller bearings? ... Hoover U5450-900 Windtunnel Supreme Bagged Upright Vacuum

This is a new machine I got for Christmas. All of the dirt is staying in the area where the brushes are and then falls out when you turn off the machine. I have checked all connections and the hoses seem to be clear. All filters have been cleaned and there is not dirt trapped that I can see.

... LG Electronics Kompressor Pet Care Upright Vacuum Cleaner LUV200R

Vx550 issues Like most here, ours shuts down after a few minutes use. Ichecked everything and found the thermal protection was shutting it down. I then decided to check online to see if this was a usual problem, it seems that it is. I guess a call to nu-tone is warranted. i wonder if they will ship a new unit to western Canada.

Heven't fixed it yet, but I've pulled the motor to see what the specific issue is. As soon as I have the problem isolated and a solution, if possible, I'll post it here. I will have to contact Nutone Monday and see what they will do. If nothing, I'll ... Broan-NuTone VX475 Bagged Central System Vacuum

Our unit is 7024A Electrolux Oxygen 3 - it seems to work great but suddenly, the head or 'power brush' or whatever it is called - has died. I checked by removing the hose and plugging it directly into the body, but it is still dead. Without that motorized head working, the vacuum is useless. Is it worth replacing? The unit is only about 1 year old and has seen light use only. Very frustrating, since it was the most expensive unit in the store:(

... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

My Bissell BS3920F upright (similar to the 10N6F) has been working wonderfully for the past 3 years but suddenly seems to not pick up dog hair as well as it used to. It has been pulled apart by my husband to ensure nothing is blocking the hoses etc and when running the suction seems to be there. It seems to grab the dog hair and leave it in a straight line directly under the unit without picking it up. I then disconnect the hose and use to hose to pick up the dog hair. This works well but obviou

Check to see if your brush is not worn down, they do wear with age - compare the length of the bristles with a new one. Replace the brush ir there is a significant difference in bristle lengths. Also check the flexible ben ... Bissell Vacuums

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after

... Vacuums

I have a Hoover windtunnel T series. Model #UH70105. The system check indicator was almost red so I cleaned the filter. There are no clogs and it vacuums fine without the hose, but when I go to use the hose there is very little suction and all the vacuum dust flys out of the end the hose piece fits into when not in use. Can you please tell me what is wrong?

... Hoover Vacuums

I have a power drive baggless vacuum cleaner...it runs well, but suddenly it seems to have lost most of the suction coming through the hose and floor area. When I remove the dirt container, the suction below it seems strong. I have had it to repair twice--they have tuned it up and replaced all filters and belt. It still does not pick up well when I vacuum or use the hose. Can you help ?

There is something stopping it up,you will have to dissasemble the unit to find the blockage,this is the most likely problem. ... Hoover U6660-900 WindTunnel Bagless Upright Vacuum

The last time the vacuum cleaner was used the outlet sparked causing it to smoke when turning on vacuum cleaner. I replaced the outlet and plugged it in and things seemed o.k. Today I turned on the vacuum, it stayed on for a mili second and went off. I checked the switch on the vacuum and it showed voltage coming and going, but would not turn on again. I checked all the wires in the area of the switch all seemed o.k. I thought maybe there might be a short in the cord. When I went to plug

... Sharp Twin Energy EC-12TWT4 Bagged Upright Vacuum

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?

Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My bissell proheat upright steam cleaner is spraying out through the attachments just fine, but will not spray to the floor when using upright. we've taken it apart to find that there is no water at all going through one of the hoses, but it appears the hose is connected behind the on/off and heat switches, we can't seem to figure out how to get in there to replace that hose....any suggestions on how to access this?? just curious how you would get in to replace the hose, we know it is the hose..

Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

The hose on my Samsung 9048R is torn partly from the swivel base. The main problem is that the carpet attachment with the beater bar will not operate now. My brother checked the connectivity at both ends of the hose and there is juice at the bottom swivel part but at the other end of the hose where the carpet wand plugs in it is dead. is there any way to fix this? How does the wire go up through the hose? I have looked around on the internet and it would seem that the entire hose assembly is

... Samsung Quiet Storm 9048R Bagged Canister Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0728 seconds