Having problems with your Easy Flo EF1750 Central System Vacuum ?

EF 1750 has lost suction power. There is a noticable decrease in suction power even at the power unit inlet.


Answers :

Disconnect the actual pipe where it meets the vac. Then test the intake for suction. If you have poor suction still, check the intake itself from inside the vac body for blockage, then check the gasket on the pail for mis-alignement.

If you have suction at the actual intake, your issue will be in the house piping. Look for any damaged inlet doors which are ajar, also look at any inlets you may have recently removed for painting or renovation work. Each inlet has an o ring seal which must be properly aligned. If not aligned you will hear a hiss at the inlet when the door is closed.

Last check where any exposed pipe or pipe joint could have been jarred loose or damaged, basement , garage, etc. Post back to advise what you find
Repair Help & Product Troubleshooting for Easy Flo EF1750 Central System Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

EF 1750 has lost suction power. There is a noticable decrease in suction power even at the power unit inlet.


Disconnect the actual pipe where it meets the vac. Then test the intake for suction. If you have poor suction still, check the intake itself from inside the vac body for blockage, then check the gasket on the pail for mis-alignement.If yo ... Easy Flo EF1750 Central System Vacuum

Poor suction I have a hoover hush s5627 vacuum purchased about 4 years ago from Costco. It's suction power isn't so good anymore. I've checked all the lines & hoses and they're clear and I've changed the bag. I even disconnected the pipe from the vacuum unit and held my hand over the intake. While the machine roars like a jet engine the suction power just ain't like it used to be. What could possibly be the problem?


This vaccuum has a Fan Blade inside connected to the motor that spins to create the suction you feel. After a few years of use (and misuse) the blades on this (plastic) fan will be broken off, thus damaging the unit. These Fans are replaceable if yo ... Vacuums

Have an electrolux 2100 canister vac, it has lost suction power thru the years. no clogs in newer hose or in sweeper. even with new bag, filter and belt only increases power minimally.


Have you ever over the years replaced your brushroll ? Have you tried dropping a coin thru the hose from one end to see if it comes out the other end ? Have you taken the wand loose from the elbow ( the swivel part of your carpet sweeper) to see if t ... Electrolux Vacuums

Lack of suction at power unit


If you have remove the piping from the inlet of your vacuum and by clogging the inlet with your hand to feel if it is sucking air but still little/no suction is felt then there must be a crack from the inside of your vacuum unit where most of the a ... Electrolux Centralux Vacuum

My unit powers up but does not run for more than 10 minutes before shutting down. I also sem to have lost suction. What do you suggest I do?


The air passages inside the head are plugged and causing the motor to overheat. Remove the bottom plate and look for wads of hair or other debris jamming the passages. Same procedure on the bag end (but no plate). Don't run it longer than required fo ... Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

The model is Miele S538, but I did not see it on the list. The suction power button( ) increasing the power does not work. The suction power button (-) decreasing the power does work.


... Miele Leo S5381 Canister HEPA Vacuum Cleaner Bagged Vacuum

Decreased suction was using to vaccuum carpet and suction decreased..nothing plugging hose....suction remain at unit canister and exhaust is fine....suggestions??


You might have a clog, to try and unclog the lines, you need to unplug the unit, and remove the bag compartment. Then take a shop vac using the hose attachment hold it into the attachment door where there is low suction and try to draw the clog out t ... Broan-NuTone CV353 Central Vacuum

My Miele S5211 has lost suction power on max setting. I put on min setting to hoover chairs now when i turn upto max says on min setting


... Miele S5211 Deep Black Vacuum Cleaner Bagged Canister Vacuum

Model 116.27914 power mate connection to lower wand is loose. Head unit works when pushing forward putting downward pressure on it, but looses power when you pull back on unit and connection is lost.


... Kenmore Vacuums

Suction power level drops to zero, need to constantly readjust suction power from zero to normal operating level Appears to be some type of loose connection between hose coupler and base unit


Ok, so where as both of the solutions above are good, they will not solve your problem with the hose cutting off to 0, then having to turn it back on. \015\012\015\012This problem is caused by the static electricity which causes the hose ... Miele s558 Silver Moon Vacuum

I have a CT600 power brush that would not power up. Thinking the motor was bad in it, I replaced it with a new CT700 power brush, I am still experiencing the same problem the power brush itself does not seem to be getting electic power, but the Vacuum unit does come on with suction.


First try connecting the power nozzle directly to the hose. If it works, the problem is due to a broken wire or faulty connection in the wands. At least one wand will need to be replaced.\015\012My guess is it's probably due to a broken or di ... Broan-NuTone VX550 Bagged Central System Vacuum

My VAX Vacuum has lost ALL suction power. I've


Vax power pet 1 filter keeps getting clogged up so dirt not going into cylinder ... VAX Appliances Vax X5 Bagless Upright Cyclonic Vacuum

My kenmore model no 116.22512200 canister vacuum power head has no suction & doesn't pick up even though it shows all the signs that it is getting power. The junior power mate works fine.


... Kenmore Vacuums

Power unit suction problem


Have you checked the filters? ... Electrolux Central Vacuum

How to Reverse the hose at inlet on power unit on centralux E130A


That is the easiest way, just hold the attachment end of the hose into dirt inlet (preferably the one on the unit itself) and use your hands to try and seal the end as best you can. ... Electrolux Centralux Vacuum

It has lost most of its suction power...what to do?


Clean all the filters if this doesn't help then check for blockages at head, hose and entrance to collection chamber ... Vacuums

Hoover Windtunnel T-Series UH20700 9 mos old. Keeps clogging in hose just above the beater brush assembly. I think it clogs because the suction is too weak to pull much through. Primary filter is clean and HEPA filter is replaced. Even when everything is unclogged, suction is weak compared to another unit (same model) that a friend has. Any ideas?


... Hoover UH70120 WindTunnel TSeries Rewind Bagless Upright Vacuum Cleaner

Lost most all suction; pinpointed to cyclone mechanism (as input suction is perfect), but cannot figure out how to disassemble. Removed 3 torx screws from top and inner unit. Thanks!


Hi there Creddiscks, \012There isn't much more to it once you have those screws out. The rest of the chamber is not designed to be pulled apart unfortunately. I have made a video titled \012 ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

UNIT WAS ON BUT NO SUCTION. I STARTED TO CHECK THE BRUSH UNIT AND THEN NO POWER. IS THERE A RESENT BUTTON? i HAVE CHECKED THE BREAKER.


I need to know what make / model of the unit you are using here and I can help you. What make and model vacuum is this?Thanks, let me know by replying here..Tim ... Electrolux Central Vacuum

I recently lost power to the power head. Thinking the hose was not sending current to the head, I bought a new hose. It did not solve my problem. I have since noticed that a warning symbel is appearing that indicates what looks like a key with TA inside. The vacumn has good suction. Please advise John.


Hi\015\012\015\012Please check the link bellow to diagnose your problem…..\015\012\015\012http://home.howstuffw ... Electrolux Epic 6500 Vacuum

My Dyson DC14 has lost its suction power. And when using the hose it has no suction at all. Any suggestions?


... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

I have a power drive baggless vacuum cleaner...it runs well, but suddenly it seems to have lost most of the suction coming through the hose and floor area. When I remove the dirt container, the suction below it seems strong. I have had it to repair twice--they have tuned it up and replaced all filters and belt. It still does not pick up well when I vacuum or use the hose. Can you help ?


There is something stopping it up,you will have to dissasemble the unit to find the blockage,this is the most likely problem. ... Hoover U6660-900 WindTunnel Bagless Upright Vacuum

My vacuum has lost a lot of iots suction power. How can I regain its power?


The pipe leading from the motor to the bag is clogged ... Bissell Vacuum - Momentum Cyclonic 1 ea Bagless Upright Vacuum

My Bissell 9200 is not sucking the water into the dirty water resevoir. 1. The gasket on the clear-view seems fine. 2. The suction power just doesn't seem powerful enough (feeling with my hand). 3. The brushes turn fine and belt is fine (not sure if that even matters for this issue). Any help appreciated. Thanks, - Matt


Disassemble all lines and check to see if all O rings are installed. If cracked missing or stretched out of shape no suction will be provided ... Bissell 9200 Upright Vacuum

We have lost suction power from our dc07 but only from the base the hose still has decent suction


It sounds like a clog. I have had vacuum cleaners that i had to take almost all the way apart just to get the clog totally cleaned. Vacuums do need some maintenance due to the fact the amount of dust and hair they collect can easily clog them. You ca ... Dyson DC07 Allergy Blue/Turquoise Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0898 seconds