Having problems with your Electrolux C101 Bagged Canister Vacuum ?

2100 comes on but will not keep running, I have changed filter and bag.

Answers :

The dial on top of the machine should be set about mid-point. If it is, then turn until the small dot and the arrow are lined up. If this doesn't help, turn all the way around so large dot and arrow line up.
\015\0122. Detach hose from vacuum. Turn on. If it continues running, place hand flat against the intake. If it shuts off immediately, there's probably a problem with the "Control Valve Assembly". This is a part that can be purchased at your local Aerus Electrolux store. I highly recommend allowing them to replace it rather than trying to yourself.
\015\012If you don't know where the closest store is, go to aerusonline.com, click on "store locator" button at bottom of page, type in your zip code and click on the find store button.
\015\012If your vacuum runs fine without the hose attached, then check hose and power nozzle for a clog.
Repair Help & Product Troubleshooting for Electrolux C101 Bagged Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

2100 comes on but will not keep running, I have changed filter and bag.

The dial on top of the machine should be set about mid-point. If it is, then turn until the small dot and the arrow are lined up. If this doesn't help, turn all the way around so large dot and arrow line up.\015\0122. Detach hose from vacuum ... Electrolux C101 Bagged Canister Vacuum

I have a Z345 Electrolux cylinder vacuum cleaner, from the 1970s probably, but not used much. I have lost the guide. I forgot to change the bag before it was full. Smoke started to come out - smelling of burnt paper, not rubber. So switched off. It did not blow the fuse, and may be OK. I wish to inspect it. How do I open it up? Alos I have an air filter and a motor filter for it. I have often changed the air filter on the top. How do I get at the motor filter, if there is one? Than

Good day! OK you have to is replaced the bag and that's it.And don't forget to change the bag again to avoid that problem.Thank you ... Electrolux Guardian Bagged Canister Vacuum

I have a new Kenmore magic bued and I am about to change bags for the first time. Trying to do this the clip that is supposed to hod the bag close to the whole keeps coming off when I replace it and close the lid, turn on the vac the sucction is very low and it keeps showing the bag is full which is not true / what is going wrong here ? Thanks so much for supporting, Beba

Sorry to hear that you are having problems with you Kenmore Magic Blue.There is a so-called "bag full indicator", which will only turn red if it got some major blockage. This is the reason why there is no power suction.The "fu ... Kenmore Magic Blue 24195 Bagged Canister Vacuum

Bag full indication comes on; changed bag; still wont run.

Turn the knob on the top of the vacuum all the way to the right and try it again ... Electrolux UltraLux 2000 Bagged Canister Vacuum

HOOVER 6430-900 Runs for about a minute or two and shuts off. Wait a while and it will run again. Changed the belts, new bag, new filter. Seems to put out a lot of heat when running.

Hoover Fined for Failing to Report Vacuum Cleaner Fire Hazard\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\01 ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

I have the electrolux guardian-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)

Hi,\015\012Check your hose you have something stuck in the hose...stretch it out straight and run something through it to push out whatever is stuck in there...\015\012\015\012heatman101 ... Electrolux Guardian Bagged Canister Vacuum

I have the Aerus Lux7000-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)

Hi, you very likely have a defective control valve under the dial on top of\015\012the vac , or a kink or blockage in the tiny pressure hose that feeds\015\012the air from the throat of the vac or the back of the bag chamber\015\012against the two si ... Electrolux Guardian Bagged Canister Vacuum

Stopped running. Filter was clogged. Cleaned filter and changed bag, but still won't start. Motor was warm when it stopped.

Hi There,This sounds like the Thermal Switch in your motor tripped. All Riccar vacuum cleaners have a motor reset switch, that will shut the motor down when it gets hot. Usually it's caused by a full bag, clog, or dirty filter. ... Riccar 8850 Vacuum

Our vacuum bag was full and we keep on vacuuming. I believe some lent and hair got sucked into the vacuum motor. We've changed the bag and filters. Now the motor makes a loud noise especially when shutting off. what should we do?

Get a professional repairer to examine it. Even with an over-full bag, dirt will not have got in to the motor if the pre-motor filter was correctly positioned and in good condition. However, the motor may have been damaged through lack of air flow an ... Miele S251i Plus Bagged Canister Vacuum

Kenmore progressive cannister vacuum check bag light keeps coming on and ive changed the bag

... Vacuums

My hoover keeps cutting out I have washed the filters and changed the bag but still keeps cutting out every 15secs

... Hoover Vacuums

I have a mile tt2000 that works fine up to 1300W but if I crank it up higher the motor decreases and increases speed every couple of seconds. I have changed the bag and filters and done the usual cheCks for blockages but can find nothing amiss. Unusually when it is running and I block the intake it will run at full power but as soon as I clear it the motor "hunts" again. Any ideas.

... Miele Cat & Dog 326i Bagged Canister Vacuum

We have a Kenmore Progressive Model 116 Upright bagged vacuum with Hepa filter. It's at least a couple years old. For quite some time now when ever we use the vacuum the vacuum motor will shut off nafter about 5 min. of use. We then need to let it sit for awhile and then we can run it again for another 5 min. The bag has been change. Any one have any ideas how to fix this?

I suspect that you have a restriction. The motor sounds like the thermal break is stopping the motor before damage, due to heat.\012You must witness that the entire suction and discharge side are clear. This is not always very easy, but necessa ... Kenmore 34612 Bagged Upright Vacuum

My Dirt Devil M082476 Full Bag indicator light keeps coming on when I turn my vacum up to full intensity. I have tried changing the bag and checked that all hose is clear. If I leave the vacum on low intensity the suction is minimal and does not increas when I turn up the suction. Is there a solution to this? I look forward to your response

... Dirt Devil M084105 Jaguar Vacuum

I have an electrolux epic 6500 sr. The change bag light came on, I changed the bag, now it won't run properly. If the bag is out and the hose attached it will run or if the bag is in and the hose is off it will run, but not if the bag is in and the hose is attached. Any suggestions?

First, if it runs without a bag, there's a problem with the bag lock-out switch or wiring. This needs to be replaced/repaired by an authorized Aerus Electrolux technician.\015\012\015\012First, turn dial on top of vacuum counter-clockwis ... Electrolux Epic 6500 Vacuum

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But

Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

Electrolux Diplomat canister vacuum. The bag light comes on and it stops. It has to do with the hose because if I take the hose off, then the vacuum keeps running. I can't see anything blocking the connection. any suggestions on what else to look at?

... Electrolux Vacuums

My Kenmore Progressive keeps burning up belts even after I have changed the bag, cleaned the filters and checked to make sure the agitator was clean and free turning

On the left hand side, just above the handle release, is a lever to adjust if you are doing hard wood or carpet cleaning. When adjusted for hard wood, that lever releases the belt and just uses the "vacuum" function. When set for carpet it engages ... Kenmore Vacuums

My Miele White Star Model # S3141 was running fine, then stopped mid-vacuuming. I changed the bag and cleaned the filters (which were dirty), let it cool off, and tried to start it up again, but no luck. What do I do now? Are there any repair places in Ft. Myers, FL?? Thank you for your help.

... Miele Vacuums

Question mark light has come on my vacuum and it wont run. I replaced the bag, but it wont start. I don't have a new filter is that the problem?

... Electrolux Vacuums

Hello! I have a Kenmore Progressive bagless vacuum with the Easy Clean extended life filter. The model number on my vacuum is 34728401. I was vacuuming the carpet when it just stopped running. The dirt sensor light will come on, but nothing else. The belt looks fine, and I don't see anything keeping the beaters from rotating. Help Please!!!

You can have power to the dirt light sensor, but it seems like the motor itself is not using the power supplied. ... Vacuums

Panasonic canaster vacumn cleaner model MC-9647C only runs a few seconds and shuts off, after a rest starts then stops after a few seconds. I changed bags and cleaned the filter...any suggestions? Thanks, Phil

... Panasonic Vacuums

Have the cannister 6500 SP just changed all filters but when I start the vaccum it shuts itself back off and the full bag indicator light comes on?

It sounds like the valve assembly (full bag control) is faulty. Threr are two O rings inside of it and the plactic holding the bottom one has broken. You'll have to take it to the shop. ... Electrolux UltraLux 2000 Bagged Canister Vacuum

Bosch Vacuum Cleaner: I changed bag. Cleaned out all suction hose and hepa filters, however, my 1450 w 12 amp upright vacuum cleaner will die after five minute run - overheating. Please advise.

Greetings from GoVacuum.com,It sounds like you may have a bad thermal switch inside the machine. Most vacuum cleaners have a switch connected to the motor, so if the vacuum cleaner is running hot, it will shut off to prevent any damage ... Bosch Vacuums

I have a Kenmore Elegance model 116 that has lost suction. There is no blockage and both the filter and bags have been changed. The powerhead turns on but the vacuum itself is fairly quiet, not sure if that motor is running. How can I regain the suction?

... Kenmore Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0750 seconds