Having problems with your Electrolux Central Vacuum ?

Power unit suction problem

\015 I Have an Electrolux system and I have no suction. I have followed a flow chart for troubleshooting and at the power unit with the pipe disconnected I have very little/no suction, but I do have a ton of exhaust\015

Answers :

Have you checked the filters?
Repair Help & Product Troubleshooting for Electrolux Central Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Poor suction I have a hoover hush s5627 vacuum purchased about 4 years ago from Costco. It's suction power isn't so good anymore. I've checked all the lines & hoses and they're clear and I've changed the bag. I even disconnected the pipe from the vacuum unit and held my hand over the intake. While the machine roars like a jet engine the suction power just ain't like it used to be. What could possibly be the problem?

This vaccuum has a Fan Blade inside connected to the motor that spins to create the suction you feel. After a few years of use (and misuse) the blades on this (plastic) fan will be broken off, thus damaging the unit. These Fans are replaceable if yo ... Vacuums

I have a CT600 power brush that would not power up. Thinking the motor was bad in it, I replaced it with a new CT700 power brush, I am still experiencing the same problem the power brush itself does not seem to be getting electic power, but the Vacuum unit does come on with suction.

First try connecting the power nozzle directly to the hose. If it works, the problem is due to a broken wire or faulty connection in the wands. At least one wand will need to be replaced.\015\012My guess is it's probably due to a broken or di ... Broan-NuTone VX550 Bagged Central System Vacuum

Power unit suction problem

Have you checked the filters? ... Electrolux Central Vacuum

The brushes and the belt are not rotating. The power seems fine and there is suction. I have no other history on this problem since I was given this almost new unit over Thanksgiving. Where should I be looking for a problem/solution.

If you've got suction, but the brushes and belt are not rotating, then either the belt has come off the motor shaft, or the belt is broken and just looks OK.Remove the bottom cover off the floor head and check that the brush roller turns ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

EF 1750 has lost suction power. There is a noticable decrease in suction power even at the power unit inlet.

Disconnect the actual pipe where it meets the vac. Then test the intake for suction. If you have poor suction still, check the intake itself from inside the vac body for blockage, then check the gasket on the pail for mis-alignement.If yo ... Easy Flo EF1750 Central System Vacuum

I have a Nutone CV-450. When the unit is turned on the motor makes a high pitched whining sound. The suction seems like it is reduced and there is a burning rubber smell coming from the unit. Suction at the unit itself is also reduced. Any ideas about the cause of the problem and the solution?

... Broan-NuTone CV450 Central Bagged Central System Vacuum

When vacuuming carpet with the electric power brush it will ocassionly , go to zero suction mode and shut off the brush. I have tried to cause it to happen by playing with the joint areas ( handle to tube and tube to power brush) without sucess. When the problem does occur I just turn the suction back on and power up the brush again at the handle controls.

You gave a good start to giving us good information to help you with solving this problem-- But I need a little more information:It sounds like you have the Electric Motor driven Power nozzle/ Floo ... Miele Blue Moon Bagged Canister Vacuum

Suction power level drops to zero, need to constantly readjust suction power from zero to normal operating level Appears to be some type of loose connection between hose coupler and base unit

Ok, so where as both of the solutions above are good, they will not solve your problem with the hose cutting off to 0, then having to turn it back on. \015\012\015\012This problem is caused by the static electricity which causes the hose ... Miele s558 Silver Moon Vacuum

Shark s3325 stopped working while steaming; thinking the unit had ran out of water I allowed unit to cool before refilling, however unit over flowed with only 700ml water added. When I plugged unit back into outlet it would not turn on (red light was not on) but I hear a click upon plugging in unit, when turning unit power button on and when turning on the handle switch. Please advise how to resolve this problem.

... Euro-Pro S3325 Handheld Steam Vacuum

Lack of suction at power unit

If you have remove the piping from the inlet of your vacuum and by clogging the inlet with your hand to feel if it is sucking air but still little/no suction is felt then there must be a crack from the inside of your vacuum unit where most of the a ... Electrolux Centralux Vacuum

Attachment problem used a new unit w/attachment for 5 minutes...dispensed solution in a powerful triangular fashion. Then the fluid quit dispensing out of the attachment nozle amost like the pump quit working. Primed the unit several times w/ no success. checked for clogs. can't tell if the floor portion is "pumping' or just dribbling solution onto the floor with the trigger. can see no leaks at this point. unit worked for about 5 minutes on apholstery

Make sure everything is filled and secured tightly, if this a new unit it should be something simple ok, also check where machine folds down that the solution hose is not being pinched its right behind the dirty water tank ... Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

Blue Moon S658 Miele vacuum problem where suction cuts off. The power light stays on. Sometimes I lose full suction, and other times I just lose partial suction. This shows on the handle by going from 1000 to 400, or nothing. Any thoughts on what this could be?

This is a problem with the circuit board in the SES-125 hose. If you replace the hose, this problem will stop. Unfortunately this is the only solution to this problem. \015\012\015\012-R ... Miele Blue Moon Bagged Canister Vacuum

Smell/suction I have a Eureka Altima Model 2991 Type AVZ. I have suction when I use the power paw and attachments. I have all hoses clear. My brush is spinning and belt is not broken (I opened it up and checked), but I have no suction when I turn it on to vacuum my living room carpet. I also have a burning smell to go with it after about 30 seconds. I've never had a problem with this vacuum cleaner before.

Ours started smelling too, and it seems that the plastic end on the roller brush was melting. In process of finding rollerbrush for it now ... Eureka 2971AV EZ Kleen Bagless Upright Vacuum

Proteam Pro force 1500xp Upright vacuum... When I switch to the carpet setting I have no suction power but the beater bar is turning. If I switch back to the floors setting, the suction is excellent. Wondering if the problem is in the on/off switch?

Just undo the screws on the front part of the switch assembly, carefully check all the leads to the switch. Mine slide off all the time as the switch is poorly designed and subject to damage when the darn thing tips over (easily!!!) new switches are ... Proteam ProForce® 1500XP Bagged Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.

Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

My Error light will not go off. I just bought new batterie, as I thought that was the problem. If I hold down the power button and the play button on the vacuum it will run. When released it stops. The remote will work for the unit if I am holding down the power button on the vacuum.

... Infinuvo QQ1 CleanMate 365 Robotic Vacuum


I need to know what make / model of the unit you are using here and I can help you. What make and model vacuum is this?Thanks, let me know by replying here..Tim ... Electrolux Central Vacuum

Have a canister model Lux5500-ser#F35365B and power nozzle number N115Q-problem: The power nozzel does not stay completely connected to the hose-there seems to be some slipage where the hose connects to the nozzel-preventing a solid connection and the unit from working properly. I tried to tighten the connections on the nozzel, but this has not helped

... Electrolux Guardian Bagged Canister Vacuum

I recently lost power to the power head. Thinking the hose was not sending current to the head, I bought a new hose. It did not solve my problem. I have since noticed that a warning symbel is appearing that indicates what looks like a key with TA inside. The vacumn has good suction. Please advise John.

Hi\015\012\015\012Please check the link bellow to diagnose your problem…..\015\012\015\012http://home.howstuffw ... Electrolux Epic 6500 Vacuum

Suction problem My vaccum does not have the same suction power. What can I do?

Change the filters if they are blockedof just old they wont work right but 1 of then is washable it says it ou the filter  ... Dyson DC07 Bagless Upright Cyclonic Vacuum

Bought today a used rca rp3721a clock radio without the manual. need user manual to adjust all the settings, for example TIME, ALARM TIME, ALARM ON AND OFF, radio or "beeper" alarm on, entire unit on and off without unplugging it from shore power,and anything I haven't thought of up to here. The unit is RCA Model RP3721A clock radio, and appears to be functional. Our problem seems to be "the nut behind the wheel". e-mail: [email protected]

Hello,I advice you check the links below to search for the\015\012manual of your device, the link contain almost virtually all the manuals of all \015\012device.manualsonline.comORmanualnguide.com ... Vacuums

Vacuum Problem My dirt devil vacuum is losing suction and keeps clogging. All the dirt keeps sticking to the screen by the filter and then it would stop working. Also the hose does not have a strong suction power either. So what can I do?

The Bissell can have several filters in it, depending on the model. Some have a round hepa filter that is covered with a foam sleeve. This filter is located at the bottom of the dirt cup. Others have a foam filter that is located under the dirt cup i ... Dirt Devil Vision Turbo W/Bonus Upright Vacuum Vacuum

Meile Solaris. Power cord connection faulty. Unit powers on/off when cord is being retracted/pulled out. Maybe a break in wire close to connection point in vacuum. Or, the connection point itself is loose? The problem likely resulted from trying to use vacuum at furthest extent of cord.

Cord reel likely needs to be tightened. requirs disassembly and large washers installed to keep reel connections tight. Jim ... Vacuums

Suction Problem I took my unit to my work and used it, when I returned home it wouldn't suck up anything. I took the recovery take out and it has inward suction. Shouldn't that be outward, so it goes into the tank? It also blows out of the bottom by the brushes. I check the filter in the bottom and that is fine. Is it possible that it is somehow reversed the direction of the air flow (rotor running backwards)? I am perplexed. What am I missing?

There is a stand pipe seal where the bucket sits on, and if it isn't there or out of place could cause a suction problem like you said yours is doing. In the picture it is #10. The motor seal may have gone bad and is leaking # 15.\015\012 ... Hoover F7220900 SteamVac V2 Upright Vacuum

No suction I have a similar problem - volta vortex bagless vacuum will not ****. Worked for 1 job then quit sucking, I have had the heads replaced, then the barrel - 2 months later same problem. I push the power lever to max - 10 seconds later it turns itself down and doesn't work properly. I am over it, now looking for refund

Hi there SmartAlec from NelsonVacuums.com.au here. The problem is going to be the filter. THis kind of vacuum basically replaces the bag with a simple filter and the vacuum ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0883 seconds