Having problems with your Electrolux Centralux Vacuum ?

Hi I need help because I have a problem with my Electrolux Centralux Central Vac system in my house. When I plug the vac hose in the central vac socket at first I heard the motor running very gently with NO suction then after a minute or so it went completely dead and they is NO motor sound, suction, or anything happening what so ever. Can anyone tell me what this problem is???


Answers :

Have you checked for a clog in the lines or in the hose? If there is no clog in the system anywhere, then your motor could be dying.
Repair Help & Product Troubleshooting for Electrolux Centralux Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Hi I need help because I have a problem with my Electrolux Centralux Central Vac system in my house. When I plug the vac hose in the central vac socket at first I heard the motor running very gently with NO suction then after a minute or so it went completely dead and they is NO motor sound, suction, or anything happening what so ever. Can anyone tell me what this problem is???


Have you checked for a clog in the lines or in the hose? If there is no clog in the system anywhere, then your motor could be dying. ... Electrolux Centralux Vacuum

No suction I have the central vac type. It has no suction at the can. I pulled the hose going to the walls and tested there...and nothing. I removed the dirt can and checked the motor ...it is spinning but does not feel like any suction. I checked the exhaust and it is pushing strong air out. I also cleaned the filter and still nothing. Is there a relay or something that would cause only exhaust air. I emptied the can of dirt and put it back together and have absolutely no air.....hear the motor


On some units there is a screen that protects the impeller of the motor. If this gets sealed off with debris then it is like putting a potato in the tail pipe of a car. Taking the top off the unit reveals the motor. DO UN-PLUG the unit first from th ... Electrolux Central Vacuum

Recently my central vac system started making a louder than usual and laboured sound when in uise, enough so that I took note and inspected the canister and motor while running. The motor was trowing off blue sparks and looked like it could 'POP' at any moment. I will not risk using it until I know what the problem is and how to repair it. My assumption is the motor needs to be replaced. The system came with the resale house I bought 3 yrs ago but I do not know the age of the system itself.


... Vacuums

We have an Eureka The Boss Central Vac Model ACV2001B. When you plug in the vac the motor starts momentarily and then stops. What could be the problem? Thank you.


Most likely there is a short in the low voltage wiring in the hose. ... Vacuums

Suction Problem I just borrowed the Hoover Steam Vac Deluxe w/ 5 brush agitator from my neighbor and it worked ok for the first few minutes, although the suction would stop and go. When I had enough water to dump I did it and when I put it back on it no longer sucked the water up from the carpet. She admits to having it for 15 years, but why did it have to break on me. Makes me look as though I did it!


Check and make sure the dirt water tank is properly on if it it is chech inside the lide to make sure the red stopper is not stuck to the top this will cut off the suction ... Hoover F7431-900 SteamVac Vacuum

I have a NUTONE central vac, when I turn on the power, It sounds like its grinding glass and doesnt suction. Could it be that broken glass got caught in the motor and all I need to do is clean it, or is this the sound of a failed motor?


More likely it's something in the fan. However, I suggest taking it to a vacuum repair shop to make sure. Something could have got into the fan system and is making a racket, but the motor itself won't crunch up glass. ... Electrolux Central Vacuum

No suction I am getting no suction on my central vac at the vac. I do not believe that the piping is plugged up, the vacuum is not creating suction. What are the causes of no suction at the vacuum and how do I take the top half of the Nutone central vac off?


Use the guide at builtinvacuum.com/flowchrt.html to find the issue and solution. Most likely you need to test it without any filter and be sure the bottom of the unit is attached :) To get access to the motors you need to unbolt the very top sides. ... Broan-NuTone CV350 Performance Bagged Central System Vacuum

Our central vac has no suction. I think the filter may have been damp when I reinstalled it after washing! Have I ruined the motor?


I don't think that you have "ruined" the motor. however, you should go to the unit and take the bucket off of the machine and let the motor underside dry out when your not using the unit. Just keep an ear out for the machine next time you start it up ... Electrolux Central Vacuum

My central vac unit does not turn off even when hose is disconnected. I have to unplug the motor unit in the garage to shut it off. What do you think the problem is? It is a 7 year old Electrolux


Possibly the power module. Or a short in the wiring. Take it to the local Aerus Electrolux store and have it checked by a service tech to be sure. The pm is a lot less expensive to replace than a whole cv. ... Electrolux Central Vacuum

I have a modle # 1584 electrolux central vac no suction. This modle has a lid not a canister. Motor goes on. Need help


Likely is a leak somewhere. check all the outlet doors ... Electrolux Vacuums

Burned out The best way for me to describe the problem is to post reviews I made on Amazon.com, which is where I purchased them. ________________ Based on my past experience, I bought another 6 months ago. I live in a very tiny 2 room apartment and do not vacuum lots of dirt. I noticed this new vac getting very hot to the touch where the motor is located with only a few minutes of use. Today it just STOPPED. When I felt the canister, it was HOT. It obviously has burned out. Upon closer inspect


... Euro-Pro HEPA Shark EP238 Bagged Canister Vacuum

My central vaccum cleaner has no suction at all outlets even at the canister. The motor is still working and blowing air out the air release tube. What could be the problem


Check the filter in the tank. If this is dirty, the motor will still run, but there will be little to no suction. Rinse thoroughly under warm water, then allow to thoroughly air dry before replacing into vacuum. \015\012I recommend having tw ... Electrolux Central Vacuum

Troubleshoot a problem with central vac - not in the vac hose


The only thing you can use really is a plumbers snake.Not sure if thats what its called in the States. Its a long flexible metal spiral spring that plumbers use to clear blocked drainsRob in the UK ... M&S Systems AirVac AVP1200 Platinum Series Central Vac - 12,000 sq ft Bagged Central System Vacuum

Central vac our central vac will not work unless the main vac in the garage is switched on manualy.... its sucking fine but i have to switch it off at the main switch in the garage after i have used it normaly i just plug in the hose and vac away and it switches itself off we have just had cable installed with a fisher guy in the walls do you think that would be the problem thanks a lot


It is possible that the low voltage wiring that controls your central vacuum has been damaged during the cable work. You can check to see if the low voltage relay is working by shorting the two terminals together at the unit. Just disconnect the two ... M&S Systems AirVac AVP1200 Platinum Series Central Vac - 12,000 sq ft Bagged Central System Vacuum

No suction on my Electrolux central vacuum in all outlets even though motor is running and there is no clog in the hose.


I would start with washing out the ilter really good and letting dry. then try the system. ... Electrolux Central Vacuum

My Electrolux Central Vac E130G stopped running. I checked the motor by circumventing the pc board and putting 110 VAC directly on the motor . It ran at full power. Is it the pc board I should repla


... Vacuums

Have a Centralux Aerus about 5 years old. Don't see a model number. There is suction but beater brush quit working. Was using for a few minutes, shut it off for a few minutes, turned it back on and suction only. Tried the reset button also. Tried the sidekick attachment and it works fine. There was no smell like something was hot. Belt is fine. Are there any fuses or anything else to try? This vacuum cleaner has not really been used that much, it is hard to believe the motor would need replaced


There probably is a loose wire in the handle near the switch or a wire off near the swivel elbow near the vac power head. With the right fastener tool to remove some screws you can fix it yourself ... Electrolux Centralux Vacuum

Replacement parts... I've got a 3594 Bissell and the belt has come completely off. In the process of breaking, it bent the metal guide inside the motor housing and melted the plastic that holds the guide and keeps the belt inline with the roller. I've got it running again by using a screw I filed all the threads off of, but it only works for 10 minutes at a time before breaking another belt. This process is getting expensive, as it usually takes 30 minutes to completely vacuum the house. Is ther


Most likely it is the top cover that needs to be replaced, part #2031238 and is around $30. It would have that guide on it. ... Bissell 3594 CleanView PowerTrak Bagless Upright Vacuum

My vac has lost suction. When I vacuum it picks up very little, but when I remove the wand hose it has good suction. We have cleaned both filters, checked for blockage in all hoses & cleaned the beater bar brush. All to no avail. Is it the motor? Or is there a blockage deep in the vac somewhere? We're debating repair versus buying a new one. Hope you can help. Thanks.


Hi there,Sorry to hear you're having a problem with your DC14. Since you say you've already washed the filters and checked for blockages, it's probably best if you get in touch with us so we can run through some simple troubleshooting ste ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

Problems with Beam central vac


My Beam central vac has started turning off after about 10 minutes of use. I thought it was the hose, but the hose in the garage does the same thing, and I've also tried the other outlets, and the same. The canister was just emptied about two weeks a ... Beam Industries 2775 Serenity Plus Central System Vacuum

I have a Eureka Mega Boss Central Vac Model # CV1801P. The suction works when the handle button is pushed left (floor mode) but no suction happens when the button is pushed right. When the floor attachment is hooked up and the button is pushed right, the brush rotates, but there is no suction.


... Eureka Vacuums

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

Low suction I have a Hoover central vacuum system. I've reset the fuse box, checked the fuses, all of the lines are clear and there are no holes for escaped air to travel out. The filter has been cleaned as well. The vac works well with high suction when hooked directly to the unit, however when using any of the indoor connections there is extremely low suction. The machine still turns on so I do not believe it is an electronic issue. I have troubleshooted the issue as best I could and would


... Hoover L2310 GUV Central System Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

Dead motor? My 8 year old Miele S251i has worked fine, until I was recently vacuuming and moved the plug from one outlet to another. When I restarted the vacuum, it made rrrrr.....rrrrrr....rrrrr noises and smelled like something was burning. I turned it off, and it's shown no signs of life since. Sound like a motor problem? I've taken the cover off and looked at the cord and seen the motor, nothing looks obviously wrong, but I'm also not mechanical.


... Miele S251 Flamenco II Bagged Canister Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0876 seconds