Having problems with your Electrolux EL5010A Bagged Upright Vacuum ?

Have a electrolux aptitude model el5010. Motor runs, no blockagae, belt not broken. What's up?


Answers :

Repair Help & Product Troubleshooting for Electrolux EL5010A Bagged Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Have a electrolux aptitude model el5010. Motor runs, no blockagae, belt not broken. What's up?


... Electrolux EL5010A Bagged Upright Vacuum

Ihave a Hoover Windtunnel self-propel model U6445-920. The belt from the drive motor to the big wheel will not run in the center of the wheel. The belt runs about 1/3 off the wheel. I have tried several new belts and still the same problem. What do I need to do to repair this problem.


The large wheel may be worn off center. If the belt stays on and is not thrown, you can run the vac. if there is wobble in the wheel causing a genuine belt to slide off replace the wheel mechanism. ... Vacuums

My bissell model 18Z6 has developed a loud noise and vibration when the brush is running. I have removed the brush assy and cleaned all the hair, etc but still the noise. I ran the brush motor with the belt disconnected and all seemed ok, but of course there was no load on the motor. I suspect a problem with the brush assy bearings or axle or both but I hate to just throw parts at the problem. any suggestions would be greatly appreciated.


... Bissell Vacuums

My kenmore vacuum model 116.36933502. It has no suction. I have cleaned out every spot,taken off the back and still nothing. The motor runs but doesnt seem to be at full power. The agitator brush works. When it broke i seemed to smell something and since it has no belt. Does this possibly have to motors?


... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

I have sewing machine Model 158 1340281 which has 25 years warranty. The problem is eventhough Motor is running but the belt does not go round .


... Vacuums

Why thw the motor will not run on the beater of my Bissell 3760-1 the belt is not broken


... Bissell Vacuums

Helping out someone that has a ECV 1590A model 117A Electrolux central Vacuum. There seems to be a problem with the brushes. I'm looking for a manual or what brushes to get or a new motor. It seems to run fine what it starts.


... Electrolux Vacuums

Electrolux epic 3000 not working on carpet setting. Belt is not broken. Could it be switch or motor?


... Electrolux Vacuums

Changing fan I changed the broken fan in my eureka 1934A. Put the cover back on and reattached the belt and when I went to start it, it wouldn't work. I took the cover back off to see what was going on and it looked like the motor was running in reverse of what it had been. Is this possible?


My solution is one that only works if the vacuum is a spare... To get mad at it and throw it in the garbage... \015\012\015\012My thought though on what the problem actually was... Seeing as where the vacuum came from and what the problem ... Eureka 1934 Bagged Upright Vacuum

Aquavac runs for short time then cuts out blowing the RCD . Have rewired mains cable thinking a broken or loose wire... still same problem. Have also noticed that a lot of sparks etc coming from the motor brushes. Vac approx 10-15yrs old.Aquavac is model 6310B


... Vacuums

Electrolux 2 in 1 Ergorapido stick Vacuum. Motor runs then cuts out after 3 - 4 seconds. Sometimes it will run properly for 10 minutes so batteries are good. Why does it cut our usually?


If the hand held is working correctly (By itself) try pulling up a little bit on the 4 metal connection tabs on the wand. The connection tabs were not making a proper connection on my unit. ... Electrolux Pronto 2-In-1 Stick/Hand Vacuum - Cayenne

I'm using (or WAS using) a Eureka ''the boss'' model 8803. The belt broke, no biggie, so I replaced it with a Eureka model U belt, the problem is when I put the new belt on and turn on the vaccuum, the belt breaks again. I am also having trouble getting the brush roller to fit right when the belt is in place. I can't find any sharp edges that would cut the belt,nor can I find where any small bits may have broken. Anyone have a solution for me?


First, make sure you have the right belt, second, i am thinking that you are not lineing the roller up right, it will only fit one way. look at the ends of the roller and the grooves where it slides in, you should be able to see clearly how it goes. ... Vacuums

Kenmore canister model 116.25513506 wont turn on. when handle switch is turned to floor. vac motor does not turn on. When switch is turned to carpet, floor nozzle works but vac motor does not. I checked fuse, all o.k. checked continuity for plug, o.k. removed wires for bag full switch...motor wont run. I wired motor directly power cord...motor runs. Thinking it must be the circuit board, how do I bypass it or test it?


... Vacuums

The belt is broken on our Hoover Allergen Filtration Model U5018-900 120 v. 60 Hz 12.0 A. Belt 38528040. Where can I get the belt and instructions on how to replace the broken belt?


The owner's manual can be downloaded here (in red, "Download the Instruction Manual (PDF))\015\012http://www.hoover.com/product.aspx?model=U501 ... Hoover U5018-900 Bagged Upright Vacuum

Broken belt I have a royal canister model 4750 with a broken belt on the power head. I don't know how to disassemble the head to get at the belt.


If you have the power head with the headlight, squeeze the sides of the upper part (almost like a superstructure,) where the headlight is located. It should lift off, allowing access to the screws to get the powerhead apart the rest of the way, and o ... Vacuums

Model # 5770 the brush motor runs and shuts down after a few seconds...Turn unit off and the brush again will run for a second or two...If I don't turn unit off brush will not start up..Could it be the printed board..the motor brushes..or the wiring that goes from the printed board to the main motor...Thank you


Seems like your unit goes into failsafe because it detects something wrong. Well you should check the brushes and replace them if they are worn out. Also check the wiring for shorts etc, becaue the unit maybe tripping due to an overload. The printed ... Bissell Vacuums

Noise My Dyson DC08 is making a loud, rough, vibration/noise that seems to be coming from the from the rotating brush housing. I replaced the old belt which was several years old and slipping. When I run the motor with the new belt removed the machine sounds normal. The bearings on the rotating brush seem to be running smoothly when turned by hand both when out of the brush holder and when installed in the machine. I can't find anything rubbing on the belt or rotating brush. I applied a bit o


Hi there, it's Jack at Dyson.\012I'm sorry to hear you're having difficulty with your Dyson vacuum. From your \012description, it sounds like the model number you've supplied may not be correct, \012as DC08 is a cylinder vacuum which doesn't use ... Dyson DC08 Cylinder Bagless Canister Cyclonic Vacuum

We own a dirt devil model 088600, and are experiencing a problem with the belt wearing away a section between where the belt connects to the brushes and the motor. There is a lot of plastic/rubber residue coming out from the vacuum. We have tried new belts only to find the same problem occurs. I noticed that the source of the dust is coming from the section between the brushes and motor, where there appears to be a section that is misshapen and melted. I looked up the schematic online and can't


If you are certain that the belt is seated correctly and the beater bar is nested in its holder and the cover of the assembly has been properly installed and you still see a contact area between the belt and cover, you should either: return the vac ... Dirt Devil Vacuums

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

I can't find replacement belt for little lux (original model bought in 1991). Stamped on back "Model 1673BA". Motor works fine but belt doesn't turn roller any more.


... Electrolux Little Lux Bagged Handheld Vacuum

I have hoover steamvac models f5889-900 and f7222-900. The brush motor is broken in model f7222-900 and I replace with working motor in f5889-900? I am using f5889-900 just as parts


... Vacuums

I have an older Oreck XL vacuum that sounds like it is running twice as fast as it should. I disassembled the entire vacuum, including disconnecting the motor wires, to clean out the hair, string, and other things. When I put everything back and connected all the wires, everything appears to work, including the light. The only problem is, it sounds extremely loud like the motor is running too fast. The model number is: XL3610HH Ser. No. 3610HHXA039740-6 I do not have as electrical diagram to see


... Oreck XL Ultra Bagged Upright Vacuum

Hello, I have a Hoover 3200 Turbo Power vaccum. while the motor appears to be working fine the vaccum no longer picks up the dirt. I turned the vaccum upside down and the belt appears to be broken. would a broken belt stop the pick up, there appears to be no suction. This vaccum is approximately 10 years old. is it worth fixing? I live in Virginia Beach Va, where would I take the vaccum for repair? my zip code is 23456- Thanks Cleta Goode


... Hoover Vacuums

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Beater bar not spinning on my dyson animal DC14. Motor turns on and sounds good. My belt is not broken, and still tight on the bar. It looks like another possible belt or gear box between motor and bar. Can anyone please point me to next step?


... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0849 seconds