Having problems with your Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum ?

Model el7001 You can push the button on the hose and the unit will come on then immediately stop. Once in awhile it will stay running. I have replaced the bag and the hepa filter but that didn't help. Any thoughts


Answers :

Repair Help & Product Troubleshooting for Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Model el7001 You can push the button on the hose and the unit will come on then immediately stop. Once in awhile it will stay running. I have replaced the bag and the hepa filter but that didn't help. Any thoughts


... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

My electrolux oxygen cannister has the "bag change" light on when there is a new bag. The light stays on when the suction power is high (to pick up small particles) and it won't pick up, but the ight goes off when the suction power is low (to pick up big objects). I changed the hepa filter, cleaned the motor filter and changed bags, but all that didn't help.


You may have a clog in the hose, and/or the inlet by the brush roll. A clog will turn on that light as well as a full bag. ... Vacuums

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

I have older Electrolux Epic Model C102D - warning light is on (icon of cup with bunch of holes in it). Is this about the filter BAG needing replaced or about the HEPA filter? Do I have a HEPA filter, and if so, how do I replace it?


... Electrolux Lux 5500 Canister Vacuum

My Electrolux guardian C135 vac has lost suction. replacing the bag does nothing. removing the HEPA filter has no effect - what do you suggest? Will a replacement HEPA filter make any significant difference?


No you have a clog in the hose, wand or at the power head. Remove the hose wand and power head from the the vacuum. Turn on the vacuum, put the palm of your hand over the hole in front, you should feel plunty of suction. Then replace just the hose an ... Electrolux Guardian Bagged Canister Vacuum

I have an Ecectrolux Epic canister vacuum. As soon as it starts sucking, the vacuum cuts off. I put a new filter and bag in, but it doesn't seem to help. If I open the front where the bag goes, take the bag out and depress the safety button the vacuum will run. Need some help or direction. Thank you


Try this.\015\012Disconnect hose. Turn machine on and place hand over intake. If it shuts off immediately, first try turning dial on top of machine so largest dot matches up with arrow. Turn on and place hand over intake again. If it still ... Electrolux Vacuums

Bissell powerforce My lower pickup tube became clogged so I removed it and cleaned it out and reinstalled it.Now everything runs good but the vaccum want pick up any dirt .I replaced the bag andf when I turn it on it just exhaust air but does not have any suction,I tired tp pull the bag door of while it was running whick I could not do so it has plenty of suction inside just not getting any outside can you help?


... Bissell Vacuums

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

We have a Kenmore Progressive Model 116 Upright bagged vacuum with Hepa filter. It's at least a couple years old. For quite some time now when ever we use the vacuum the vacuum motor will shut off nafter about 5 min. of use. We then need to let it sit for awhile and then we can run it again for another 5 min. The bag has been change. Any one have any ideas how to fix this?


I suspect that you have a restriction. The motor sounds like the thermal break is stopping the motor before damage, due to heat.\012You must witness that the entire suction and discharge side are clear. This is not always very easy, but necessa ... Kenmore 34612 Bagged Upright Vacuum

I have the same problem as steve967 The dyson dc16 is fully charged, runs well for 5-10 seconds and shuts down. I wait for a second or 2 and it runs again for 5-10 seconds. This will continue for numerous cycles, until I am finished cleaning. I have cleaned all the filters, and the power is good, The system will just not stay on. It is just over 2 years old. A friend of mine had the same problem with his Dyson DC16 after just a couple of months and has replaced his Dyson with a Black N De


Dear Michael_Stad,I am going to sound like a broken record but here is my same answer to another person with the same problem.I have I had the same problem with my Dyson DC16, where it only runs for a few\015\012seconds at a t ... Dyson DC16 Root 6 Bagless Handheld Cyclonic Vacuum

Bsa2222uc/06 what kind of bags does this take,and i need replacement hepa filter,there is a intake filter and frame missing, someone told me it needs a new motor, roger


... Bosch BSA2200UC Compact Plus Health Guard Bagged Canister Vacuum

The hose is disconnected, new bag in unit, new filter, unit runs when hose is detached but immediately turns off when hose is attached but hose has no obstruction, etc.. i was told i need some sort of valve. HELP! I have birds, a cat and 2 large dogs and no vacuum :)


There is a vacuum hose that attaches inside the unit to a round clear plactic piece. In most cases you can simply cut the small vacuum hose and it will fix the problem. ... Electrolux Epic 3500 Vacuum

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But


Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

Replace belt hoover 5100 - Hoover U5444-900 5100 Wind Tunnel 15 Inch Wide Hepa Filter Bagged Black VacuumVacuum


... Hoover U5444-900 5100 Wind Tunnel 15 Inch Wide Hepa Filter Bagged Black VacuumVacuum

My Kenmore canister vacuum smells bad while in operation. Replacing the bag does no good. I removed the HEPA filter and it smelled fine. How do I correct this problem??


... Kenmore 23612 Progressive PowerMate Bagged Canister Vacuum

I have a Eureka 4800 series the Boss upright with a bag and Hepa filter. I love it! I was just vacuuming with the hose part and all was well and then suddenly the lower brush came on and a "burning" smell followed. Thought it was the belt so my husband was going to put on the new belt which I had on hand! When he turned it over, the "bar" that holds the belt looks as though it "shot through" the plastic side of the housing on the vacuum. There is melted plastic on the outside of the vacuum and o


I had the same problem. Take out the old belt if possible. Remove the 4 screws inside the filter and the 3 on the front of that housing. pull out the foam around the motor. carefully pull out the suction tube that is press fit against the motor. ... Eureka 4874 Bagged Upright Vacuum

Bosch Vacuum Cleaner: I changed bag. Cleaned out all suction hose and hepa filters, however, my 1450 w 12 amp upright vacuum cleaner will die after five minute run - overheating. Please advise.


Greetings from GoVacuum.com,It sounds like you may have a bad thermal switch inside the machine. Most vacuum cleaners have a switch connected to the motor, so if the vacuum cleaner is running hot, it will shut off to prevent any damage ... Bosch Vacuums

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

Epio 6500 canister electrolux won't stay running...says the bag is full even when it isn't. Will start but as soon a load is placed on the unit it shuts down. Any thoughts?


There might be something stuck ... Electrolux Epic 6500 Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

I have an L shaped piece of metal with a hole at one end that fell out of my hoover elite bagged upright vaccuum cleaner. I repaired the belt but don't know where this metal piece goes. I think it has something to do with the wheel assembly which is replaced and it seems to want to stay there. any thoughts


This metal clip was for the wheel assembly, but not always needed. you can diregard the part if your vac is working correctly with the front wheels. ... Hoover Elite U5061-900 Bagged Upright Vacuum

I have a power drive baggless vacuum cleaner...it runs well, but suddenly it seems to have lost most of the suction coming through the hose and floor area. When I remove the dirt container, the suction below it seems strong. I have had it to repair twice--they have tuned it up and replaced all filters and belt. It still does not pick up well when I vacuum or use the hose. Can you help ?


There is something stopping it up,you will have to dissasemble the unit to find the blockage,this is the most likely problem. ... Hoover U6660-900 WindTunnel Bagless Upright Vacuum

Question mark light has come on my vacuum and it wont run. I replaced the bag, but it wont start. I don't have a new filter is that the problem?


... Electrolux Vacuums

I was given a Kenmore progressive hepa filter 22313 Bagged Canister Vacuum recently, but don't have the manual. We used it once to vacuum the house and it worked beautifully. Then we used it 5-6 days later and it started whining and getting hot. What year was this vacuum manufactured? Where can I download an owners manual?? Help!


Http://www.managemylife.com/mmh/owner_manuals/5461/KENMORE-Vacuum-Canister-L0809572 ... Kenmore 22313 Bagged Canister Vacuum

My Miele White Star Model # S3141 was running fine, then stopped mid-vacuuming. I changed the bag and cleaned the filters (which were dirty), let it cool off, and tried to start it up again, but no luck. What do I do now? Are there any repair places in Ft. Myers, FL?? Thank you for your help.


... Miele Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0896 seconds