Having problems with your Electrolux Epic 6500 Vacuum ?

The question mark light on the canister of my Electrolux Epic 6500 series has come on and the vacum will not power one. This has never occurred before. It seems to be somethng with the bag but we checked that.


Answers :

This indicates that the bag is full, but may be caused by other problems. If you have fine dust in your area, the bag may seem like it's not full, but the pores in the bag are clogged so the vacuum will shut off as if the bag is full. This can be partially solved by setting the dial on top to the smallest dot.
\015\012The problem could also be caused by a dirty afterfilter. This filter is located beneath the tool caddy on the back of the machine. Access is gained by pressing the tab on the back of the machine and lifting the caddy. If dirty, replace it. If you don't have a replacement, check to see if the vacuum will run without it. It should if there is not other problem causing the vacuum to not run.
\015\012Third, try detaching the hose, turn the machine on to see if it runs. If it does, place your hand over the in port. If the vacuum shuts off, the problem is most likely a broken, worn, or clogged Control Valve Assembly. This is the part the dial connects to. This is a problem that should only be repaired by an authorized Aerus Electrolux service tech. If you have been using generic "Made to fit Electrolux" bags, the motor and interior of the machine should be cleaned. This is worth doing as there should be a long "life" ahead for the vacuum. Periodic maintenance should be done.
\015\012You can find the nearest store using the below link.
\015\012It could also be caused by loose connections, worn or broken switch/es, broken wires, or bad motor. This can be narrowed down at the shop.
\015\012
\015\012http://www.aerushome.com/storelocator/
Repair Help & Product Troubleshooting for Electrolux Epic 6500 Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

The question mark light on the canister of my Electrolux Epic 6500 series has come on and the vacum will not power one. This has never occurred before. It seems to be somethng with the bag but we checked that.


This indicates that the bag is full, but may be caused by other problems. If you have fine dust in your area, the bag may seem like it's not full, but the pores in the bag are clogged so the vacuum will shut off as if the bag is full. This can be p ... Electrolux Epic 6500 Vacuum

I have the Miele S7280...the one without the clog hatch on the back. I took the bag cover off, then continued the remove the screws and cover underneath it to detatch the top from the bottom. Found the clog and cleaned it out. Heres the problem...now the power nozzle light comes on and the vacuum "on" is lite up red, but it will not come on. Checked the filters and the bag. It certaintly seems like the top and bottom are meeting up to latch into each other, but I have no power. Help!!


... Miele S7210 Bagged Upright Vacuum

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?


Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Windtunnel first one used 6 times beater bar stopped working, took apart cleaned and belt was fine. this one had a reset switch for beater bar. had insurance at best buy so returned for a new one. used 2x beater bar not working and not dirty, no reset switch on this one., now back to the store for another? i don't even want the same one. I wonder how many they are gonna give me. This seems to be a common occurance.


Sorry, you feel like that. I have rentals and 6 windtunnel's (I prefer the bagged ones) and have never had a problem such as you have described. I think Hoover makes a great vacuum. ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

Dirt smell I seem to have a smell of dust when I vac. I have changed the bag and checked all areas where dirt collects and nothing is plugged. Seems to be puffing out from bottom and behind the unit


Orecks do have a lot of leaks in the airdut system of their machines. Most likely the smell however, is coming from the outer bag itself. That get so coated with fine dust that eventually it will start to smell like dust. Only by replacing the out ... Oreck XL Ultra Bagged Upright Vacuum

I have a Panasonic MC-E3011 and it won't ****. I have checked all the pipes from the beater to the inlet at the dust bag, and they are both clear, pluss the air comming out of the vent at the bottom of the upright (above the beater) casing seems abnormally hot. I have allso checked the the belt and beater bar and they are functioning A1 OK.


... Panasonic MC-V7395 Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

How to disassemble the brush to empty anything that might be stuck inside of the brush? The motor seems to be overheating, all belts have been checked, all airways are clear and the filter is clean. The vacuum is vibrating and releasing a burning smell, but still sucking up dirt. There is nothing stuck on the outside of the brush, but is there a way to check inside of it to see if that is where a clog is occuring?


If there's a burning smell and the belts are fine, the problem is going to be hot wires causing the insulation to melt, or the motor going bad. Discontinue use and have it checked at a repair shop. ... Bissell 6594 PowerForce Bagless Upright Vacuum

Just replace both belts cause the skinny one seem too big. the new one is the same so the roller woun't go around. Its a Hover windtunnal with bag


... Vacuums

Not sucking i have a KIRBY G3 that was working great. One day there was a strong smell and the brush roller belt broke so I replaced it. The fan looks good. Now the vacuum does not **** up dirt but instead seems to very gently blow air forward. I took the (new) bag off and it is blowing hard int the bag. I am stumped!


Belt is not connect to the drive pulley, see manual for fitting or see utube for video ... Kirby Generation 3 Bagged Upright Vacuum

No suction I just replaced the bag, and normally after this I have a lot of suction. Now that I have changed the bag I have less suction that I had before. Not even enough to picj up dog hair. I snaked he hose and checked all of the connections. It seems to have an air leak but no amount of tape will fix this. I cleaned the filer as well with warm water and dried it and re installed but still absolutely no suction. I am ready to throw it out! Any suggestions would be appreciated


1, Does the blower (discharge) side blow bunches of air??Yes: Something is clogged from the bag to the hose end. Try blowing out the hose from the discharge side.Or: The bag is not properly seated. Make sure that the plastic piece is ... Kenmore 23313 Whispertone Bagged Canister Vacuum

Hi. I purchased a Simplicity Freedom about 2 years ago. I have had it in for various repairs several times. One persistant problem that the repairman cannot seem to fix is the dirt does not fall down into the bag - it just stays up around the suction hole. I only use simplicity bags. Any suggestions would be most appreciated. thank you


You can let the vacuum run alittle longer so the bag fills up with air, also make sure that the bag in on correctly and you have the right bag for the unit. Let me know if this helps. ... Simplicity Vacuums

Need Kirby Generation 3 Vacuum cleaner manual. Vacuum is not picking up dirt from floor. Seems to have enough suction to inflate the bag, but when you check the suction under the vacuum, there seems to be extremely litle suction.


If your brush roll is turning and your bag is not overly full, then the only other thing it can be is a clog where the bag connects to the vacuum. Turn the plastic part out away from vacuum and lift off to see if you have something clogging it. It ... Kirby Generation 3 Bagged Upright Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

My kenmore intuition vacuum seems to have lost suction and the check bag light comes on. the bag has just been changed (2x). cannot see if there is any type of blockage. any ideas? thanks. ps. only had this vacuum for 3 months.


If you bought it new then do not screw w it take it back to sears and demand a replacement or your money back Sears is very reasonable re this ... Vacuums

Brushes stopped The brushes stopped turning while using the cleaner. I removed the brushes to see if the spindle was broken, it wasn't. I then removed the top plastic cover and checked the switch that engages the brushes; it didn't seem to be moving correctly. There's one spring on the switch - should there be two? Or do you think something has broken on the inside? Thanks for any help


Most likely the turbine is bad, it may just be clogged up, you can take it apart and clean it out real good. That may work, but it may not. Sometimes it is best to replace the turbine. ... Hoover F7431-900 SteamVac Vacuum

Blowing out? I have checked all hoses for clogs, I have even taken it all apart, but it seems to be blowing out? The bag inside the canister is sucked in? Can the motor reverse on itself, I'm baffled!!


Did you check the inlet down by the brush roll? ... Bissell 3522 PowerForce Bagged Upright Vacuum

ORECK VACCUM older oreck xl, new belt , new bag, checked for clogs, does not pick up as it used to, and, much harder to push, seems to grab or drag, why????


Http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=747767\015\012Generic problem for all Vacuums\015\012ORECK VACCUM\015\012Posted by FISHERMAN928 on Jul ... Vacuums

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u


Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

It leaves dirt and fluff in the rollers not in the filter. So is not cleaning properly. There is never anf fluff at all in the filter. Also the lid does not close properly and we constantly get the 'check tank' light coming on. It leaves streaky marks across the floor and seems to leave the floor too wet (hence the streaks). Look forward to hearing from you.


Is there something stuck in the air passage between the tank and inlet ... iRobot 5800 Scooba Vacuum

Cleaner stopped working, changed bag still not working. Have checked mains fuse and liittle fuse on printed circuit board. When cleaner is on moving slider to the off positon the LED's glow red for a fraction of a second. Reset button does not feel as though it clicks when pressed, it does not seem to move. Many thanks, Hugh


... Panasonic MC-E583 Bagged Upright Vacuum

Stopped working Was working fine then it smelled like burning rubber, not the belt I checked. It sounds like the motor wants to run then it just stopped but the light is on. What do you think, go by a new one?? This has been a great vacuum cleaner and I can not seem to find a Sharp anywere. Thanks for your time.


Well it could be the motor, if it is it would cost around $80 or so for a motor. May be better to buy new, thre are a number of good brands out there. ... Sharp Twin Energy EC-12TWT4 Bagged Upright Vacuum

The brush roller stops turning and I can smell the belt burning, then it will catch and start working normal. I looked under the plate to check the belts and they looked okay and no hang ups of string or anything. The only thing that seemed weird was that the smaller belt that actually attaches and turns the roller is a bit loose. The larger belt is tight but looks like its the one that is burning and causing the smell.


Better to replace both belts the smaller one is stretched out thats whyits slipping ,be sure to clean the old rubber off the motor shaft before replacing the belts.it will cause the new belts to run unevevly and go bad before their time ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Seems to have proper suction but dirt is not reaching the bag? I have checked all the hoses and there is no blockage.


There may be a blockage on the inside of the vac. I have had this happen to me a couple of times. The first thing I try to do is to make sure the beater brush is turning. If it isn't turning the dirt will not go into the bag. The other thing to do is ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0781 seconds