Having problems with your Electrolux Epic 6500 Vacuum ?

We have an Epic6500. when we plug it in the machine works without the hose. We even purchased a new hose thinking there was a problem with the hose. However as soon as we put the hose on the machine the machine does not work. What do you think the problem may be?


Answers :

Wow, this is a good one. I wonder if anyone has wrked on this machine before. Do you remember what happened when it stopped working / Obviously there is a foul up in the wiring. I need more info. When the machine is on does it shut off as soon as the hose is plugged in? All I can figure with the info. I have is the hose is plugged which overloads the machine overheating it and the heat sensor shuts it down. But, if bought a new hose that cant be can it? Check the hose anyway for clogs. Blow in the hose with your mouth and se if the air goes through easily. Also, check the back side if the machine to see if the motor is hot. Please, let me know what you find, this is weird. After fixing Electrolux for almost 25 years I have never come across this. Chris email me [email protected]
Repair Help & Product Troubleshooting for Electrolux Epic 6500 Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

We have an Epic6500. when we plug it in the machine works without the hose. We even purchased a new hose thinking there was a problem with the hose. However as soon as we put the hose on the machine the machine does not work. What do you think the problem may be?


Wow, this is a good one. I wonder if anyone has wrked on this machine before. Do you remember what happened when it stopped working / Obviously there is a foul up in the wiring. I need more info. When the machine is on does it shut off as soon as the ... Electrolux Epic 6500 Vacuum

Hi. I have Dyson dc08 hepq+. Thet problem is its not having suction .I checked inside the pipe and foot , ery thing is fine. And if i take the whole dirtbin out ...machine workes fine. when i put ery thing back ....as soon as i start it , after 2 second machine change its voice...and loos suction. I think its just happen because ...the saftey yellow valve inside the machine turns up because the dirt drum is blocked inside some where. Any suggstion ...what can i do with it. I m tahnkful in avance


Hi its Darran at Dyson.From your description of the problem, it sounds as though the bin inner is missing. To confirm this, if you remove the cyclone and bin from the machine, then separate the 2 pieces as if you were going to empty it, w ... Dyson DC08 Hepa Allergy Bagless Canister Cyclonic Vacuum

Hi I’ve got a Panasonic vacuum cleaner MC E468 1600W a few years old now but works well up to recent problem. Not picking up I checked the obvious things and found excessive air being sucked in around the hose housing at the back of the vacuum (as it enters the waste bag) On inspection it appears to me as if there should be some sort of gasket that may have perished and been sucked in, however I can’t identify any such part. Any thoughts on what the problem/solution may be will be appreciate


The hose on the back might be loose - check to see that the hose is not obstructing anything where it screws in at the back - or indeed the screws may be loose themselves; some of the MCE 468 models had an additional ring washer that sits between the ... Panasonic Vacuums

My Windsor Sensor XP12 says the bag is full when it's not. I have removed the hose, brush, and filter and cleaned everything. I can put a bag on without the cover and it works great. However, when I add the bag to the front cover and close the latch the right way, it does not work. I'm thinking that the cover is not seating the bag correctly over the hole, but I can't figure out how to fix it. Any suggestions?


... Windsor SR12 Sensor Bagged Upright Vacuum

I also have a Hoover upright and I need to replace the electrical cord. I have dimantled the back, where the tools are stored, and the hose. I still cannot find the screws or whatever, to get to the area behind the cord, so I can replace it. I think I will have to take off the bottom too. Has anyone out there tried to do this? It seems crazy. This machine works great so I hope I can also put it back together. Thanks for the help.


Since I do not know your specific model I can only supply you with general instructions. Be aware that most of the time you only need to gain access to the on/off switch to replace the power cord. Also Make sure that you are replacing the existing co ... Vacuums

Bissell 8910e Aromapro. Jams when being pushed along floor. I think brushes drop down and cause problem. However brushes turn when machine is laid flat. Motor works. Doe it need new belt ?


Check your depth adjustment on your brushes ... Bissell Vacuums

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?


Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Little green machine pro heat pet the collection tank wasn't collection and dirty water was coming out of the bottom. i took it apart, cleaned it up and put a new "duckbill" gasket in. then it quit spraying, but i think i got that working again. now after i spray and get a good foam on the carpet, i switch to suction and it seems very weak. i can see the water moving (trickling) from the head into the hose but it is not reaching the collection tank -- actually, i am not sure where its goin


... Bissell THE BISSELL LITTLE GREEN MACHINE Vacuum

Currently my dyson does not work when in the upright position. When I pull the handle back, it will run, but the suction is not very good at all. I tried washing the filter, but that didn't work. Sometimes it works for awhile, but then the problem occurs after the machine has been used for awhile. What do you think the problem is?


Hi its Darran at Dyson.It sounds as though the brush bar may not be turning properly when you put the machine into the upright position. To test, lie the machine on its side in the vacuuming position (head released) then switch it on and ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

My Ultralux 2000 vacuum power head does not work on my machine but does work on a different machine. What are the possilbe problems? I tried replacing the hose with a new one and that didn't help.


It's probably due to bad wiring connections between the wands, hose and wand, or power nozzle and wand. If it came with the Sidekick, try using it on the end of the hose. If not, simply try using the power nozzle on the end of the hose (no wands). ... Electrolux Eureka Easy Clean 2 in 1 Stick and Handheld Vacuum Model 108A 1 ea

The problem is that the cleaner is heavy to use and does not pull itself forward as it should. It has been back to the supplier 3 times but they have not fixed the problem. The LED's on the front flicker and I think it may be a problem with the sensor. If you have any info. on how the sensor works and where it is located it would be useful as well as any other suggestions to fix the problem please.


If it heavy then do some muscle work and body building ... Vacuums

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after


... Vacuums

Scunci steamcanister model 52038 Steam does not get from canister through hose to nozzle. No apparent leaks - hose does not get warm. appears may be valve problem from canister to hose. Only used bottled water - barely used this machine.


... Scunci Vacuums

MY WIFE BOUGHT THIS FOR ME FOR FATHERS DAY GIFT ABOUT ALMOST 2 YEARS NOW OR SO,BUT I HAVE THIS PROBLEM THAT THE BRUSH DOS'NT SPIN ANYMORE EVERYTIME I PUT THE SWITCH ON FOR BRUSH ON,THE HOSES BRUSH SPIN IS WORKING BUT FOR THE FLOOR CARPET BRUSH SPIN IS NOT WORKING,AND THIS IS THE MODEL NUMBER OF MY HOOVER VACUUM CARPET SHAMPOO CLEANER IT'S F7411-900


This unit uses a turbine assy to turn the brushes. The brushes could have something jamming them. Remove the brush unit, it is held on 2 spring hooks 1 on each side. The brush unit is driven thru a 1/4" square post, only one brush is driven and it dr ... Hoover SteamVac Carpet/Upholstery Deep Cleaner Vacuum

I have a dirt devil ultra vision turbo, it lost suction. took it apart blew it out with the air hose, I think we put the bottom plate on wrong but can't figure out how it goes, it is blowing dirt out but the suction hose works.


... Dirt Devil Vision Turbo W/Bonus Upright Vacuum Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.


Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?


... Kenmore 34722 Grab-N-Go Upright Vacuum

Shampoo-er This seems to be a common problem, the shampooer is putting out alot of water and hardly any suds. I read through the posts about the little filter that sometimes gets out of place and I think I found it in the box - is it about 1" diameter hard plastic ring around very fine mesh? If so where exactly does it go? Some posts say in the hose, and others say in the opening of the tank. Or does it go in the place where the hose attaches to the tray? I also found a round sponge in the box o


It goes on the small hole on the tank where the hose attaches to it. The sponge goes in the hole directly under the on/off valve. Here is a link to my online shampooer instructions.\015\012 \015\012 ... Kirby Ultimate G Bagged Upright Vacuum

My machine (Hoover Wind Tunnel - bagless) is only 1 yr. old. The agitator brush doesn't turn all the time. I know it's not supposed to turn when in the upright position. However, it only seems to work when I have the setting on high. When I stop, but have not put the machine in the upright position, it stops again and then slowly starts moving. Could the V-belt be worn out already? In the owner's manual it states that this belt is not normally replaced. The exact same thing happened with my old


Sounds like you should do two things:\015\0121- Remove and clean the beater brush of all debris as best you can. At the end of the brush you will see a hard rubber piece, at both ends, that holds it in place in the body of the vacuum.\015\012Add som ... Hoover Self-Propelled WindTunnel Bagless Upright VacuumVacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

Hi monarch 650 duct cleaner when we connect the hose to the point the machine start and when we take off still the machine working what is the problem Tommy


... Vacuums

No water I have a Bissell 1694 and it is not ejecting the water cleaner solution out of the front of the machine. The belts are ok. The two nozzels and hoses are not clogged and do not have any holes. I think the pump still works because water still comes out of the brush tool.


It is easy to take the top off. Mine has just 6 screws. Then you can see all the tubing and parts. For example, you can unclip the nozzles and see if water flows. Try blowing through the nozzle to see if it is plugged.\015\012\015\012Some people s ... Bissell Powersteamer 1694 Upright Vacuum

Oreck xl doesn't pick up dirt but rather blows air out. Brush is clean but the belt and brush should be replaced however I am reluctant to put money toward vacuum if it's a broken machine. I think it's about 10 yrs old. I got it from a family member.


... Oreck XL Ultra Bagged Upright Vacuum

Our Miele vacuum is only 2/3 years old and seems to have given up the gost, our previous one lasted 15 yrs. The machine starts ok and within 4/5 minutes the power drops down and the hoover comes to a stop and it may re-power itself again within minutes, as of today their is no power when the on button is pressed. What do you think the problem is Thank you.


There is a circut board that is going bad and not providing the power to run the motor. You will need to contact a Miele dealer for that part. It is the only board that is in this machine so they should just need a model number in order to get it ... Oreck XL Ultra Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0922 seconds