Having problems with your Electrolux Epic 6500 Vacuum ?

Warning Light What does the light mean on the canister that has two prongs on one end and one on the other. The vacuum works fine but the light is on. I changed the bag and filter.


Answers :

Check the hose and wands for a clog. Usually that light means a full bag, but a clog or restriction will also cause it to come on.
Repair Help & Product Troubleshooting for Electrolux Epic 6500 Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Warning Light What does the light mean on the canister that has two prongs on one end and one on the other. The vacuum works fine but the light is on. I changed the bag and filter.


Check the hose and wands for a clog. Usually that light means a full bag, but a clog or restriction will also cause it to come on. ... Electrolux Epic 6500 Vacuum

I was vacuuming and noticed that the bag needed changing. the red light with the ! inside the triangle also came on. When the bag was changed, the vacuum would not restart. The red light came on. Tried the reset button but nothing happened. Tried unplugging and re-plugging in and nothing happened. Replaced all the filters and still it wouldh't start. So I brought it downstairs and tried one more time to get it to start. it worked! Is there something wrong with the vacuum cleaner? Was it overheat


It was overheated that is why it worked downstairs after cooling off. ... Miele S548 Bagged Canister Vacuum

We have two of these vacuums and both of them have experienced the same problems. First the floor heighth adjustment doesn't work and now neither one will pick up on either carpet or floor when in the brush/floor mode. They both seem to work with the suction hose function. We have removed the back panel to see if there was an obstruction but it was clear. We have changed the bag and the small filter (not the HEPA filter) all to no avail. What else can we do? We are desperate to use our vacu


Did you check the powerhead for obstructions? With a bend in the tube just below where the hose connects, this is a common spot for clogs. To check, detach hose and drop a coin in the hole. If it doesn't drop through, a blockage is present. Use t ... Electrolux Oxygen 3 Upright Vacuum Cleaner - EL5035 Vacuum

Won't start. My son was using the vacuum & Didn't change the bag. The vacuum was making the full bag smell, but the light was't on & it didn't stop. I stopped him, changed the bag, checked the filter, closed the compartments & turned on the vacuum. Nothing happened. I checked to be sure that it was plugged in, that wasn't the problem. I've let the vacuum "rest" for several days, It still won't start. Any suggestions?


There is a reset button at the back of the powerhead. The user manual can be downloaded from the electrolux website, although I didn't find it very useful. There was some info on how to change the powerhead drive belt. ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

My electrolux epic series 6000 sr vacuum is not working. I was vacuuming when it shut off and the bag light came on. After changing the bag I tried turning it on and the question mark light comes on instead of the vacuum. What does this mean? How can I fix this?


... Vacuums

I have a Z345 Electrolux cylinder vacuum cleaner, from the 1970s probably, but not used much. I have lost the guide. I forgot to change the bag before it was full. Smoke started to come out - smelling of burnt paper, not rubber. So switched off. It did not blow the fuse, and may be OK. I wish to inspect it. How do I open it up? Alos I have an air filter and a motor filter for it. I have often changed the air filter on the top. How do I get at the motor filter, if there is one? Than


Good day! OK you have to is replaced the bag and that's it.And don't forget to change the bag again to avoid that problem.Thank you ... Electrolux Guardian Bagged Canister Vacuum

Electrolux oxy 3 vaccum has stppoed working and all three blue lights flashing My electrolux oxy 3 ZO6330 stopped working suddenly and all lights are flashing. I've changed the bag and filter and its still not working. Any ideas??


... Electrolux Vacuums

We have a Kenmore Progressive Model 116 Upright bagged vacuum with Hepa filter. It's at least a couple years old. For quite some time now when ever we use the vacuum the vacuum motor will shut off nafter about 5 min. of use. We then need to let it sit for awhile and then we can run it again for another 5 min. The bag has been change. Any one have any ideas how to fix this?


I suspect that you have a restriction. The motor sounds like the thermal break is stopping the motor before damage, due to heat.\012You must witness that the entire suction and discharge side are clear. This is not always very easy, but necessa ... Kenmore 34612 Bagged Upright Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos


It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

Oreck XL21 just will not work at all any more. Beater is clean - belt is fine. Fresh bag - inflates. Took the thing apart - checked for blockages at intake, bag entry, and the tube. It just doesn't vacuum anything. No suction at all for anything stronger than air. I'd say it doesn't ****, but that would be ironic. Are these known for just "quitting" after a while? We take it in for maintenance as recommended to replace filters, etc. Is there some miracle trick to make it work or sho


Did you make sure the brush turns freely? Even though it is clean, if it does not turn freely with the belt, it will not beat the carpet and pull debris up into the unit.\015\012\015\012Another (drastic?) thing to try would be to take the unit ... Vacuums

Kenmore 21875 One day it's working fine. Next day, it won't turn on. When I attach the hose to another vacuum cleaner, it runs. Is there a reset button on the canister? Could it be the receptacle is bad? My Kenmore Progressive won't turn on today either -but was fine last week. I cleaned the filters checked for blocked air, tried a different outlet and no luck. I'll check the pins on the connections and see if one of them is not matching up or appears worn.


Give the prongs a wiggle and see if there is any play in them.Might just be a plug end. ... Kenmore 25512/ 25513 Progressive Canister Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

I was just using my Bosch 1450W bagged vacuum and all of a sudden, the motor just shut down. No warning, no problems. The light still turns on, but the motor is unresponsive. There is a clean bag and filter, and nothing caught in the front roller. The motor sounded fine - no shaking, or weird frequency variations. There were no weird smells, just a little bit of heat, but nothing beyond normal. I've had this thing for several years, and never had a bit of trouble with it. Any suggestions


Many vacuums have internal thermal switches that need to cool to allow the vac to operate. After 30 minutes, check all 3 air filters and try again.\012Gary ... Bosch BSG71310UC Bagged Canister Vacuum

I have a Eureka Contour model 2900 type A upright vacuum, the roller works fine nothing clogged, took it apart motor blade is free of debris, no suction from tube and blasts OUT air from the front HEPA filter location. New bag, New belt, nothing in hose.any clues as to why this can be happenning? Air should not be blasting out of the HEPA filter.


Even with your explanation,it seems the hose is clogged.Try taking the hose off,then blow through it or pour water through it.If this doesn't do it,make sure the suction canals are going to the proper areas. ... Eureka 2900A / 2901A Contour Bagged Upright Vacuum

I have the Miele S7280...the one without the clog hatch on the back. I took the bag cover off, then continued the remove the screws and cover underneath it to detatch the top from the bottom. Found the clog and cleaned it out. Heres the problem...now the power nozzle light comes on and the vacuum "on" is lite up red, but it will not come on. Checked the filters and the bag. It certaintly seems like the top and bottom are meeting up to latch into each other, but I have no power. Help!!


... Miele S7210 Bagged Upright Vacuum

I have the Riccar Starbright canister vacuum. I have replaced the bag and filter, however it will not work. All of the indicator lights are on and should be vacuuming, but nothing. This has


... Riccar 3623210300 RC 1700, 1800 Full Size Canister Electric Suction Hose

My kenmore vacuum 35922502 sensor dirt lights stay on red all the time. I have changed the bag, filter, little sponge filter, still they stay on. What is wrong? Lynn [email protected]


... Kenmore 31912 Progressive Direct Drive Bagged Upright Vacuum

Stopped working Was working fine then it smelled like burning rubber, not the belt I checked. It sounds like the motor wants to run then it just stopped but the light is on. What do you think, go by a new one?? This has been a great vacuum cleaner and I can not seem to find a Sharp anywere. Thanks for your time.


Well it could be the motor, if it is it would cost around $80 or so for a motor. May be better to buy new, thre are a number of good brands out there. ... Sharp Twin Energy EC-12TWT4 Bagged Upright Vacuum

My dirt finder light is not working My dirt finder red light never goes off. Have changed the bag, cleaned all filters.


Take the bag out and the filter,put the coveer back on and start it up.see what the light says.if there is a clog somewhere and air is not getting into the bag it will read full.if that workd then put the filter back in and start it up.when the bag i ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u


Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

Motor quit working. i was vacuuming and all seemed fine. then the motor went really low. when I opened it I noticed that the bag was not attached and the cannister had filled up with stuff and the filter was full. the vacuum will not run now.


My friend, the dirt you sucked up went right into the motor and it burned up. I am very sorry to tell you this. It is probably not worth repairing unless you are able to replace it yourself.\015\012\015\012In addition to not being able ... Kenmore 31912 Progressive Direct Drive Bagged Upright Vacuum

My electrolux oxygen cannister has the "bag change" light on when there is a new bag. The light stays on when the suction power is high (to pick up small particles) and it won't pick up, but the ight goes off when the suction power is low (to pick up big objects). I changed the hepa filter, cleaned the motor filter and changed bags, but all that didn't help.


You may have a clog in the hose, and/or the inlet by the brush roll. A clog will turn on that light as well as a full bag. ... Vacuums

Unbeknownst to me, someone took the bag out of my Kenmore Progressive vacuum and failed to replace it. I have been vacuuming without a bag for months, and today the vacuum stopped sucking. When I opened up the front to replace the bag, tons of dirt and dust came pouring out. I thoroughly cleaned the vacuum, put in a new bag, but still no sucking power. Just dust coming from the rear vents where one of the filters is. Is the vacuum ruined, or is it a simple solution of buying a new filter?


Sounds like you need to buy a new motor. All that grit and dust will ruin a motor and I'm surprised it lasted as long as it did.\015\012This is where a vacuum that won't run without a bag would have been nice. (Aerus for one) ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

Confusion and embarrasement have caused me to appeal for expert advice. I need to add a second flourescent light fitting in the loft. I recently added one from the existing wiring circuit via junction box and pull chord switch and it works fine. I have wired in the second light and now neither of them work. I have replaced the starter (as I had a faulty one in the first light. But i annot get them to work. I have installed a second junction box for the second light and wired all like terminals


... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1514 seconds