Having problems with your Electrolux Epic 6500 Vacuum ?

Won't start orange canister type,has change ba light hepa &motor filter,and power hose and beaterhead,put new filters in checkedthe hose,made sure it wasnt clogged

Answers :

Take an AC VOLT Meter and place the leads of the meter where the power cord terminates,one on the white lead and one on the black. There should be 110-120 volts AC. If that is good then move one of your meter leads to the other side of the on switch. With the on switch ON there should be 110-120 volts AC.If that is good, you may want to connect the motor directly to wall current to ensure that it is good. BE VERY CAREFULL IF YOU DO THIS!!!!!!!!!!!!!!!!!!! Before you do anything be sure to make sure that there is not a breaker or reset button somewhere on the machine that has been overlooked.
Repair Help & Product Troubleshooting for Electrolux Epic 6500 Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Won't start orange canister type,has change ba light hepa &motor filter,and power hose and beaterhead,put new filters in checkedthe hose,made sure it wasnt clogged

Take an AC VOLT Meter and place the leads of the meter where the power cord terminates,one on the white lead and one on the black. There should be 110-120 volts AC. If that is good then move one of your meter leads to the other side of the on switch ... Electrolux Epic 6500 Vacuum

Have an electrolux 2100 canister vac, it has lost suction power thru the years. no clogs in newer hose or in sweeper. even with new bag, filter and belt only increases power minimally.

Have you ever over the years replaced your brushroll ? Have you tried dropping a coin thru the hose from one end to see if it comes out the other end ? Have you taken the wand loose from the elbow ( the swivel part of your carpet sweeper) to see if t ... Electrolux Vacuums

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u

Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

My dirt devil quick lite has lost it's suction power. I have checked all the hoses etc for clogs or debris.I bought it in Dec 2010. I think maybe it needs a new filter. Where can I find an F44 filter or do you have any other solutions?

... Dirt Devil Easy Lite Quick Vacuum

Hello, I have a Eureka 71b handheld vacuum. There is literally no suction. I checked the hose and it is NOT clogged. I thought it might be the filter so I bought a new filter. Still no filter. The rot

... Eureka Vacuums

No Suction I get great suction in the hose, but when I plug the hose back into the unit, there is no suction and the air flow indicator line goes completely red. I've changed the bag and filters. I took the small panel off the back and made sure there is no clog, and took the hose off to make sure there was no clog there. Still no suction. Please help.

I about to say that's always a clog of some sort that causes that ... Miele S7210 Bagged Upright Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.

Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

No suction I have new belts. Everything is clean. No clogs. When I turn it on it smells like rubber , the brush doesnt spin. Everything seems to be free flowing.. Roller brush isnt stuck on the ends. Took off hose to make sure no clogs anywhere. There is not even suction thru the hose with the handle in upright position.

Generally, the problem is that the belt is not running the brushes.  This is caused by one of the following:\015\012\015\012\015\012beater brush is jammed.  This is either an object stuck in the brush or im ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.

Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

Dyson DC17 hose collapses when I try and use the pull out wand and attachments. Cannot see anything in the hose blocking the suction, filter is clean. . . help? Not sure how to find the clog and fix it. Thanks

Click the link below for full instructionshttp://www.youtube.com/watch?v=kWFn6dF1ah8 ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

Hoover ultra upright. No suction. It has new bag, new filter, hose is not clogged. What can cause it?

... Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum

Picks up some of the dirt but does not send it to the canister it just stays in the base and clogs up the bottom hose. There is no suction on the detachable hand hose. Have cleaned out all filters and the belt is new. Cannot figure out the problem!

Have you checked all of hose,detatchable and fixed if it has any,for holes,kinks and blockages sounds like a lack of suction ... Vacuums

The vacuum i've had for 6 months has very liittle suction power. checked that the belt is on. cleaned filter. checked to see if hoses were clogged. I used a super vac to suction any debris out of vacuum. still little suction power

As this unit has 3 filters on it, a lot of people forget about the one filter that will cause all of your trouble here. \012\012There is the exhaust hepa filter, no problem, your unit is pretty new, it shouldn't be a problem. \012Th ... Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

My vax power 8, 2200 watts 300 air watts 4L capacity upright Hoover is brand new, I emptied out the dust/dirt collecter and cleaned the motor filter yesterday for the first time, i switched it on and all fine, the brush is spinning and the hose is sucking, put the Hoover to work it's fine for about 30 seconds then then suction stops and its dead it won't collect no more, so switched off taken apart again and the motor filter is blocked and full of dust, so I unblocked it, do the same process aga

I had the same problem. It looks like the seal on the lid on the bottom of the cylinder has fallen out when it was emptied. There is no longer a proper vacuum being created so you don't get the cyclone effect and the dirt doesn't collect where its su ... Vacuums

Clogged sweeper filters changed and hose cleaned, but no dirt collecting in the bag. I am no sure what do do next

You have a rubber flap in the dust collection bin that may have been pulled out causing the collection bin to close when vacuum tries to pass through. Try pushing the flap back in to see if that's the cause of your vacuum loss. To test if this is the ... Eureka 5849A Boss Bagless Upright Cyclonic Vacuum

I have a Dyson all-floor model (not the ball). I recently replaced my carpet to a Frieze. Since replacing the carpet, the Dyson is extremely hard to push. It almost forms a "seal" with the carpet. Seems to work fine on Berber carpet and laminate floor. My husband has checked to make sure the brushes are working, hoses are not clogged and belts are OK. I've had it for about a year. It is virutally impossible to push on the new carpet. Any ideas?

Have you adjusted the brush control system. If you look at the link below page 6 will tell you how to adjust. If this is not you vacuum please give the model # of the one you have so I can help you more.\015\012\015\012 ... Dyson DC14 All floors Bagless Upright Cyclonic Vacuum

I have an Oreck XL Hand Vac Model #BB870-AW Type 2 Serial #SN870AWP3Z101356-Z which was used to **** up a large amount of fresh coffee grounds (not used). The vac will not turn on. What can I do? Hose not clogged; put in a new bag. Can't find my manual. Is there a filter or reset button?

... Oreck Vacuums

I have two older Filter Queen (brown vacuum cleaners). Besides unclogging the hose area and making sure it is not filled with dirt, what else would cause the machine to run hot and have a high pitched sound? Is there another area where I might have clogs?

There is a secondary filter under the paper cone that gets filled with fine dust. It can choke off the airflow. The noise motor sounds like a bearing going dry. That should be replaced ... Filter Queen Majestic Canister Vacuum

Vacuum Problem My dirt devil vacuum is losing suction and keeps clogging. All the dirt keeps sticking to the screen by the filter and then it would stop working. Also the hose does not have a strong suction power either. So what can I do?

The Bissell can have several filters in it, depending on the model. Some have a round hepa filter that is covered with a foam sleeve. This filter is located at the bottom of the dirt cup. Others have a foam filter that is located under the dirt cup i ... Dirt Devil Vision Turbo W/Bonus Upright Vacuum Vacuum

NO POWER My Dyson DCO4 Absolute (purple&lime) won't' switch on. I've checked the plug fuse, wall socket and also filters and hoses on machine all seem fine so think the problem is with the on/off button (maybe loose wire or something) but how do i get to it, is there a special way to remove the green on/off button in order to check the connection? Thankyou in advance for the help i am sure you will be able to provide.

The problem is almost certainly a fatigue break in the flex. These usually happen where the flex enters the handle through the rubber sleeve near the on off switch. You will need to cut about four inches off the wire and reconnect it to the switch. ... Vacuums

We have a Russell hobbs power cyclonic pets 2000w vacum cleaner that seems to have lost quite a bit of suction, we have cleaned the filter and made sure there are no obstructions in the hose. We have only had the item for 2 months so would like some help with the problem. Regards Mrs D.Cook

... Vacuums

Vacuum My vacuum is loosing it's suction power. I've checked the belt and it's in perfect shape...I've bought a new filter cup...I've checked for clogs and there aren't any...I've cleaned the entire machine...and I still can't find the source of the problem.

You checked the belt, but I bet it has stretched and won't drive the brush roll under load like it should. Belts only last a few months the stretch and should be replaced. Iff you have suction at the hose, then it has to be down below, either belt/ ... Eureka Whirlwind 4480 Upright Vacuum

Bissell 37604 Bagless Upright Vacuum. Hose keeps clogging every time I vacuum. Is there a way to prevent this? I am ready to buy a new vacuum, but it does do a great job picking up hair...until it clogs. It clogs at top of hose. Could the hose be kinked? It does not look like it.

That is a defect in the design of that style of vacuum. I went back to my old vac because I got so tired of having to unstop it. The sharp turns in the hose and the molded plastic causes it. Find one without the turns. ... Bissell 37604 Lift-Off Pet Bagless Upright / Canister Vacuum CleanerVacuum

The hose is disconnected, new bag in unit, new filter, unit runs when hose is detached but immediately turns off when hose is attached but hose has no obstruction, etc.. i was told i need some sort of valve. HELP! I have birds, a cat and 2 large dogs and no vacuum :)

There is a vacuum hose that attaches inside the unit to a round clear plactic piece. In most cases you can simply cut the small vacuum hose and it will fix the problem. ... Electrolux Epic 3500 Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!

... Miele Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1110 seconds