Having problems with your Electrolux Guardian Bagged Canister Vacuum ?

RENAISSANCE HOSE/VAC I HAVE A RENAISSANCE VAC WON'T RUN,POWER IDICATOR LIGHT ON THE HOSE HANDLE IS FLASHING ALSO JUST BEFORE IT QUIT THE BAG INDICATOR ON THE HOSE HANDLE WAS ON.


Answers :

THE RENAISSANCE IS KNOWN FOR HAVING PROBLEMS WITH THE CIRCUIT BOARD IN THE HANDLE.YOU'LL NOTICE THAT MODELS THAT CAME AFTER THAT HAD SLIDING SWITCHES. UNFORTUNATELY THE NEW HOSE DESIGN WON'T WORK ON YOUR MACHINE BECAUSE THE CIRCUIT BOARD INSIDE THE MACHINE WAS CHANGED TOO.AERUS MAY OR MAY NOT STILL MAKE THE PARTS YOU NEED. OTHER WISE LOOK ON E-BAY FOR A NEW HOSE.
\015\012ELECTROLUX FOOLISHLY REPLACED IT'S FLAGSHIP STEEL MACHINE WITH THIS DESIGN...A FEW YEARS LATER ALL THEY HAD WORTH SELLING WAS THEIR NAME, HENCE THE NEW NAME AERUS.
Mine is doing the same thing. I took it to a local repair shop and was told that there was a short in the hose and the circut board may need to be replaced. I thought it was the sensor at first and bypassed it and it didn't help. The other thing I found out was that the parts have to come from electrolux because of the year that model was made. I am on the hunt for parts - good luck with yours.
Repair Help & Product Troubleshooting for Electrolux Guardian Bagged Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

RENAISSANCE HOSE/VAC I HAVE A RENAISSANCE VAC WON'T RUN,POWER IDICATOR LIGHT ON THE HOSE HANDLE IS FLASHING ALSO JUST BEFORE IT QUIT THE BAG INDICATOR ON THE HOSE HANDLE WAS ON.


THE RENAISSANCE IS KNOWN FOR HAVING PROBLEMS WITH THE CIRCUIT BOARD IN THE HANDLE.YOU'LL NOTICE THAT MODELS THAT CAME AFTER THAT HAD SLIDING SWITCHES. UNFORTUNATELY THE NEW HOSE DESIGN WON'T WORK ON YOUR MACHINE BECAUSE THE CIRCUIT BOARD INSIDE THE ... Electrolux Guardian Bagged Canister Vacuum

Wondering if the head is plugged up because it makes a sound like air is escaping somewhere. I've replaced the original cloth bag with a comparable "O" paper bag from Sears. I tried to see if there was a clog in the hose by placing a broom handle in the hose to see if something would loosen. I also cleaned the filter and the air filter. If the head is plugged, how can I fix it? We can't get the vacuum apart. Thanks.


I had this problem, but suction improved when the attachments were properly secured in their holders. ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

My sebo 1.1 has a red light flashing, indicating bag needs emptied or clog. There is plenty suction with the hose attachments, and I cannot see any blockages in hoses etc. Some of the dirt seems to be collecting in the small flap in the base of the hoover. Any tips as to what could be the problem would be gratefully received


... Sebo Automatic X1 Bagged Upright Vacuum

No power to sensor SR 12. I also have cleaned rollers and filters and bags. I have reset the handle. When I hit the power the check brush and full bag lights flash once. That is the only power that is getting through.The unit was in storage for a bit and got wet but its been drying off for a couple months. Is there something I can check or replace. Its a great Vac.


... Windsor SR12 Sensor Bagged Upright Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

When I flip the switch on my sebo x1 upright, a red light comes to the brush and bag icons. However, I cleaned out the hose and checked to make sure there is no obstruction from the brush to the hose also, or from the hose to the bag. It is clear that juice is coming to the vacuum, but there is no sign of life except the two red lights.


Thanks for contacting fixya. You should pull out the bag and reset the machine. You should take all the user replaceable items. And turn it on. You will get lot of errors. Then turn the machine off. Put back all the accessor ... Sebo Automatic X1 Bagged Upright Vacuum

I have just replaced the bag in my miele and the indicator is showing that the bag is full. The air coming from the exhaust is hot and the machine is making a higher pitched sound as it does when the bag is full. When the hose is detached, the indicator registers as empty and there doesn't seem to be a blockage.


... Miele Vacuums

I have an Electrolux Renaissance Vacuum C104H. How do I get take the hose off of the handle to install a new hose but keep the handle I have?


... Vacuums

I have lost the manual and forget how to use the hose part of vacuum, also the handle turns and is not secure ( that is the handle in the upright position). It is a bagless Stick Shark Vac. I need to know how to attach the hose to the vac so I can clean furniture and corners.


... Euro-Pro V1828 Shark Stick Vac Bagless Vacuum

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But


Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

LUX RENAISSANCE WONT TURN ON. HOSE CONTROL BAG LIGHT IS ON


Could be the board in the handle but I found that a lot of the times the contacts where the handle meets the hose just need to be cleaned. It could also be a clogged hose but I'd say it's one of the other two. ... Electrolux Vacuums

I have a Kirby G4. I have noticed the last few days when trying to vacuum that it is blowing more than it is sucking up. I put on a new bag to make sure it wasn't too full. I also put on the hose and noticed it's not sucking as well as normal. I unzipped the back of the bag holder and noticed the bag isn't inflating as it should be as well. I appreciate any advice. Thank you.


Take the mini emptor off(plastic piece on bottom of cloth bag) this is done by rotating it away from the body of the machine. There is most likely a clog there. Also take the brush head off and inspect fan for chips or cracks this will also reduce su ... Kirby G4 Bagged Upright Vacuum

I just received My brand new hoover platinum lightweight upright UH30010 (with canister) which I ordered through ebay and today is just the SECOND time I used it but the check bag light indicator is already flashing. My husband and I live in a 1 bedroom (695 sq t) apartment (no kids or pets). I checked the bag and the dirt is just maybe two inches - far from the limit line showing on the bag..and I remembered the advertisement on TV that it can even last upto to six months depending on the usage


I have the same problem. If it was just an indicator light I could live with it, but mine actually shuts the vacuum off. I can only run the vacuum for 3-5 seconds before it turns itself off. Any ideas? ... Hoover Platinum Collection Upright Vacuum

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u


Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

No Suction I get great suction in the hose, but when I plug the hose back into the unit, there is no suction and the air flow indicator line goes completely red. I've changed the bag and filters. I took the small panel off the back and made sure there is no clog, and took the hose off to make sure there was no clog there. Still no suction. Please help.


I about to say that's always a clog of some sort that causes that ... Miele S7210 Bagged Upright Vacuum

Red "bag is full" indicator shows even though new bag has been put in and vacuum cleaner wont pick up. Also floor adjustment does not adjust. This is for a powerforce model 3522 series


The red light tell you that it is sensing a full bag. But a clog in the hose or the inlet down by the brush roll will also do this. ... Vacuums

Shark s3300 Purchsed quite some years ago, amazing little thing (grey) but the hose near the handle seems to be leaking - is there anyone who can give me advice as to where I can a spare hose?


... Euro-Pro Shark Steam Mop - Gray/ Purple Vacuum

I have an Electrolux Renaissance Vacuum C104H. Where can I find buy a hose control handle or the circuit bord for the control handle ?


... Vacuums

Hoover tempo upright is clogged. I can only vac for a few minutes, then I have to unplug it and turn it over and clean out the under part under the roller. It is totally stuffed with dirt and dust and carpet fibers. I have a new bag in. It is like it is clogged up inbetween the bag and the roller. Also gets clogged when using the hose. It is maybe a year old. How can I take it apart and unclog it?


Disconnect the hose and head and wands. Drop a quarter thru the hose, the handle sometimes clogs. peer thru the wands and inspect the elbow on the head for blockage as well ... Vacuums

Help hi there. i have a hoover savvy u8172-900 vaccum. the hose has great suction, but there is limited suction on the main unit and the brush does not spin when i try to use the product. we have cleared the brush of any debris and have also installed a new bag. a few days ago, we disconnected the hose to make sure there was not any foreign bodies stuck in the unit...nothing seems to help. any advise?


As the hose fits into the base (if i am correct) the power at the base should be fine, make sure the base is clean and free from blockage,\015\012you say the brush doesn't spin, has the belt broken, if so replace it, (very cheap) and only a couple of ... Hoover U8171-900 / U8172-900 / U8173-900 / U8174-900 Savvy Bagless Upright Vacuum

Miele Blue moon vacuum motor surging on and off and power light flashing. After many surges of the motor (on->off->on-> off etc), the motor no longer attempting to start as ferquently ie. now off for many seconds and may turn on for 1 second.. sometimes stops turming on and just power light flashes. There is also no voltage at the plug for the hose for the power head. I noticed that the vacuum first started having probs when hair was caught in the power head and the ovetrheating light went on


... Miele Blue Moon Bagged Canister Vacuum

Our miele red star(s314i) vacuum was running great and quit suddenly. It had not been running for a very long time and just quit. Newish bag, no clogs in hose and doesn't seem overly hot. the over heated warning light did not come on. I've waited 30 plus minutes to try to restart and no luck. Any ideas


Ok, so if the cord test didn't fix the problem, then it sounds like either the plug has gone bad, or the switch. The plug is a very common problem to go bad, and can be caused by just simply yanking the plug out of the wall, or putting too much tens ... Miele Red Star Bagged Canister Vacuum

My Dirt Devil M082476 Full Bag indicator light keeps coming on when I turn my vacum up to full intensity. I have tried changing the bag and checked that all hose is clear. If I leave the vacum on low intensity the suction is minimal and does not increas when I turn up the suction. Is there a solution to this? I look forward to your response


... Dirt Devil M084105 Jaguar Vacuum

Have an lg Hoover and the red light on the handle keeps flashing and the blue light on the Hoover is also flashing and then it cuts out. Has little suction with the head on it but better when you take it off. How do I fix the problem?


... Vacuums

Bag full indicator light on only when I plug the hose back in...


Drop a marble or something similar through the hose to see if its clogged ... Bissell 3522 PowerForce Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0805 seconds