Having problems with your Electrolux Guardian Bagged Canister Vacuum ?

I have the electrolux guardian-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)


Answers :

Hi,
\015\012Check your hose you have something stuck in the hose...stretch it out straight and run something through it to push out whatever is stuck in there...
\015\012
\015\012heatman101
Repair Help & Product Troubleshooting for Electrolux Guardian Bagged Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have the electrolux guardian-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)


Hi,\015\012Check your hose you have something stuck in the hose...stretch it out straight and run something through it to push out whatever is stuck in there...\015\012\015\012heatman101 ... Electrolux Guardian Bagged Canister Vacuum

I have the Aerus Lux7000-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)


Hi, you very likely have a defective control valve under the dial on top of\015\012the vac , or a kink or blockage in the tiny pressure hose that feeds\015\012the air from the throat of the vac or the back of the bag chamber\015\012against the two si ... Electrolux Guardian Bagged Canister Vacuum

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But


Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

My new Kenmoore Powermate 116 canister has poor suction. I have no pets and light dust. Its not picking up small particles on the wood floor with the floor attachment. When I put my hand to the suction it feels weak. Cleared hose and changed bag. Using again, same issues. This should not be happening with a new vacuum. Is it a bad design in the elbow joint of the hose? I want to return this!!!!


First of all disassemble the handle and hose as much as possible and examine the inside. Make sure there is not any significant debris lodged in the hose somewhere like a plastic bag or something.\015\012\015\012Also check at the top of t ... Kenmore 23912 Progressive PowerMate Bagged Canister Vacuum

I have a BC-A41 vacuum cleaner which has been working well, but now it appears to blow stuff away from the cleaner as I hoover. I find the hose packed up with stuff, but no content in bag. I recently changed the bag...could it be that the bag is not fitted correctly..I am puzzled by the instruction to put the bottom under the rib. I am a pensioner on my own, and would welcome any help. Thanks, Jim


I think there should be some probem in the vacuum section..its failing to **** the objects ... Vacuums

No Suction I get great suction in the hose, but when I plug the hose back into the unit, there is no suction and the air flow indicator line goes completely red. I've changed the bag and filters. I took the small panel off the back and made sure there is no clog, and took the hose off to make sure there was no clog there. Still no suction. Please help.


I about to say that's always a clog of some sort that causes that ... Miele S7210 Bagged Upright Vacuum

I have a dc18 vacuum and though you can feel the suction from the hose when you put your hand over it, it will not pick up anything from the floor at all. I have cleaned the hose, filter and the holes from inside the canister and still nothing. Help?


Here is a Link to one of my Tips that should solve the problem you are having:www.fixya.com/support/r6311178-vacuum_brush_bar_not_spinning ... Vacuums

Why am I getting a smell out of my Kirby when I am vacuuming, I have tried changing the bag thinking it was something to do with that, but even with the new bag I get the same horrible smell. Can you help please. Thank you.


If it is a burning rubber smell then that means that the belt needs to be changed. Here are the belts you need:Kirby Ultimate G Belts ... Kirby Ultimate G Bagged Upright Vacuum

I have an Oreck XL Hand Vac Model #BB870-AW Type 2 Serial #SN870AWP3Z101356-Z which was used to **** up a large amount of fresh coffee grounds (not used). The vac will not turn on. What can I do? Hose not clogged; put in a new bag. Can't find my manual. Is there a filter or reset button?


... Oreck Vacuums

Vacuum shut off immediatly when suckchen is applied new bag hepa filter removed plus hose is removed when i put my hand over suckghen side it shuts down


Sounds like motor overheating due to fault within....Operates a thermal overload, This could also be faulty ... Electrolux EL7055A Bagless Canister Vacuum

I was putting some bedding in a bag for storage and decided to ''**** it down with my dyson hose to fit it in a smaller space. My dyson quit working and now it will not turn on can you please help...??? I know I didn't **** anything up but I can't live without a vacuum!! I have tried the brush reset button but can't find another reset...


There is no other reset. The Dyson will cut out if it gets too hot, but resets itself when it cools. In doing the job you describe, I doubt that you have operated it long enough to cause overheating, or to do any other damage. I suspect the problem i ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

I'm trying to change the filter....One person told me to open the hose end and take the bag out and go from there, but that isn't the right way!!! It's the other end where a couple brushes are able to be stored on top of the canister, but I can't figure out how to get that section off..it's as tight as a drum HELP PLEASE and thanks. Betty


There's a tab at the middle of the lower back of the tool holder (air diffuser). Pressing in on that tab should enable you to lift the back of the holder first, then lift off the whole thing. It will come off, just make sure the tab is in far enoug ... Electrolux Epic 6500 Vacuum

35922, sounds like there is a clog , have cleared hoses, put new bag in loss of suction, still hear loud clogged noise near rear vent hole


Try putting the vacuum hose end into vent hole while running. That may dislodge the clog. Otherwise, you will need to disassemble the machine far enough to get to the clog area. ... Vacuums

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?


Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

I have a Eureka 4800 series the Boss upright with a bag and Hepa filter. I love it! I was just vacuuming with the hose part and all was well and then suddenly the lower brush came on and a "burning" smell followed. Thought it was the belt so my husband was going to put on the new belt which I had on hand! When he turned it over, the "bar" that holds the belt looks as though it "shot through" the plastic side of the housing on the vacuum. There is melted plastic on the outside of the vacuum and o


I had the same problem. Take out the old belt if possible. Remove the 4 screws inside the filter and the 3 on the front of that housing. pull out the foam around the motor. carefully pull out the suction tube that is press fit against the motor. ... Eureka 4874 Bagged Upright Vacuum

My shop vac blows and doesn't ****! I put the hose on either hole and it blows dirt all in my house. I'm trying to vacuum. I can't find a switch to change it from blowing to sucking and if I put the hose in either hole it just blows.


... Eureka 2812 Wet/Dry Vacuum

My electrolux oxygen cannister has the "bag change" light on when there is a new bag. The light stays on when the suction power is high (to pick up small particles) and it won't pick up, but the ight goes off when the suction power is low (to pick up big objects). I changed the hepa filter, cleaned the motor filter and changed bags, but all that didn't help.


You may have a clog in the hose, and/or the inlet by the brush roll. A clog will turn on that light as well as a full bag. ... Vacuums

I HAVE A BISSELL PROHEAT CARPET CLEANER I DISSEMBLY IT TO CLEAN IT. I DON'T KNOW IF I PUT THE HOSES BACK IN THE RIGHT LOCATION BECAUSE AFTER I PUT IT BACK TOGETHER IT'S LEAKING WATER ALL OVER THE FLOOR BUT IT WILL RECOVER THE WATER FROM THE FLOOR AND THE SOLUTION WON'T SPARY OUT I THINK THE HOSES ARE NOT IN THEIR RIGHT LOCATION TO STOP THE FLOW WHEN IT'S NOT SUPPOSE TO BE COMING OUT CONSTANTLY HELP PLEASE IS THEIR A HOSE DIAGRAM FOR THE HOSES INSIDE THE CARPET CLEANER


Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

The hose is disconnected, new bag in unit, new filter, unit runs when hose is detached but immediately turns off when hose is attached but hose has no obstruction, etc.. i was told i need some sort of valve. HELP! I have birds, a cat and 2 large dogs and no vacuum :)


There is a vacuum hose that attaches inside the unit to a round clear plactic piece. In most cases you can simply cut the small vacuum hose and it will fix the problem. ... Electrolux Epic 3500 Vacuum

I HAVE A BISSELL PROHEAT CARPET CLEANER 7920 I DISSEMBLY IT TO CLEAN IT. I DON'T KNOW IF I PUT THE HOSES BACK IN THE RIGHT LOCATION BECAUSE AFTER I PUT IT BACK TOGETHER IT'S LEAKING WATER ALL OVER THE FLOOR BUT IT WILL RECOVER THE WATER FROM THE FLOOR AND THE SOLUTION WON'T SPARY OUT I THINK THE HOSES ARE NOT IN THEIR RIGHT LOCATION TO STOP THE FLOW WHEN IT'S NOT SUPPOSE TO BE COMING OUT CONSTANTLY HELP PLEASE IS THEIR A HOSE DIAGRAM FOR THE HOSES INSIDE THE CARPET CLEANER


Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

I have a Kirby G4. I have noticed the last few days when trying to vacuum that it is blowing more than it is sucking up. I put on a new bag to make sure it wasn't too full. I also put on the hose and noticed it's not sucking as well as normal. I unzipped the back of the bag holder and noticed the bag isn't inflating as it should be as well. I appreciate any advice. Thank you.


Take the mini emptor off(plastic piece on bottom of cloth bag) this is done by rotating it away from the body of the machine. There is most likely a clog there. Also take the brush head off and inspect fan for chips or cracks this will also reduce su ... Kirby G4 Bagged Upright Vacuum

I have an Ecectrolux Epic canister vacuum. As soon as it starts sucking, the vacuum cuts off. I put a new filter and bag in, but it doesn't seem to help. If I open the front where the bag goes, take the bag out and depress the safety button the vacuum will run. Need some help or direction. Thank you


Try this.\015\012Disconnect hose. Turn machine on and place hand over intake. If it shuts off immediately, first try turning dial on top of machine so largest dot matches up with arrow. Turn on and place hand over intake again. If it still ... Electrolux Vacuums

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

Help hi there. i have a hoover savvy u8172-900 vaccum. the hose has great suction, but there is limited suction on the main unit and the brush does not spin when i try to use the product. we have cleared the brush of any debris and have also installed a new bag. a few days ago, we disconnected the hose to make sure there was not any foreign bodies stuck in the unit...nothing seems to help. any advise?


As the hose fits into the base (if i am correct) the power at the base should be fine, make sure the base is clean and free from blockage,\015\012you say the brush doesn't spin, has the belt broken, if so replace it, (very cheap) and only a couple of ... Hoover U8171-900 / U8172-900 / U8173-900 / U8174-900 Savvy Bagless Upright Vacuum

My Windsor Sensor XP12 says the bag is full when it's not. I have removed the hose, brush, and filter and cleaned everything. I can put a bag on without the cover and it works great. However, when I add the bag to the front cover and close the latch the right way, it does not work. I'm thinking that the cover is not seating the bag correctly over the hole, but I can't figure out how to fix it. Any suggestions?


... Windsor SR12 Sensor Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1259 seconds