Having problems with your Electrolux Guardian Bagged Canister Vacuum ?

Have a canister model Lux5500-ser#F35365B and power nozzle number N115Q-problem: The power nozzel does not stay completely connected to the hose-there seems to be some slipage where the hose connects to the nozzel-preventing a solid connection and the unit from working properly. I tried to tighten the connections on the nozzel, but this has not helped


Answers :

Repair Help & Product Troubleshooting for Electrolux Guardian Bagged Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Have a canister model Lux5500-ser#F35365B and power nozzle number N115Q-problem: The power nozzel does not stay completely connected to the hose-there seems to be some slipage where the hose connects to the nozzel-preventing a solid connection and the unit from working properly. I tried to tighten the connections on the nozzel, but this has not helped


... Electrolux Guardian Bagged Canister Vacuum

Model 116.27914 power mate connection to lower wand is loose. Head unit works when pushing forward putting downward pressure on it, but looses power when you pull back on unit and connection is lost.


... Kenmore Vacuums

Our unit is 7024A Electrolux Oxygen 3 - it seems to work great but suddenly, the head or 'power brush' or whatever it is called - has died. I checked by removing the hose and plugging it directly into the body, but it is still dead. Without that motorized head working, the vacuum is useless. Is it worth replacing? The unit is only about 1 year old and has seen light use only. Very frustrating, since it was the most expensive unit in the store:(


... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

Hooked everything up per directions. I plugged it in to the closest electrical outlet and nothing happened. The lights did not light up, the connected wall control and sensors leds do not light up. It appears the unit doesn't have power. The electrical outlet socket is fine as everything else I plug into it works fine. I have tried every other electrical outlet available. The unit won't power on from any outlet, and all of those outlets run other things, like power tools an refrigerators


Dear Davehibshman,Firstly; dismantle the plug and replace the fuse with the same rating as the one you have just taken out. Replace the plug cover, put the plug into the socket and try again. If this doesnt work, there may be a problem wi ... Vacuums

Model, 116.c85pbpk0v022 Power-Mate Jr. attachment stopped working, could it be a part within the unit (i.e. the electrical component) or do I need to replace the unit? How do I troubleshoot the electrical connection? No known drop or abuse. Worked last time I used it.


This model frequently stops because, lint, hair, etc. gets caught between the two end pieces of the brush cylinder. Do the following to fix it:1) Remove the two Philips screws from the underside of the unit. 2) The side with the tag will ... Kenmore Vacuums

Power head attachment works great when plugged into the hose part of the vacuum. The problem is when I attach it to the tube for normal use there is no power. I have checked all the connections and switched the power switch on and off still no power from tube to power head. Is there anything else I can try? Model Callisto


Try having someone turn the machine on and off while you pull the cord in and out with the cord more angled towards the on/off switch. Sometimes these models have a break in the cord rewind and will not put the power through to the motor. ... Miele Vacuums

We have inherited a Filter Queen Majestic Triple Crown Model 99C vaccum and have no owners manual stating the year it was purchased and parts available. Our power hose electic wire connection (about 6 inches long) which plugs into the main unit is split in the hose attachment end. The motor sound went instantly quieter and I wondered if this was why when I found this frayed electical wire. It has not been used since this problem was found. How much is this single replacement part? I live


... Vacuums

Suction power level drops to zero, need to constantly readjust suction power from zero to normal operating level Appears to be some type of loose connection between hose coupler and base unit


Ok, so where as both of the solutions above are good, they will not solve your problem with the hose cutting off to 0, then having to turn it back on. \015\012\015\012This problem is caused by the static electricity which causes the hose ... Miele s558 Silver Moon Vacuum

Wont charge new roomba for xmas. lights on charging unit both flashing but no power in roomba. it worked yesterday when i got it out of the box and did a full clean. i feft it on charge over night ready for the clean today but when i got up no power atall please can you offer a solution. i have held down pock and start - no joy. i have checked the battery connections - no joy please help many thanks caroline


Did you try plugging in 560 driectly to charger then run it? ... iRobot Roomba 560 Robotic Vacuum

Bissell 7700 series, pro heat all rounder. Won't spray water. Have checked the line from the unit to the spray nozzel and all seems clear. Water doesn't seem to be flowing from the tank to the end of the unit where the hose connects into. What could be the problem? Any assistance would be greatly appreciated. Thank You. Steve


HelloGrasp the cleaning solution tank, and remove it from the machine. Reinsert the tank into the machine, making sure it fits snugly in the machine. If the tank is even slightly dislodged, water cannot get into the machine. Visually insp ... Vacuums

Callisto S5280 unit (seb217-3) doesnt power brush. I replaced the hose but no luck. Should I have 120v at pins on canister where hose connects?


... Miele Vacuums

I have the model C134B Gaurdian model. The green light on the power nozzel is lite howerer the unit will not turn on. The swtiches seem to be working. What can I try?


... Electrolux Guardian Bagged Canister Vacuum

Central Vacuum works when power switch on canister is turned on, but will not turn on when connecting the hose.


DOes it not work on any of your wall inlet valves? If all wall inlets appear dead take a coin making a connection with both of the contacts inside the throat of the valve. If the vacuum turns on the problem is in your hose or the powerhead. If nothi ... Kenmore Vacuums

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

I have a one year old Beam central vac. It has supervalves. The handle (connected to the hose stopped turning on the unit. The handle still powers the brush but no longer turns on the suction?


Http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=566201 ... Vacuums

When i use the power brush attachment, dust flies out of the hole that the hose attaches to... is there a way to prevent this or is it just how it works?


This is the nature of this vacuum, the roller will always spin, when the vac is turned on. You can either cover wit tape or maybe find a sock to put in it (remember to remove sock) when putting hose back ... Hoover U5507900 Elite Rewind Bagless Upright Vacuum

Beam solaire hose only works to suction The power head isn't working. Have another hose and the power head does work on that one so I know it is the hose


... Vacuums

The motor on my Epic 6500 works, the hose is sucking, but the power head isn;t working... I tried the sidestep power head and that one works. Ive opened and replaced the belt and that is fine. The bulb was already burned out and wasn't replaced so I cant tell if theres power to the head. What else could it be?


Connect the power nozzle directly to the hose and try.\015\012Check the terminals where the wand connects to the PN. If any are discolored or cracked, that may be the problem.\015\012Open the PN and check for loose or broken wires and co ... Electrolux Epic 6500 Vacuum

The power brush floor rug attachment on my Eureka 6997 A Oxygen Canister Vacuum goes on an off as I use it. I replaced the The power cord from the handle has 2 plug in connections: 1 at the handle / upper wand 1 at the lower wand top of the power brush attachment I replaced the entire wand assembly and it worked great for a year or so and now it's doing the same thing again. I was told to keep the power switch on the handle set to off when connecting the power brush attachment or it will bu


This is from the prongs not making a good connection causing an arch inside the plugg causing what looks like rust on the plugg. I would try snugging up the connection by squeezing the female section to get a better connection on the prongs when it i ... Vacuums

Electrolux Centralux I have a Electrolux Centralux. When I plug the hose in at one of the wall outlets the motor will not start. If I go to the motor and slap the unit it will start.....then...it will not stop unless I unplug the power cord to the motor. If I plug the power cord back in, the unit will not restart until I slap the motor unit again. The unit has only been used 20 - 30 times. Any suggestions?? Thanks, Bruce


I dont know if you had your unit looked at yet but it sounds like the Power module is going. I repair the machines so I know some of the work. ... Electrolux Centralux Vacuum

Meile Solaris. Power cord connection faulty. Unit powers on/off when cord is being retracted/pulled out. Maybe a break in wire close to connection point in vacuum. Or, the connection point itself is loose? The problem likely resulted from trying to use vacuum at furthest extent of cord.


Cord reel likely needs to be tightened. requirs disassembly and large washers installed to keep reel connections tight. Jim ... Vacuums

My Bissell BS3920F upright (similar to the 10N6F) has been working wonderfully for the past 3 years but suddenly seems to not pick up dog hair as well as it used to. It has been pulled apart by my husband to ensure nothing is blocking the hoses etc and when running the suction seems to be there. It seems to grab the dog hair and leave it in a straight line directly under the unit without picking it up. I then disconnect the hose and use to hose to pick up the dog hair. This works well but obviou


Check to see if your brush is not worn down, they do wear with age - compare the length of the bristles with a new one. Replace the brush ir there is a significant difference in bristle lengths. Also check the flexible ben ... Bissell Vacuums

My Prosine 2.0 display panel displays Panel Fault: Memory error and the display error as well as all LEDs are off. The unit looks as if it has no power to it. I reset (power off.power on) the Prosine and all LEDs on the display (except for the back lit display) turn on for about 3 seconds then all go off again. I am able to use 120v RV Resort power and all 120v equip works. The Coach batteries do not charge and were low. I charged the Coach batteries with an external charger. The charge works ye


... Vacuums

Attachment problem used a new unit w/attachment for 5 minutes...dispensed solution in a powerful triangular fashion. Then the fluid quit dispensing out of the attachment nozle amost like the pump quit working. Primed the unit several times w/ no success. checked for clogs. can't tell if the floor portion is "pumping' or just dribbling solution onto the floor with the trigger. can see no leaks at this point. unit worked for about 5 minutes on apholstery


Make sure everything is filled and secured tightly, if this a new unit it should be something simple ok, also check where machine folds down that the solution hose is not being pinched its right behind the dirty water tank ... Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

The power wand electrical connection on the power unit itself seems to be corroded. I think I need a new two wire plug to plug into the wand. the model is a Eureka 6984 A. I am able to disassemble the power unit if necessary and replace the wire and plug if one is available


Try hesco inc they have a on line store with all the vacs parts diagrams and fast shipping. ... Eureka Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0760 seconds