Having problems with your Electrolux Lux 5500 Canister Vacuum ?

Can't open the bloody thing .... to check the power terminals connection

Answers :

I strongly suggest not opening it. Although it is simple to open if one knows how, there can be difficulties getting it put back together correctly. And generally problems are due to things other then wiring connections.
\015\012However, to open, open bag door and remove bag. Place machine on one side with the door open. Insert flat head of a screwdrive into the space at back end of the rubber strip on side of machine. Using a hammer, gently hit the screwdriver shaft until strip slides forward about 4-6". Grab front end of strip and pull forward. Repeat with other side. Place vacuum on it's top, grasp bottom half of case, and lift. With some manipulation it should come off fairly easily.
\015\012Reassembling is a bit more difficult.
\015\012Be aware that shops will usually charge more to reassemble a vacuum if they didn't take it apart or repair it.
Repair Help & Product Troubleshooting for Electrolux Lux 5500 Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Can't open the bloody thing .... to check the power terminals connection

I strongly suggest not opening it. Although it is simple to open if one knows how, there can be difficulties getting it put back together correctly. And generally problems are due to things other then wiring connections.\015\012However, to op ... Electrolux Lux 5500 Canister Vacuum

After a brief power outage my Marantec 4700 garage door opener has problems opening/closing. When opening it stops at the fully open position and the lights blink, when closing it automatically reverses just as it fully closes and then the lights start to blink again. I checked for obstructions and tried to reset the limits of travel per the manual, it still does the same thing. Any ideas on what to try next?

This is not a sensor issue, I have a similar problem, sensors work fine, garage door is still fully functional, all operations, including safety sensors work properly, just the overhead lights flash. I suspect there was damage to the power board due ... Vacuums

The power brush floor rug attachment on my Eureka 6997 A Oxygen Canister Vacuum goes on an off as I use it. I replaced the The power cord from the handle has 2 plug in connections: 1 at the handle / upper wand 1 at the lower wand top of the power brush attachment I replaced the entire wand assembly and it worked great for a year or so and now it's doing the same thing again. I was told to keep the power switch on the handle set to off when connecting the power brush attachment or it will bu

This is from the prongs not making a good connection causing an arch inside the plugg causing what looks like rust on the plugg. I would try snugging up the connection by squeezing the female section to get a better connection on the prongs when it i ... Vacuums

Power head attachment works great when plugged into the hose part of the vacuum. The problem is when I attach it to the tube for normal use there is no power. I have checked all the connections and switched the power switch on and off still no power from tube to power head. Is there anything else I can try? Model Callisto

Try having someone turn the machine on and off while you pull the cord in and out with the cord more angled towards the on/off switch. Sometimes these models have a break in the cord rewind and will not put the power through to the motor. ... Miele Vacuums

Hooked everything up per directions. I plugged it in to the closest electrical outlet and nothing happened. The lights did not light up, the connected wall control and sensors leds do not light up. It appears the unit doesn't have power. The electrical outlet socket is fine as everything else I plug into it works fine. I have tried every other electrical outlet available. The unit won't power on from any outlet, and all of those outlets run other things, like power tools an refrigerators

Dear Davehibshman,Firstly; dismantle the plug and replace the fuse with the same rating as the one you have just taken out. Replace the plug cover, put the plug into the socket and try again. If this doesnt work, there may be a problem wi ... Vacuums

The motor on my Epic 6500 works, the hose is sucking, but the power head isn;t working... I tried the sidestep power head and that one works. Ive opened and replaced the belt and that is fine. The bulb was already burned out and wasn't replaced so I cant tell if theres power to the head. What else could it be?

Connect the power nozzle directly to the hose and try.\015\012Check the terminals where the wand connects to the PN. If any are discolored or cracked, that may be the problem.\015\012Open the PN and check for loose or broken wires and co ... Electrolux Epic 6500 Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.

Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

NO POWER My Dyson DCO4 Absolute (purple&lime) won't' switch on. I've checked the plug fuse, wall socket and also filters and hoses on machine all seem fine so think the problem is with the on/off button (maybe loose wire or something) but how do i get to it, is there a special way to remove the green on/off button in order to check the connection? Thankyou in advance for the help i am sure you will be able to provide.

The problem is almost certainly a fatigue break in the flex. These usually happen where the flex enters the handle through the rubber sleeve near the on off switch. You will need to cut about four inches off the wire and reconnect it to the switch. ... Vacuums

My Kenmore 116.25812508 power nozzle motor will not run unless I tilt the handle. I checked the connectivity from the circuit board in the power nozzle base to the telescoping wand with an ohm meter and there is no indication of disconnect.

I have had this vacuum for about 3 yrs and nothing but issues with it. It's been in the shop already once and it needs to go again. No power in the power head. A wheel came off of the powerhead too .. keep snapping it back on but it always comes off. ... Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

I have my vacume electrical cord tangled inside and disconnected (I can see the open end of the connection from the power cord collector wheel! I need to take the vacume apart so get access to the wire inside. I need to know if there is something else to open other than the 4 screws. Your help is highly appreciated in advance.

Since you did not provide a model number for your vacuum, it is difficult to provide any precise directions regarding disassembly.\015\012\015\012However, most vacuum cleaners are fairly straightforward machines, and as long as you unplug ... Vacuums

I bought a Euro Pro Shark Steam Vaccum about 3 yrs ago. Now, suddenly, it won't switch on. I checked the power receptacle and tried other receptacles. It still won't switch on. I wanted to open and check the inside but it needs some special tools (and long screw drivers!). Any suggestions on what I could do?

... Euro-Pro S3325 Handheld Steam Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Our Winsdor Sensor XP12 does not show any power or lights, I did check the handle connection, it was fine. The power cord has been repaired with duct tape 3-4 x where someone has sucked up the cord, this may be the cause yet it ran fine last time it was used! so I am at a loss, please help if possible.08/31/2010 Steve

Any time the cord has been damaged badly enough to require taping, the possibility or intermittent "opens" exist. This means the wires are in contact much of the time, but will losed contact periodically. Even if it worked fine seconds ago, jigglin ... Windsor SR12 Sensor Bagged Upright Vacuum

Wont charge new roomba for xmas. lights on charging unit both flashing but no power in roomba. it worked yesterday when i got it out of the box and did a full clean. i feft it on charge over night ready for the clean today but when i got up no power atall please can you offer a solution. i have held down pock and start - no joy. i have checked the battery connections - no joy please help many thanks caroline

Did you try plugging in 560 driectly to charger then run it? ... iRobot Roomba 560 Robotic Vacuum

BEAM model 178 central Vacuum. Motor will not start. Has power but just won't start. No click when switch is turned on. Is there any fuse to check? Could it be the relay? Any other thing to check? Thank you. Pierre

... Vacuums

Smell/suction I have a Eureka Altima Model 2991 Type AVZ. I have suction when I use the power paw and attachments. I have all hoses clear. My brush is spinning and belt is not broken (I opened it up and checked), but I have no suction when I turn it on to vacuum my living room carpet. I also have a burning smell to go with it after about 30 seconds. I've never had a problem with this vacuum cleaner before.

Ours started smelling too, and it seems that the plastic end on the roller brush was melting. In process of finding rollerbrush for it now ... Eureka 2971AV EZ Kleen Bagless Upright Vacuum

My Miele capricorn has started making an odd noise. It seems like something is blocking the engine. I've turned if off and on, and reset it and it still have the odd, almost loud barking noise. The power nozzle also does not seem to be working. I've checked the connections. Right before this happened I was using the vacuum. I didn't notice anything out of the ordinary until this.

Greetings,\015\012\015\012This is a major problem. The Miele vacuums motor should never make a loud noise, period. The way the motor is designed, it's quiet and should be quiet for the life of the motor. There are two motors on your ... Vacuums

The unit is not powering on, I have changed the plug and opened up the unit to ensure all the electrical connections look ok..Is it the heater element?

Hi,Yes, they burn out easily...Here is a tip that I wrote about the Euro-Pro Shark Steam Mop and why it maynot be getting steam to the head... ... Euro-Pro Shark Steam Mop - Gray/ Purple Vacuum

I have a DC25 that will not pick anything up. It seems to be throwing everything back out somewhere. It only powers on when its not in the upright position. There is also a strange noise when it's turned on. I have taken the whole thing apart and cleaned all of the filters and checked for blockages but it hasn't help.

Hi there,\015\012\015\012Sorry to hear you're having a problem with your DC25. You should be able to resolve the issue by following these simple steps: ... Dyson DC25 All Floors Bagless Upright Vacuum

My Dyson just stopped sucking up dirt. I have checked all the obvious things like clogs and filters. I noticed when I turn it on, there is a valve on the top of the cannister that opens and you can feel suction from the vent hole. Is this valve malfunctioning, or is it working correctly because something else is malfunctioning?

Your cyclones could be clogged. You can clean them yourself pretty easily. See this video. http://www.youtube.com/watch?v=2OO3ugkyzxk ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Brand new hoover steam vac max extract. brushes won't spin. I have check connections, read the manual and nothing. have the switch to power scrub. works with hand tool.

... Hoover Vacuums

When I turned on the sweeper it would not start. I put a different power cord on it and it worked fine. now it won't start but the light on the brush and the bag full will flash when i turn it on and off but it wont start. i have 2 of these doing the same thing. do you have any idea what could be wrong. I have checked for clogs but have found none. Bob

Its sounds to me like the computer board inside the machine has gone bad. Keep in mind that the filters in these machine do need to be replaced regularly to keep the vacuum working correctly. Any good vacuum shop should be able to fix your problem. R ... Windsor SR12 Sensor Bagged Upright Vacuum

I have a Bissell power steamer 1631. I do not know how to fill the tank. Where do you add the shampoo? Also, the hose has an added small tube or hose like thing, where does this connect to?

A look here: http://www.bissell.com/Products/c/uprightdeepcleaner/p/1623PSPBS/ak/features/product.aspx ... Vacuums

We do not h ave the manual anymore, and the carpet wheel isn't turning, but the belt doesn't seem to be broken, is there another belt and how do you open the darn thing to check it out

Http://www.bissell.com/images/UserGuides/7901_608.pdf ... Bissell 8910 ProHeat Clear View Upright Vacuum

Power brush does not run, light does not work when plugged in...checked connections...seems ok

... Broan-NuTone CV350 Performance Bagged Central System Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0651 seconds