Having problems with your Electrolux Lux 7000 Bagged Canister Vacuum ?

Lux legacy my vacuem wont run but 1second after i push the on switch. the full bag light comes on when it shuts off.i turn it on again and it runs for asecond and cuts off. it has abrand new bag in it.i tried adjusting the suction knob on top to no avail.


Answers :

Actually the problem is inside of the canister itself. You need to change a part called the control valve. Occaisonally when fine particles get inside of the valve it damages the inside of the valve, sending a false reading to the main motor, causing it to shut off. This is a relatively quick and easy repair and should be recieved on a same day basis.
Replace the switch for the bag senscer
Repair Help & Product Troubleshooting for Electrolux Lux 7000 Bagged Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Lux legacy my vacuem wont run but 1second after i push the on switch. the full bag light comes on when it shuts off.i turn it on again and it runs for asecond and cuts off. it has abrand new bag in it.i tried adjusting the suction knob on top to no avail.


Actually the problem is inside of the canister itself. You need to change a part called the control valve. Occaisonally when fine particles get inside of the valve it damages the inside of the valve, sending a false reading to the main motor, causi ... Electrolux Lux 7000 Bagged Canister Vacuum

I have an Ecectrolux Epic canister vacuum. As soon as it starts sucking, the vacuum cuts off. I put a new filter and bag in, but it doesn't seem to help. If I open the front where the bag goes, take the bag out and depress the safety button the vacuum will run. Need some help or direction. Thank you


Try this.\015\012Disconnect hose. Turn machine on and place hand over intake. If it shuts off immediately, first try turning dial on top of machine so largest dot matches up with arrow. Turn on and place hand over intake again. If it still ... Electrolux Vacuums

I have a Electrolux Epic 6500 SR canister vacum cleaner. It is nine years old and for the past few weeks it has started shutting off for no apparent reason.The symbol for bag change lights up and it cuts off, but even after I have put a new bag in, it still does the same thing. Do you have any suggestions? There is a little button or switch that the top of the bag fits on. Do you think it could be the problem?


Your machine is probably clogged, look through the wands, look in the bottom attachment, to see if there is anything stuck there. You can also drop a marble through the hose itself to see if anything is stuck there as well. To unclog the hose try hol ... Electrolux Harmony Canister Vacuum - EL6985 Vacuum

I bought new C type bags at Sears but my Lux 5000 refuses to run


Cure is ..don't buy cheap bags at Sears for your Electrolux. You get what you pay for! ... Electrolux Lux 5500 Canister Vacuum

HOOVER 6430-900 Runs for about a minute or two and shuts off. Wait a while and it will run again. Changed the belts, new bag, new filter. Seems to put out a lot of heat when running.


Hoover Fined for Failing to Report Vacuum Cleaner Fire Hazard\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\01 ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

I have the electrolux guardian-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)


Hi,\015\012Check your hose you have something stuck in the hose...stretch it out straight and run something through it to push out whatever is stuck in there...\015\012\015\012heatman101 ... Electrolux Guardian Bagged Canister Vacuum

I have the Aerus Lux7000-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)


Hi, you very likely have a defective control valve under the dial on top of\015\012the vac , or a kink or blockage in the tiny pressure hose that feeds\015\012the air from the throat of the vac or the back of the bag chamber\015\012against the two si ... Electrolux Guardian Bagged Canister Vacuum

Nilfisk GD-2000. Same problem with the new vacuum as the old one, runs 30 seconds to a minute & shuts down. Sometimes it'll start & run another 30 seconds or so, but shuts down. Other times it won't start back up at all. No clogs & bag is new. Please help.


... Vacuums

Bag indicator light won't go off, therefore vaccuum cleaner won't run. It acts as if the bag is full even with a new bag.


The bag indicator is either rusted out or broken. it only realy's on a little spring that bounces up and down so dont trust those things ... Vacuums

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

I have a new electrolux el7025a-r and it keeps cutting off while I am vacuuming. I am using the small powerhead on hard floors and I have checked the hoses for blockages and the bag is new. I can not figure out why it keeps turning off in the middle of a job.


The wands are notorious for going out on that unit. One or both probably need to be replaced. Try to get it done under warranty if you still have the receipt, but they shouldn't cost you too much if you can't. \015\012\015\01 ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

The hose is disconnected, new bag in unit, new filter, unit runs when hose is detached but immediately turns off when hose is attached but hose has no obstruction, etc.. i was told i need some sort of valve. HELP! I have birds, a cat and 2 large dogs and no vacuum :)


There is a vacuum hose that attaches inside the unit to a round clear plactic piece. In most cases you can simply cut the small vacuum hose and it will fix the problem. ... Electrolux Epic 3500 Vacuum

We have an MC-3003 vacuum cleaner which keeps cutting out. We've changed the bag, but the problem still occurs with a new bag fitted. Could it be an electrical fault and is the machine repairable?


... Panasonic Vacuums

My hoover vacuum runs for about 10-15 minutes then the saftey feature shuts it off(overheat?). i have taking it apart a cleaned it with no results, added new bag also. after an hour it cools down and works again. do i just need a new vacuum?


Do you have suction through the tools? Does it look like it picks up when it runs? The machine could be clogged and that would cause the problem, but unfortunately the sensor that shuts the machine off could be bad if the machine isnt clogged. Its no ... Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum

My cleaner ( Oreck 40th Anniversary, XL2 Ultra) several years old, and I love it. My questin, is there a reset button? Vacuum just quit....no noise, sputtering, smell, nothing, just stopped while running cleaner. New bag, new belt. Any ideas?


... Oreck Vacuums

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.


Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

Machine running hot. new bag but red flag indicator is fully closed at stsrt up. Runs but overheats and shuts off and red reset light comes on


You may have a blockage in either the hose, the telescopic wand or the power nozzle/floor attachment. The easiest way to tell, as you have a new bag in there is to disconnect the hose and start the machine. If the suction is good there, start to narr ... Miele S548 Bagged Canister Vacuum

How do i attach new outer bag to top of heritage handle


... Vacuums

HVR 200 keeps cutting off.


Henry has a has a thermal cut off (a thermostat that protects the cleaner in case of motor overheating). When you have no bug inside the hoover will be very cold. \015\012\015\012Check if the hose is blocked with dust.heck also th ... Numatic Henry Bagged Canister Vacuum

Red light on. Works for 2 minuets and then cuts out.  Does not ned a new bag.  Could it be the filter?


It could be a clogged bit of dust. Check the main hose, remove it by unlocking at the top and check the whole assembly including the pull out wand part. Then check the underside. Either inspect using the trapdoor or remove the beater bar and see if t ... Sebo Automatic X1 Bagged Upright Vacuum

Motor/Fan does not run. I have removed and taken the top of the canister plastic motor housing apart and tested for power. I have power through the cord to the switch and power from the switch to the two wire terminals. I have not removed the motor. Looks like I will need special tools to take out the motor. The Vac looks almost new. It has been setting for several years. What do you think?


Sorry to read about your problem, I hope this helps you out.Well you can order a new motor at shop vac, check out this link.you dont have to remove to check the motor, just connect power to the motor leads ... Shop Vac QPMH450 Canister WetDry Vacuum

My lux 7000 has a new bag but when i start to use it with the power unit or without the unit shut's it self off i can reset the lites or the motor if you will by clicking the on off switch 4or 5 times and i'm ready to go again untill you start to work and off it goes you can repeat the switch thing as long as u want, it just won't let u vacuum ,it turn's it self off .I blew it all out but found nothing in it. if u don't try to vacuum it will run as long as u want to listen to it. Can you


Have you replace the afterfilter? It may also cause this if rather dirty. It's located under the tool caddy/air diffuser on the back half of the machine.\015\012Try this: Disconnect hose, turn on vacuum. Does it continue running? If so, pl ... Electrolux Lux 7000 Bagged Canister Vacuum

The vacuum cleaner stopped working.. It will not run. How do I fixs it? A new bag is on it.


... Simplicity 7850 Premier Bagged Canister Vacuum

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u


Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

We have bissell pro heat and I have put new belts on and took off the top plastic cover I blew out the lines and I still can't get it to pump water or solution. The red little spinner flow indicater does'nt get water, if I pour water into it it runs out the front. I guess I don't know what else to do. The machine worked fine the last time we used it about 6 months ago. Any suggesttions?


Did you check and make sure the belt is still on right? They do come off from time to time.There are like 6 long screws holding the top cover to the bottom. The are real pain in the behind to put back together once you take them off. T ... Bissell Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0574 seconds