Having problems with your Electrolux UltraLux 2000 Bagged Canister Vacuum ?

Lack of suction even with filter removed.

\015 There is some suction but not nearly what it should be. Bag is new, and for a test I removed the filter and that only made minimal improvement.\015

Answers :

I used to be a service manager for Electrolux. It sounds like possibly a clogged fan or hose. Take the hose off and check the amount of vacuum at the opening of the cleaner. If it has more suction without the hose, hold the hose in place backwards to try to **** the junk out of it. If the hose was damaged inside, it may be necessary to have it cleaned out with a very small hook. Make sure you have the filter & bag in place. They are needed to make a complete seal in the vacuum system. Make sure the suction control door on the hose (near the handle) if shut. This is normally only opened to vacuum curtains and loose hanging draperies.
What you can do is
check that the pipes are not blocked
this happens alot

to check if it is your vacume or pipes
unclip the pipes and put your hand to where the pipe conects with the unit on
if there is still no suction look to see if there is a speed switch and turn this up if it is low
if this dose not work you might need a new motor
hope this helps ;-)
ricko
Repair Help & Product Troubleshooting for Electrolux UltraLux 2000 Bagged Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Lack of suction even with filter removed.


I used to be a service manager for Electrolux. It sounds like possibly a clogged fan or hose. Take the hose off and check the amount of vacuum at the opening of the cleaner. If it has more suction without the hose, hold the hose in place backwards ... Electrolux UltraLux 2000 Bagged Canister Vacuum

The vacuum does not have suction. I have cleaned the filters, checked the hose paths and the hose won't **** anything up. I even checked with all the filters removed, still no suction. It is blowing air out the exhaust.


Have you checked the belt? ... Bissell 89Q9 Bagless Cyclonic Vacuum

Dyson DC 14 hose has no suction, with or without brush attachments. Hot air shoots out from the base of the canister when I try to use the hose. I cleaned the top filter, but can't figure out how to remove the hepa filter to clean it without destroying the case. It looks like it might take three hands to insert pennies and "flip" the case open as is suggested on a youtube video for a different model. Would this even help, assuming I could get the thing open?


... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

Lacking suction from largest filter I don't know how to remove it


Hi there VacuumGuru for nelsonvacuums and VacuumSpot here. I have actually made a video on how to locate and change your filters for the dyson dc07. See link below. ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

I have removed a clog from the hose and cleaned the air filter. But I have no suction. If i remove the filter the is plenty of suction.


Get a new filter ... Dirt Devil Featherlite Bagless Vacuum M085845Vacuum

I have a DC07 and the brush wasn't rotating and I had no suction at the brush but perfect suction through the hose. I noticed a large build up of dog hair around the brush so I took off the cover plate and removed all the hair, cleaned inside the floor/brush housing and cleaned out the hose. I also cleaned the filter and removed the other air access cover and made sure that they were clear. I put everything back and the brush still doesn't turn and there is still no suction through the bottom


Hi and welcome to FixYa. I am Kelly. \015\012\015\012Here is a link that can assist you in your quest for the missing suction: \015\012\015\012 ... Dyson DC07 Bagless Upright Cyclonic Vacuum

Hoover Windtunnel T-Series UH20700 9 mos old. Keeps clogging in hose just above the beater brush assembly. I think it clogs because the suction is too weak to pull much through. Primary filter is clean and HEPA filter is replaced. Even when everything is unclogged, suction is weak compared to another unit (same model) that a friend has. Any ideas?


... Hoover UH70120 WindTunnel TSeries Rewind Bagless Upright Vacuum Cleaner

Recently purchase SC-N500 vacuum cleaner. Worked well only the first 2 times I used it to clean up plaster dust from floor after sanding. Since then it has not worked at all well wiht very poor suction. Fluff gets stuck in the hose and has to be manually removed. Suction power is very poor. I have washed the filter to remove the dust with no difference. Who do I contact in Brisbane to service or assess the problem further.


... Sanyo Vacuums

The hose to my Dyson Dc24 has no suction. There is suction from the exhaust when I move the cyclone bin. I have removed, washed and replaced filters. The valve next to the top filter keeps flapping. I've checked for blockages and can't find anything.


... Dyson Ball DC24 Bagless Upright Vacuum

Hello- my motor filter is becoming clogged every time i use it. i have removed and washed it--I thought maybe i didn't have the lid closed tight enough but for some reason dirt is pouring into the filter, it seems that some of the dirt suctioned is actually being pulled into the filter intead of the canister


One way or another, dirty air is by-passing the cyclone. My best guess is that when you emptied the clear bin, a seal has dropped out (or become displaced) and the base of the clear bin is no longer sealing properly against the bottom of the cy ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

No suction I have the central vac type. It has no suction at the can. I pulled the hose going to the walls and tested there...and nothing. I removed the dirt can and checked the motor ...it is spinning but does not feel like any suction. I checked the exhaust and it is pushing strong air out. I also cleaned the filter and still nothing. Is there a relay or something that would cause only exhaust air. I emptied the can of dirt and put it back together and have absolutely no air.....hear the motor


On some units there is a screen that protects the impeller of the motor. If this gets sealed off with debris then it is like putting a potato in the tail pipe of a car. Taking the top off the unit reveals the motor. DO UN-PLUG the unit first from th ... Electrolux Central Vacuum

I have a Kenmore central vacuum cleaner model number c107 34601. We have emptied the bucket and shaken the filter out to clean it. There is a filter that is filthy so we shook it out into a bag but the cleaner still seems to not have great suction. I notice there is a similar cap to the outlets I plug the central vac hose into on the unit itself that doesn't power the nozzle when used. 1 - what is this for? 2 - Should I somehow remove the entire filter and if so - can you tell me step by step ho


... Electrolux Vacuums

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

My shop vac is plugged. The hose is clear. The filter is removed. The filter bag is not installed. It still won't draw a suction. It sounds like it is plugged. The motor whines at a higher-than-usual pitch. What can I do?


Turn off the vac, take the head off of it and remove the filter paper. Inside, there's a white ball (bigger than golf ball, smaller than baseball) that's inside a cage. This is designed to keep water out of the blower when the vac tips over, and sh ... Vacuums

I cleaned out the hose and removed brush to clean and checked belt. Everything seems to work but will not pick up or suction on carpet. The hose is totally clear from clogs. I can see the floor from one end to the other. What am I missing that might be causing lack of suction?


Hi troupdavid,I see that your Vacuum is having issues with it suction, you mentioned that you took it a part to clean it, see steps below.\015\012\015\012Check if everything is inserted prope ... Hoover Tempo Widepath Upright Vacuum - Blue

It starting to put out a hot type smell. I have tried cleaning the filters real well and even tried to see if there was problem with the ozone filter. We have checked and could not find a jam. I know the hose has excellent suction. The vacumn works but the intelliclean sensors will not. It only takes about 15 seconds or so for the odor to start. Then it gets real strong and it makes my eyes water


Hi,The hot smell could be from the belt or the motor. Turn it on for a moment, turn it off, then flip it on its side and smell the belt that drives the brush. If that is where the smell is coming from, then your belt is burning up. ... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

I was given a model 6591, plugged it in and it worked but didnt "****" and didnt sound right. I turned it off and removed the hose from the back found a badly plugged hose. Removed the hair plug cleaned filters and when I tried to turn it on again. Now the motor will not turn on or even make a noise. I hear there is a fuse that can be blown? How can I find the fuse if there is one? Thank You Ron


The User Guide for the bissell Clearview Power Trak\012\012http://canada.bissell.com/images/UserGuides/3590C.pdf\012 ... Bissell 6591 Power Trak Revolution Bagless Upright Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

I took the vacuum apart, and cleaned the filter, cannister reservoir, removed all the hair which was wrapped around the beater bar. One the filter was dry (next day), I put it all back together. Now, there is no suction, and it sounds differently than it did before.


Check its assembled correctly . Sounds like something is out.... ... Dyson Slim DC18 All Floors HEPA Bagless Upright Vacuum - Iron/Titanium/Yellow

My brushes on my hoover streamvac will not rotate. I removed and cleaned assuring that the filter was also cleaned. The only different thing I have done is to insert the upholstery attachment and removed it after use (didn't work so well) suction seemed weak. I am also noticing that there is air being blown out of sides where the dirty water container is. (don't recall that in the past).


... Hoover F5900-900 Upright Steam Vacuum

We have two of these vacuums and both of them have experienced the same problems. First the floor heighth adjustment doesn't work and now neither one will pick up on either carpet or floor when in the brush/floor mode. They both seem to work with the suction hose function. We have removed the back panel to see if there was an obstruction but it was clear. We have changed the bag and the small filter (not the HEPA filter) all to no avail. What else can we do? We are desperate to use our vacu


Did you check the powerhead for obstructions? With a bend in the tube just below where the hose connects, this is a common spot for clogs. To check, detach hose and drop a coin in the hole. If it doesn't drop through, a blockage is present. Use t ... Electrolux Oxygen 3 Upright Vacuum Cleaner - EL5035 Vacuum

Dyson animal loses suction when I let the handle down from the upright position to use, I've cleaned the foam filter, and the plastic filter holder and dried thoroughly, removed and cleared the right side U-bend, and the center, rear U-bend access, also made sure nothing was in the way of the beater bar. Any thoughts? thanks. lorri


Is the noise a loud screaming or a grinding/vibration? The screaming is an air flow problem and you'll want to check your hoses are clear and all the seals are tight. The grinding is an issue with the roller/belt/clutch/motor/housing. From what I'm r ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

I have a power drive baggless vacuum cleaner...it runs well, but suddenly it seems to have lost most of the suction coming through the hose and floor area. When I remove the dirt container, the suction below it seems strong. I have had it to repair twice--they have tuned it up and replaced all filters and belt. It still does not pick up well when I vacuum or use the hose. Can you help ?


There is something stopping it up,you will have to dissasemble the unit to find the blockage,this is the most likely problem. ... Hoover U6660-900 WindTunnel Bagless Upright Vacuum

My Electrolux guardian C135 vac has lost suction. replacing the bag does nothing. removing the HEPA filter has no effect - what do you suggest? Will a replacement HEPA filter make any significant difference?


No you have a clog in the hose, wand or at the power head. Remove the hose wand and power head from the the vacuum. Turn on the vacuum, put the palm of your hand over the hole in front, you should feel plunty of suction. Then replace just the hose an ... Electrolux Guardian Bagged Canister Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0858 seconds