Having problems with your Electrolux Vacuums ?

Have an electrolux 2100 canister vac, it has lost suction power thru the years. no clogs in newer hose or in sweeper. even with new bag, filter and belt only increases power minimally.

Answers :

Have you ever over the years replaced your brushroll ? Have you tried dropping a coin thru the hose from one end to see if it comes out the other end ? Have you taken the wand loose from the elbow ( the swivel part of your carpet sweeper) to see if there was a blockage ? Does the motor make a strange noise ? Have you ever had a tune-up on your vac.
\015\012You might think about taking your vac to your Aerus/Electrolux shop.
Repair Help & Product Troubleshooting for Electrolux Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Have an electrolux 2100 canister vac, it has lost suction power thru the years. no clogs in newer hose or in sweeper. even with new bag, filter and belt only increases power minimally.

Have you ever over the years replaced your brushroll ? Have you tried dropping a coin thru the hose from one end to see if it comes out the other end ? Have you taken the wand loose from the elbow ( the swivel part of your carpet sweeper) to see if t ... Electrolux Vacuums

I have the Aerus Lux7000-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)

Hi, you very likely have a defective control valve under the dial on top of\015\012the vac , or a kink or blockage in the tiny pressure hose that feeds\015\012the air from the throat of the vac or the back of the bag chamber\015\012against the two si ... Electrolux Guardian Bagged Canister Vacuum

I have the electrolux guardian-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)

Hi,\015\012Check your hose you have something stuck in the hose...stretch it out straight and run something through it to push out whatever is stuck in there...\015\012\015\012heatman101 ... Electrolux Guardian Bagged Canister Vacuum

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u

Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

Unbeknownst to me, someone took the bag out of my Kenmore Progressive vacuum and failed to replace it. I have been vacuuming without a bag for months, and today the vacuum stopped sucking. When I opened up the front to replace the bag, tons of dirt and dust came pouring out. I thoroughly cleaned the vacuum, put in a new bag, but still no sucking power. Just dust coming from the rear vents where one of the filters is. Is the vacuum ruined, or is it a simple solution of buying a new filter?

Sounds like you need to buy a new motor. All that grit and dust will ruin a motor and I'm surprised it lasted as long as it did.\015\012This is where a vacuum that won't run without a bag would have been nice. (Aerus for one) ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

My electrolux oxygen cannister has the "bag change" light on when there is a new bag. The light stays on when the suction power is high (to pick up small particles) and it won't pick up, but the ight goes off when the suction power is low (to pick up big objects). I changed the hepa filter, cleaned the motor filter and changed bags, but all that didn't help.

You may have a clog in the hose, and/or the inlet by the brush roll. A clog will turn on that light as well as a full bag. ... Vacuums

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!

... Miele Vacuums

Electrolux 2100 vac dies when you attach hose even with new bag.

If the bag full light keeps coming on, you can first try adjusting the dial on top of the vacuum cleaner. If that does not work, then you need to change the control valve. This is an internal component of the canister and is directly below the dial ... Electrolux UltraLux 2000 Bagged Canister Vacuum

The hose is disconnected, new bag in unit, new filter, unit runs when hose is detached but immediately turns off when hose is attached but hose has no obstruction, etc.. i was told i need some sort of valve. HELP! I have birds, a cat and 2 large dogs and no vacuum :)

There is a vacuum hose that attaches inside the unit to a round clear plactic piece. In most cases you can simply cut the small vacuum hose and it will fix the problem. ... Electrolux Epic 3500 Vacuum

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.

Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

Won't start orange canister type,has change ba light hepa &motor filter,and power hose and beaterhead,put new filters in checkedthe hose,made sure it wasnt clogged

Take an AC VOLT Meter and place the leads of the meter where the power cord terminates,one on the white lead and one on the black. There should be 110-120 volts AC. If that is good then move one of your meter leads to the other side of the on switch ... Electrolux Epic 6500 Vacuum

I Have two questions concerning my AIRVAC AV2500 Red Series Vacuum System. How do you replace the light in the floor power head sweeper and can you replace the permanent fabric filter? We had the system installed in 2004 and the light in the sweeper head just went out and can not find any manual on line on how to replace it. The filter if not torn but avter 6 years it probably needs some kine of cleaning or replaced even though it says permanent. Any help would be appreciated. Jim McCluskey

... Vacuums

Poor suction (new bag, clean filter, clear hose)

Check the impeller on the moter it may be missing a fin or two (question does it make any unusual noise or vibration ?) ... Vacuums

I have a Kenmore central vacuum cleaner model number c107 34601. We have emptied the bucket and shaken the filter out to clean it. There is a filter that is filthy so we shook it out into a bag but the cleaner still seems to not have great suction. I notice there is a similar cap to the outlets I plug the central vac hose into on the unit itself that doesn't power the nozzle when used. 1 - what is this for? 2 - Should I somehow remove the entire filter and if so - can you tell me step by step ho

... Electrolux Vacuums

My electrolux lux 2000 kkeeps shuting down as though the bag is full(bag light) even with new bag , hose is clear but shuts down as soon as air flow is interupted an any rate

... Electrolux Vacuums

Poor suction I have a hoover hush s5627 vacuum purchased about 4 years ago from Costco. It's suction power isn't so good anymore. I've checked all the lines & hoses and they're clear and I've changed the bag. I even disconnected the pipe from the vacuum unit and held my hand over the intake. While the machine roars like a jet engine the suction power just ain't like it used to be. What could possibly be the problem?

This vaccuum has a Fan Blade inside connected to the motor that spins to create the suction you feel. After a few years of use (and misuse) the blades on this (plastic) fan will be broken off, thus damaging the unit. These Fans are replaceable if yo ... Vacuums

My dirt devil quick lite has lost it's suction power. I have checked all the hoses etc for clogs or debris.I bought it in Dec 2010. I think maybe it needs a new filter. Where can I find an F44 filter or do you have any other solutions?

... Dirt Devil Easy Lite Quick Vacuum

Faithful Sebo X1 upright, about 12 years old, stopped working today. I replaced old with new dust bag, checked all dust paths were clear, checked main brush was clear/clean, and drive spindle rotated OK with fingers. When power switched on, the two red indicators briefly flash on then off, but nothing more happens, motor does not start - even with power reaching machine. Tried removing all consumables, refitting and turning on a few times to reset, no joy. Removed base cover, both belts were i

At 12 years, this vacuum has had a good long life. I suspect the motor is shot, but it could be due to faulty wiring and connections. A bad switch, break in the power cord, and worn brushes in the motor are other causes.\015\012I recommend ta ... Sebo Automatic X1 Bagged Upright Vacuum

Hoover ultra upright. No suction. It has new bag, new filter, hose is not clogged. What can cause it?

... Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.

Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

I have a Eureka Boss Power Plus and the beater bar is rolling, the belt is turning, but after vacuuming up around the litter box (not a lot of litter), when I turn the vacuum off, the litter, or even household dirt, falls out. When I hold the vacuum back to turn it off so that it doesn't fall on the floor, it's sitting in the cubby where the wheels are. The bag is empty, the hose is not plugged, the hose is securely fitted on both ends of the unit. This vacuum was purchased in July and is being

Even though the brush is spinning, you probably need to replace the belt because it is s ... Eureka Vacuums

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Full bag light goes on even with new bag and filter

It is due to defective switch . replace it . ... Electrolux UltraLux 2000 Bagged Canister Vacuum

I bout this vacume in mid December 07 and about February-March it started not picking up the dust on the floor. So in early April I bout a new filter and it still wasn't picking up the way it had in the beginning. I've taken it a part several times and cleaned it out with it being plugged at the bottom hose with dust bunnies. Well I just took it back to Walmart where I purchased it and I failed to keep the reciet they could not do any thing about the sweeper. I went back to the sweepers and re

Pull the hose out of the holder, is there suction there. If not, then there is a clog in the hose. If there is suction, then check the dirt outlet by the brush roll. Also if the belt is slipping, it may appear to not have as much suction, belts wi ... Dirt Devil Vacuums

Hose i put a new bag in but the hose has vey little sucking power to it

Either the hose or the inlets are clogged. ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0910 seconds