Having problems with your Electrolux Vacuums ?

Helping out someone that has a ECV 1590A model 117A Electrolux central Vacuum. There seems to be a problem with the brushes. I'm looking for a manual or what brushes to get or a new motor. It seems to run fine what it starts.


Answers :

Repair Help & Product Troubleshooting for Electrolux Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Helping out someone that has a ECV 1590A model 117A Electrolux central Vacuum. There seems to be a problem with the brushes. I'm looking for a manual or what brushes to get or a new motor. It seems to run fine what it starts.


... Electrolux Vacuums

I have a vax cylinder model V-094. Working fine then started to play up. Switch it on and the motor seems to struggle to power up. Kind of wurrs up and down. Was thinking it could be the brushes have worn. Tokk to bits and cleaned her up, took a look at motot and brushes, cleaned them too, back together and still them same problem. Help please, hoover is not old but has done some work really don't want to through away something that can be fixed.


Hi.\015\012\015\012after all you have done I would be pretty confident its the motor thats faulty they are expensive to buy so machine is going to be scrap,\015\012\015\012Sorry.\015\012\015\012 ... Vacuums

The brushes and the belt are not rotating. The power seems fine and there is suction. I have no other history on this problem since I was given this almost new unit over Thanksgiving. Where should I be looking for a problem/solution.


If you've got suction, but the brushes and belt are not rotating, then either the belt has come off the motor shaft, or the belt is broken and just looks OK.Remove the bottom cover off the floor head and check that the brush roller turns ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Brush Roller Wondering if I need a new brush as well as a belt. The Roller seems to have trouble spinning when it makes contact with the carpet no matter how the height is set. Everything else seems to work fine. Do I need a new roller to fix this problem?


The bearings can go bad in the brushroll. It may need replaced, even if the brushes aren't worn. Helpful link....\015\012\015\012 ... Kirby G6 Bagged Upright Vacuum

Eureka 2961AVZ Will not start ...I get a momentary flicker of power about every 3d or 4th time that I flick on the power sw. Outlet is fine / Plug looks good / chord looks good / I see no obstructions ........Would appreciate any helpful thoughts ....Trying to get Mom's Eureka 2961avz back up and running. Thanks


CAREFUL! This is how my problems started. The cheap switches (and wiring) Eureka is using in some models, especially my model) should provoke a lawsuit imo.Here's my story, just in case it might help. Mine started with a problem very similar ... Eureka 2961AVZ Bagless Upright Vacuum

I have a Eureka 4870GZ. It turns on, but the brush roller doesn't move. The belt looks fine. I do have an extra belt and would try replacing the old belt, but I can't get the old one off the motor shaft or the new one on. I called Eureka customer service. The lady said there's supposed to be a small space between the motor shaft and the outside edge of the vacuum where I can slip the old belt off and the new one on. I don't see it. It looks like the motor shaft goes into a recessed place in the


Remove the top cover so that you can access to belt, You'll find 2 rows of 4 decorative holes on the top cover, In two of the holes you'll find the screws, Please use a flash light to see in that., Once the screws are removed, you'll be able to ... Eureka Vacuums

I have a CT600 power brush that would not power up. Thinking the motor was bad in it, I replaced it with a new CT700 power brush, I am still experiencing the same problem the power brush itself does not seem to be getting electic power, but the Vacuum unit does come on with suction.


First try connecting the power nozzle directly to the hose. If it works, the problem is due to a broken wire or faulty connection in the wands. At least one wand will need to be replaced.\015\012My guess is it's probably due to a broken or di ... Broan-NuTone VX550 Bagged Central System Vacuum

My FEIN 9-55-'13 recently started making more noise and is now officially a "screamer". There also developed quite a vibration associated with the noise which made me think it was probably bearings. So I took it apart and found no detectable play or lateral movement in the bearings, they seem fine to me. So I thought perhaps the brushes. The rotor where the brushes ride is quite black but I can't figure out how to get to those brushes, although I don't really think they are causing the noise


This problem is only caused by one thing the motor bearings are noisy, I have never found any other reason, they may look good and fell good but trust me replace the motor and the noise ... Fein 9-55-13 Turbo II Bagged Canister Vacuum

My first proheat lasted four years so I bought a new one. After I used my Pro Heat for only the fourth time my first issue occured, the gear on the pump that runs the brushes came off, so I had the one from my old proheat, I just changed the gear spindle that is screwed to the pump and fixed that problem but now it will not pump water. That is why I bought a new proheat, I could not get the old one to pump even after a new pump and made sure all lines were not cloged.


Is your new machine a 2X or like the old style proheat? ... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?


... Kenmore 34722 Grab-N-Go Upright Vacuum

Press the power button on - good got a green light (new battery) press the clean button - got a green light iRobot runs for a couple of seconds and stops, then starts, then stops. After two or three times I now have a red light on for the Status. All of the wheels seem to be clean. I used compressed air to clean the underside. But still have the start stop problem.


How many times does the red light blink before it pauses? ... iRobot Roomba Discovery SE Bagless Robotic Vacuum

IRobot rumba 4000 seems to run ok and then starts making a kinda hi pitched growling noise and slows way down. it is very clean(blown clean with air compressor)sensors are clear ,newly installed well lubricated on ends of brush and beater bar, new battery. it seems like the wheel tracks may be dragging . i have cleaned and lubricated where i could on them but can't find a way to totally remove and inspect wheel tracks.


It sounds like your Roomba's brush gears are not working. Run the robot without the dust bin to see if the brushes are turning. If they are not, the robot will need to be replaced. Contact iRobot CS for support at (877) 855-8593. ... iRobot Roomba 4000 Bagless Robotic Vacuum

I have a whirlpool personal valet steamer system that is mounted to the wall. The system was in the house when I purchased it so I would suspect it's about 8 - 10 years old and I cannot find the manual for it. When I push the start button it automaitcally cancels the set up and will not run. I have unplugged it for a while and then put it back in and it's worked before but not anly longer. How do i get a manual or can I find a repair person to look at it.


... Vacuums

My Dyson animal seems to have an electrical issue that I am unable to pinpoint. Neither the wand nor the floor vac have any suction AT ALL. In fact the vac makes absolutely no sound and you wouldn't even know that it had power to it unless the rollers are turned on, the rollers work just fine. I had this problem start about a month ago and then it just started working again after messing with it for a while, now it has happened again and I am getting a little agitated! Please Help!!!!!!!!!!!


There is a filter inside the canister, and by your description it sounds like it needs to be cleaned. if you remove the filter and blow it out using a air compressor or using a slightly ridged brush and tapping the filter out this should solve your ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

I have a Kirby Dual Sanitronic '50' Vacuum Cleaner I bought in 1966. The motor does not start when I attach the belt lifter of the rug nozzle. When I remove the rug nozzle and detach the belt from the motor fan shaft the motor starts when I depress the nozzle switch and the power switch . Seems like the brushes in the motor are worn out. I do not have a manual for this unit. Can you assist me as to what newer unit is this compatible to and the problem I'm having at present??


... Kirby Vacuums

Elkay drinking fountain M#erpb28c continuously runs, having problems getting mounting nut back onto bubbler, seems basin should come off for access, however needind a reapir manual or access instructions to make repairs..please help


The Elkay fountains are turned on by a solenoid powered valve. There is a rubber grommet in that valve assembly that gets holes in it and then water gets behind it, causing the valve to stick on. To test that it is a solenoid problem, turn the wate ... Vacuums

My Kenmore canister model (116) 26212601 works in hard-surface mode (basic suction), but the brush won't spin for carpets, and when I try to turn it on, it makes a whiny sound and then turns off as it does when I need to press the overload button. I looked inside a bit, and the belt isn't broken--it seems fine. So not sure what the problem is. Thanks for any help.


... Kenmore 27815 Bagged Canister Vacuum

Runs but doesn't vacuum/****. Sidebrush works fine. Cleaned the roller brushes, and that seemed to confuse the robot and now it keeps going backward a few inches, turning, and then starts going backward again.


Sounds like a sensor problem. pull and clean the front black/white caster assembly and the revealed movement sensor and the 4 cliff sensors along the bottom of the front. Make sure the front caster wheel turns freely. You may have to remove the rolle ... iRobot Roomba 560 Robotic Vacuum

Bought a Kenmore Progressive canister vacuum at a garage sale that looked in better than average condition, filters clean, new bag, all accessories intact, some debris in roller brush. problem is no suction when turned on. There does not appear to be any obstruction in hose. did not have manual


Hello,Carnister vacuum cleaners are all built with the same principle in mind. A motor \015\012generates power which powers a vacuum which, in turn, creates suction to\015\012 lift debris. The most common areas of suction loss are within ... Kenmore 25512/ 25513 Progressive Canister Vacuum

Burning smell There is a burning smell when I run my Kirby Ultimate G.  The smell seems to be coming from the belt.  I looked at the brushes and they are spinning so the belt is working.  the Post on the vacuum is getting very hot not sure if that is normal.  What is causing this?


Unlock the sweeper brushes and take them out. on each end is a cup bearing and should be free of debris.then check around and under the belt and likely there is debris wrapped around it.the post is getting hot as your pulling too much of ... Kirby Ultimate G Bagged Upright Vacuum

We have a series e rainbow cleaner. my wife had been using it i turned off and turned the canister up sie down to get the serial number. it would not turn back on.we need a new hose and thats why i was looking for the serial num. it has a rocker switch and the motor will work on low but will not run on the suction side. i have checked the wiring harnesses out as best i could without taken it all apart. im wondering if it may be the switch. it started once and then stopped.


There is one way to verify if it is the switch.It's kind of dangerous though,but not too bad.You need an extra piece of wire,fairly thick.I would use 4 guage myself.Hold it with pliers,just in case it gets hot.Turn the switch on and hold the wire to ... Rainbow Vacuums

Noise My Dyson DC08 is making a loud, rough, vibration/noise that seems to be coming from the from the rotating brush housing. I replaced the old belt which was several years old and slipping. When I run the motor with the new belt removed the machine sounds normal. The bearings on the rotating brush seem to be running smoothly when turned by hand both when out of the brush holder and when installed in the machine. I can't find anything rubbing on the belt or rotating brush. I applied a bit o


Hi there, it's Jack at Dyson.\012I'm sorry to hear you're having difficulty with your Dyson vacuum. From your \012description, it sounds like the model number you've supplied may not be correct, \012as DC08 is a cylinder vacuum which doesn't use ... Dyson DC08 Cylinder Bagless Canister Cyclonic Vacuum

My model F5906-900 --- problem is the brushes have stoped working... I pulled the brush assembly out by holding the two tabs, and all seems clean and the brush assembly rotates easly... onced the brush assembly is removed. What I did notice is the female driver slot (found in the main assembly unit) that drives the brushes seems stuck..Is that normal when the machine is not hooked up to power? How can I get the brushed going??? it is a good machine, but the brush options is important too it's ab


(1) Assure the Brush Control on the hood is NOT set to the OFF position.\015\012(2) Remove the brush assembly by pulling/unlatching it from base on each side.\015\012(3) Does one of the brushes ... Hoover F5906-900 Upright Steam Vacuum

I just used my Bissell Proheat, when I heard the vacuum sound get lower and lower then suddenly something "gave" and it got very loud and started emitting a burnt rubber smell. It still worked to put liquid into the carpet; seemed to have trouble getting it out. I checked the tank, filters, belt, and roller and all seemed OK - but when I started up again and looked down I saw sparks in the motor/belt area and shut it down immediately. Any thoughts?


The bearing that is located at the top of the vacuum motor has failed . Because of that the shaft of the motor's rotor is out of position and the pulley attached to it has started rubbing on the other pulleys, giving you that smell. the spark appear ... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

Bissell 8920 proheat x2 brushes not turning i only noticed this after i finished cleaning.. or kinda cleaning because of the brushes ntot turning.. water comes out fine suction is fine but its not scrubbing so its not as clean as it could be. manual part works well water coming out hot. I did take it apart and cleaned off all the hairs in hopes maybe that was it.. put it together still nothing.. No idea how the belts should look onit and i cant find a picture or a video showing how belts look o


Hello,\015\012\015\012Here's a link to a very helpful video that shows you step by step on how to access and replace the belt on your machine. When the brushes stop spinning, but the rest of the machine works fine, this is a tell-tale ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.2384 seconds