Having problems with your Electrolux Vacuums ?

My FIL purchased an Electrolux bagless canister vacuum model EL5 76501 last year. When I tried to use it today, the hose keeps pulling out of the power brush whenever I pull it towards me. it doesn't seem like anything has broken off. The only thing I noticed was that the rubber ring washer seems to be flattened. Could it be something that simple or do you think some part has fallen off and gone missing? Regards, Craig Somersett


Answers :

I believe I've just had the same problem and after searching for a small gray horsehoe clip that needs to first be found and then inserted into the slot for it on the tube section that comes out of the beater bar. Insert this clip from the outside after placing the hose attachment over the tube. Once figured out it is an easy fix.
Repair Help & Product Troubleshooting for Electrolux Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My FIL purchased an Electrolux bagless canister vacuum model EL5 76501 last year. When I tried to use it today, the hose keeps pulling out of the power brush whenever I pull it towards me. it doesn't seem like anything has broken off. The only thing I noticed was that the rubber ring washer seems to be flattened. Could it be something that simple or do you think some part has fallen off and gone missing? Regards, Craig Somersett


I believe I've just had the same problem and after searching for a small gray horsehoe clip that needs to first be found and then inserted into the slot for it on the tube section that comes out of the beater bar. Insert this clip from the outside af ... Electrolux Vacuums

Where can I get replacement rubber "o" rings for my Alto Nilfisk Dynamic 4350 pressure washer? I can't seem to find any data relating to the size of the rings for the hoses and accessory wands etc


... Vacuums

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

My Miele capricorn has started making an odd noise. It seems like something is blocking the engine. I've turned if off and on, and reset it and it still have the odd, almost loud barking noise. The power nozzle also does not seem to be working. I've checked the connections. Right before this happened I was using the vacuum. I didn't notice anything out of the ordinary until this.


Greetings,\015\012\015\012This is a major problem. The Miele vacuums motor should never make a loud noise, period. The way the motor is designed, it's quiet and should be quiet for the life of the motor. There are two motors on your ... Vacuums

My filter queen majestic quit working. I opened up the unit to see what was wrong and I did not immediately notice anything wrong. Upon furter examination I noticed one of the traces on the printed circuit card was burnt. I used a soldering iron to "bridge the trace and it appeared to fix the problem for a while. Now it has stopped working again, and when I jumper the trace to run the motor it seems to work. Should I just replace the card? Or is there a more serious problem with too much current


I recommend replacing the card. Soldering involves the risk of further damaging the card, so it would be useless anyway. Why waste valuable time?\015\012There is a possibility of the motor overheating, generally due to a blockage in the airfl ... Filter Queen Majestic Canister Vacuum

The vacuum turns on but wont run smells like burning rubber I took the bottom off and the belts dont appear to be broken but the one connected to beater bar seems like it may be loose


Http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=542493\015\012Generic problem for all Vacuums\015\012The vacuum turns on but\015\012Posted by mmetcalf on Apr 24 ... Vacuums

I own a Hoover Turbo power windtunnel 6500 12 amp vacuum, and it doesn't seem to be vacuuming up the dirt. I tried getting all of the hair unstuck from roller at the bottom and looked at the belt, and it's not broken. Is there anything else I can do?


... Hoover Windtunnel Turbo Power U4645-930 Vacuum

When using my hoover wind tunnel the last few times it has emitted a burnt rubber smell so my husband checked the belt and is wasn't broken or off but now when I use the vacuum the beater bar doesn't seem to be going around as well as it should be can you help


I take it the belt was put back on !! i would say hubbi forgot the tension arm a little black striker that can go in two ways but put in back wards it will not tension the arm ... Hoover Self-Propelled WindTunnel Bagless Upright VacuumVacuum

Rubber ring in tank broken - Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum


... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

MY dc07 MAKES A LOT OF NOSIE WHEN IS USE ON CARPET MODE ONLY. SOUNDS LIKE SOMETHING IS IN THERE OR THAT THE RUBBER BAND IS COUGHT OR BROKEN. THE BAND SEEM TOBE INTACT. [email protected] TANYA


Hi there SmartAlec here. The noise is coming from the clutch, you have either got something caught in the roller or maybe the bearings are siezed in the brush roller. I have made a video to show you how to fix either problem. If the video is helpful ... Dyson DC07 Bagless Upright Cyclonic Vacuum

I heard that a class action lawsuit against Oreck Vacuum is being started because of all the problems customers are having with their vacuums. Does anyone know about this? My Oreck is only a couple of years old and keeps burning up belts. I took it in after only one week of usage when I started to notice white smoke coming out of it and the smell of burning rubber. I feel like I got the old run-around, when the service tech told me he couldn't find anything wrong (but replaced the burned up belt


You are correct about the fact that legal action has been taken. Go to this link to read more\015\012\015\012 ... Oreck XL2200 Bagged Upright Vacuum

Hi, I have a Dirt Devil Model # M08100REDC. I desperately need to change the bag, but I don't see an obvious way to do it. I'm afraid to try pulling on the cloth tab thingy that's just below the handle, between the rubber ring that holds the bag on the vac, because it seems like stuff will fly everywhere from the force required to remove it, and I might not be able to get it back on there. Should I just pull on that cloth tab until the bag comes off? Thanks, Roberta


You can pull on the tab to remove the bag, but probably a better way is to gently pull on the rubber ring that attaches the bag to the back of the vacuum body. If you don't yank and ****, it should come off without spilling the dirt. There may also b ... Dirt Devil Classic M08100 Bagged Handheld Vacuum

The Lower body of the Bissell QuickSteamer, water pours out from the body. Solution: I took apart the machine and there is a spring loaded valve with a rubber washer at the bottom. Think of the letter T upside down with the rubber washer on it. The washer stretches over the bottom and the spring creates a leakproof plug and won't allow water to pass till the button on the handle is pressed. This old washer came partially off and allowed water to leak. I purchased from the plumbing dept. a mi


... Bissell Vacuums

Belt seems to have broken where do I get new belt for my eureka


If this is the same model as the one you have dont forget the 402A has a brush roll on/off function located on the main power switch so that it can be used with the beater bar on or off. If you remove the sole plate you'll find a toothed drive belt. ... Eureka 402A Bagless Upright Vacuum

Hoover Wind Tunnel 7500 Brush not Turning. I have replaced the Brush and the belt. The problem does not seem to be either to me. I believe might be a missing part. The place were the belt hooks on is a metal pole which never seems to grip the belt well. In fact it seems loose most of the time and slips on the brush, causing the belt to eventually burn up. Could there be a missing plastic or rubber piece meant to hold the belt taught  on the metal pole?


Check the Idler Pulley part Number 43241004 (Item 13 in the IPB)http://64.49.205.183/v/u6451900.pdf ... Vacuums

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.


Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?


Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

On-off switch My problem is finding a source for an on-off switch for an electrolux vacuum sweeper model 2100. I have replaced the broken toggle and now the sweeper turns on but only as long as the outside button is depressed. It appears that the on-off switch itself is broken as the switch does not ''hold'' when the toggle is activated. It seems to return to it's ''off'' setting as soon as the toggle is released. What ''holds'' the switch in its ''on'' position? Does it depend only on the on-


Hi Hugh. The 2100 has a rocker switch under neath the button. it is probably broken, or the button has a worn detent spring. If you would like, I could send you a switch kit with the rocker, button, and detent spring enclosed for around 20 dollars ... Vacuums

When I vacuum w/ the brush control in the on position it make a really loud noise, almost like a grinding sound. I have looked at it and nothing seems to be wrong, but I notice that the pin that engages the belt seems to vibrate a bit, possibly creating the noise. It started when I accidentally got part of a plastic grocery bag caught in the brush. Could it have stretched a belt? Nothing is caught any other place and it only makes the noise when the brush in in the on position.


Yes, the belt could have been stretched and is now vibrating and hitting other parts and creating a noise if much of the bag got caught under the belt. If you have another belt for this vacuum, please put it on and see if the noise stops. If it does ... Hoover U5780-900 Windtunnel Cyclonic Bagless UprightVacuum

My hoover windtunnel is not picking anything up all of a sudden. Also the roller underneith is not spinning. I've replaced filters and the attachment part is working fine, just when it's in the upright position it won't pick anything up. It also doesn't seem to be self propelled anylonger either. It use to **** everything up, including the dog. Please help!


The belt that drives the brush roll has broken. That's why it doesn't pick up and why it doesn't pull itself forwards. Check the User Manual (download from Hoover website if necessary) for information on replacing the belt. Good luck! ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

Floor tool wheel will not revolve on dyson dc08 origin vacuum - seems to be jammed. How do I disassemble the unit to fix the problem with the wheel. Everything seems to be clicked in. I do not want to force anything - I might just break it. Any help will be appreciated. Thanks.


Hi,The wheels on the floor tool get junked up with hair pretty quickly, at least they did for our Dyson. The metal peg that holds them in has grooved teeth to prevent it coming out easily, but it will come out if you get a claw hammer an ... Vacuums

Windtunnel belt I have a new Hoover Windtunnel canister. The belt keeps coming off. It happened a couple weeks ago (several times after putting the belt back on) so I assumed I might need a new belt as it might have dried out at the store. I ordered new belts and today I used it for about an hour and the belt came off again, twice. There doesn't seem to be anything to hold the belt on the stem as it seems to slip off. I have tried it centered, to the left and to the right....can you help. I am v


I've successfully used a compatible belt - Royal 104425001 .It's still new, but for the time being at least - it works. ... Hoover S3765-040 WindTunnel Bagless Canister Vacuum

We have the bissell quicksteamer and as I was shampooing I began to notice something burning so I unplugged our machine immediately; then my mom and I started cleaning all the filters assuming that could be the source of our problem and yes it was a little dirty but I suspected that it would take more thant that to cause our machine to somke soI turned it upside down and noticed there is a cable of copper threads that appear to have some type of rubber or plastic insulation tubing around it but


Was the exposed copper wiring on the electrical cord? If is then replace the cord. The main problem with this model is that Bissell obsoleted it as well as parts for it. But if all you need is a cord, you should be able to get one from a repair shop. ... Bissell 1960-3 QuickSteamer Plus Upright Vacuum

No suction. I have followed the detachable parts no suction. I have followed the detachable parts and it seems to have suction through to the base but doesn't pick up anything significant. I have looked through the hose connecting the base but I can not see anything obstructing it.


Poor suction can be caused by obstructions, poor air flow or a compomise in the air flow (hole in the hose). Since you have started with that I would next look at all filters and clean them. First check for suction at the motor, then at accessory hos ... Vacuums

No vacuum My Floormate has plenty of air moving, but no vacuum at the nozzle. When I turn it on, the filter hops up to the black rubber "intake", rather than staying in its spot. It seems to me that the intake should be in contact with the filter when the reservoir is installed. And I don't understand why the intake isn't closer to it, but it seems fixed there, almost an inch higher than the filter. When I remove the bottom reservoir and turn the h3000 on, I feel vacuum at the intake, and air


Someone must have lost the filter cover from the machine. It is a clear blue plastic cover that goes over the filter and has a hole that lines up with the motor intake. It is approx. 3 inches square and has an angular top to coincide with the motor i ... Hoover Floormate H3000 Upright Wet/Dry Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0530 seconds