Having problems with your Electrolux Vacuums ?

My suction motor won't run on my electrolux Prolux vacuum

\015 When I turn on vacuum brush turns but no suction\015

Answers :

Repair Help & Product Troubleshooting for Electrolux Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My suction motor won't run on my electrolux Prolux vacuum


... Electrolux Vacuums

No suction on my Electrolux central vacuum in all outlets even though motor is running and there is no clog in the hose.


I would start with washing out the ilter really good and letting dry. then try the system. ... Electrolux Central Vacuum

The Electrolux Prolux upright vacuuum cleaner vacuum motor is not running and the brush is working well. What is the problem and how to open up the cleaner


... Electrolux EL5010A Bagged Upright Vacuum

My Electrolux Upright vacuum cleaner will not suction. Motor will run to turn roller, though.


The air passage form the brush area to the bag is plugged somewhere. Remove the lower plate and the bag above so that you have access to the air passage from both ends. A hooked, stiff wire will help pull the debris out. This problem is usually cause ... Vacuums

No suction After taking the vacuum apart, I noticed there is no suction at all. The motor runs, belt runs, but no suction coming through.


You have a clog somewhere in the vacuum. Check the hose and the little trap door on the underneath side of sweeper.Does the brush turn? If not, then the belt that drives the brush is broken. Replace the beltJim ... Hoover Tempo Widepath Upright Vacuum - Blue

No suction My Hoover Wind Tunnel vacuum runs but there is no suction. The last two or three times I used it, it shut itself off after having a burning smell. When I unplug it for the suggested 30 minutes, the motor will run again but no suction. What is wrong?? Should I just buy a nve one? This one is 8 years old.


Sounds like your motor bearings are going bad. This is generally indicated by the motor overheating, and the heat transferring out through the motor pulley, which is where the belt attaches. So, your machine is overheating, melting the belt, and then ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Brand new LG LUV200r used 10 minutes now after removing dust tank & reinstalling the vacuum motor does not run only the beater bar??? I have located wo circuit breakers both seam to be set. This suction motor should run when the switch is pressed & the beater bar should operate when the handle is moved down??? Not A happy customer will return unit to Best Buy only 100 mile round trip!!!! RDH


... LG Electronics Kompressor Pet Care Upright Vacuum Cleaner LUV200R

On an old upright prolux plus, I just replaced the belt and cleaned out the brush motor, ran the vacuum for a bit, then the vacuum motor died...it's always run great. any suggestions of what to check?


... Electrolux Vacuums

Hi I need help because I have a problem with my Electrolux Centralux Central Vac system in my house. When I plug the vac hose in the central vac socket at first I heard the motor running very gently with NO suction then after a minute or so it went completely dead and they is NO motor sound, suction, or anything happening what so ever. Can anyone tell me what this problem is???


Have you checked for a clog in the lines or in the hose? If there is no clog in the system anywhere, then your motor could be dying. ... Electrolux Centralux Vacuum

Electrolux 2 in 1 Ergorapido stick Vacuum. Motor runs then cuts out after 3 - 4 seconds. Sometimes it will run properly for 10 minutes so batteries are good. Why does it cut our usually?


If the hand held is working correctly (By itself) try pulling up a little bit on the 4 metal connection tabs on the wand. The connection tabs were not making a proper connection on my unit. ... Electrolux Pronto 2-In-1 Stick/Hand Vacuum - Cayenne

How do I gain access to the motor of an Electrolux 2000 canister vacuum. The air intake on the motor must be partially blocked as there is a loss of suction and the motor makes that high pitched whine like it does when you cover the hose with your hand


Dismantling the vacuum probably won't help much, and reassembling can be a bear. \015\012To check the intake, remove bag and look into bottom of bag well. It there's a filter there, remove it and check intake at bottom of bag well. Clear if t ... Electrolux UltraLux 2000 Bagged Canister Vacuum

The motor running the beater bar on ny Electrolux canister vacuum cleaner runs intermittently. It runs about 2 minutes and then cuts off and automatically starts again after a 1 to 2 minute interval. I have tried taking it apart and removing the dust and grit in the beater bar attachment but with no change in operation. What would you suggest?


Check all the wiring connections to make sure they're tight. \015\0121/2. Wiring to power nozzle motor or reset switch is loose.\015\0121. Cord from power nozzle to upper wand. If the plastic portion of the wand is cracked near the co ... Electrolux UltraLux 2000 Bagged Canister Vacuum

Series 6500 motor shuts off, vacuum continues to run, not suction


It's tripping the temperature overload in the motor. The most common cause for this is a clogged hose. Take the hose loose and attach it to the exhaust port under the back cover. You should be able to see if it's clogged and unclog it. I might also s ... Electrolux Epic 6500 Vacuum

I have a Kenmore Elegance model 116 that has lost suction. There is no blockage and both the filter and bags have been changed. The powerhead turns on but the vacuum itself is fairly quiet, not sure if that motor is running. How can I regain the suction?


... Kenmore Vacuums

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos


It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

My kenmore vacuum model 116.36933502. It has no suction. I have cleaned out every spot,taken off the back and still nothing. The motor runs but doesnt seem to be at full power. The agitator brush works. When it broke i seemed to smell something and since it has no belt. Does this possibly have to motors?


... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

No suction - motor runs, belt running. - Vacuums


Clogs, som,e times on the bottom there is a pan and a hose opening secured, if its clogged, it won't work, open the bottom where there should be a small latch, also I have used shop vacs to **** clogs out threw hoses? ... Vacuums

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.


Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

Electrolux Prolux Plus Commercial Heavy Duty Upright Vacuum Cleaner brush didn't run


... Electrolux Vacuums

Electrolux Prolux Plus Commercial Heavy Duty Upright Vacuum Cleaner brush didn't run


... Electrolux Vacuums

My machine ran over some string,made a funny noise and emitted some smoke,the hand suction pipe at the rear works perfectly, the motor runs fine,but the front of the vacuum will not work.thankyou very much, Thomas.


The string bound up the beater bar (brush), keeps the belt stationary, and the motor spindle is just rubbing against the belt and melting it. remove the belt guard, remove the brush, and the belt. clean off the brush bearings (at the ends of the br ... Panasonic Vacuums

Vac motor runs but belt wont turn - Eureka Power Plus 4703D Bagless Upright Vacuum


Its time to check and/or change your belt. to do this you want to remove the two screws on the top casing and remove the cover. There are detailed belt change instructions on a sticker under the top casing on how to remove the brush and b ... Eureka Power Plus 4703D Bagless Upright Vacuum

Motor runs vacuum has suction on attachment but brushes won't Rotate


This problem is most often caused by a broken brush roller belt. Sometimes, although very rarely, there is a separate motor which turns the brush, or there may be something that is causing brush roller to bind so that a belt does not last long. I do ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

I have a windtunnel 2 vacuum. It sucked up a cord that wrapped around the beater bar. Now the bar won't turn. There was no smoke or sign of something burning. The motor still runs and there is suction but no turning. We have it apart but nothing is obvious. What should I check?


Check the actual beater bar for movement. I have seen the plastic melting, and bearings seized under such circumstances. Also I am unsure by your question, but the motor that creates the vacuum (sucking) is different than the motor that spins your ... Vacuums

Motor runs,brushes turn,no suction - Vacuums


Either the fan on motor is broken or off shaft or the unit is plugged,if its plugged the motor will sound like its running faster than usual ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1318 seconds