Having problems with your Electrolux Vacuums ?

Z330A Suction & Motor Good. Continuity of running is broken with any pull on the hose

Answers :

Repair Help & Product Troubleshooting for Electrolux Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Z330A Suction & Motor Good. Continuity of running is broken with any pull on the hose

... Electrolux Vacuums

Does not pick up, no vaccum, motor runs, no blockage, should feel suction on hose outlet without hose hook up. Paper filter missing over cloth filter. float overload ball free, seal on section good no leakage. Maybe bad motor but runs.

Here\015\012 is a Link to one of my Tips:www.fixya.com/support/r6311178-vacuum_brush_bar_not_spinningThis\015\012 should solve the problem. ... Minuteman C82906-01 HEPA Vacuum Vacuum

I have Nutone VX550C. Motor runs intermittently (cycles on and off rapidly--the light on the handle is blinking furiously) when I use the on/off switch on the hose. This happens at all of the wall connectors, so suggests a hose contact problem. Motor runs continuously when I turn it on at the switch on the wall unit.

The unit does have a switchs the PVC outlets, and it sounds like the hose mech to operate the switches is broken, and intermittently making contact. A replacement hose would likely fix the problem. Looked them up on the net, and they're not che ... Broan-NuTone VX550 Bagged Central System Vacuum

Blocked suction The FLOOR suction line (Hose) is clogged. I Can vaceum the floor, but it will not pick up anything because the hose to the bagless canister is blocked. I can switch from floor to hose and can vaceum furniture. it will not pick up off the floor. I have tried running a wire down/up the hose. I Can feel the blockage, but I cannot get it out. I am afraid to pull the flem hose out as I do not know how it is attached at each end.

Hi,Here is a tip that I wrote about my Bissel ... the hose should just pull out... it is just stuck in there tightly...\015\012Bissell Bagless Upright Vacuum ... Royal 088500 Featherlite Upright Vacuum

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.

Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

Hoover SteamVac Model F6056-900 SteamVac/SpinScrub. Indicator light and high pitch suction noise indicates that dirty water tank is full. However, water level indicator (yellow bobbing plastic thing) is at the bottom of the tank and there is no water in the tank. Have check all the hoses for clogs, none found. Checked water port from motor area to receptacle tank for clogs, none found. Fixed broken hose to upholstery wand with duck tape, (wire not broken, just cracked plastic hose). The onl

There are 2 filters, make sure they are clean, one is on the tank lid, the other is from the bottom, it is red, pull it out and clean it. If yours has a foam filter on the tank lid covering the yellow ball, make sure there is at least a 1/4 in. gap ... Hoover Vacuums

My Eureka/The Boss doesn't seem to have the suction power it had. However, when I place my hand under the hose, it has good suction, then when I try to pull in a small particle, it doesn't, unless I have the hose nozzle completely over the particle. The vac is 10 yrs. old. I cleaned everything. Someone said the belt. Would the belt matter if the hose doesn't **** well? It is just old and worn out? It did shut off recently do to overheating. Help. Thanks. Lorraine

Doesn't "The Boss" Vacuum have a filter? Perhaps your filter is clogged and not allowing it to work properly. ... Vacuums

No suction I have the central vac type. It has no suction at the can. I pulled the hose going to the walls and tested there...and nothing. I removed the dirt can and checked the motor ...it is spinning but does not feel like any suction. I checked the exhaust and it is pushing strong air out. I also cleaned the filter and still nothing. Is there a relay or something that would cause only exhaust air. I emptied the can of dirt and put it back together and have absolutely no air.....hear the motor

On some units there is a screen that protects the impeller of the motor. If this gets sealed off with debris then it is like putting a potato in the tail pipe of a car. Taking the top off the unit reveals the motor. DO UN-PLUG the unit first from th ... Electrolux Central Vacuum

My vac has lost suction. When I vacuum it picks up very little, but when I remove the wand hose it has good suction. We have cleaned both filters, checked for blockage in all hoses & cleaned the beater bar brush. All to no avail. Is it the motor? Or is there a blockage deep in the vac somewhere? We're debating repair versus buying a new one. Hope you can help. Thanks.

Hi there,Sorry to hear you're having a problem with your DC14. Since you say you've already washed the filters and checked for blockages, it's probably best if you get in touch with us so we can run through some simple troubleshooting ste ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

Hi I need help because I have a problem with my Electrolux Centralux Central Vac system in my house. When I plug the vac hose in the central vac socket at first I heard the motor running very gently with NO suction then after a minute or so it went completely dead and they is NO motor sound, suction, or anything happening what so ever. Can anyone tell me what this problem is???

Have you checked for a clog in the lines or in the hose? If there is no clog in the system anywhere, then your motor could be dying. ... Electrolux Centralux Vacuum

Bissell powerforce My lower pickup tube became clogged so I removed it and cleaned it out and reinstalled it.Now everything runs good but the vaccum want pick up any dirt .I replaced the bag andf when I turn it on it just exhaust air but does not have any suction,I tired tp pull the bag door of while it was running whick I could not do so it has plenty of suction inside just not getting any outside can you help?

... Bissell Vacuums

Poor Suction Heya! So I just picked up a used Dyson, but when I vacuum with it, the suction is pretty weak and it spits all kinds of stuff out the back and into my feet. When I pull the hose I have good suction, but in regular mode it hardly picks up anything. The brushes are spinning, and it eventually will clean an area if I go over it again and again. Maybe a clog somewhere? Please tell me that Dysons have better suction than my $50 Dirt Devil! Thanks!

I recently bought a second hand Dyson DC07. Its suction was poor. I removed all the un-clipable pipe bits and to remove any blockage but it all looked clear. The Final Sponge and hepper filter did have a lot of dust in it and the rotating brush was f ... Dyson DC07 Bagless Upright Cyclonic Vacuum

No suction on my Electrolux central vacuum in all outlets even though motor is running and there is no clog in the hose.

I would start with washing out the ilter really good and letting dry. then try the system. ... Electrolux Central Vacuum

My Bissell BS3920F upright (similar to the 10N6F) has been working wonderfully for the past 3 years but suddenly seems to not pick up dog hair as well as it used to. It has been pulled apart by my husband to ensure nothing is blocking the hoses etc and when running the suction seems to be there. It seems to grab the dog hair and leave it in a straight line directly under the unit without picking it up. I then disconnect the hose and use to hose to pick up the dog hair. This works well but obviou

Check to see if your brush is not worn down, they do wear with age - compare the length of the bristles with a new one. Replace the brush ir there is a significant difference in bristle lengths. Also check the flexible ben ... Bissell Vacuums

Dyson Animal motor is running, beater bar is turning but very little if any suction. No suction from hose either. The inside canister is filling and moving, so there is some dirt being sucked in there. I have thoroughly cleaned all filters but not sure what is causing the problem. Any ideas?

Obstruction in the hose?\015\012Your vac has developed a hairball possibly.... when a piece of flexible media ie.... cardboard, plastic etc... gets lodged in the hose, and begins collecting hair & dust to the point it no longer has enough d ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Hello, I have a Hoover 3200 Turbo Power vaccum. while the motor appears to be working fine the vaccum no longer picks up the dirt. I turned the vaccum upside down and the belt appears to be broken. would a broken belt stop the pick up, there appears to be no suction. This vaccum is approximately 10 years old. is it worth fixing? I live in Virginia Beach Va, where would I take the vaccum for repair? my zip code is 23456- Thanks Cleta Goode

... Hoover Vacuums

The motor runs slow (so does not pick up properly) and does not run at all if the hose is pulled out. There doesn't seem to be a blockage and the roller is clean. Could it be as simple as changing the filters?

... Sebo Felix Ice Blue Bagged Upright Vacuum

Motor is pulsing on and off, suction is good when motor running

... Broan-NuTone CV653 Bagged Central System Vacuum

Low suction Have a Powr-Flite PF 18, suction is good at motor, but low at where hose comes out of top of vacuum. Could new lid seals help the problem? Where can I get new seals for this model. Also my zip is 98801 and my shop is not listed, could you add it please? Sew Creative 1139 N. Princeton Wenatchee, Wa 98801 509-663-5516 Thanks, Lauren-Sew Creative

Replacing the motor cover solved the problem, it must have been warped and was letting suction out thru it. ... Vacuums

Series 6500 motor shuts off, vacuum continues to run, not suction

It's tripping the temperature overload in the motor. The most common cause for this is a clogged hose. Take the hose loose and attach it to the exhaust port under the back cover. You should be able to see if it's clogged and unclog it. I might also s ... Electrolux Epic 6500 Vacuum

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after

... Vacuums

Currently my dyson does not work when in the upright position. When I pull the handle back, it will run, but the suction is not very good at all. I tried washing the filter, but that didn't work. Sometimes it works for awhile, but then the problem occurs after the machine has been used for awhile. What do you think the problem is?

Hi its Darran at Dyson.It sounds as though the brush bar may not be turning properly when you put the machine into the upright position. To test, lie the machine on its side in the vacuuming position (head released) then switch it on and ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

When we plug in the hose the motor in garage runs but no air or suction comes out of the outlets. we cleared all the lines too.

Check to see if you have suction at the unit. If you have suction at the unit, your pipes are stopped up. If you don't have suction, you have a pipe loose under the house. Also you could just have a stopped up hose ... Electrolux Centralux Vacuum

I have a Nutone central vacuum model number CV450W that was working great until I recently removed the hose and it now runs continuously until I pull the plug....any suggestions please

Disconnect the thin low voltage wiring between the vac and the rest of the house. If the vac continues to run you have a defective relay in the vac motor housing. If the vac stops you have a short in the wiring in the house, likely behind an in ... Broan-NuTone CV450 Central Bagged Central System Vacuum

My dehumidifier, model # HD 456E, : motor runs continually, no water being pulled, bin is always dry. Also, how do I set the humidity/temp control to keep my basement dry? D

First, check and clean your filter, since a clogged filter could be your problem. Here's suggestions for the humidity levels from answerbag.com:\015\012 \015\012On One Hand: Low Humidity Levels\015\012According to an ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0923 seconds