Having problems with your Eureka 2961AVZ Bagless Upright Vacuum ?

I just bought a new belt, put it on, took two swipes, smelled burnt rubber again. My new belt broke. Why?


Answers :

The beater bar is probably not turning. It get's jammed up with hair and strings and Christmas icicles and anything else on the floor. Taking the bar out and cutting all the stuff off is the easiest way to clear it. Make sure it turns freely before you hook the belt to it again and watch it when you turn it on to see if it's turning.
Repair Help & Product Troubleshooting for Eureka 2961AVZ Bagless Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I just bought a new belt, put it on, took two swipes, smelled burnt rubber again. My new belt broke. Why?


The beater bar is probably not turning. It get's jammed up with hair and strings and Christmas icicles and anything else on the floor. Taking the bar out and cutting all the stuff off is the easiest way to clear it. Make sure it turns freely before y ... Eureka 2961AVZ Bagless Upright Vacuum

Belt problem My belt broke. I put a new belt in, followed the instructions, seemed to be right but as I started using the vaccuum, it starting smelling like burnt rubber. The belt was extremely hot. Took it apart, tried again and the same thing happened. Please help me!!!!


Get the old lady to use a dustpan and brush instead SORTED ... Kirby Generation 3 Bagged Upright Vacuum

Belts I have recently bought new belts and when I installed the green light only comes on sometimes and I can smell rubber burning. The last belt broke very quickly so I am assuming that when I put the vacuum back together I am doing something incorrectly. Can you help instruct me?


Recently received a kirby from mother in law and don't how to change the belts ... Kirby Ultimate G Bagged Upright Vacuum

My oreck upright smells like rubber burning when i vacuum. i just put a new belt on but it smelled like that before i even put the belt on


... Oreck XL Ultra Bagged Upright Vacuum

I have two old identical 5842's that I use in the garage and around the house. The belt broke on one so I bought a bag of 2 genuine Eurika "U" belts, which is the correct belt for this vacuum. They were obviously smaller than the original belt because they were not stretched out. When I put the new belt on it lasted about 20 minutes and then came off. I put it back on and ran the vacuum with the cover off to see what was wrong. Everything looked fine except the belt rides to the outside edge of


Not 100% sure this is the remedy for that particular problem, but I would take the time to clean both of the brushes that the belts operate, one on each machine.\015\012Remove the brushes and clean as best you can. At the end of each brush there sho ... Eureka Whirlwind Litespeed 5840 Bagless Upright Cyclonic Vacuum

I have a Kirby Heritage II which normally works amazingly well, but it's not playing at all nicely today - and of course we have apartment inspections tomorrow. *dies* The belt broke today (as did the replacement belt, which I'd bought at the same time, so apparently the rubber was old), so I went over to Stark's to get some new ones - but it still won't cooperate. I've taken the head apart and put it back together several times, to be sure that everything is properly seated, but it's just not


... Kirby Heritage II Vacuum

My Kirby is brand new(Sentria). Everytime I turn it on to vacuum, it smells like burnt rubber. I've checked the belt twice, it's on fine. What am I doing wrong?


Please check out my step by step instructions.....http://reviews.ebay.com/CHANGING-THE-BELT ... Kirby G6 Bagged Upright Vacuum

I just used my Bissell Proheat, when I heard the vacuum sound get lower and lower then suddenly something "gave" and it got very loud and started emitting a burnt rubber smell. It still worked to put liquid into the carpet; seemed to have trouble getting it out. I checked the tank, filters, belt, and roller and all seemed OK - but when I started up again and looked down I saw sparks in the motor/belt area and shut it down immediately. Any thoughts?


The bearing that is located at the top of the vacuum motor has failed . Because of that the shaft of the motor's rotor is out of position and the pulley attached to it has started rubbing on the other pulleys, giving you that smell. the spark appear ... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

My belt broke...I bought a new belt..but I do not know how to put the new on on. I took out the brush roller and put the belt around it but I have no idea how to get it to go on the part that makes it move.


Hello,\015\012Here is a link to my free online guide...\015\012\015\012http://reviews ... Kirby Ultimate G Bagged Upright Vacuum

Hoover bagless cannister 3765 - belt on power head slips off spindle. bought new belts - same problem. is this a design problem or can it be fixed? I don't want to take it to a repair shop 100 miles away and have them just put on a new belt. saw idea of smaller belt - what number? couldn't find suggested royal 104425001 belt.


I would not recommend a smaller belt. You will only wear the motor. This model series power nozzle needs to have a metal clip installed near the belt on the brush roller housing. I know that most of them left the factory without it. Remove the cover ... Hoover S3765-040 WindTunnel Bagless Canister Vacuum

Belts breaking/melting The original belt broke at almost 1 year so I replaced it. I changed the carpet setting to shag even though my carpet is very low pile to make it easier on the vacuum. I didn't get to use it but just a couple minutes and could already start smelling the new belt getting hot. I checked the roller and it is easy to spin. Not clogged with hair or dirt. Now the inside of the new belt has small pieces of rolled rubber instead of being smooth. The metal shaft that goes into the


... Dirt Devil M088905 Vision Bagless Upright Vacuum

I have a kirby sentria. vacuumed up my son's headphones and immediately shut if off. took brush off, unwound headphones, put it back together. when i turned it back on, the belt snapped. so i went to vacuum place, got new belt, but when i put it on, with the green arrows lined up, it doesn't have much suction. with the red arrows lined up, it just smells like its burning and i don't want to break another belt! HELP!!


Take the front off the vacuum and check inside both the front portion and the canister for additonal clogs. Sometimes something will get caught in the impellor, causing the motor to overheat. Since there's little suction and the smell, I'd guess th ... Kirby Generation 3 Bagged Upright Vacuum

Belt slipping Belt slips off and rubs causing burning smell from the belt over heating. Of course this puts an indent into the belt and has to be replaced. How do I keep the belt from slipping off? I see no place for a belt adjustment. Which I know would eliminate the problem. Really aggravating to have to replace belt only after two uses.


On the roller/brush where the belt sits if that is scarred up or grooved out that will cause the belt to slip if you can fix roller try but i suggest new roller ... Hoover Company Wind Tunnel U53019 Upright Vacuum

I bought new belts to replace the old ones (one had broken and the water would not feed) My cousin took it apart and now I need to put the new belts on and get it back together - do you have instructions or a diagram?


There are different variations with Bissell. They have the ProHeat series and a Power Turbo series. Below is a link with instructions and diagrams for the Belt Access Door. If this doesn't solve your problem or isn't the correct model, please post ... Bissell ProHeat Turbo Deep Cleaner Upright Steam Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

I can't seem to get the belt cover off of my Kenmore Progressive 400. There are two buttons that say above "belt and bulb change" but the buttons do not move. Do you know how I can remove so I can put a new belt on? Thank you!


You have to take off the top of the power nozzel that has the light lense. There are two pressure locks,one on each side. Use a screw driver to release. You will see the screws.Take the two screws out and on some models, there are two pressure locks ... Kenmore 23612 Progressive PowerMate Bagged Canister Vacuum

I have a Eureka 4800 series the Boss upright with a bag and Hepa filter. I love it! I was just vacuuming with the hose part and all was well and then suddenly the lower brush came on and a "burning" smell followed. Thought it was the belt so my husband was going to put on the new belt which I had on hand! When he turned it over, the "bar" that holds the belt looks as though it "shot through" the plastic side of the housing on the vacuum. There is melted plastic on the outside of the vacuum and o


I had the same problem. Take out the old belt if possible. Remove the 4 screws inside the filter and the 3 on the front of that housing. pull out the foam around the motor. carefully pull out the suction tube that is press fit against the motor. ... Eureka 4874 Bagged Upright Vacuum

Bought a new sweeper and brush ( beater bar ) does not turn. The large belt is fine and turns. The small thin belt is also fine but does not turn the brush. It is either the wrong belt or is there something that could be missing to put tension on it ?? Thank You [email protected]


Jim, To put tension on the brush, tilt machine forward when upright, move carpet selector knob to carpet. then turn vac on. Brush will only spin when vac is tilted back to operate. brush stops when upright and on to use hand tools so the er is no dan ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

I thought I was buying a manual. I put a new belt on my vacumn but it makes a funny noise and does not leave vacumn lines on the carpet like it used. I don't know if it takes two belts or one.Wish I had a manual.


Hi Frrank: The Owner's Manual for the Euro-Pro Infinity NV31N Vacuum can be downloaded in PDF from the following site:http://dl.owneriq.net/d/df ... Euro-Pro NV31 Infinity Vacuum

My Dyson Root 6 made a loud banging sound, and now its motor emits a strong burning smell every time it's switched on. It runs for a second or two, making a lot of noise, and then stops. (Just bought a new battery for it, too - what a drag...) It's off warranty, and Dyson wants almost as much to fix it as a new one would cost. Is my Root 6 e-waste, or is there anything that can be done for it?


... Dyson DC16 Root 6 Bagless Handheld Cyclonic Vacuum

Put on a new beater brush belt that I bought from Sears as detailed on the plate on the vacuum. It immediately snapped. Is there a diagram for the routing for the belt (there is a drive spindle and a tensioner)? Thanks.


I would first check to see if the beater brush is turning freely. You should be able to turn it by hand. If you can not, remove it from the vacuum and clean any debris on the brush and especially on the ends that hold it in place.\015\012Some WD40 ... Kenmore Whispertone 29512 Vacuum

D.d vaccum i have a dirt devil dynamite...i bought a new for it i put it on and not even 1 minute of using it the belt broke again!!!!i dont know whats going on do i have 2 put it on a certain way does it need grease or what!


Did you check the brush roll, if the ends aren't turning freely, then it needs to be replaced also. ... Dirt Devil M084600 Dynamite Bagless Upright Vacuum

After a few minutes of using my vacume it starts to smell like burnt rubber. like the belt is burningthe only belt I can see looks fine and is turning the brush


But how tight is the belt and how easy is the brush to turn? if the belt is slopy it will slip on the motor drive spindle,,,and it will get very hot then,,, also if the brush head is tight that makes the belt slip too, ... Hoover U5780-900 Windtunnel Cyclonic Bagless UprightVacuum

HOOVER 6430-900 Runs for about a minute or two and shuts off. Wait a while and it will run again. Changed the belts, new bag, new filter. Seems to put out a lot of heat when running.


Hoover Fined for Failing to Report Vacuum Cleaner Fire Hazard\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\01 ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

The rubber band that turns the roller on the vacuum keeps breaking. I just bought a new rubber band, put it on, and it broke immediately. Can it be fixed?


Generic problem for all Vacuums\015\012The rubber band that turns\015\012 \015\012The rubber band that turns the roller on the vacuum keeps breaking. I just bought a new rub ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1124 seconds