Having problems with your Eureka Sanitaire SC4570 Bagged Upright Vacuum ?

No suction, clean bag and new belt,good brush

Answers :

Repair Help & Product Troubleshooting for Eureka Sanitaire SC4570 Bagged Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a Kirby G series diamond edition. There seems to be no suction when I turn on the vaccum. The bag inflates, but the roller does not turn. It has a new belt and the roller brush is clean. Any suggestion on what I might do to increase the suction and get the roller bar moving?


Bought a Kenmore Progressive canister vacuum at a garage sale that looked in better than average condition, filters clean, new bag, all accessories intact, some debris in roller brush. problem is no suction when turned on. There does not appear to be any obstruction in hose. did not have manual

Hello,Carnister vacuum cleaners are all built with the same principle in mind. A motor \015\012generates power which powers a vacuum which, in turn, creates suction to\015\012 lift debris. The most common areas of suction loss are within ... Kenmore 25512/ 25513 Progressive Canister Vacuum

No suction, clean bag and new belt,good brush

... Eureka Sanitaire SC4570 Bagged Upright Vacuum

The brush is spinning (and has been cleaned), there is a new bag, but we get no suction.

The reason the brush is not spinning is because the belt is stretched or broken. You can get a replacement belt here:Hoover U5491-900 Belt ... Hoover U5491-900 Bagged Upright Vacuum

I have a hoover windtunnel platinum. I have changed the bag ( hepa Q bag) but the bag light wont reset. so the vaccum wont turn on. I have unpluged it and let it set for a while with the new bag in and repluged it in. I have checked the brushes and it is all clean but it will not reset. This only the second bag so it is a new machine I should not be having problems. Is there some sore of reset button I can hit.

... Hoover Company Wind Tunnel U53019 Upright Vacuum

Have a hoover windtunnel platinum. I have changed the bag ( hepa Q bag) but the bag light wont reset. so the vaccum wont turn on. I have unpluged it and let it set for a while with the new bag in and repluged it in. I have checked the brushes and it is all clean but it will not reset. This only the second bag so it is a new machine I should not be having problems. Is there some sore of reset button I can hit.

... Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum

My electrolux oxygen cannister has the "bag change" light on when there is a new bag. The light stays on when the suction power is high (to pick up small particles) and it won't pick up, but the ight goes off when the suction power is low (to pick up big objects). I changed the hepa filter, cleaned the motor filter and changed bags, but all that didn't help.

You may have a clog in the hose, and/or the inlet by the brush roll. A clog will turn on that light as well as a full bag. ... Vacuums

No suction I have new belts. Everything is clean. No clogs. When I turn it on it smells like rubber , the brush doesnt spin. Everything seems to be free flowing.. Roller brush isnt stuck on the ends. Took off hose to make sure no clogs anywhere. There is not even suction thru the hose with the handle in upright position.

Generally, the problem is that the belt is not running the brushes.  This is caused by one of the following:\015\012\015\012\015\012beater brush is jammed.  This is either an object stuck in the brush or im ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My vac has lost suction. When I vacuum it picks up very little, but when I remove the wand hose it has good suction. We have cleaned both filters, checked for blockage in all hoses & cleaned the beater bar brush. All to no avail. Is it the motor? Or is there a blockage deep in the vac somewhere? We're debating repair versus buying a new one. Hope you can help. Thanks.

Hi there,Sorry to hear you're having a problem with your DC14. Since you say you've already washed the filters and checked for blockages, it's probably best if you get in touch with us so we can run through some simple troubleshooting ste ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

Help hi there. i have a hoover savvy u8172-900 vaccum. the hose has great suction, but there is limited suction on the main unit and the brush does not spin when i try to use the product. we have cleared the brush of any debris and have also installed a new bag. a few days ago, we disconnected the hose to make sure there was not any foreign bodies stuck in the unit...nothing seems to help. any advise?

As the hose fits into the base (if i am correct) the power at the base should be fine, make sure the base is clean and free from blockage,\015\012you say the brush doesn't spin, has the belt broken, if so replace it, (very cheap) and only a couple of ... Hoover U8171-900 / U8172-900 / U8173-900 / U8174-900 Savvy Bagless Upright Vacuum

My Kirby vacuum is a G100 upright. It has no suction. It has been cleaned and the bag is empty (new bag). My mother-in-law bought the same kind and hers is doing the same thing. It has no suction and won't pick up anything. Thank you, Rachel Souza - [email protected]

... Kirby Vacuums

Lost suction my DCO7 lost suction in the hose I started taking it apart and cleaning it and looking for clogs (probably more than I should have) and when I put it back together it has awesome suction in the hose but no suction in the base. It just pulls the pine needles up (christmas tree) but they never appear in the "bag" compartment and when I look they are just all gathered in a clump in the bottom by the brush.

Hi.\015\012\015\012Remove the sole plate turn the 3 plastic screws to unlock & lift off.\015\012\015\012Now remove the blockages that have accumilated from the oppening of short clear hose.\015\012Check you can turn ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Have suction, new bag, brush moving but does not

Solved!!!\015\012\015\012I went to my local Sears store and the salesman there looked at my vacuum and was able to resolve the issue. There was a piece of wire that had been sucked into the machine that then blocked anything else from bei ... Kenmore 22313 Bagged Canister Vacuum

Poor suction (new bag, clean filter, clear hose)

Check the impeller on the moter it may be missing a fin or two (question does it make any unusual noise or vibration ?) ... Vacuums

Dc11 dyson the brush head turns very slowly but when i take brush head cover of (the yellow part) and put my hand over the suction inlet part the brush head turns really fast. Have cleaned out collection chambers eg the hoover bag have washed the sponge with the little pictures of taps on it what now . thanks alan

I have taken the brush heads off and pulled all the hair out of the small gap between the chrome shaft and the plastic gear housing. Then a small amount of 3-in-1 oil into that gap to lube the internals and just a little through the air intake on th ... Dyson DC11 All Floors Bagless Canister Cyclonic Vacuum

My eureka vacuum won't suction and starts to smoke when I try to use it. It sounds like it is suctioning when I first turn it on, but after about 20 seconds it begins to smell like burning and does not suction at all. I have tried cleaning and unclogging the filter and everything. It's bagless so I don't need a new bag.

The problem is that your belt is stretched and worn. This causes that burning smell and it also causes the vacuum to not pick up well. You need to replace the belt. Here is the belt you need and the manual with instructions: ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.

Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

Miele s7000 I first got the vacuum and used it for 20mins then the vacuum just lost the suction, the brush works but it just push the dirt around the house and I can see the dust and dirt flying around.So, I thought maybe the bag was fulled so I put the new bag in but still pushing the dirt around. What's wrong with it?

... Vacuums

Model 8850 riccar no suction at all bag is new, no clogs, brush is turning,everything, seems fine,just no suction

The bag has a cardboard collar with latex. It must seal over the inlet. Make sure not to tear the bag when replacing.Is the cover closing properly? The cover seals against a gasket. The same with the filter. ... Riccar 8955 Upright Vacuum

My upright kenmore progressive vacuum will not suction up when using the sweeper. It will suction things when I use one of the tools. I have put in a new bag and have tried to see if anything is blocking the bottom. It sometimes makes a very loud noise when I try to vacuum. If I press the intell clean on and off yellow button the noise may go away but it still does not work.

Double check hose placement, making sure you have the hose inserted into the correct slot. The long attachment nozzle stores in the front hole on the right, and the sucking hose inserts into the rear hole on the right. I know this is too simple of a ... Vacuums

No suction--blocked hose was cleaned out, but there is no suction now. I put in a new bag and air filter, also.

You may have a broken belt that turns the brush.Jim ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

I have a Kenmore Progressive Inteleclean Upright vacuum cleaner (with Bag) . It has good suction only through the hose now and none through the bottom for cleaning carpets. and, there is a noise like it has a suction leak. the brush is rotating.

Theres a little bendable neck that hose with suction plugs into. Thats the one thats clogged. You will have to fish it out by taking off the roller and clearing the clog. ... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

Both lights are on - check brush & brush operation okay are on. just got vacuum used & cleaned it, new bag, filter good.

... Windsor VS14 Versamatic Bagged Upright Vacuum

I have a DC07 and the brush wasn't rotating and I had no suction at the brush but perfect suction through the hose. I noticed a large build up of dog hair around the brush so I took off the cover plate and removed all the hair, cleaned inside the floor/brush housing and cleaned out the hose. I also cleaned the filter and removed the other air access cover and made sure that they were clear. I put everything back and the brush still doesn't turn and there is still no suction through the bottom

Hi and welcome to FixYa. I am Kelly. \015\012\015\012Here is a link that can assist you in your quest for the missing suction: \015\012\015\012 ... Dyson DC07 Bagless Upright Cyclonic Vacuum

Hi the turbo brush with my new hoover whirlwind has stopped working. the suction on the appliance is fine and there are no blockages. have tried cleaning the head but it is still not working. any ideas//

... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0839 seconds