Having problems with your Eureka Vacuums ?

Motor runs fine and hosed not clogged will not pickup dirt

\015 Took out filters and tried it without filters. There is no suctions. The belt is turning fine. Plenty of air is being pushed out the side where the side filter is located.\015

Answers :

Check your fan for damaged or worn blades, then following the flow towards the bag check for blockage. Does your bag inflate when the vacuum is on? If so, it is less likely that you have blockage, than it is that there is an issue with the fan.
Repair Help & Product Troubleshooting for Eureka Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Motor runs fine and hose not clogged will not pickup dirt


This may sound silly, but have you checked the belt? A lot of Eureka vacuums use the vac motor to run the brush, and if the brush is not running the vacuum won't pick up. Another thing to check is the condition of the fan blades.. if they get worn th ... Eureka Vacuums

Motor runs fine and hosed not clogged will not pickup dirt


Check your fan for damaged or worn blades, then following the flow towards the bag check for blockage. Does your bag inflate when the vacuum is on? If so, it is less likely that you have blockage, than it is that there is an issue with the fan. ... Eureka Vacuums

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.


Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

No suction on my Electrolux central vacuum in all outlets even though motor is running and there is no clog in the hose.


I would start with washing out the ilter really good and letting dry. then try the system. ... Electrolux Central Vacuum

How do I access the motor to my eureka capture? It has no suction at all but turns on just fine..filters are cleaned and there are no clogs or leaks on the hose....im thinking there must be something stuck in the motor possibly but there are soo many screws that im having trouble removing them all....whats the best way to access the motor to check it??


... Eureka Capture Upright Vacuum Vacuum

While vaccuming it just stopped. Tried another outlet and checked power cord. Did find tube clogged with a dirt clog but no motor strain heard. Cleaned it out, Still not running


On the back of most vac's , u will find a red butten,use that to reset the vac. but even if that works u can avoid this usely buy ajusying the vac to a higher set . that helps reduse strian that the belt gets.\015\012 thanks\015\012 ... Bissell 68001 Canister Vacuum

Bissell powerforce My lower pickup tube became clogged so I removed it and cleaned it out and reinstalled it.Now everything runs good but the vaccum want pick up any dirt .I replaced the bag andf when I turn it on it just exhaust air but does not have any suction,I tired tp pull the bag door of while it was running whick I could not do so it has plenty of suction inside just not getting any outside can you help?


... Bissell Vacuums

Dirt Devil bagless upright. sucks up dirt in the front and spits it out in the back. I have taken it apart to check for visible clogs in hoses and checked belt and rollers all of which are fine. what next?


There seems to be no vacuum drawing the debris away from the brush head. Remove the debris canister to check for air blowing into it. Check particularly, the area where the brush head pivots off of the upright portion. Hope this helps! ... Dirt Devil M110000 Bagless Upright Cyclonic Vacuum

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after


... Vacuums

Have an old upright that does not pickup dirt. The beater bar runs but the suction motor doesn't. Do not know how to disasemble upright.


I don't recommend taking it apart yourself. The problem could be a switch, wiring, or connection. The motor could also be bad. I strongly recommend taking it to an authorized Aerus Electrolux store for a free diagnosis. Let a trained service tech ... Electrolux EL5010A Bagged Upright Vacuum

My Bissell Powertrak Cyclonic Vacuum has started running REALLY loud! I have cleaned the filters, checked for any clogs in the hoses and replaced the belt, but it stull sounds like a jet plane! Could it be the motor? Any suggestions!?


... Bissell 6594 PowerForce Bagless Upright Vacuum

It wont pick up dirt and motor is very loud it was clogged but cleared it still loud belt is fine


Check impeller that is the part that creates the suction in a vacum if impeller is broke that will make the vacum loud and vibrate ... Bissell 3910 Bagless Upright Cyclonic Vacuum

I have two older Filter Queen (brown vacuum cleaners). Besides unclogging the hose area and making sure it is not filled with dirt, what else would cause the machine to run hot and have a high pitched sound? Is there another area where I might have clogs?


There is a secondary filter under the paper cone that gets filled with fine dust. It can choke off the airflow. The noise motor sounds like a bearing going dry. That should be replaced ... Filter Queen Majestic Canister Vacuum

Dyson Animal motor is running, beater bar is turning but very little if any suction. No suction from hose either. The inside canister is filling and moving, so there is some dirt being sucked in there. I have thoroughly cleaned all filters but not sure what is causing the problem. Any ideas?


Obstruction in the hose?\015\012Your vac has developed a hairball possibly.... when a piece of flexible media ie.... cardboard, plastic etc... gets lodged in the hose, and begins collecting hair & dust to the point it no longer has enough d ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

All fo a sudden, no suction, motor runs fine, no clogged tubing.


Be sure the upper attachment hose is inserted firmly into the lower hose into the nozzle. Check for suction at the end of the hose, and if there is no suction there must be an obstruction in the hose, or the filter inside the bag compartment is plugg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Does not pick up, no vaccum, motor runs, no blockage, should feel suction on hose outlet without hose hook up. Paper filter missing over cloth filter. float overload ball free, seal on section good no leakage. Maybe bad motor but runs.


Here\015\012 is a Link to one of my Tips:www.fixya.com/support/r6311178-vacuum_brush_bar_not_spinningThis\015\012 should solve the problem. ... Minuteman C82906-01 HEPA Vacuum Vacuum

When I sart to run my bagless vacuum, it runs for a second and then shuts off. I replaced the belt and the filter. The repairman told me that on bagless vaccuums, the motor and bearings get clogged w


Take the brush roller off and on the ends are the bearing caps.try to take those off and clean the bearings ,carpet strands and hair will cause that.after you do that make sure the roller turns freely if not then the bearings might be bad and if that ... Vacuums

I have Nutone VX550C. Motor runs intermittently (cycles on and off rapidly--the light on the handle is blinking furiously) when I use the on/off switch on the hose. This happens at all of the wall connectors, so suggests a hose contact problem. Motor runs continuously when I turn it on at the switch on the wall unit.


The unit does have a switchs the PVC outlets, and it sounds like the hose mech to operate the switches is broken, and intermittently making contact. A replacement hose would likely fix the problem. Looked them up on the net, and they're not che ... Broan-NuTone VX550 Bagged Central System Vacuum

Hoover SteamVac Model F6056-900 SteamVac/SpinScrub. Indicator light and high pitch suction noise indicates that dirty water tank is full. However, water level indicator (yellow bobbing plastic thing) is at the bottom of the tank and there is no water in the tank. Have check all the hoses for clogs, none found. Checked water port from motor area to receptacle tank for clogs, none found. Fixed broken hose to upholstery wand with duck tape, (wire not broken, just cracked plastic hose). The onl


There are 2 filters, make sure they are clean, one is on the tank lid, the other is from the bottom, it is red, pull it out and clean it. If yours has a foam filter on the tank lid covering the yellow ball, make sure there is at least a 1/4 in. gap ... Hoover Vacuums

Kirby heritage 2 will not operate with hose on but with hose off it runs fine


... Vacuums

I have a mile tt2000 that works fine up to 1300W but if I crank it up higher the motor decreases and increases speed every couple of seconds. I have changed the bag and filters and done the usual cheCks for blockages but can find nothing amiss. Unusually when it is running and I block the intake it will run at full power but as soon as I clear it the motor "hunts" again. Any ideas.


... Miele Cat & Dog 326i Bagged Canister Vacuum

I have a kenmore vacuum cleaner model # 116.23612. When the hose is attached to the canister it runs, but if you remove the head to just use the hose the unit stops working. Is the motor dead or is there some type of reset or fuse. Could you please tell me how to test this. If so could you please send me instructions on how to replace the motor. Thank you in advance for your help, Tony


... Kenmore Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0875 seconds