Having problems with your Eureka Whirlwind 4388 Bagless Upright Cyclonic Vacuum ?

My vacuum worked fine yesterday and now doesn't start

\015 My vacuum worked fine yesterday. I think I might have flipped a switch somewhere accidentally other than the power switch on the lower left side. Is there another place to turn it off that maybe I don't know about and just found accidentally? Or other troubleshooting as to why it won't start now?\015

Answers :

My vacuum was fine yesterday now today it will not power on? I checked or clogs,checked hoses tried different outlets but it still will not power on, any suggestions? It's been three months since I purchased it. Eureka airspeed AS1000A
To my knowledge, the on/off switch is the only area to turn your vacuum on or off. There might be a problem with your cord, or with the switch itself. I suggest checking for clogs and anything that may cause a problem.

I also suggest taking it to a local vacuum shop to have it looked and as you may need some new parts (cord/switch)
Repair Help & Product Troubleshooting for Eureka Whirlwind 4388 Bagless Upright Cyclonic Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My vacuum worked fine yesterday and now doesn't start

My vacuum was fine yesterday now today it will not power on? I checked or clogs,checked hoses tried different outlets but it still will not power on, any suggestions? It's been three months since I purchased it. Eureka airspeed AS1000A ... Eureka Whirlwind 4388 Bagless Upright Cyclonic Vacuum

I have a miele S712 (2 yrs old worked fine yesterday) - I had been doing some diy work inside and had the vac on just to reduce some of the dust in the air - after a while the vacuum fizzled out. I guessed it had overheated and took it outside to cool down - when I tried to turn it back on pressing the power button gives it power and it starts to **** but it won't STAY on, soon as you release the power button it stops, and the orange bag indicator is showing full. As I have a compressor I took

You have got dust in the micro switch and it is not latching on, if you look at this and clean it, that will solve your problem, however blowing the motir has probably wrecked the motor bearings. ... Miele Vacuums

Vacuum will not stand, I does not lock into place anymore and it will not **** up dirt, it worked fine yesterday, but this morning I started having these problems

... Vacuums

Suction Problem I was vacuuming and stopped to empty the cannister. When I started vacuuming again - the suction wasn't working properly. The vacuum was just pushing stuff around the floor. I cleaned the hair out the brush on the bottom and it still isn't working. It was working fine before I emptied the tube :( I can't figure out what happened.Help!

Greetings from GoVacuum,\015\012\015\012I believe what may have happened is that your vacuum cleaner belt has either broken, or been stretched so far that ithe brushes are no longer spinning fast enough. \015\012\015\012Here' ... Vacuums

Infinity Vaccum by Shark, model number NV31COS, will not start. The vacuum was running just fine until it grabbed the edge of a curtain. Turned it off to release the suction. Turned it back on and was working fine. About a minute later the vacuum was making an odd noise. Every 2 seconds or so it would "heave" (lack of a better word) then go away, then come back and so on. Turned the vacuum off and checked for blockage, none that could be seen or felt, and now the vacuum won't turn. Any suggestio

Carpet brush won't turn when vac on ... Euro-Pro NV31 Infinity Vacuum

G5 vacuum won't start (turn on) when I try to use the accessory hose. It starts (works fine) when using the regular floor brush for vacuuming.

... Kirby G5 Bagged Upright Vacuum

I have a Dyson vacuum cleaner ...upright....all of a sudden my vacuum started making this awful sound...like a loud buzz...but only when I have it on carpet....when I have it on "floor" mode it's fine....sometimes(although seldom) it has worked without buzzing...and it's LOUD!!....I have only had this vacuum for a year....and no...I have never picked up any coins or hard stuff.only use it for 2 rooms.the rest of the house is wood floors.......what shall I do? Thanks......Gloria

It may just be, that on carbet the brushes make noise that you dont hear on woodfloors.\015\012If there is a hights adjustment, set it higher for shaggy carpet and lower for berber. ... Vacuums

Cleartrak vacuum suddenly cleartrak started to make weird loud noise i cleaned. When it got jammed I stopped the vacuum and dislodged the jam and it worked fine. How to stop the weird loud noise?

... Vacuums

It has no suction. It was fine yesterday. I washed the dirt container and the filter, let it dry and put it back in the vacuum. Today my vacuum isnt picking up any dirt and has no suction. When I took the hose out of the back, it started blowing dust and dirt out but still no suction.

Look for a place where the vacuum line has to turn in a near 90 degree turn. It's easy for it to get stopped up there. ... Vacuums

I have a Miele s251i vacuum that was working just fine until I umplugged it (while running) and re-plugged it in at a closer socket. When I replugged it, it started for a second and then stopped. Will not start now whether we use the on/off switch or not...suggestions? Would also like to know how to disassemble the unit so I could check out the wiring with a multitester..thanks

I just had exactly the same problem. Opened the vac, checked the circuit\012 next to the motor and it can be clearly seen that the Triac burned thru\012 the PCB. Will replace it and check again. Vac bought long ago, works \012extremely well. ... Miele Vacuums

Have a rexair model D series vacuum cleaner that worked fine until recently. Started making noise and then started smoking/overheating. I took apart the machine cover and am unsure how to get it tore down to see the motor or belt in there. Please help!

Below I have listed a link to the manual that has instructions on how to change your belt and a link for the replacement belt you need. ... Vacuums

My Vacuum DC-17 has just quit sucking. It has been making quite a racket since I had the belt changed at a repair shop several months ago. I was told that the belt was a new design and figured that was why it was making so much noise. it seemed to work fine, was picking up dirt and all, but today, when I started vacumming, I noticed it was not sucking air either with the belt engaged or not. My vacuum is approx. 5 years old.

... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

While using the pin stitch , the machine has started skipping stitches, knocking loudly, the top thread is breaking, sometimes thread knots up on the underneath side. I have cleaned bobbin area, changed needle and bobbin, using quality thread, the last time I used machine worked fine, yesterday when I started sewing I had this mess HELP!

Hi,Please go through the link given bellow to have the resolution to your problem...\015\012http://sewing.about. ... Vacuums

Runs but doesn't vacuum/****. Sidebrush works fine. Cleaned the roller brushes, and that seemed to confuse the robot and now it keeps going backward a few inches, turning, and then starts going backward again.

Sounds like a sensor problem. pull and clean the front black/white caster assembly and the revealed movement sensor and the 4 cliff sensors along the bottom of the front. Make sure the front caster wheel turns freely. You may have to remove the rolle ... iRobot Roomba 560 Robotic Vacuum

My Eureka Maxima isn't working right. The belt is spinning fine until I lower the handle to start to vacuum and then the belt stops spinning. As soon as I put the handle back in the upright position the belt spins again.

Sounds like belt is worn try changing belt. ... Eureka 4700A Maxima Bagless Upright Vacuum

Vacuumed up some-little water & it started smelling & now it doesnt work

Once water or other liquids get into the motor, it's ruined. The smell is a dead give-away that the motor has burned out and needs replaced. ... Riccar Vacuums

My Oreck XL was working fine, then when I vacuumed a shag rug is started smoking and smelled like something is burning. (I changed the bag, checked for clogs--none found, and roller brush is turning. It has a metal handle.) Now I am afraid to use it.

Even though the brush is spinning, the belt is probably worn out and stretched. when you vacuum the shag carpet, it puts more drag on the brush. try running it on a shorter carpet or hard floor for a few minutes. if it doesn't smoke, then you know i ... Oreck XL2000 Bagged Upright Vacuum

My Nilfisk King 505 vacuum has decided not to go all of a sudden, was working fine, and now wont, could it be the start button has worn out?

Just had the same problem with mine. I am thinking the on/off switch too, but it could be motor related. ... Vacuums

Lux legacy vacuum runs fine and was recently serviced - yesterday the tone of the motor on the vac started a higher sounding pitch - is this a potential problem and is there anything i can do with it - thank you

You don't mention whether it was the canister or upright model, but if it sounds differnet than what it usually does, then there is a potential problem. It could be anything from a full/clogged bag to a dirty filter to a clogged hose. You can check ... Electrolux Vacuums

Hi...my dyson cylinder vac,DC08will not start when plugged in and switched on...after working fine yesterday...have checked plug etc. Any ideas??? Thanks.

Hi its Darran at Dyson. If the machine had been left overnight and then would not switch on the next day, then this sounds as though there may be a problem with the switch or the motor. So that we can help you further, please ... Dyson DC08 Cylinder Bagless Canister Cyclonic Vacuum

My Dyson vacuum works fine for cleaning the rug but the hose doesnt get any suction at all. I removed the hose and all the parts around it that I could and dont see any clogs or broken pieces. I lost my manual so I dont know if this is addressed, or if there is a switch Im not flipping. Gave it a thorough look but found nothing.

Hi there,Sorry to hear you're having a problem with your DC07. If you have suction through the cleaner head but not through the wand, it sounds as though you have a blockage. Although you say you've already checked for these, you may find ... Dyson DC07 Bagless Upright Cyclonic Vacuum

Luv300b vacuum brushes won't spin. The belt is fine but still not working. Any suggestions?

... LG Electronics Kompressor Plus Upright Vacuum Cleaner LUV300B

I have a windsor vsp 14, it is making a bad grinding noise, when I take the top blue piece off it stops, the brush works fine and when I put the top back on it grinds really loud and gets hot. it still vacuums and the belt and brush are working fine, can't figure it out. and when the lid is on I cant see what its grinding on. It only makes a grinding noise when you pull handle back and engade to vacuum flor and stops when you put it upright.

... Windsor VS14 Versamatic Bagged Upright Vacuum

My Dyson Animal has good suction and works fine for actually picking up dirt, but when I use the vacuum with the roller, I hear a grinding/rumbling noise. Its only when I use the vacuum with the brush rotating. It does not happen hen I shut the roller brush off. The belt is fine. I cannot figure out what is wrong as there are no clogs, debris, or foreign objects stuck in the brush or in the belt. The noise seems to be the only issue. The vacuum picks up fine. It just doesn't sound right a

Trace the path of the suction into the tank and see if there is anything loose or ingested.\015\012Also, remove the brush and clean as best you can. Perhaps there is something caught in it. Lubricate where it makes sense with some WD40. ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1423 seconds