Having problems with your Fein 9-77-25 Turbo III Bagged Canister Vacuum ?

I have a fein turbo III and I think it got some dust in the motor and now it wounds like it is going to blow up when I turn it on. Is there anything that I can do?


Answers :

Best bet is try to access the motor and disassemble if possible. There will be fine fine dust in the fans causing eventual wear and bushings or bearings as well as the carbon brushes. To clean it properly all must be dismantled. Any fine dust on the armature should be cleaned with forced air or suction and a soft brush
Repair Help & Product Troubleshooting for Fein 9-77-25 Turbo III Bagged Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a fein turbo III and I think it got some dust in the motor and now it wounds like it is going to blow up when I turn it on. Is there anything that I can do?


Best bet is try to access the motor and disassemble if possible. There will be fine fine dust in the fans causing eventual wear and bushings or bearings as well as the carbon brushes. To clean it properly all must be dismantled. Any fine dust on th ... Fein 9-77-25 Turbo III Bagged Canister Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

The vacuum is making a noise like something is stuck when it is in the carpet position but not when in the floor position. I can't find anything that is stuck in the areas that I can see. I have cleaned the brush but it does not seem to want to turn. Does this machine need to be oiled so the roller will turn? Is there a way to check inside the motor? Do you think that because the brush won't turn that is making the noise? Do you know of any repair shops in the Lake Havasu City, Arizona area?


As far as the roller brush goes, yes, it does need to be cleaned. Follow the directions to remove it and clean as best you can of all debris. On both ends of the roller brush there will be two "holders" of sort that connect the brush to the frame o ... Dyson DC07 Bagless Upright Cyclonic Vacuum

My filter queen just had the motor rebuilt last year and was basically a brand new unit when I got it back. It is not picking anything up now when I vacuum. The beater bar on the carpet attachment is turning fine and when I take all the attachments off the hose I can feel the suction being created like it should be picking up debris just fine. I have emptied the canister even when it did not have much in it; however, it still will not pick anything up off the carpet. It picks up debris tempo


It sounds as if you have a clog inside the "Power Nozzel". They mention that there are "no user serviceable parts within the Majestic® Power Nozzle" My advice would be to see if you can see a clog with in reachable distance and try to remove the ... Filter Queen Vacuums

My Dyson Animal vacuum sounds like the motor is going? It has also lost suction power and I have cleaned all areas and washed the filter. Is there anything I can do to fix the problem? Where is the closest repair center? My zip code is 17972


... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

My Bissell Rewind Smartclean 58F8 vacuum is making a loud noise when you turn it on and while cleaning with it. It sounds like the motor is going out.


... Vacuums

Have a Centralux Aerus about 5 years old. Don't see a model number. There is suction but beater brush quit working. Was using for a few minutes, shut it off for a few minutes, turned it back on and suction only. Tried the reset button also. Tried the sidekick attachment and it works fine. There was no smell like something was hot. Belt is fine. Are there any fuses or anything else to try? This vacuum cleaner has not really been used that much, it is hard to believe the motor would need replaced


There probably is a loose wire in the handle near the switch or a wire off near the swivel elbow near the vac power head. With the right fastener tool to remove some screws you can fix it yourself ... Electrolux Centralux Vacuum

On the back of the shop vac there's a hole...what is supposed to go in there...i turn it on and dust blows out of it like crazy


Should have a exhaust filter in the hole. it is round and 5-6 inches long with a type of filter on the end. ... Shop Vac Shop-Vac 905-65-00 1-1/4" by 8 QSP Hose w/ Handle and Airflow Control Wet Washer

I have a Flex hand held vacuum. It turns on, the motor works, air is blowing out of the side vent very forcefully, but it is not picking up anything with the hose - no suction at all. My hose does not seem to be clogged.


No the hose,, check the filter and compartment behind the filter.. Note if there is air passing through the filter,, or being sucked through it.. If not chances are the extractor fan inside the machine may have broken ou will need to open it up and r ... Black & Decker CHV9600 Handheld Vacuum

Motor is sparking and smells like burning rubber. When it first happened I thought the vacuum had something jamming the beater bar. That was the smell it had, like when the belt gets burned. But when we turned it over, it wasn't jamming. Took off the base plate and turned it on. The motor area is sparking and it makes a weird noise (I assume that is because the motor fails and restarts). I looked for loose wires, can't find any. I believe I need some sort of part replaced, maybe even a n


From sound and description most possible is motor is burnt up sparks usually mean metal on metal either bearing or bushings went on motor if u can jiggle the shaft thats bearing if u rotate the shaft by hand and feel and or hear rough grinding the br ... Oreck Vacuums

Roomba Discovery Roomba is fully charged and cleaned with sensor wiped clean. When turned on it it sounds normal and commences to go, but it then acts like it is putting on the breaks, spins, tries to go and manages a short distance and breaks again, just not making any progress because it keeps breaking after a foot or so and turns and tries again. Sometimes is gets so stuck from moving forward at all, like it is stuck in one spot just trying to go while seemingly surrounded by barriers. Somet


I had the same back-up, turn, move forward a couple inches, backup-up, etc. problem. Try cleaning/cutting the hair, etc. out from around the brushes, as well as around the ends of the brushes. Also, try a Q-tip to clean out the four pair of sensors ... Roomba Robotic Floor Bagless Vacuum

Brand new 3HP shop vac smells like motor burning when turned on!


... Shop Vac ShopVac 3 HP 2 Stage 10 Gallon--Automotive Wet/Dry Vacuum Vacuum

Bad Motor I have purchased two of the Kenmore direct drive beltless systems with Progressive systems. The first died after a year, the vacuum motor start making a grinding noies. I pulled the side HEPA filter and could see a fine coating of graphite like dust. Took it to a vacuum repair shop. They said the brushes were going and thus the motor was shot. I liked the vacuum and bought a second, 1 year later the motor is making a slight noise that and removing the HEPA filter I find a slight metall


That dust is from the carbon brushes on the motor. You may need to check them, and also clean out the motor compartment. A slight noise could be a motor bearing starting to go. Does the smell like rubber or electrical. If rubber, then the belt h ... Vacuums

Dead motor? My 8 year old Miele S251i has worked fine, until I was recently vacuuming and moved the plug from one outlet to another. When I restarted the vacuum, it made rrrrr.....rrrrrr....rrrrr noises and smelled like something was burning. I turned it off, and it's shown no signs of life since. Sound like a motor problem? I've taken the cover off and looked at the cord and seen the motor, nothing looks obviously wrong, but I'm also not mechanical.


... Miele S251 Flamenco II Bagged Canister Vacuum

I have an Electrolux LITE upright carpet cleaner - about 15 years old. Suddenly last night when using it, from the normal motor (whooshing) sound, the motor suddenly went very slow and with a slight grinding sound. The brushes are now just turning round very slowly and areobviously not picking up anything. Has the motor gone or is this repairable, or should I just get a new cleaner? I have tried to open the machine from the bottom to see if anything is obviously wrong, but it looks complicated a


... Electrolux Vacuums

I have a new Hoover BH50015 hand vac. The noise is terrible. It sounds like the bearing are bad. When you take off the cup and the filter and listen to the motor as it slows down after turning it off it definitely sounds like bad motor bearings. Hoover tells me the loud noise is normal. Can you help?


Yes the bearing is full of dust and dirt\015\012unscrew the housing and clean the bearing area and shaft\015\012then add a dap of Vaseline to the shaft and reassemble\015\012The shaft rides on a nylon bushing which acts like a beari ... Hoover BH50015 Bagless Handheld Cyclonic Vacuum

The brushes spin very, very slowly and stop altogether sometimes - like they just don't have any power behind them.I've cleaned the brushes and also turned it on without the brushes inside to see if the female plug that the brushes go into turns - it does, but not very fast. My husband said he thought he smelled something - like burning. Is there a way to take the underside cover off and clean something?


... Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

Went to turn it on after not using for several weeks and it states not ready to brew like usual but after about four minutes it just turns off. Wont let us brew a cup or access the menu even to choose size of cup or anything. It sounds like it's sucking up water to make cup and pokes hole in the coffee but nothing more than that. It is almost brand new


You have posted the fault in the wrong column with no instruction of the make/model.\012Assuming it to be new , Is it passed the warranty period before we take a look ,?\012Just lave it on for sometime and see if there is any change. per ... Vacuums

My beater bar is struggling to turn. actually, it appears as though it is the motor that is struggling, as it slows down when going against the pile and the motor labours so much that it frequently fails to turn the bar until i lift it up again. the belt appears ok, and it is clean of hair etc. it is a 5 year old beam central vac. thanks, D


... Beam Industries 875 Classic Central System Vacuum

I have to go into the garage to turn on the motor on the tank and to shut it off. When I plug the hoses into the outlets in the house, it doesn't turn on the tank motor. I don't know what part to get and nobody in Raleigh, NC shops can help me.


Is this Electrolux that's now known as Aerus? If so, take it in to the Aerus Electrolux store for a tech to look at. You can find the nearest Aerus Electrolux store by following the instructions on the site at bottom of page.\015\012\01 ... Electrolux Central Vacuum

Vaccum overheating I have a hoover u5458-900 wind tunnel and the auto shot off has kicked in for overheat protection. i've cleaned the entire thing and let it sit like i was supposed to but it still won't fully turn on and stay on. it will turn on for a few minutes and then shut off and just cycle like that for a few times. is there anything i can do to fix this or should i just clean it more (if possible)?


Either the motor protector is bad, or you have a clog in the hose or the dirt inlet by the brush roll. Are the filters clean? It is also possible that there is a problem with the motor. ... Vacuums

WHEN I TURN ON UNIT IT SMELLS LIKE WHEN THE RUBBER BELT STOPS TURNING ON A SWEEPER. HOW DO GET TO THE MOTOR AREA?


Mosture has gotten into the motor. Take the bottom tank off and let the unit run for 30 seconds. It will dry out the compartment ... Hoover F7425-900 SteamVac V2 Widepath Upright Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos


It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

I have a dyson canniter stow away vacuum. i've had it for 2 years and it just started having a problem. when i turn it on the motor starts just fine but the vacuum head does not turn on. Yet when i push it forward it trys to start and turns on for a second and turn off - almost like the connector isn't connecting the hose to the head very well anymore.


Hi, After reading you're problem, the symptom's are just like you said. Its just a matter of checking the connections. The connection where it plugs into the head it self. When you push forward the forward motion and down pressure makes ... Dyson "Stowaway" Canister Vacuum Vacuum

Kitchen exhaust fan no suction, though motor turns and fan blows


... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0736 seconds