Having problems with your Filter Queen Majestic Canister Vacuum ?

I just got the majestic and it doesn't seem to have a lot of suction power- I ran water thru the hose and it drained out fine I also put the hose on top and blew it out. Could it still be the hose?-or does it sound like a bigger problem?


Answers :

Did you change the filter cone? Clogged pores can and do inhibit airflow. Bent fan blades can be another problem. Holes, slits, and cracks, no matter how small, in the hose can result in reduced suction.
\015\012And you should NEVER run water through a hose that contains electrical wiring, which I suspect yours does.
Repair Help & Product Troubleshooting for Filter Queen Majestic Canister Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I just got the majestic and it doesn't seem to have a lot of suction power- I ran water thru the hose and it drained out fine I also put the hose on top and blew it out. Could it still be the hose?-or does it sound like a bigger problem?


Did you change the filter cone? Clogged pores can and do inhibit airflow. Bent fan blades can be another problem. Holes, slits, and cracks, no matter how small, in the hose can result in reduced suction.\015\012And you should NEVER run water ... Filter Queen Majestic Canister Vacuum

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u


Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

Shampoo-er This seems to be a common problem, the shampooer is putting out alot of water and hardly any suds. I read through the posts about the little filter that sometimes gets out of place and I think I found it in the box - is it about 1" diameter hard plastic ring around very fine mesh? If so where exactly does it go? Some posts say in the hose, and others say in the opening of the tank. Or does it go in the place where the hose attaches to the tray? I also found a round sponge in the box o


It goes on the small hole on the tank where the hose attaches to it. The sponge goes in the hole directly under the on/off valve. Here is a link to my online shampooer instructions.\015\012 \015\012 ... Kirby Ultimate G Bagged Upright Vacuum

I took the hose off to wash it then after letting it dry overnight I put it back on but Im guessing it there was still a little bit of water in between the grooves which ran to bottom of vacuum and now my dyson gets stuck, sort of like a tight hinge. It vacuums fine but I have to keep pushing it down to the carpet with my foot. How can I fix this problem?


Lubrication at the pivot points ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

We have bissell pro heat and I have put new belts on and took off the top plastic cover I blew out the lines and I still can't get it to pump water or solution. The red little spinner flow indicater does'nt get water, if I pour water into it it runs out the front. I guess I don't know what else to do. The machine worked fine the last time we used it about 6 months ago. Any suggesttions?


Did you check and make sure the belt is still on right? They do come off from time to time.There are like 6 long screws holding the top cover to the bottom. The are real pain in the behind to put back together once you take them off. T ... Bissell Vacuums

I have a windsor vsp 14, it is making a bad grinding noise, when I take the top blue piece off it stops, the brush works fine and when I put the top back on it grinds really loud and gets hot. it still vacuums and the belt and brush are working fine, can't figure it out. and when the lid is on I cant see what its grinding on. It only makes a grinding noise when you pull handle back and engade to vacuum flor and stops when you put it upright.


... Windsor VS14 Versamatic Bagged Upright Vacuum

I have a DC07 and the brush wasn't rotating and I had no suction at the brush but perfect suction through the hose. I noticed a large build up of dog hair around the brush so I took off the cover plate and removed all the hair, cleaned inside the floor/brush housing and cleaned out the hose. I also cleaned the filter and removed the other air access cover and made sure that they were clear. I put everything back and the brush still doesn't turn and there is still no suction through the bottom


Hi and welcome to FixYa. I am Kelly. \015\012\015\012Here is a link that can assist you in your quest for the missing suction: \015\012\015\012 ... Dyson DC07 Bagless Upright Cyclonic Vacuum

No spray My Bissell Pro Heat 7901 will not put out any spray. I Took the pump out so I could get at it and disconnected the hoses. I put the one on the input side and the other in a bottle of water. Put the belt on the pump and turned on the machine .Nothing at all coming out of the pump. Where can I get a new pump? Also the lever that goes to the little flapper at the top under the clear plastic piece on the front that connects to the knob that changes from tools to floor broke off. Where can I


Search for bissell pro heat pump. bissell.com will not have it ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

No spray My Bissell Pro Heat 7901 will not put out any spray. I Took the pump out so I could get at it and disconnected the hoses. I put the one on the input side and the other in a bottle of water. Put the belt on the pump and turned on the machine .Nothing at all coming out of the pump. Where can I get a new pump? Also the lever that goes to the little flapper at the top under the clear plastic piece on the front that connects to the knob that changes from tools to floor broke off. Where can I


Pump part number is 2107181, the diverter valve # 2136988. You can Bissell and they can tell you who may have parts near you, or you maybe able to order thru Bissell.com. Before you took it apart, were you getting water to spray out of the hose. I ... Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum

My Hoover Steamvac Widepath will NOT pickup the water after dispensing. I checked the hose inside the cleaner, there was a cut in the hose so I put electrical tape and completely sealed the cut. Still will NOT pick up water. I can't find any other problems with the hose. Any suggestions?


HelloHere are some suggestions you might want to follow to solve this problemFirst double check if there are other cuts in the hose or any sort of blockage or clogging in the hose and be sure to remove any form of debris ... Hoover F6213-900 SteamVac Agility TurboPOWER Steam Vacuum Vacuum

The suction in the hose of my 2 year old Dyson Animal vacuum is compromised. I may have sucked up a small cat toy or something. Regular vac still is fine. The hose "sucks closed" after a few seconds near the top. I love my Dyson! Please help.


Hi there, it sounds as though the wand handle is blocked. To test this, remove the wand handle from the hose and test the suction at the top of the hose. If its strong here, then you will need to remove the blockage from the wand handle. If the suc ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?


... Kenmore 34722 Grab-N-Go Upright Vacuum

I have a Eureka Altima vaccuum and it no longer suctions like it use to and also has a burning smell. I have cleaned all filters, brush, hoses, and filters. There are no blockages. I have also checked the belt and it's still good. Any other ideas as to what may be the problem?


This bagless model gets buildup of really fine dirt in the motor and starts to clog up the fan airducts. You will need to take the motor out and clean it. ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

I also have a Hoover upright and I need to replace the electrical cord. I have dimantled the back, where the tools are stored, and the hose. I still cannot find the screws or whatever, to get to the area behind the cord, so I can replace it. I think I will have to take off the bottom too. Has anyone out there tried to do this? It seems crazy. This machine works great so I hope I can also put it back together. Thanks for the help.


Since I do not know your specific model I can only supply you with general instructions. Be aware that most of the time you only need to gain access to the on/off switch to replace the power cord. Also Make sure that you are replacing the existing co ... Vacuums

My dyson dc animal's brush is not spinning. The machine smells like burning rubber. I believe the clutch has gone out but the machine also only sucks from the top of the hose in the handle. I am wondering if the machine is not locking properly which is causing the brush to not need to spin. If this is the problem how do i fix this problem.


... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

Low suction Have a Powr-Flite PF 18, suction is good at motor, but low at where hose comes out of top of vacuum. Could new lid seals help the problem? Where can I get new seals for this model. Also my zip is 98801 and my shop is not listed, could you add it please? Sew Creative 1139 N. Princeton Wenatchee, Wa 98801 509-663-5516 Thanks, Lauren-Sew Creative


Replacing the motor cover solved the problem, it must have been warped and was letting suction out thru it. ... Vacuums

I have a Electrolux Epic 6500 SR canister vacum cleaner. It is nine years old and for the past few weeks it has started shutting off for no apparent reason.The symbol for bag change lights up and it cuts off, but even after I have put a new bag in, it still does the same thing. Do you have any suggestions? There is a little button or switch that the top of the bag fits on. Do you think it could be the problem?


Your machine is probably clogged, look through the wands, look in the bottom attachment, to see if there is anything stuck there. You can also drop a marble through the hose itself to see if anything is stuck there as well. To unclog the hose try hol ... Electrolux Harmony Canister Vacuum - EL6985 Vacuum

I have lost suction on my Bissell. It is also clogging in the Plastic tube that runs from the roller to the hose. What could have caused this? All filters have been cleaned, tube as well, but the problem still persists.


... Bissell 82H1 Cleanview Helix Bagless Upright Vacuum

My electrolux vacuum suddenly stopped while vacuuming. The bag icon on the outside top of the machine was lite red so I assumed that the bag needed to be changed. Unfortunately, the problem still persisted. Also the" on button" on the exterior shell will not engage. Help


... Electrolux Guardian Bagged Canister Vacuum

I have a Craftsman wet dry vac with blower capability (22 L). While I was using it to **** up water, the water came out of the blower hose. Now I can't get it to work as a vacuum. What can I do to fix this problem? Is there a toggle switch somewhere that allows me to choose vacuum or blower? Also, will the vacuum still work without the filter nut attached to the plate? Please let me know at your earliest convenience. Thank you.


... Craftsman Vacuums

Miele Cat & Dog vacuum gets VERY hot and is VERY loud. Hose has no restrictions and I have changed the dust compartment (motor) filter and the exhaust filter. It still gets hot when I run it with the top open and all filters removed, so I'm guessing the problem is with the motor. Should I be going into the motor compartment? If so, what am I looking for?


Hi\015\012\015\012The fact that it gets very hot could be due to a number of issues.,but the fact that it started making a very loud noise at the same time suggests that there might be more problems maybe brushes etc.\015\012\ ... Miele S514 Solaris Bagged Canister Vacuum

No suction I have the central vac type. It has no suction at the can. I pulled the hose going to the walls and tested there...and nothing. I removed the dirt can and checked the motor ...it is spinning but does not feel like any suction. I checked the exhaust and it is pushing strong air out. I also cleaned the filter and still nothing. Is there a relay or something that would cause only exhaust air. I emptied the can of dirt and put it back together and have absolutely no air.....hear the motor


On some units there is a screen that protects the impeller of the motor. If this gets sealed off with debris then it is like putting a potato in the tail pipe of a car. Taking the top off the unit reveals the motor. DO UN-PLUG the unit first from th ... Electrolux Central Vacuum

Dc07 problem I have a dc07 cyclonic vaccum and like this model,however, for some reason,it has been very dificult to push and pull for the past month or so. i have completely cleaned the brush assembly,cleared any obstructions in the hoses,and, cleaned the filter.I also checked the belt tension,wich i thought was fine but to no avail.Be advised that the brush assembly is spinning and suction is excellent. It just feels like the brush drags along the carpeting. this is a great vacuum cleaner and


The dyson uses two belts, one from the motor to a clutch and then from the clutch to the brush roller, the belts that they use are not much better then any other belt ( those you should change yearly ) but you cant just change the belts you have to c ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

NO POWER My Dyson DCO4 Absolute (purple&lime) won't' switch on. I've checked the plug fuse, wall socket and also filters and hoses on machine all seem fine so think the problem is with the on/off button (maybe loose wire or something) but how do i get to it, is there a special way to remove the green on/off button in order to check the connection? Thankyou in advance for the help i am sure you will be able to provide.


The problem is almost certainly a fatigue break in the flex. These usually happen where the flex enters the handle through the rubber sleeve near the on off switch. You will need to cut about four inches off the wire and reconnect it to the switch. ... Vacuums

Have ultra vision and have changed filter and foam filter, checked all hoses but still will not pick up. Belt is fine and brush is clean and spinning properly. dirt stays at top of filter instead of falling into canister.


My kids get mine stuck all the time :(Take the vacuum outside then:Remove the hose at the bottom and see if there is any obstructions. Also shake the hose to make sure there is nothing in there as well or take it out side and make s ... Dirt Devil Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0803 seconds