Having problems with your Hoover F6020-900 SteamVac Upright Vacuum ?

Motor or pump problem?

\015 Works fine when first turned on, but after a few minutes makes white smoke and terrible smell.\015

Answers :

My guess is you burned out the motor. go to thehooverstore site. look for your machine. they have a parts list for just about any hoover made.
Repair Help & Product Troubleshooting for Hoover F6020-900 SteamVac Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Motor or pump problem?

My guess is you burned out the motor. go to thehooverstore site. look for your machine. they have a parts list for just about any hoover made. ... Hoover F6020-900 SteamVac Upright Vacuum

Hoover Jet and Wash 1500w S6254 001. Used once with great difficulty as assembly and use instructions are hard to follow.Now will not work as carpet shampooer at all, although assembly is correct as far as I can see and both motor and pump appear to be working and I am using the recommended cleaning fluid.Hoover website is no use at all in solving the problem.No cleaning fluid is being drawn up from the tank in to the cleaning fluid hose.There is suction from the suction hose so the problem appe

I am having the same prob my uncle got me one i cant find the manual anywhere to set it up the prob i have is where does the handle to make the water go out connect tooo ??? on the main pipe that sucks it back up i have tried every which way but not ... Vacuums

I have a hayward 1HP superpump with an Ao Smith UST 1102 motor on it. Last year I had a leak in the pump, and I believe I got some water in the bearings of the motor. Over the winter I replaced all the seals in the pump, and have no leaks this year, but the pump is sounding pretty loud since opening the pool this year. I have (2) fold question: (1)I can not find any information on the where I can find a replacement bearing for this pump. (2) I can not find a procedure on HOW to go about

Hello. I get my parts here http://www.poolcenter.com/parts_pumps_hayward_superpump.htm\015\012\015\012Joe ... Vacuums

Motor smells I have the same problem. Did you get this fixed? Was the problem the motor or the brushes. I don't want to spend $80 for the motor KC92FCJNZ000 is there another way to repair this?

... Kenmore Vacuums

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.

It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

Saeco Odea Giro pumps the water but the internal spline or gear is not turning moving the ground coffee grinds to the point where the water can pump to the front exit lines so the water is pumped into the over flow resevoir. How do I replace the gear or check to make sure this is the problem. I want to replace this myself.. Also how do I get the unit apart it seems to be bullet proof. Is this a common problem.

It is a common problem if it is what I think it is. However your description is a little confusing. So the coffee does get ground up, but then has a hard time getting to the next stage of the process? Please clarify... And no water gets pumped th ... Vacuums

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?

... Kenmore 34722 Grab-N-Go Upright Vacuum

We own a dirt devil model 088600, and are experiencing a problem with the belt wearing away a section between where the belt connects to the brushes and the motor. There is a lot of plastic/rubber residue coming out from the vacuum. We have tried new belts only to find the same problem occurs. I noticed that the source of the dust is coming from the section between the brushes and motor, where there appears to be a section that is misshapen and melted. I looked up the schematic online and can't

If you are certain that the belt is seated correctly and the beater bar is nested in its holder and the cover of the assembly has been properly installed and you still see a contact area between the belt and cover, you should either: return the vac ... Dirt Devil Vacuums

Hi I need help because I have a problem with my Electrolux Centralux Central Vac system in my house. When I plug the vac hose in the central vac socket at first I heard the motor running very gently with NO suction then after a minute or so it went completely dead and they is NO motor sound, suction, or anything happening what so ever. Can anyone tell me what this problem is???

Have you checked for a clog in the lines or in the hose? If there is no clog in the system anywhere, then your motor could be dying. ... Electrolux Centralux Vacuum

My bissell model 18Z6 has developed a loud noise and vibration when the brush is running. I have removed the brush assy and cleaned all the hair, etc but still the noise. I ran the brush motor with the belt disconnected and all seemed ok, but of course there was no load on the motor. I suspect a problem with the brush assy bearings or axle or both but I hate to just throw parts at the problem. any suggestions would be greatly appreciated.

... Bissell Vacuums

Motor wiring My Vax VS19TL motor died and I have managed to get hold of a new Vax 006 Turboforce motor which is the same size . My problem is that the original motor had two wires (black and white) which ran to the PCB switch. The new motor has three wires (black, white and yellow). I have ordered the PCB wiring loom for the 006 motor but I can't find any documentation that tells me where each wire goes. Can anyone help?

... VAX Appliances Vax X5 Bagless Upright Cyclonic Vacuum

My first proheat lasted four years so I bought a new one. After I used my Pro Heat for only the fourth time my first issue occured, the gear on the pump that runs the brushes came off, so I had the one from my old proheat, I just changed the gear spindle that is screwed to the pump and fixed that problem but now it will not pump water. That is why I bought a new proheat, I could not get the old one to pump even after a new pump and made sure all lines were not cloged.

Is your new machine a 2X or like the old style proheat? ... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

Aquamate basin pump does not work. Used it 3 times, stored it for a year and pump does not work. Looks like a reliability issue. Is this product defective for everybody? I saw an ebay listing for the basin that states "the pump works." Looks like I am not the only one with this problem if he has to mention that the pump worksl How do I get a basin with a working pump? gap920

Hmmm............ looks like the impeller is already stuck from a year w/o using it!\012\012\012I suggest if u could open it and spray some penetrating oil on the bushing of the pump motror and the impeller, force the motor to turn m ... Rainbow E series Canister Wet/Dry Vacuum

Motor problem I just picked up a screw. It appears to be stuck in motor. The sound of the motor changed to a whirring noise and it started to smoke. How can i access the motor?

First six pictures HERE will let you know how to remove shell to see the motor. I would not recommend starting it before you get the screw out (you will need to ... Kirby Generation 3 Bagged Upright Vacuum

Shopvac 90L400 quit working (4 years old). Thought the switch was bad but not the problem. I read that there is a fuse link in the motor that frequently burns up. I tried to take motor apart but not sure of the process. I was able to get to the motor but cannot pull it out of the armature. It appears I have to take the aluminum blower unit off the shaft (it appears to be pressed on with a retaining washer). Do I have to take it off to pull the shaft and motor assembly out? Is that where the fuse

By pass the switch and take power right to the motor leads.. that should tell you if the motor is ok.. have not seen fuse link on a vac motor.. graingers has new motors, but not inexpensive ... Vacuums

I have a Hoover, Steam spin scrub, Model F5897-900. Only used it a couple times and the motor gave out. First started being noisy then a bad smell. It did seem noisier that what I would expect from the start but I didn't realize it was a problem with the shaft of the motor. I took it apart and found the motor shaft wasn't true and causing sparks. The motor looks like it can not be taken apart and repaired. This seems like a default from the beginning but it is past warranty. Also noti

You will have to replace the motor and the hose asm. thehooverstore.com may be able to help, or you should be able to find a repair shop that can order them for you. ... Vacuums

I have a Kirby Dual Sanitronic '50' Vacuum Cleaner I bought in 1966. The motor does not start when I attach the belt lifter of the rug nozzle. When I remove the rug nozzle and detach the belt from the motor fan shaft the motor starts when I depress the nozzle switch and the power switch . Seems like the brushes in the motor are worn out. I do not have a manual for this unit. Can you assist me as to what newer unit is this compatible to and the problem I'm having at present??

... Kirby Vacuums

I have a proheat 2x, and the pump will only spray water for a few seconds when unit is turned on, then nothing. The attachment is the same way. I think this is the pump failing, and the unit is only over a year old. How much would a pump cost? If this is the problem.

I just had my pump replaced for $66 and the repairman said this unit is notorious for this problem. He had 6 other units in his shop when we came in. Make sure you keep your clean water tank FULL, as he said the pump fails as soon as it runs dry. ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

Our Hoover U8172-900 brush motor is not working. Do you have a wiring diagram so I can determine if the motor circuit board is the problem or the motor?

No diagrram is necessary unless you have dismandled.\012Check if the brushes are touching the mtor commutator. If not you can easily remove both the brushes and polish the surface evenly .Insert only after cleaning the motor commutator till the ... Hoover Vacuums

The pump motor in my Bissel Proheat 2x Plus seems to have failed. It was seized so I sprayed WD-40 in it and let it sit for 3 days. Now I can turn it by hand, but when plugged into the unit it still doesn't spin. Here's a picture: http://bbay.dreamhost.com/bissel_proheat_2x_plus/P1070021.JPG I wanted to take the motor out and hook it into another power source to see if I can get it going but it has 3 wires. I'm used to only 2 (+ and -). How can I hook the motor up to another power source,

... Bissell Vacuums

There is no power...seems like a motor problem. The bag is clean...the mouth is clean the plug us in...NOTHING! I took mouth off and manipulated/pushed in that power press area that engages the motor on the front (not the switch on the back) and NOTHING! Not sure if motor died and/or what to do now. Help. I have had this baby for 15 years.

The front safety switch must be pushed in by either the hose or head (or manually), before the on/off switch will operate. The most common reason for no power is a bad cord. Second most common is worn carbons in the motor, and third is a bad switch. ... Kirby G4 Bagged Upright Vacuum

Dead motor? My 8 year old Miele S251i has worked fine, until I was recently vacuuming and moved the plug from one outlet to another. When I restarted the vacuum, it made rrrrr.....rrrrrr....rrrrr noises and smelled like something was burning. I turned it off, and it's shown no signs of life since. Sound like a motor problem? I've taken the cover off and looked at the cord and seen the motor, nothing looks obviously wrong, but I'm also not mechanical.

... Miele S251 Flamenco II Bagged Canister Vacuum

Miele Cat & Dog vacuum gets VERY hot and is VERY loud. Hose has no restrictions and I have changed the dust compartment (motor) filter and the exhaust filter. It still gets hot when I run it with the top open and all filters removed, so I'm guessing the problem is with the motor. Should I be going into the motor compartment? If so, what am I looking for?

Hi\015\012\015\012The fact that it gets very hot could be due to a number of issues.,but the fact that it started making a very loud noise at the same time suggests that there might be more problems maybe brushes etc.\015\012\ ... Miele S514 Solaris Bagged Canister Vacuum

Nilfisk GM 90 motor bearing Hi I have replaced the motor bearing on the GM 90 model but having problem with re fitting the turbyne I forgot the sequence it has 2 turbines and 4 2 inch washers Can you please tell me the sequence it is fitted Thanks,,,Ps the motor is 100% ok now Peter

... Nilfisk Vacuums

Motor problem When i plug my steam vac in the motor sparks and smokes. It smells as if the motor is burning out. I've tried different outlets through out the house and get the same outcome, what can i do to solve this?

Nothing you can do im affraid its the motor armature so unless it can be stripped down then you will need to replace the motor i would get a price for the motor to decide if it is worth doin sorry. ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1903 seconds