Having problems with your Hoover F7220900 SteamVac V2 Upright Vacuum ?

Hoover shampooer motor is running ,but no suction


Answers :

When you place the recovery tank on the machine, there is a mating of the tank to the motor intake and this directs the suction into the tank. Make sure the lid is on the tank correctly. You also should check that the seal on the motor intake is in place. Take the tank off the machine, and look on the front left area where the tank sits. There is a round intake and should have a black rubber seal sitting on top of it. Sometimes these seals fall off. If it is missing, check inside the machine around the intake and you may find it lying in there somewhere.
Repair Help & Product Troubleshooting for Hoover F7220900 SteamVac V2 Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Hoover shampooer motor is running ,but no suction


When you place the recovery tank on the machine, there is a mating of the tank to the motor intake and this directs the suction into the tank. Make sure the lid is on the tank correctly. You also should check that the seal on the motor intake is in p ... Hoover F7220900 SteamVac V2 Upright Vacuum

No suction My Hoover Wind Tunnel vacuum runs but there is no suction. The last two or three times I used it, it shut itself off after having a burning smell. When I unplug it for the suggested 30 minutes, the motor will run again but no suction. What is wrong?? Should I just buy a nve one? This one is 8 years old.


Sounds like your motor bearings are going bad. This is generally indicated by the motor overheating, and the heat transferring out through the motor pulley, which is where the belt attaches. So, your machine is overheating, melting the belt, and then ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

Hoover Jet and Wash 1500w S6254 001. Used once with great difficulty as assembly and use instructions are hard to follow.Now will not work as carpet shampooer at all, although assembly is correct as far as I can see and both motor and pump appear to be working and I am using the recommended cleaning fluid.Hoover website is no use at all in solving the problem.No cleaning fluid is being drawn up from the tank in to the cleaning fluid hose.There is suction from the suction hose so the problem appe


I am having the same prob my uncle got me one i cant find the manual anywhere to set it up the prob i have is where does the handle to make the water go out connect tooo ??? on the main pipe that sucks it back up i have tried every which way but not ... Vacuums

Hoover upright bagless vacum.motor runs, brush turns, no suction through hole behind brush roller. however there is suction going out of dust cannister filter flap to motor. what could possible problems be?


Sorry to read about your problem, I hope this helps you out.you have a clog between the brush and bagI tried to help you. Please help me and Rate/Vote on my response, thanks and good luck ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

NO SUCTION ,EITHER AT WHERE THE HOSE GOES IN OR AT THE MAIN NOZZLE. WHAT COULD BE THE PROBLEM, HOOVER ELITE? ALSO MOTOR IS RUNNING AT A HIGH SPEED THAN NORMAL.


It might be clogged. ... Hoover Elite U5349-900 Upright Vacuum

I have a Hoover Steam Vac All Terran floor shampooer, I have taken apart the brushes and other parts to make sure there are no clogs, but it still is not spinning. What else can I do? the Motor is working fine. and the suction is fine too.


There may be some substances such as dust or sand stuck in the spinning parts of the wheel. The substances are restricting the mechanism to work properly and causing blockage in the rotating causing your problem. Cleaning every part of the motor's ro ... Vacuums

Hoover bagless vacuum motor not running


... Hoover S3765-040 WindTunnel Bagless Canister Vacuum

No suction After taking the vacuum apart, I noticed there is no suction at all. The motor runs, belt runs, but no suction coming through.


You have a clog somewhere in the vacuum. Check the hose and the little trap door on the underneath side of sweeper.Does the brush turn? If not, then the belt that drives the brush is broken. Replace the beltJim ... Hoover Tempo Widepath Upright Vacuum - Blue

My vax power 8, 2200 watts 300 air watts 4L capacity upright Hoover is brand new, I emptied out the dust/dirt collecter and cleaned the motor filter yesterday for the first time, i switched it on and all fine, the brush is spinning and the hose is sucking, put the Hoover to work it's fine for about 30 seconds then then suction stops and its dead it won't collect no more, so switched off taken apart again and the motor filter is blocked and full of dust, so I unblocked it, do the same process aga


I had the same problem. It looks like the seal on the lid on the bottom of the cylinder has fallen out when it was emptied. There is no longer a proper vacuum being created so you don't get the cyclone effect and the dirt doesn't collect where its su ... Vacuums

Hi I need help because I have a problem with my Electrolux Centralux Central Vac system in my house. When I plug the vac hose in the central vac socket at first I heard the motor running very gently with NO suction then after a minute or so it went completely dead and they is NO motor sound, suction, or anything happening what so ever. Can anyone tell me what this problem is???


Have you checked for a clog in the lines or in the hose? If there is no clog in the system anywhere, then your motor could be dying. ... Electrolux Centralux Vacuum

Brand new LG LUV200r used 10 minutes now after removing dust tank & reinstalling the vacuum motor does not run only the beater bar??? I have located wo circuit breakers both seam to be set. This suction motor should run when the switch is pressed & the beater bar should operate when the handle is moved down??? Not A happy customer will return unit to Best Buy only 100 mile round trip!!!! RDH


... LG Electronics Kompressor Pet Care Upright Vacuum Cleaner LUV200R

Does not pick up, no vaccum, motor runs, no blockage, should feel suction on hose outlet without hose hook up. Paper filter missing over cloth filter. float overload ball free, seal on section good no leakage. Maybe bad motor but runs.


Here\015\012 is a Link to one of my Tips:www.fixya.com/support/r6311178-vacuum_brush_bar_not_spinningThis\015\012 should solve the problem. ... Minuteman C82906-01 HEPA Vacuum Vacuum

Motor is running and the brush is also running but i have no suction and the suction tube is clear


A clogged filter or if it has a bag hole in bag or bag isn't in correct. ... Hoover Vacuums

Hoover Elite motor runs when moving backwards but not forward


Are you sure its not just your belt on the beater of head slipping and needs to be replaced? ... Hoover Elite Rewind Bagless Upright VacuumVacuum

Makita 440 Dust Extractor - Trying to rectify a problem, when i switch on an appliance plugged into the socket, it will not run. IS used to run with this plugged in, but the hoover motor runs no problem. Any ideas what might be amiss, or where i can get a wiring diagram? Thanks in Advance!


... Makita 440 Wet/Dry Vacuum

Dyson dc04 motor runs but has no suction.


I would make sure it is the motor first by isolating the sounds to just the motor. Take off the dirt cup, both filters, and belt, then run it and see if the sound is still there. If it is, you need a new motor. If it isn't, you need to look for a clo ... Dyson DCO7 Animal Bagless Upright Cyclonic Vacuum

I have a riccar 8905 the motor runs but no suction


... Riccar 8955 Upright Vacuum

No suction on my Electrolux central vacuum in all outlets even though motor is running and there is no clog in the hose.


I would start with washing out the ilter really good and letting dry. then try the system. ... Electrolux Central Vacuum

No suction Brushes won't turn, belt attatched to motor but not spinning I have no suction in main part of the hoover.


Are you saying that the motor runs but there is no brush rotation ?\015\012 \015\012If yes then firstly switch machine on then when you pull handle back as if to vacuum the carpet the clutch drive dial must ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Motor is pulsing on and off, suction is good when motor running


... Broan-NuTone CV653 Bagged Central System Vacuum

When my dyson dc14 hoover is on it has a strange burning smell, and a noise like air popping, there seems to be suction from beater and it spins. and definitley suction from extension. Filters are clear and no blockages. Is it the belt I don't think it is. or motor ? Grateful for any advice.


It could be the belt. However, the popping sound does have me puzzled. The popping could be coming from a partially broken belt slapping against plastic.Jim ... Vacuums

Have a Rainbow SE passed down from my Mom who bought it used.Never any trouble, haven't used it for couple of months. When I turn it on now , the motor hums, but doesn't suction. Was afraid to keep it running as I didn't know if the motor was locked or what. Can you advise if there is any home repair I might attempt?


I believe the motor on this unit has brushes. These are little conductive pieces that provide electricity to the spinning motor windings. They wear out over time and need replacing. I have found a link online that will show you how to ... Rainbow E series Canister Wet/Dry Vacuum

Dyson Animal motor is running, beater bar is turning but very little if any suction. No suction from hose either. The inside canister is filling and moving, so there is some dirt being sucked in there. I have thoroughly cleaned all filters but not sure what is causing the problem. Any ideas?


Obstruction in the hose?\015\012Your vac has developed a hairball possibly.... when a piece of flexible media ie.... cardboard, plastic etc... gets lodged in the hose, and begins collecting hair & dust to the point it no longer has enough d ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0687 seconds